Welcome to the Vovin.CmcLibNet documentation

Documentation for the Vovin.CmcLibNet assembly.

Getting Started

  • Download and install the assembly here

See Also

Other Resources

Source code on GitHub

Arno van Boven - Vovin IT Services

Send comments on this topic to feedback


Teaser

A short teaser

Demonstrates

How querying a Commence database is made easier with Vovin.CmcLibNet

Getting basic info

Imagine you want a list of all categories and their item numbers. Something along the lines of:

Category 'Accounts' contains 12 items
Category 'Contacts' contains 75 items
..etc..

A simple enough requirement, but not that straightforward to achieve. Commence does not provide easy access to that kind of information. You have to use the dreaded DDE syntax.

Let's see that in action in Visual Basic Script

VBScript
Copy
Option Explicit 'enforce explicit variable declaration
Const DELIMITER = "||" 'define a delimiter
Dim oCmc 'Commence.DB
Dim oConv 'ICommenceConversation
Dim oCategoryList 'array to hold out category names
Dim sDdeCommand 'string to hold DDE command text
Dim sCategoryName

Set oCmc = CreateObject("Commence.DB")
Set oConv = oCmc.GetConversation("Commence", oCmc.Path)
sDdeCommand = "[GetCategoryNames(" & DELIMITER & ")]"
oCategoryList = Split(oConv.Request(sDdeCommand), DELIMITER)
For Each sCategoryName In oCategoryList
  sDdeCommand = "[GetItemCount(" & sCategoryName & ")]"
  WScript.Echo "Category " & sCategoryName & " contains " & oConv.Request(sDdeCommand) & " items"
Next

Set oConv = Nothing
Set oCmc = Nothing
WScript.Quit 0

This will work fine, but it is a fair bit of coding. Also, figuring out the syntax for the DDE requests can be quite a challenge.

And because this example uses the Windows Scripting Host, it isn't immediately trivial to run on 64-bit Windows. You have to explicitly tell it to use the Windows Based Script Host.

But wait, what is with this old-school VBScript stuff? Surely you can use PowerShell to talk to any COM interop capable application? Yes, you can. So let's do the same in PowerShell:

PowerShell
Copy
# get a list of categories and item counts using PowerShell

# specify a (badly chosen) delimiter (not going into details why it's bad)
$delim = '|'

# create COM reference to Commence
$cmc = New-Object -ComObject Commence.DB

# lets see what we have
$cmc | Get-Member

# Get-Member only returns some generic .Net methods that all objects share.
# It tells you nothing about what interfaces Commence exposes.
# To actually get something from Commence, you must use the IDispatch interface.
# You just have to know that.

# get path
$path = [System.__ComObject].InvokeMember('Path',[System.Reflection.BindingFlags]::GetProperty,$null,$cmc,$null)

# create a reference to the ICommenceConversation interface (i.e. the DDE stuff)
$dde = [System.__ComObject].InvokeMember('GetConversation',[System.Reflection.BindingFlags]::InvokeMethod,$null,$cmc, @('Commence', $path))

# construct DDE request syntax
$request = "[GetCategoryNames($delim)]"

# call a method of ICommenceConversation
$categories = [System.__ComObject].InvokeMember('Request',[System.Reflection.BindingFlags]::InvokeMethod,$null,$dde,$request)

# loop through categories
foreach ($s in $categories.Split($delim))
{
$request = "[GetItemCount(`"" + $s + "`")]"
Write-Host Category $s contains ([System.__ComObject].InvokeMember('Request',[System.Reflection.BindingFlags]::InvokeMethod,$null,$dde, $request)) items.
}

# release COM references so Commence can be closed
[System.Runtime.Interopservices.Marshal]::ReleaseComObject($dde)
[System.Runtime.Interopservices.Marshal]::ReleaseComObject($cmc)

Yikes! That is some scary code, right? While it proves that it is perfectly possible to talk to Commence from Powershell directly, it also shows that it is by no means a walk in the park. There is this IDispatch stuff to invoke memthods and there is the mysterious DDE syntax Commence uses. It is certainly non-trivial.

Okay, so let's do the same one more time, again using Powershell but this time also using Vovin.CmcLibNet. By the way, it doesn't matter if you run 32- or 64-bit Powershell.

PowerShell
Copy
# bring in the assembly
Add-Type -Path "C:\Program Files\Vovin\Vovin.CmcLibNet\Vovin.CmcLibNet.dll"
# create regular .Net object, exposed by CmcLibNet
$db = New-Object -TypeName Vovin.CmcLibNet.Database.CommenceDatabase
# call some methods and output results
$db.GetCategorynames() | foreach-object {
Write-Host Category $_ contains $db.GetItemCount($_) items
}
$db.Close() # explicitly release object reference

That is a lot simpler!


Powershell Basic example

PowerShell examples

Demonstrates

Usage of Vovin.CmcLibNet from PowerShell.

  • Some important="" differences between the Commence API and CmcLibNet.
  • Some advantages of CmcLibNet over using the 'raw' Commence API.

Basic usage

I will show you a few lines of PowerShell and talk you through it. You can find the complete script at the end of this page.

Intended audience:

  • Administrators who want to use PowerShell to perform operations on Commence, such as nightly exports.

  • Developers familiar with Commence.

Disclaimer I did not speak PowerShell prior to writing this example (ironic, isn't it?). Usage of this code is at your own risk.

Requirements for running this example

  • PowerShell must be configured to run (at least) .NET 4.5 code. On any version of Windows 10 you should be fine.

  • Commence must be running, and the Tutorial database must be open.

Note: if you are running PowerShell as Administrator, you must start Commence as Administrator as well.

Let's get started.

First of all, it should be noted that you already communicate with Commence from PowerShell without any additional tools. See the Teaser section for an example. Second, a lot of the Powershell commands in here can be shortened, but I have chosen to keep it quite explicit so we can focus on the Commence API differences. In the Export sample I use more shorthand code.

CmcLibNet is an assembly that exposes the entire Commence API via .NET and has some added functionality to boot.

In this example, assume Vovin.CmcLibNet.dll is just a file sitting on your computer.

Copy
Add-Type -Path "C:\Program Files\Vovin\Vovin.CmcLibNet\Vovin.CmcLibNet.dll" # reference the assembly
$cmc = New-Object -TypeName Vovin.CmcLibNet.CommenceApp # get a reference to Commence via Vovin.CmcLibNet
# Get-Member nicely returns the methods and properties of the $cmc object.
$cmc | Get-Member
# Output name and path of the database
$cmc.Name
$cmc.Path

Let's do something more useful and illustrate some features of CmcLibNet as we go along.

In the above example, we talked to the Commence application. That's nice, but in almost all cases you will want to do something with the Commence database. All database functionality in CmcLibNet is exposed by the ICommenceDatabase interface.

Copy
$db = New-Object -TypeName Vovin.CmcLibNet.Database.CommenceDatabase

Note that while you can get references to the CommenceApp and CommenceDatabase types directly, they are also part of the top-level type Vovin.CmcLibNet.Application So if you prefer a more parent-child-like approach to your code, the following would also work. I have commented out the code because the example is built as a real-life script. (Complete code at the end of this page.)

Copy
# Example of alternative way to get types
# $cmclibnet = New-Object -TypeName Vovin.CmcLibNet.Application
# $cmc = $cmclibnet.CommenceApp # get reference to CommenceApp
# $db = $cmclibnet.Database # get reference to CommenceDatabase

Let's say we want a list of all the e-mail addresses of Contacts who work for the Account called 'Commence Corporation'. Assume we want that list to be exported to an Xml file. Wait, what? Commence can do that? No, but CmcLibNet can. It can also export to Json, I'll show that later. Remember, this example assumes Commence is running with the Tutorial database opened.

PowerShell
Copy
$cursor = $db.GetCursor("Contact")

Let's talk about that line some more. If you are familiar with Commence API scripting, a few things may catch your attention. In VBScript, chances are you would have written something like cursor = db.GetCursor(0, "Contact", 0) In our case, we did not supply any parameters with the GetCursor command. That is because the GetCursor method has several overloads, i.e. several ways of calling it. The above line is equivalent with cmc.GetCursor(0,"Contact",0), just shorter. If you want to, you can still supply parameters, just use another overload. For example, getting a cursor on a view would be written as cmc.GetCursor("MyViewName", 1, 0)Note: The parameter order is different from the order in the Commence API. That is because in .NET, optional parameters must come last and both the 1 and 0 are optional in this case.

Okay, now we have a cursor reference. Let's check how many items we have:

PowerShell
Copy
$cursor.RowCount

This should return the number of items in the Contact category.

We want only contacts connected to 'Commence Corporation', so we are going to have to filter the cursor. You can still do that with the dreaded .SetFilter("[ViewFilter(Very-Long-String-With-Mysterious-Parameters)]") syntax, but the preferred way of filtering in CmcLibNet uses a different mechanism. In CmcLibNet, a Filter is just an object with properties. That may sound mysterious at first, so let's just show how that works.

We will create a filter of type CTI (Connection To Item) and make it the first filter.

PowerShell
Copy
$filter = $cursor.Filters.Create(1, [Vovin.CmcLibNet.Database.FilterType]::ConnectionToItem)

That will look completely crazy to people who have used the Commence API before.

Let's compare it to the 'classic' way of doing it. In VBScript, you would have written something along the lines of: result = cursor.SetFilter("[ViewFilter(1,CTI,,Relates to, Account, Commence Corporation)]", 0) This is the simplest of all filters and even after over 2 decades, I still struggle with that syntax.
In essence, it calls a method "Setfilter() to which a string parameter is passed that describes a DDE request ViewFilter and its impossible to remember parameters. CmcLibNet was designed to do away with that.

Also,

Copy
[Vovin.CmcLibNet.Database.FilterType]::ConnectionToItem
is a lot of stuff to type. You don't have to write it like that but I want to focus on Commence here, not provide Powershell tips.

Let's inspect that $filter thingie:

PowerShell
Copy
$filter | gm

You will notice that it is an object with properties that match the parameters that you can pass to the DDE ViewFilter request.

When you create a Filter of a certain type in CmcLibNet, it will contain the properties pertaining to that particular filtertype.

Let's see some of properties that belong to our 'CTI' filter in action:

PowerShell
Copy
$filter.Connection = "Relates to" # IMPORTANT: connection names in Commence are case-sensitive!
$filter.Category = "Account" # Category name
$filter.Item = "Commence Corporation" # Item name. Ideally, you should use a clarified itemname, or, alternatively, set the ClarifySeparator and ClarifyValue properties.

There are many more properties you can set, but these suffice for this example.

We have defined our filter, but it isn't enforced yet. For that, you have to call the Apply() method of the Filters collection. The Apply() method returns the cursor's rowcount after filtering, or throws an error when something goes wrong.

PowerShell
Copy
$cursor.Filters.Apply()

We now have a cursor containing contacts connected to 'Commence Corporation. Let's assume we only want the name and e-mail fields. Setting fields on a cursor works in much the same way as using the Commenc API

PowerShell
Copy
$cursor.SetColumn(0, "contactKey", [Vovin.CmcLibNet.CmcOptionFlags]::Default) # [Vovin.CmcLibNet.CmcOptionFlags]::Default is 0, you could use 0. Harder to remember though.
$cursor.SetColumn(1, "emailBusiness", 0) # Again, note that you can either provide the native value of the CmcOptionFlags enum (0), or just pull the value from the enum (recommended!)

However it is easier to use the methods provided by the Columns property of a cursor. This is also specific to CmcLibNet. You can use either mechanism, but do not intermix them!

PowerShell
Copy
# $cursor.Columns.AddDirectColumns("contactKey", "emailBusiness") # commented out because we already set them.
# $cursor.Columns.Apply()

Check if we actually have our two columns as expected:

PowerShell
Copy
$cursor.ColumnCount # should return 2

Let's export the data. Wait, you can export a cursor? Yes, and it is very simple, too.

The default export format is Xml. No matter what file extension you set, you get Xml.

For a more in-depth look at the CmcLibNet IExportEngine options, see the export example.

PowerShell
Copy
$cursor.ExportToFile("C:\temp\cursor.xml") # adjust path for your system

While not strictly necessary it is recommended practice to close the cursor when no longer needed.

It may prevent some unexpected behaviour when -for example- trying out things in PowerShell ISE or VS Code.

The Close() method explicitly releases COM references to Commence. If you do not call it, the commence.exe process may keep running even after you close the Commence application.

PowerShell
Copy
$cursor.Close()
# Alternatively you can also call Close() on the database in this example.
# This will close *all* COM-references created by this $db object, including other cursors you have open.
$db.Close() # closes all COM-references created using $db

That concludes this example. We barely scratched the surface, but I hope you got an idea of what CmcLibNet can do.

Below is the complete script used in this example.

PowerShell
Copy
Add-Type -Path "C:\Program Files\Vovin\Vovin.CmcLibNet\Vovin.CmcLibNet.dll"
$cmc = New-Object -TypeName Vovin.CmcLibNet.CommenceApp
$cmc | Get-Member
$cmc.Name
$cmc.Path
$db = New-Object -TypeName Vovin.CmcLibNet.Database.CommenceDatabase
$cursor = $db.GetCursor("Contact")
$cursor.RowCount
$filter = $cursor.Filters.Create(1, [Vovin.CmcLibNet.Database.FilterType]::ConnectionToItem)
$filter |gm # gm is just short for Get-Member, btw
$filter.Connection = "Relates to" # IMPORTANT: connection names are case-sensitive!
$filter.Category = "Account" # Category name
$filter.Item = "Commence Corporation" # Item name. Ideally, you should use a clarified itemname, or, alternatively, set the ClarifySeparator and ClarifyValue properties.
$cursor.Filters.Apply()
$cursor.SetColumn(0, "contactKey", [Vovin.CmcLibNet.CmcOptionFlags]::Default)
$cursor.SetColumn(1, "emailBusiness", 0) # Again, note that you can either provide the native value of the CmcOptionFlags enum (0), or just pull the value from the enum (recommended!)
$cursor.ColumnCount
$cursor.ExportToFile("E:\temp\cursor.xml")
# optional but recommended
$cursor.Close() # clean up
$db.Close() # clean up
See Also

Other Resources

Powershell export example


Powershell Export example

Shows different export options in CmcLibNet.

Basic export example

I will be taking advantage of some PowerShell 5 features. It is the default version on Windows 10.

First of all, we must tell PowerShell that we want to use CmcLibNet. We also bring in the namespaces we will use so that we don't have to fully qualify them every time. Important: if you installed the Vovin.CmcLibNet.dll somewhere else, change the path reference accordingly.

PowerShell
Copy
using namespace Vovin.CmcLibNet.Database # requires PS 5 or higher
using namespace Vovin.CmcLibNet.Export # requires PS 5 or higher
Add-Type -Path "C:\Program Files\Vovin\Vovin.CmcLibNet\Vovin.CmcLibNet.dll" # the default path of the assembly when you used the installer

We want to use features in the ExportEngine

PowerShell
Copy
$export = New-Object ExportEngine # short for $export = New-Object -TypeName Vovin.CmcLibNet.Export.ExportEngine

The export engine interface is also a property of the Vovin.CmcLibNet.Application object. Depending on the code-style you like you can also get it like this (commented out here because we already have a reference):

PowerShell
Copy
# $app = New-Object -TypeName Vovin.CmcLibNet.Application
# $export = $app.Export

Now define an export path to use for this example (our Desktop)

PowerShell
Copy
$exportPath = [Environment]::GetFolderPath([Environment+SpecialFolder]::Desktop) # we're being PS pedantic here

There are three types of datasets you can export: categories, views and cursors.

Export the Contact category to a file named contacts.xml:

PowerShell
Copy
$export.ExportCategory("Contact", (Join-Path -Path $exportPath -ChildPath "contacts.xml")) # Join-Path is again being pedantic about PS but okay

The export engine cleans up after itself after a succesful export.

Export view Account List (a view in the Tutorial database) to a file named accounts.xml.

PowerShell
Copy
$export = New-Object ExportEngine
$export.ExportView("Account List", $exportPath + "Account List View.xml") # View names in Commence are case-sensitive!

The first line of which is short for: $export = New-Object -TypeName Vovin.CmcLibNet.Export.ExportEngine. An example of exporting cursors can be found in the remainder of this document.

Note that not all viewtypes can be exported. This is a limitation of Commence.

Tip: if you want to export the currently active view, supply either null or an empty string: ExportView(null,file,settings).

In the above examples, the resulting export files will be in Xml format. Xml is the default format of the export engine. Node names and values will be escaped so as to to comply with XML specs

The file-extension you supply to the export files has no special meaning, it can be anything.

CmcLibNet will (by default) export connected items as separate nodes, not as delimited strings like Commence does.

Custom formats

To export to other formats, you have to supply an argument of type IExportSettings.

You can create a one from scratch with

PowerShell
Copy
$BrandNew_ExportSettingsObject = New-Object ExportSettings # create Settings object from scratch

But it is usually easier to use the default settings property provided by the export engine.

PowerShell
Copy
$settings = $export.Settings

The settings object controls all export customization. One of its most important is the export format (see ExportFormat).
CmcLibNet can also export to plain text, Html, Json and Microsoft Excel.

Let's see some of this in action. Set it to Json

PowerShell
Copy
$settings.ExportFormat = [ExportFormat]::Json # export to JSON

Tell it to skip connected values. This is useful when exporting categories when you do not want all connected data.

PowerShell
Copy
$settings.SkipConnectedItems = $true

Make Commence return values in a consistent format. In CmcLibNet this includes connected values, something which Commence does not do natively.

PowerShell
Copy
$settings.Canonical = $true

When you export data, chances are you will want to import them into something else. That often requires some form of field-mapping. For argument's sake, let's say Commence uses the fieldnames 'firstName' and 'lastName', but the receiving application uses 'First_Name' and 'Last_Name'. There are several ways to overcome this. One is to define a view in Commence containing the two fields, and give the fields custom labels using Design View. In that case, you can export the view and tell the export engine to use the labels, not the fieldnames:

PowerShell
Copy
$settings.HeaderMode = [HeaderMode]::Columnlabel

Let's see this in action. It uses a Report view present in the Tutorial database:

PowerShell
Copy
export.ExportView("All Contacts-Report", $exportPath + "Contacts with labels as property names.json", $settings) # Create json file with the field labels (and not field names) as property names

You could also get really funky and define your own headers (columnnames), ignoring everyting in Commence

Beware that this a little more tricky. The custom names must be unique and match the number of Commence fields! I.e. it must match the number of fields present in the dataset (be it a category, view, or cursor) regardless of using SkipConnectedItems.

To show an example with custom headers without actually modifying the Tutorial database, we have to get a little fancy. You will also see the use of some other features of CmcLibNet. Exporting isn't limited to categories or views. You can also export a cursor.

PowerShell
Copy
$settings.ExportFormat = [ExportFormat]::Json
$settings.CustomHeaders = @("First_Name","Last_Name") # supply an array of custom headers
$settings.HeaderMode = [HeaderMode]::CustomLabel
$db = New-Object CommenceDatabase
$cursorToExport = $db.GetCursor("Contact") # create cursor on contact category
$cursorToExport.Columns.AddDirectColumns("firstName","lastName") # define columns to use
$cursorToExport.Columns.Apply() # apply columnset
$cursorToExport.ExportToFile($exportPath + "Contacts with custom property names.json", $settings) # create json file with custom property names 'First_Name' and 'Last_Name'.

CmcLibNet can export to HTML as well. Note that Commence already supports exporting to HTML (Save View as HTML, or via the Report Viewer). CmcLibNet just adds additional functionality. Note that CmcLibNet adds classes and identifiers to every exported element that you can use in an (optional) CSS file.

Copy
$export.Settings.ExportFormat = [ExportFormat]::Html
$export.Settings.CSSFile = "some-stylesheet.css" # include a stylesheet reference in the exported HTML file. Note that this is just a dummy that will be ignored.
$export.Settings.HeaderMode = [HeaderMode]::Columnlabel # reset header mode. Now would have been an appropriate time to create a new Settings object!
# 'All Contacts-Report' is a view in the Tutorial database
$export.ExportView("All Contacts-Report", $exportPath + "Contacts with fieldlabels as table headers.html")

You can also export to Text. Note: in most cases, using the built-in export features in Commence are easier and much faster. CmcLibNet will be considerably slower, but it does give you better control over the export.

The two main enhancements include:

  1. supplying a custom field delimiter

  2. exporting connected fields other than the Name field(!)

PowerShell
Copy
$settings.ExportFormat = [ExportFormat]::Text
$settings.HeadersOnFirstRow = $false # set to $true to include fieldnames/labels at the top
$settings.TextDelimiter = "|" # use pipe symbol as delimiter. Default is tab.
$settings.TextQualifier = "#" # use (pound) symbol as text-qualifier. Default is " (quote).
$export.ExportCategory("Contact", $exportPath + "Contact.txt", $settings)

Last but not least you can export to Microsoft Excel. That is fairly straightforward. There are a few options you can set, refer to ExcelUpdateOptions.

Excel does not have to be installed. The export file will be in the xlsx format, so reading the file requires Excel 2007 or higher.

For this to work, you need a Full install of Vovin.CmcLibNet, since it depends on an additional component.

PowerShell
Copy
$settings.CustomRootNode = "MySheet" #define a sheet name (optional)
$settings.ExportFormat = [ExportFormat]::Excel
$export.ExportCategory("Contact", $exportPath + "Contact.xlsx", $settings)

The end. Have fun exporting!

Complete script

The complete script

PowerShell
Copy
using namespace Vovin.CmcLibNet.Database
using namespace Vovin.CmcLibNet.Export
Add-Type -Path "C:\Program Files\Vovin\Vovin.CmcLibNet\Vovin.CmcLibNet.dll" # the default path, adjust if necessary
$export = New-Object ExportEngine # short for: $export = New-Object -TypeName Vovin.CmcLibNet.Export.ExportEngine
$exportPath = [Environment]::GetFolderPath([Environment+SpecialFolder]::Desktop)
$export.ExportCategory("Contact", (Join-Path -Path $exportPath -ChildPath "contacts.xml"))
$export.ExportView("Account List", (Join-Path -Path $exportPath -ChildPath "Account List View.xml")) # note that view names are case-sensitive!
$BrandNew_ExportSettingsObject = New-Object ExportSettings # create Settings object from scratch
$settings = $export.Settings
$settings.ExportFormat = [ExportFormat]::Json # export to JSON
$settings.SkipConnectedItems = $true
$settings.Canonical = $true
$settings.HeaderMode = [HeaderMode]::Columnlabel
$export.ExportView("All Contacts-Report", (Join-Path -Path $exportPath -ChildPath "Contacts with labels as property names.json"), $settings) # Create json file with the field labels (and not field names) as property names
$settings.ExportFormat = [ExportFormat]::Json
$settings.CustomHeaders = "First_Name","Last_Name" # PS automatically creates the array
$settings.HeaderMode = [HeaderMode]::CustomLabel
$db = New-Object CommenceDatabase
$cursorToExport = $db.GetCursor("Contact") # create cursor on contact category
$cursorToExport.Columns.AddDirectColumns("firstName","lastName") # define columns to use
$cursorToExport.Columns.Apply() # apply columnset
$cursorToExport.ExportToFile((Join-Path -Path $exportPath -ChildPath "Contacts with custom property names.json"), $settings) # create json file with custom property names 'First_Name' and 'Last_Name'.
$export.Settings.ExportFormat = [ExportFormat]::Html
$export.Settings.CSSFile = "some-stylesheet.css" # include a stylesheet reference in the exported HTML file. Note that this is just a dummy that will be ignored.
$export.Settings.HeaderMode = [HeaderMode]::Columnlabel # reset header mode. Now would have been an appropriate time to create a new Settings object!
# 'All Contacts-Report' is a view in the Tutorial database
$export.ExportView("All Contacts-Report", $(Join-Path -Path $exportPath -ChildPath "Contacts with fieldlabels as table headers.html"))
$settings.ExportFormat = [ExportFormat]::Text
$settings.HeadersOnFirstRow = $false # set to $true to include fieldnames/labels at the top
$settings.TextDelimiter = "|" # use pipe symbol as delimiter. Default is tab.
$settings.TextQualifier = "#" # use (pound) symbol as text-qualifier. Default is " (quote).
$export.ExportCategory("Contact", (Join-Path -Path $exportPath -ChildPath "Contact.txt"), $settings)
# Exporting to Excel requires that you did a full install of Vovin.CmcLibNet
# because it relies on an additional component
$settings.ExportFormat = [ExportFormat]::Excel
$settings.CustomRootNode = "MySheet"
$export.ExportCategory("Contact", (Join-Path -Path $exportPath -ChildPath "Contact.xlsx"), $settings)
$export.Close() # optional, ExportEngine releases all COM-references automatically


VBScript example

VBScript example

Demonstrates

Usage of Vovin.CmcLibNet from a Commence Item Detail Form.

VBScript example

This example assumes that the Commence Tutorial database is opened.

VBScript
Copy
' Sample VBScript illustrating the use of CmcLibNet, a .NET wrapper around the Commence API
' CmcLibNet was developed for use from within .NET applications.
' Because it was also made 'COM-visible', it is possible to use it from any COM capable language
' Therefore, you can use it from Commence Form Scripts as well.
' This example illustrates how to use CmcLibNet from VBScript.
' For this example to work, CmcLibNet has to be registered for ComInterop
' If you did not check that option in the installer,
' you have to register it manually with regasm.exe.

' CmcLibNet contains several 'components': CommenceApp, Database, Export and Services
' * CommenceApp: get info on the Commence.exe application
' * Database: anything that has to do with manipulation the Commence database
' * Export: the export engine contained in CmcLibNet
' * Services: some esoteric features, not shown here.

' Get a reference to the Commence application through CmcLibNet.
Dim app : Set app = CreateObject("CmcLibNet.CommenceApp")
' Display name of currently opened database.
MsgBox "Commence database name: " & app.Name ' this is a silly example of course
' Let's assume we're completely done with our app object.
app.Close
' A note on the Close method:
' Because .NET and COM are very different techniques, you *must* explicitly call the Close method.
' Basically, if you are not using CmcLibNet from a .NET language, make sure you call Close.
' It is *not* sufficient to just set the reference variable to Nothing.
' Failing to call Close() will keep the commence.exe running in the background when the user closes Commence.
' In that case you have to manually end the process in the Windows Task Manager.
' As a rule of thumb: when you CreateObject("CmcLibNet.[Something]"), you must Close it.
' (The story gets weirder though: when used from the Windows Scripting Host,
' which is not .NET, it is not needed. Don't know why.)
'Set app = Nothing ' Optional, but regarded good practice.

' Let's show something more useful.
' Assume we want a list of people connected to account "Concorde Aviation Ltd".
' This means talking to the Commence database.
' Get a reference to the Commence database through CmcLibNet.
Dim db : Set db = CreateObject("CmcLibNet.Database")

' Get a cursor. Note how we do not supply any flags, just the category name.
' This gets a cursor on a category with default flags.
' It is equivalent to [FormOA.CommenceDB.]GetCursor(0, "Contact", 0)
' If you want a cursor on a view, CmcLibNet uses a different parameter order than the Commence API:
' GetCursor("MyView", 1, 0) where 1 indicates you want a view and 0 is the default flag.
' Refer to the documentation for the values of the flags used in CmcLibNet.
' If their meaning is equivalent to their Commence counterpart, they have the same value.
' We will only be dealing with category data, so we don't need any flags here.
' We can just do:
Dim cur : set cur = db.GetCursor("Contact")

' The cursor will contain all items in Contact.
' Let's see how many we have:
MsgBox cur.RowCount & " items in Contact category."

' Nothing spectacular yet. We wanted specific contacts, so the next step is to define a filter.
' This is where things in CmcLibNet get funky.
' To take full advantage of the CmcLibNet way of filtering,
' you need a IDE that supports Intellisense/Autocomplete. Most script editors do not.
' If you want to, you can set filters just like you would with the Commence API (i.e., use SetFilter() and SetLogic()).
' In this example, we'll do it the CmcLibNet way.
' Get a reference to the filters 'factory'. Every cursor in CmcLibNet has one.
Dim filters : Set filters = cur.Filters

' Create a CTI filter (Connection-To-Item)
Dim f : Set f = filters.Create(1, 1)

' What do parameters 1 and 1 mean?
' The Create method takes 2 parameters: Create(filterClause, filterType)
' The first parameter '1' just means you want it to be the first filter. You can define up to 8 of them)
' The second parameter '1' identifies the filtertype. These types are defined in a special list called an 'enumeration',
' just like the Commence option flags. Refer to the CmcLibNet documentation for the values.
' This is where an IDE with Intellisense comes in handy, it can just pull the correct value from the CmcLibNet assembly.

' filters.Create() will return a Filter object, with properties and methods.
' Moreover, it will only have the properties and methods that apply to that filtertype.
' Let's just see it in action:
' Define the connection name.
f.Connection = "Relates to" ' connection names are case-sensitive!
' Define the connected category.
f.Category = "Account"
' Define the item.
f.Item = "Concorde Aviation Ltd"

' We have defined a filter now. Remember you can create up to 8 filters.
' We now have to apply them. Call the Apply method of the filtering 'engine'.
' Apply will return the number of items in the cursor after applying the filters,
' so we can check how many items we have now.
' Note that does not guarantee your filters all worked as *you* intended,
' it just means Commence accepted them as valid filters.
Msgbox filters.Apply & " items in cursor after applying filters."

' Okay, 1 item left. Let's assume we're interested in the Name of the Contact and the business e-mail.
' Define those columns:
cur.SetColumn 0, db.GetNameField("Contact") ' get whatever the name field in the category is called
cur.SetColumn 1, "emailBusiness"
' There a few things to note here.
' First of all, we didn't specify an option flag SetColumn(index,fieldname,option flag)
' Second, we used a built-in CmcLibNet function te get the name of the Name field

' This 'old-fashioned' way of setting columns works fine
' You can also set them in batch by passing them as an Array.
' Do *not* mix single- and batchmode. That's why the following line is commented out.
'cur.SetColumns Array(db.GetNameField("Contact"), "emailBusiness")

' You can set related columns like you would in the Commence API directly
' Related columns cannot be set in batch mode.
' Assume we want to know the Employee Type of the Contact.
cur.SetRelatedColumn 2, "Relates to", "contactType", "contacttypeKey" ' again, no additional flag required
' Let's see how many columns we have now:
MsgBox cur.ColumnCount & " columns were set in cursor"
'cur.ExportToFile("C:\Temp\MyExportFile.xml")

' Okay, we have 1 item and 3 columns. Let's do something with the data.
' Let's export it to file.
' One of the features unique to CmcLibNet is the ability to directly export cursors
' You could call cur.ExportToFile("MyExportFile.xml")
' This would produce a XML file. Do not be fooled by the .xml extension,
' it has nothing to do with the XML export format, XML is just the default.
' I want to show you something a little more fancy. Let's export to JSON!
' For this, you have to supply an extra parameter, a 'ExportSettings' object.
' This is a feature of the CmcLibNet export engine, so we have to talk to that
Dim exportEngine : Set exportEngine = CreateObject("CmcLibNet.Export")
' The export engine exposes a settings feature unsurprisingly called 'Settings'
Dim settings : Set settings = exportEngine.Settings ' The Settings thingie is an object, so we have to use 'Set'
' Settings has a bunch of properties you can set.
' One of them is the export format. CmcLibNet currently supports Text, HTML, Microsoft Excel, XML and JSON.
' JSON has a value of 1
settings.ExportFormat = 1
cur.ExportToFile "C:\temp\sampleContactExport.json", settings
' Which will produce a file C:\temp\sampleContactExport.json. (change your path accordingly)

' That almost concludes the example. There is a lot more to tell, but this covers the basics.
' Please refer to the documentation on http://cmclibnet.vovin.nl for more.

' Remember, you have to close the references to CmcLibNet.
' If you got a script error at some point (we did not include any error checking!),
' the lines below will not be called and commence.exe will keep running after closing Commence
' This is extremely annoying, and something I hope to fix in the future. But do not keep you hopes up.
' Just be careful to include appropriate error-checking in your production code.
Set settings = Nothing
exportEngine.Close
db.close
Set exportEngine = Nothing
Set db = Nothing
MsgBox "VBScript example of using CmcLibNet finished."


Vovin.CmcLibNet Namespace

Contains core functiionality.
Classes
 | Class | Description
Public class | Application | CmcLibNet is a .NET assembly that wraps the Commence API. The primary goal for developing this library was to make it easier to communicate with Commence from Powershell. Some convenience methods can only be used from .NET applications, but all functionality as defined in the Commence API is available from COM.
Public class | AssemblyInfo | Contains general assembly information.
Public class | CommenceApp | CmcLibNet is a .NET assembly that wraps the Commence API. The primary goal for developing this library was to make it easier to communicate with Commence from Powershell.
Public class | CommenceCOMException | Custom Commence COM exception thrown when a COM error occurs while talking to Commence.
Public class | CommenceDDEException | Custom Commence DDE Exception thrown when DDE call failed.
Public class | CommenceMultipleInstancesException | Custom exception thrown when assembly is invoked while Commence is running more than 1 instance.
Public class | CommenceNotRunningException | Custom exception thrown when assembly is invoked while Commence is not running.
Interfaces
 | Interface | Description
Public interface | IApplication | Application interface.
Public interface | ICommenceApp | Interface for CommenceApp.


Application Class

CmcLibNet is a .NET assembly that wraps the Commence API. The primary goal for developing this library was to make it easier to communicate with Commence from Powershell. Some convenience methods can only be used from .NET applications, but all functionality as defined in the Commence API is available from COM.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNetApplication

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class Application : IApplication
Public Class Application
    Implements IApplication

The Application type exposes the following members.

Constructors
 | Name | Description
Public method | Application | Initializes a new instance of the Application class
Top
Properties
 | Name | Description
Public property | AssemblyInfo | Returns information on the assembly. .Net only.
Public property | CommenceApp | Returns a reference to the Commence application
Public property | Database | Returns a reference to the Commence database.
Public property | Export | Returns a reference to the Export engine.
Public property | Services | Returns a reference to the Services utility.
Public property | Version | Returns assembly version.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

COM clients can use it by calling it with ProgId 'CmcLibNet.Application'.

COM applications such as Commence Item Detail Form scripts that use so-called 'late binding' can call the assembly thus:

VBscript:

VBScript
Copy
Dim obj : Set obj = CreateObject("CmcLibNet.Application")
See Also

Reference

Vovin.CmcLibNet Namespace


Application Constructor

Initializes a new instance of the Application class

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public Application()
Public Sub New
See Also

Reference

Application Class
Vovin.CmcLibNet Namespace


Application Properties

The Application type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInfo | Returns information on the assembly. .Net only.
Public property | CommenceApp | Returns a reference to the Commence application
Public property | Database | Returns a reference to the Commence database.
Public property | Export | Returns a reference to the Export engine.
Public property | Services | Returns a reference to the Services utility.
Public property | Version | Returns assembly version.
Top
See Also

Reference

Application Class
Vovin.CmcLibNet Namespace


Application.AssemblyInfo Property

Vovin.CmcLibNet, a .Net library for Commence RM

ApplicationAssemblyInfo Property

Returns information on the assembly. .Net only.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public AssemblyInfo AssemblyInfo { get; }
Public ReadOnly Property AssemblyInfo As AssemblyInfo
    Get

Property Value

Type: AssemblyInfo

Implements

IApplicationAssemblyInfo
See Also

Reference

Application Class
Vovin.CmcLibNet Namespace


Application.CommenceApp Property

ApplicationCommenceApp Property

Returns a reference to the Commence application

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceApp CommenceApp { get; }
Public ReadOnly Property CommenceApp As ICommenceApp
    Get

Property Value

Type: ICommenceApp

Implements

IApplicationCommenceApp
See Also

Reference

Application Class
Vovin.CmcLibNet Namespace


Application.Database Property

ApplicationDatabase Property

Returns a reference to the Commence database.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceDatabase Database { get; }
Public ReadOnly Property Database As ICommenceDatabase
    Get

Property Value

Type: ICommenceDatabase

Implements

IApplicationDatabase
See Also

Reference

Application Class
Vovin.CmcLibNet Namespace


Application.Export Property

ApplicationExport Property

Returns a reference to the Export engine.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IExportEngine Export { get; }
Public ReadOnly Property Export As IExportEngine
    Get

Property Value

Type: IExportEngine

Implements

IApplicationExport
See Also

Reference

Application Class
Vovin.CmcLibNet Namespace


Application.Services Property

ApplicationServices Property

Returns a reference to the Services utility.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IServices Services { get; }
Public ReadOnly Property Services As IServices
    Get

Property Value

Type: IServices

Implements

IApplicationServices
See Also

Reference

Application Class
Vovin.CmcLibNet Namespace


Application.Version Property

ApplicationVersion Property

Returns assembly version.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get

Property Value

Type: String

Implements

IApplicationVersion
See Also

Reference

Application Class
Vovin.CmcLibNet Namespace


Application Methods

The Application type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Application Class
Vovin.CmcLibNet Namespace


AssemblyInfo Class

Contains general assembly information.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNetAssemblyInfo

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class AssemblyInfo
Public Class AssemblyInfo

The AssemblyInfo type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyInfo | Initializes a new instance of the AssemblyInfo class
Top
Properties
 | Name | Description
Public property | ClrVersion | Returns CLR version.
Public property | FileVersion | Returns the file version.
Public property | ImageRuntimeVersion | Returns the ImageRuntimeVersion.
Public property | Path | Returns the location of the assembly
Public property | ProductVersion | Returns the product version.
Public property | TargetedFramework | Returns targeted framework version.
Public property | Version | Returns assembly version.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet Namespace


AssemblyInfo Constructor

Initializes a new instance of the AssemblyInfo class

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public AssemblyInfo()
Public Sub New
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


AssemblyInfo Properties

The AssemblyInfo type exposes the following members.

Properties
 | Name | Description
Public property | ClrVersion | Returns CLR version.
Public property | FileVersion | Returns the file version.
Public property | ImageRuntimeVersion | Returns the ImageRuntimeVersion.
Public property | Path | Returns the location of the assembly
Public property | ProductVersion | Returns the product version.
Public property | TargetedFramework | Returns targeted framework version.
Public property | Version | Returns assembly version.
Top
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


AssemblyInfo.ClrVersion Property

AssemblyInfoClrVersion Property

Returns CLR version.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClrVersion { get; }
Public ReadOnly Property ClrVersion As String
    Get

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


AssemblyInfo.FileVersion Property

AssemblyInfoFileVersion Property

Returns the file version.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FileVersion { get; }
Public ReadOnly Property FileVersion As String
    Get

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


AssemblyInfo.ImageRuntimeVersion Property

AssemblyInfoImageRuntimeVersion Property

Returns the ImageRuntimeVersion.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ImageRuntimeVersion { get; }
Public ReadOnly Property ImageRuntimeVersion As String
    Get

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


AssemblyInfo.Path Property

AssemblyInfoPath Property

Returns the location of the assembly

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


AssemblyInfo.ProductVersion Property

AssemblyInfoProductVersion Property

Returns the product version.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ProductVersion { get; }
Public ReadOnly Property ProductVersion As String
    Get

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


AssemblyInfo.TargetedFramework Property

AssemblyInfoTargetedFramework Property

Returns targeted framework version.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string TargetedFramework { get; }
Public ReadOnly Property TargetedFramework As String
    Get

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


AssemblyInfo.Version Property

AssemblyInfoVersion Property

Returns assembly version.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


AssemblyInfo Methods

The AssemblyInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AssemblyInfo Class
Vovin.CmcLibNet Namespace


CommenceApp Class

CmcLibNet is a .NET assembly that wraps the Commence API. The primary goal for developing this library was to make it easier to communicate with Commence from Powershell.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNetCommenceApp

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class CommenceApp : ICommenceApp
Public Class CommenceApp
    Implements ICommenceApp

The CommenceApp type exposes the following members.

Constructors
 | Name | Description
Public method | CommenceApp | Constructor.
Top
Properties
 | Name | Description
Public property | ExePath | Path to commence.exe.
Public property | Name | Name of currently open Commence database.
Public property | Path | Path of currently open Commence database.
Public property | RegisteredUser | Registered user of current Commence database.
Public property | Version | Version of active Commence application.
Public property | VersionExt | Extended version of active Commence application.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. Objects implementing this interface should be disposed after this. Important: object derived from this interface will also have their COM-references closed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks

COM clients can use it by calling it with ProgId 'CmcLibNet.CommenceApp'.

COM applications such as Commence Item Detail Form scripts that use so-called 'late binding' can call the assembly thus:

VBscript:

VBScript
Copy
Dim obj : Set obj = CreateObject("CmcLibNet.CommenceApp")

When used from Commence Item Detail Forms or Office VBA, be sure to read this: Close.

See Also

Reference

Vovin.CmcLibNet Namespace


CommenceApp Constructor

Constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceApp()
Public Sub New
Exceptions
Exception | Condition
CommenceNotRunningException | Commence is not running (COM error: 0x80131500).
CommenceMultipleInstancesException | Commence is running more than 1 instance (COM error: 0x80131500).
Remarks
If the constructor fails because either Commence is not running, or Commence is running multiple instances in the same userprofile, an exception is thrown. COM users (VBScript, VBA, etc.) will not get a useful error message. This is a bit of a problem that I am unsure how to solve. We could incorporate a lazy initialization routine and call that as soon as any of the properties are called, then return a more useful error to a consumer, but that is very messy from a .NET point of view.

Note that this behaviour may change in future releases.

Note that if you want to execute a PowerShell of VBScript script, and Commence is started as administrator (or vice-versa), the script will prompt to start another instance of Commence. The userlevel of the user of the assembly must match the userlevel of the Commence instance.

See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceApp Properties

The CommenceApp type exposes the following members.

Properties
 | Name | Description
Public property | ExePath | Path to commence.exe.
Public property | Name | Name of currently open Commence database.
Public property | Path | Path of currently open Commence database.
Public property | RegisteredUser | Registered user of current Commence database.
Public property | Version | Version of active Commence application.
Public property | VersionExt | Extended version of active Commence application.
Top
See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceApp.ExePath Property

CommenceAppExePath Property

Path to commence.exe.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ExePath { get; }
Public ReadOnly Property ExePath As String
    Get

Property Value

Type: String

Implements

ICommenceAppExePath
See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceApp.Name Property

CommenceAppName Property

Name of currently open Commence database.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Implements

ICommenceAppName
See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceApp.Path Property

CommenceAppPath Property

Path of currently open Commence database.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String

Implements

ICommenceAppPath
See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceApp.RegisteredUser Property

CommenceAppRegisteredUser Property

Registered user of current Commence database.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string RegisteredUser { get; }
Public ReadOnly Property RegisteredUser As String
    Get

Property Value

Type: String

Implements

ICommenceAppRegisteredUser
See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceApp.Version Property

CommenceAppVersion Property

Version of active Commence application.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get

Property Value

Type: String

Implements

ICommenceAppVersion
See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceApp.VersionExt Property

CommenceAppVersionExt Property

Extended version of active Commence application.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string VersionExt { get; }
Public ReadOnly Property VersionExt As String
    Get

Property Value

Type: String

Implements

ICommenceAppVersionExt
See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceApp Methods

The CommenceApp type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. Objects implementing this interface should be disposed after this. Important: object derived from this interface will also have their COM-references closed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceApp.Close Method

CommenceAppClose Method

Close any references to Commence. Objects implementing this interface should be disposed after this. Important: object derived from this interface will also have their COM-references closed.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

ICommenceAppClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

CommenceApp Class
Vovin.CmcLibNet Namespace


CommenceCOMException Class

Custom Commence COM exception thrown when a COM error occurs while talking to Commence.
Inheritance Hierarchy
SystemObject
SystemException
Vovin.CmcLibNetCommenceCOMException

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommenceCOMException : Exception
<SerializableAttribute>
Public Class CommenceCOMException
    Inherits Exception

The CommenceCOMException type exposes the following members.

Constructors
 | Name | Description
Public method | CommenceCOMException | default constructor.
Public method | CommenceCOMException(String) | overloaded constructor.
Public method | CommenceCOMException(String, Exception) | overloaded constructor.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Vovin.CmcLibNet Namespace


CommenceCOMException Constructor

Overload List
 | Name | Description
Public method | CommenceCOMException | default constructor.
Public method | CommenceCOMException(String) | overloaded constructor.
Public method | CommenceCOMException(String, Exception) | overloaded constructor.
Top
See Also

Reference

CommenceCOMException Class
Vovin.CmcLibNet Namespace


CommenceCOMException Constructor

default constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceCOMException()
Public Sub New
See Also

Reference

CommenceCOMException Class
CommenceCOMException Overload
Vovin.CmcLibNet Namespace


CommenceCOMException Constructor (String)

overloaded constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceCOMException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
Exception message.
See Also

Reference

CommenceCOMException Class
CommenceCOMException Overload
Vovin.CmcLibNet Namespace


CommenceCOMException Constructor (String, Exception)

overloaded constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceCOMException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
Exception message.
innerException
Type: SystemException
Inner exception.
See Also

Reference

CommenceCOMException Class
CommenceCOMException Overload
Vovin.CmcLibNet Namespace


CommenceCOMException Properties

The CommenceCOMException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CommenceCOMException Class
Vovin.CmcLibNet Namespace


CommenceCOMException Methods

The CommenceCOMException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CommenceCOMException Class
Vovin.CmcLibNet Namespace


CommenceDDEException Class

Custom Commence DDE Exception thrown when DDE call failed.
Inheritance Hierarchy
SystemObject
SystemException
Vovin.CmcLibNetCommenceDDEException

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommenceDDEException : Exception
<SerializableAttribute>
Public Class CommenceDDEException
    Inherits Exception

The CommenceDDEException type exposes the following members.

Constructors
 | Name | Description
Public method | CommenceDDEException | constructor.
Public method | CommenceDDEException(String) | overloaded constructor.
Public method | CommenceDDEException(String, Exception) | overloaded constructor.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Vovin.CmcLibNet Namespace


CommenceDDEException Constructor

Overload List
 | Name | Description
Public method | CommenceDDEException | constructor.
Public method | CommenceDDEException(String) | overloaded constructor.
Public method | CommenceDDEException(String, Exception) | overloaded constructor.
Top
See Also

Reference

CommenceDDEException Class
Vovin.CmcLibNet Namespace


CommenceDDEException Constructor

constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceDDEException()
Public Sub New
See Also

Reference

CommenceDDEException Class
CommenceDDEException Overload
Vovin.CmcLibNet Namespace


CommenceDDEException Constructor (String)

overloaded constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceDDEException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
Exception message.
See Also

Reference

CommenceDDEException Class
CommenceDDEException Overload
Vovin.CmcLibNet Namespace


CommenceDDEException Constructor (String, Exception)

overloaded constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceDDEException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
Exception message.
innerException
Type: SystemException
Inner exception.
See Also

Reference

CommenceDDEException Class
CommenceDDEException Overload
Vovin.CmcLibNet Namespace


CommenceDDEException Properties

The CommenceDDEException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CommenceDDEException Class
Vovin.CmcLibNet Namespace


CommenceDDEException Methods

The CommenceDDEException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CommenceDDEException Class
Vovin.CmcLibNet Namespace


CommenceMultipleInstancesException Class

Custom exception thrown when assembly is invoked while Commence is running more than 1 instance.
Inheritance Hierarchy
SystemObject
SystemException
Vovin.CmcLibNetCommenceMultipleInstancesException

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommenceMultipleInstancesException : Exception
<SerializableAttribute>
Public Class CommenceMultipleInstancesException
    Inherits Exception

The CommenceMultipleInstancesException type exposes the following members.

Constructors
 | Name | Description
Public method | CommenceMultipleInstancesException | default constructor.
Public method | CommenceMultipleInstancesException(String) | overloaded constructor.
Public method | CommenceMultipleInstancesException(String, Exception) | overloaded constructor.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Vovin.CmcLibNet Namespace


CommenceMultipleInstancesException Constructor

Overload List
 | Name | Description
Public method | CommenceMultipleInstancesException | default constructor.
Public method | CommenceMultipleInstancesException(String) | overloaded constructor.
Public method | CommenceMultipleInstancesException(String, Exception) | overloaded constructor.
Top
See Also

Reference

CommenceMultipleInstancesException Class
Vovin.CmcLibNet Namespace


CommenceMultipleInstancesException Constructor

default constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceMultipleInstancesException()
Public Sub New
See Also

Reference

CommenceMultipleInstancesException Class
CommenceMultipleInstancesException Overload
Vovin.CmcLibNet Namespace


CommenceMultipleInstancesException Constructor (String)

overloaded constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceMultipleInstancesException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
Exception message.
See Also

Reference

CommenceMultipleInstancesException Class
CommenceMultipleInstancesException Overload
Vovin.CmcLibNet Namespace


CommenceMultipleInstancesException Constructor (String, Exception)

overloaded constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceMultipleInstancesException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
Exception message.
innerException
Type: SystemException
Inner exception.
See Also

Reference

CommenceMultipleInstancesException Class
CommenceMultipleInstancesException Overload
Vovin.CmcLibNet Namespace


CommenceMultipleInstancesException Properties

The CommenceMultipleInstancesException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CommenceMultipleInstancesException Class
Vovin.CmcLibNet Namespace


CommenceMultipleInstancesException Methods

The CommenceMultipleInstancesException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CommenceMultipleInstancesException Class
Vovin.CmcLibNet Namespace


CommenceNotRunningException Class

Custom exception thrown when assembly is invoked while Commence is not running.
Inheritance Hierarchy
SystemObject
SystemException
Vovin.CmcLibNetCommenceNotRunningException

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommenceNotRunningException : Exception
<SerializableAttribute>
Public Class CommenceNotRunningException
    Inherits Exception

The CommenceNotRunningException type exposes the following members.

Constructors
 | Name | Description
Public method | CommenceNotRunningException | default constructor.
Public method | CommenceNotRunningException(String) | overloaded constructor.
Public method | CommenceNotRunningException(String, Exception) | overloaded constructor.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

Vovin.CmcLibNet Namespace


CommenceNotRunningException Constructor

Overload List
 | Name | Description
Public method | CommenceNotRunningException | default constructor.
Public method | CommenceNotRunningException(String) | overloaded constructor.
Public method | CommenceNotRunningException(String, Exception) | overloaded constructor.
Top
See Also

Reference

CommenceNotRunningException Class
Vovin.CmcLibNet Namespace


CommenceNotRunningException Constructor

default constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceNotRunningException()
Public Sub New
See Also

Reference

CommenceNotRunningException Class
CommenceNotRunningException Overload
Vovin.CmcLibNet Namespace


CommenceNotRunningException Constructor (String)

overloaded constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceNotRunningException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
Exception message.
See Also

Reference

CommenceNotRunningException Class
CommenceNotRunningException Overload
Vovin.CmcLibNet Namespace


CommenceNotRunningException Constructor (String, Exception)

overloaded constructor.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceNotRunningException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
Exception message.
innerException
Type: SystemException
Inner exception.
See Also

Reference

CommenceNotRunningException Class
CommenceNotRunningException Overload
Vovin.CmcLibNet Namespace


CommenceNotRunningException Properties

The CommenceNotRunningException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CommenceNotRunningException Class
Vovin.CmcLibNet Namespace


CommenceNotRunningException Methods

The CommenceNotRunningException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CommenceNotRunningException Class
Vovin.CmcLibNet Namespace


IApplication Interface

Application interface.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IApplication
Public Interface IApplication

The IApplication type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInfo | Returns information on the assembly. .Net only.
Public property | CommenceApp | Returns a reference to the Commence application
Public property | Database | Returns a reference to the Commence database.
Public property | Export | Returns a reference to the Export engine.
Public property | Services | Returns a reference to the Services utility.
Public property | Version | Returns assembly version.
Top
See Also

Reference

Vovin.CmcLibNet Namespace


IApplication Properties

The IApplication type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInfo | Returns information on the assembly. .Net only.
Public property | CommenceApp | Returns a reference to the Commence application
Public property | Database | Returns a reference to the Commence database.
Public property | Export | Returns a reference to the Export engine.
Public property | Services | Returns a reference to the Services utility.
Public property | Version | Returns assembly version.
Top
See Also

Reference

IApplication Interface
Vovin.CmcLibNet Namespace


IApplication.AssemblyInfo Property

IApplicationAssemblyInfo Property

Returns information on the assembly. .Net only.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
AssemblyInfo AssemblyInfo { get; }
ReadOnly Property AssemblyInfo As AssemblyInfo
    Get

Property Value

Type: AssemblyInfo
See Also

Reference

IApplication Interface
Vovin.CmcLibNet Namespace


IApplication.CommenceApp Property

IApplicationCommenceApp Property

Returns a reference to the Commence application

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceApp CommenceApp { get; }
ReadOnly Property CommenceApp As ICommenceApp
    Get

Property Value

Type: ICommenceApp
See Also

Reference

IApplication Interface
Vovin.CmcLibNet Namespace


IApplication.Database Property

IApplicationDatabase Property

Returns a reference to the Commence database.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceDatabase Database { get; }
ReadOnly Property Database As ICommenceDatabase
    Get

Property Value

Type: ICommenceDatabase
See Also

Reference

IApplication Interface
Vovin.CmcLibNet Namespace


IApplication.Export Property

IApplicationExport Property

Returns a reference to the Export engine.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IExportEngine Export { get; }
ReadOnly Property Export As IExportEngine
    Get

Property Value

Type: IExportEngine
See Also

Reference

IApplication Interface
Vovin.CmcLibNet Namespace


IApplication.Services Property

IApplicationServices Property

Returns a reference to the Services utility.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IServices Services { get; }
ReadOnly Property Services As IServices
    Get

Property Value

Type: IServices
See Also

Reference

IApplication Interface
Vovin.CmcLibNet Namespace


IApplication.Version Property

IApplicationVersion Property

Returns assembly version.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Version { get; }
ReadOnly Property Version As String
    Get

Property Value

Type: String
See Also

Reference

IApplication Interface
Vovin.CmcLibNet Namespace


ICommenceApp Interface

Interface for CommenceApp.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceApp
Public Interface ICommenceApp

The ICommenceApp type exposes the following members.

Properties
 | Name | Description
Public property | ExePath | Path to commence.exe.
Public property | Name | Name of currently open Commence database.
Public property | Path | Path of currently open Commence database.
Public property | RegisteredUser | Registered user of current Commence database.
Public property | Version | Version of active Commence application.
Public property | VersionExt | Extended version of active Commence application.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. Objects implementing this interface should be disposed after this. Important: object derived from this interface will also have their COM-references closed.
Top
See Also

Reference

Vovin.CmcLibNet Namespace


ICommenceApp Properties

The ICommenceApp type exposes the following members.

Properties
 | Name | Description
Public property | ExePath | Path to commence.exe.
Public property | Name | Name of currently open Commence database.
Public property | Path | Path of currently open Commence database.
Public property | RegisteredUser | Registered user of current Commence database.
Public property | Version | Version of active Commence application.
Public property | VersionExt | Extended version of active Commence application.
Top
See Also

Reference

ICommenceApp Interface
Vovin.CmcLibNet Namespace


ICommenceApp.ExePath Property

ICommenceAppExePath Property

Path to commence.exe.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ExePath { get; }
ReadOnly Property ExePath As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceApp Interface
Vovin.CmcLibNet Namespace


ICommenceApp.Name Property

ICommenceAppName Property

Name of currently open Commence database.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceApp Interface
Vovin.CmcLibNet Namespace


ICommenceApp.Path Property

ICommenceAppPath Property

Path of currently open Commence database.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Path { get; }
ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceApp Interface
Vovin.CmcLibNet Namespace


ICommenceApp.RegisteredUser Property

ICommenceAppRegisteredUser Property

Registered user of current Commence database.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string RegisteredUser { get; }
ReadOnly Property RegisteredUser As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceApp Interface
Vovin.CmcLibNet Namespace


ICommenceApp.Version Property

ICommenceAppVersion Property

Version of active Commence application.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Version { get; }
ReadOnly Property Version As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceApp Interface
Vovin.CmcLibNet Namespace


ICommenceApp.VersionExt Property

ICommenceAppVersionExt Property

Extended version of active Commence application.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string VersionExt { get; }
ReadOnly Property VersionExt As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceApp Interface
Vovin.CmcLibNet Namespace


ICommenceApp Methods

The ICommenceApp type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. Objects implementing this interface should be disposed after this. Important: object derived from this interface will also have their COM-references closed.
Top
See Also

Reference

ICommenceApp Interface
Vovin.CmcLibNet Namespace


ICommenceApp.Close Method

ICommenceAppClose Method

Close any references to Commence. Objects implementing this interface should be disposed after this. Important: object derived from this interface will also have their COM-references closed.

Namespace: Vovin.CmcLibNet
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

ICommenceApp Interface
Vovin.CmcLibNet Namespace


Vovin.CmcLibNet.Database Namespace

Contains all 'native' ICommenceDB database functionality, All FormOA.ICommenceConversation functionality is exposed as direct methods, there is no need to tap into GetConversation. FormOA.ICommenceCursor is implemented pretty much *as is*, with a few nifty additions.
Classes
Class Description
Public class BaseCursorFilter
CursorFilter is a an abstract base class for the various Commence filters you can create. Use CursorFilters.Add to get a derived filter object that exposes properties only applicable to that filtertype. This shields you from having to use the horrible DDE syntax the ViewFilter request takes. You can still set filters the old-fashioned way via CommenceCursor.SetFilter.
Public class BaseRowSet
Abstract base class for the various *RowSet Types.
Public class CommenceAddRowSet
Represents a AddRowSet to add items to Commence.
Public class CommenceCursor
Wrapper around the Commence FormOA.ICommenceCursor interface.
Public class CommenceDatabase
.Net Wrapper around the Commence database API.

COM clients can instantiate this by using the ProgId CmcLibNet.Database.

So from VBScript you would do:
VBScript
Copy
Dim db : Set db = CreateObject("CmcLibNet.Database")
'.. do stuff ..
db.Close
Set db = Nothing

When used fom a Commence Item Detail Form or Office VBA, be sure to read up on the Close method.

Public class CommenceDeleteRowSet
Represent a rowset of items to delete. Items are not deleted until Commit is called.
Public class CommenceEditRowSet
Represents a rowset of items to edit.
Public class CommenceQueryRowSet
Represents a rowset of items to query.
Public class CursorColumns
Convenience class for setting multiple columns in a cursor. Should not be combined with the direct methods of setting columns in ICommenceCursor.
CursorFilters
Class for creating, removing and applying Cursor filters.

This is significantly different from the usual way of filtering in Commence API.

See code samples below.

Public class CursorFilterTypeCTCF
Represents a filter of type 'Connection To Category Field' (CTCF).
Public class CursorFilterTypeCTCTI
Represents a filter of type 'Connection To Connected Item' (CTCTI).
Public class CursorFilterTypeCTI
Represents a filter of type 'Item Connected To Item' (CTI).
Public class CursorFilterTypeF
Represents a filter of type 'Field' (F).
Interfaces
Interface Description
Public interface IBaseRowSet
Exposes methods and properties shared by all rowset types.
Public interface ICommenceAddRowSet
Interface for CommenceAddRowSet.
Public interface ICommenceCursor
CommenceCursor interface.
Public interface ICommenceDatabase
Exposes all 'native' Commence API database functionality, including all functionality provided by the DDE interface (ICommenceConversation). There is no need to use DDE syntax with CmcLibNet, all DDE plumbing is hidden from the end user.

You cannot get a reference to FormOA.ICommenceConversation from CmcLibNet.

COM clients can reference this interface by using the ProgId CmcLibNet.Database.

VBScript:
VBScript
Copy
Dim db : Set db = CreateObject("CmcLibNet.Database")
'.. do stuff ..
db.Close
Set db = Nothing

When used fom a Commence Item Detail Form or Office VBA, be sure to read up on the Close method.

Public interface ICommenceDeleteRowSet
Interface for CommenceDeleteRowSet
Public interface ICommenceEditRowSet
interface for CommenceEditRowSet
Public interface ICommenceQueryRowSet
Interface for CommenceQueryRowSet
Public interface ICursorColumns
Interface for CursorColumns, allows for a convenient way of setting direct and related columns.
Public interface ICursorFilter
Exposes members of CursorFilter, a base class for all filters.
Public interface ICursorFilters
Exposes members of the CursorFilters class. For code examples see CursorFilters.
Public interface ICursorFilterTypeCTCF
Interface for CursorFilterTypeCTCF.
Public interface ICursorFilterTypeCTCTI
interface for CursorFilterTypeCTCTI.
Public interface ICursorFilterTypeCTI
Interface for CursorFilterTypeCTI.
Public interface ICursorFilterTypeF
Interface for CursorFilterTypeF.
Enumerations
 | Enumeration | Description
Public enumeration | CmcCursorBookmark | Cursor's rowpointer enum
Public enumeration | CmcCursorType | Cursor flags enum; determines what type of cursor to create.
Public enumeration | CmcLinkMode | Link modes used with View linking. Only used in the GetViewToFile method.
Public enumeration | CmcOptionFlags | Commence option flags.
Public enumeration | CommenceFieldType | Commence field types.
Public enumeration | FilterQualifier | Valid qualifiers used in a Commence ViewFilter request.
Public enumeration | FilterType | Filter Types that a Commence ViewFilter request can use, i.e. the filters you can apply to Commence.


BaseCursorFilter Class

CursorFilter is a an abstract base class for the various Commence filters you can create. Use CursorFilters.Add to get a derived filter object that exposes properties only applicable to that filtertype. This shields you from having to use the horrible DDE syntax the ViewFilter request takes. You can still set filters the old-fashioned way via CommenceCursor.SetFilter.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseCursorFilter
Vovin.CmcLibNet.DatabaseCursorFilterTypeCTCF
Vovin.CmcLibNet.DatabaseCursorFilterTypeCTCTI
Vovin.CmcLibNet.DatabaseCursorFilterTypeCTI
Vovin.CmcLibNet.DatabaseCursorFilterTypeF

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract class BaseCursorFilter : ICursorFilter
Public MustInherit Class BaseCursorFilter
    Implements ICursorFilter

The BaseCursorFilter type exposes the following members.

Properties
 | Name | Description
Public property | ClauseNumber | Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8.
Public property | Except | Except flag. Set to true to create a Except (NOT) filter.
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]].
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting.
Top
See Also

Reference

Vovin.CmcLibNet.Database Namespace


BaseCursorFilter Properties

The BaseCursorFilter type exposes the following members.

Properties
 | Name | Description
Public property | ClauseNumber | Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8.
Public property | Except | Except flag. Set to true to create a Except (NOT) filter.
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]].
Top
See Also

Reference

BaseCursorFilter Class


BaseCursorFilter.ClauseNumber Property

BaseCursorFilterClauseNumber Property

Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int ClauseNumber { get; set; }
Public Property ClauseNumber As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICursorFilterClauseNumber
See Also

Reference

BaseCursorFilter Class


BaseCursorFilter.Except Property

BaseCursorFilterExcept Property

Except flag. Set to true to create a Except (NOT) filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Except { get; set; }
Public Property Except As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterExcept
See Also

Reference

BaseCursorFilter Class


BaseCursorFilter.FiltertypeIdentifier Property

BaseCursorFilterFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract string FiltertypeIdentifier { get; }
Public MustOverride ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String

Implements

ICursorFilterFiltertypeIdentifier
See Also

Reference

BaseCursorFilter Class


BaseCursorFilter.OrFilter Property

BaseCursorFilterOrFilter Property

Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'.

The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items.

Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]].

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool OrFilter { get; set; }
Public Property OrFilter As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterOrFilter
See Also

Reference

BaseCursorFilter Class


BaseCursorFilter Methods

The BaseCursorFilter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting.
Top
See Also

Reference

BaseCursorFilter Class


BaseCursorFilter.GetViewFilterString Method

BaseCursorFilterGetViewFilterString Method

Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public virtual string GetViewFilterString()
Public Overridable Function GetViewFilterString As String

Return Value

Type: String
ViewFilter string.

Implements

ICursorFilterGetViewFilterString
Remarks
If you use CmcLibNet through COM Interop, for instance in Commence Form Script, you may have no way of inspecting the filter in an IDE. This method returns the string representation of the filter.
See Also

Reference

BaseCursorFilter Class


BaseCursorFilter.ToString Method

BaseCursorFilterToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting.
Top
See Also

Reference

BaseCursorFilter Class


BaseCursorFilter.ToString Method (Func(ICursorFilter, String))

BaseCursorFilterToString Method (FuncICursorFilter, String)

Overload allowing custom formatting.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ToString(
    Func<ICursorFilter, string> formatter
)
Public Function ToString (
    formatter As Func(Of ICursorFilter, String)
) As String

Parameters

formatter
Type: SystemFunc ICursorFilter, String
Func<IbaseCusrorFilter, string>.

Return Value

Type: String
Output of Func

Implements

ICursorFilterToString(FuncICursorFilter, String)
Remarks
Only available to .Net clients.
See Also

Reference

BaseCursorFilter Class
ToString Overload


BaseRowSet Class

Abstract base class for the various *RowSet Types.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseRowSet
Vovin.CmcLibNet.DatabaseCommenceAddRowSet
Vovin.CmcLibNet.DatabaseCommenceDeleteRowSet
Vovin.CmcLibNet.DatabaseCommenceEditRowSet
Vovin.CmcLibNet.DatabaseCommenceQueryRowSet

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract class BaseRowSet : IBaseRowSet,
    IDisposable
Public MustInherit Class BaseRowSet
    Implements IBaseRowSet, IDisposable

The BaseRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Dispose method
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


BaseRowSet Properties

The BaseRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
See Also

Reference

BaseRowSet Class


BaseRowSet.ColumnCount Property

BaseRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract int ColumnCount { get; }
Public MustOverride ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetColumnCount
See Also

Reference

BaseRowSet Class


BaseRowSet.RowCount Property

BaseRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract int RowCount { get; }
Public MustOverride ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetRowCount
See Also

Reference

BaseRowSet Class


BaseRowSet Methods

The BaseRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Dispose method
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BaseRowSet Class


BaseRowSet.Close Method

BaseRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract void Close()
Public MustOverride Sub Close

Implements

IBaseRowSetClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

BaseRowSet Class


BaseRowSet.Dispose Method

BaseRowSetDispose Method

Dispose method

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

BaseRowSet Class


BaseRowSet.GetColumnIndex Method

BaseRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public MustOverride Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.

Implements

IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
See Also

Reference

BaseRowSet Class


BaseRowSet.GetColumnLabel Method

BaseRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public MustOverride Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.

Implements

IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
See Also

Reference

BaseRowSet Class


BaseRowSet.GetRow Method

BaseRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Top
See Also

Reference

BaseRowSet Class


BaseRowSet.GetRow Method (Int32, CmcOptionFlags)

BaseRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public MustOverride Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, CmcOptionFlags)
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

BaseRowSet Class
GetRow Overload


BaseRowSet.GetRow Method (Int32, String, CmcOptionFlags)

BaseRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public MustOverride Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
See Also

Reference

BaseRowSet Class
GetRow Overload


BaseRowSet.GetRowValue Method

BaseRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public MustOverride Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.

Implements

IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
See Also

Reference

BaseRowSet Class


BaseRowSet.GetShared Method

BaseRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public abstract bool GetShared(
    int nRow
)
Public MustOverride Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.

Implements

IBaseRowSetGetShared(Int32)
See Also

Reference

BaseRowSet Class


CmcCursorBookmark Enumeration

Cursor's rowpointer enum

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum CmcCursorBookmark
Public Enumeration CmcCursorBookmark
Members
Member name | Value | Description
Beginning | 0 | Move rows starting from first row in cursor.
Current | 1 | Move rows starting from current row in cursor.
End | 2 | Move rows starting from last row in cursor.
See Also

Reference


CmcCursorType Enumeration

Cursor flags enum; determines what type of cursor to create.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum CmcCursorType
Public Enumeration CmcCursorType
Members
Member name | Value | Description
Category | 0 | Use a category.
View | 1 | Use a view.
PilotAb | 2 | Use the fields as defined for the Palm Pilot Address Book.
PilotMemo | 3 | Use the fields as defined for the Palm Pilot Memo.
PilotToDo | 5 | Use the fields as defined for the Palm Pilot To-Do list.
PilotAppt | 6 | Use the fields as defined for the Palm Pilot Calendar.
OutlookAb | 7 | Use the fields as defined for the Microsoft Outlook Address book.
OutlookAppt | 8 | Use the fields as defined for the Microsoft Outlook Calendar.
EmailLog | 9 | Use the fields as defined for the E-mail Log category.
OutlookTask | 10 | Use the fields as defined for the Microsoft Outlook Tasks.
Merge | 11 | Based cursor on the view used when Send Letter command was called.
See Also

Reference


CmcLinkMode Enumeration

Link modes used with View linking. Only used in the GetViewToFile method.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum CmcLinkMode
Public Enumeration CmcLinkMode
Members
Member name | Value | Description
None | 0 | No linkmode.
SelectedItem | 1 | Treat view as if filtered on selected item.
SelectedDate | 2 | Treat view as if filtered on selected date
SelectedDateRange | 3 | Treat view as if filtered on between data A and date B
See Also

Reference


CmcOptionFlags Enumeration

Commence option flags.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[FlagsAttribute]
public enum CmcOptionFlags
<FlagsAttribute>
Public Enumeration CmcOptionFlags
Members
Member name | Value | Description
Default | 0 | Default flag.
Fieldname | 1 | Indicates fieldnames should be used, columnnames ignored.
All | 2 | Used to request all fields from a category.
Shared | 4 | Mark item as shared when adding items.
PalmPilot | 8 | Obsolete. Changes from 3Com Palm Pilot.
Canonical | 16 | Make Commence return data in canonical (i.e. consistent) format.
Internet | 32 | Allows for the Agent subsystem to distinguish between Internet/Intranet database operations.
UseThids | 256 | (Undocumented by Commence) Make Commence return THIDs instead of Name field values. Use *RowSet.GetRowID() on a cursor defined with thids flag to get a row's THID
IgnoreSyncCondition | 512 | (Undocumented by Commence) Unknown.
See Also

Reference


CommenceAddRowSet Class

Represents a AddRowSet to add items to Commence.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseRowSet
Vovin.CmcLibNet.DatabaseCommenceAddRowSet

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public sealed class CommenceAddRowSet : BaseRowSet,
    ICommenceAddRowSet, IBaseRowSet, IDisposable
Public NotInheritable Class CommenceAddRowSet
    Inherits BaseRowSet
    Implements ICommenceAddRowSet, IBaseRowSet, IDisposable

The CommenceAddRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset (Overrides BaseRowSetColumnCount.)
Public property | RowCount | Number of items in rowset. (Overrides BaseRowSetRowCount.)
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this. (Overrides BaseRowSetClose.)
Public method | Commit | Commit changes to disk.
Public method | CommitGetCursor | Make row modifications permanent (commit to disk) and return a cursor for the newly added data. The CommenceAddRowSet should now be discarded.
Public method | Dispose | Dispose method (Inherited from BaseRowSet.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label (Overrides BaseRowSetGetColumnIndex(String, CmcOptionFlags).)
Public method | GetColumnLabel | Search the column set and return the column label or fieldname (Overrides BaseRowSetGetColumnLabel(Int32, CmcOptionFlags).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Public method | GetRowValue | Get rowvalue for specified row/column (Overrides BaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags).)
Public method | GetShared | Gets the shared/local status of the row (Overrides BaseRowSetGetShared(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifyRow | Modify fieldvalue
Public method | SetShared | Sets the shared status of the row. Shared items cannot be made unshared.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


CommenceAddRowSet Properties

The CommenceAddRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset (Overrides BaseRowSetColumnCount.)
Public property | RowCount | Number of items in rowset. (Overrides BaseRowSetRowCount.)
Top
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.ColumnCount Property

CommenceAddRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceAddRowSetColumnCount
IBaseRowSetColumnCount
IBaseRowSetColumnCount
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.RowCount Property

CommenceAddRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int RowCount { get; }
Public Overrides ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceAddRowSetRowCount
IBaseRowSetRowCount
IBaseRowSetRowCount
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet Methods

The CommenceAddRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this. (Overrides BaseRowSetClose.)
Public method | Commit | Commit changes to disk.
Public method | CommitGetCursor | Make row modifications permanent (commit to disk) and return a cursor for the newly added data. The CommenceAddRowSet should now be discarded.
Public method | Dispose | Dispose method (Inherited from BaseRowSet.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label (Overrides BaseRowSetGetColumnIndex(String, CmcOptionFlags).)
Public method | GetColumnLabel | Search the column set and return the column label or fieldname (Overrides BaseRowSetGetColumnLabel(Int32, CmcOptionFlags).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Public method | GetRowValue | Get rowvalue for specified row/column (Overrides BaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags).)
Public method | GetShared | Gets the shared/local status of the row (Overrides BaseRowSetGetShared(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifyRow | Modify fieldvalue
Public method | SetShared | Sets the shared status of the row. Shared items cannot be made unshared.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.Close Method

CommenceAddRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override void Close()
Public Overrides Sub Close

Implements

ICommenceAddRowSetClose
IBaseRowSetClose
IBaseRowSetClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.Commit Method

CommenceAddRowSetCommit Method

Commit changes to disk.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int Commit(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function Commit (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.

Implements

ICommenceAddRowSetCommit(CmcOptionFlags)
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.CommitGetCursor Method

CommenceAddRowSetCommitGetCursor Method

Make row modifications permanent (commit to disk) and return a cursor for the newly added data. The CommenceAddRowSet should now be discarded.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceCursor CommitGetCursor(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function CommitGetCursor (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As CommenceCursor

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: CommenceCursor
CommenceCursor object reflecting the changes.

Implements

ICommenceAddRowSetCommitGetCursor(CmcOptionFlags)
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.GetColumnIndex Method

CommenceAddRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.

Implements

ICommenceAddRowSetGetColumnIndex(String, CmcOptionFlags)
IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.GetColumnLabel Method

CommenceAddRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.

Implements

ICommenceAddRowSetGetColumnLabel(Int32, CmcOptionFlags)
IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.GetRow Method

CommenceAddRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Top
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.GetRow Method (Int32, CmcOptionFlags)

CommenceAddRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

ICommenceAddRowSetGetRow(Int32, CmcOptionFlags)
IBaseRowSetGetRow(Int32, CmcOptionFlags)
IBaseRowSetGetRow(Int32, CmcOptionFlags)
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

CommenceAddRowSet Class
GetRow Overload


CommenceAddRowSet.GetRow Method (Int32, String, CmcOptionFlags)

CommenceAddRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

ICommenceAddRowSetGetRow(Int32, String, CmcOptionFlags)
IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
See Also

Reference

CommenceAddRowSet Class
GetRow Overload


CommenceAddRowSet.GetRowValue Method

CommenceAddRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.

Implements

ICommenceAddRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.GetShared Method

CommenceAddRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override bool GetShared(
    int nRow
)
Public Overrides Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.

Implements

ICommenceAddRowSetGetShared(Int32)
IBaseRowSetGetShared(Int32)
IBaseRowSetGetShared(Int32)
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.ModifyRow Method

CommenceAddRowSetModifyRow Method

Modify fieldvalue

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int ModifyRow(
    int nRow,
    int nCol,
    string fieldValue,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function ModifyRow (
    nRow As Integer,
    nCol As Integer,
    fieldValue As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
nCol
Type: SystemInt32
The (0-based) index of the column.
fieldValue
Type: SystemString
new fieldValue.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.

Implements

ICommenceAddRowSetModifyRow(Int32, Int32, String, CmcOptionFlags)
See Also

Reference

CommenceAddRowSet Class


CommenceAddRowSet.SetShared Method

CommenceAddRowSetSetShared Method

Sets the shared status of the row. Shared items cannot be made unshared.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetShared(
    int nRow
)
Public Function SetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
True on success.

Implements

ICommenceAddRowSetSetShared(Int32)
See Also

Reference

CommenceAddRowSet Class


CommenceCursor Class

Wrapper around the Commence FormOA.ICommenceCursor interface.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseCommenceCursor

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class CommenceCursor : ICommenceCursor,
    IDisposable
Public Class CommenceCursor
    Implements ICommenceCursor, IDisposable

The CommenceCursor type exposes the following members.

Properties
 | Name | Description
Public property | Category | Name of the category this cursor is based on.
Public property | ColumnCount | Number of columns in cursor.
Public property | Columns | Allows for setting multiple direct and related columns at once.
Public property | Filters | Gets collection of filters to be applied on cursor. It is recommended you use this property over setting filterstrings directly.
Public property | MaxFieldSize | Maximum field size. Gets the maximum number of characters that can be read from a Commence field. Undocumented by Commence. The default value is 93750.
Public property | MaxRows | Maximum number of rows a cursor can contain. Undocumented by Commence. Effectively a measure for database capacity.
Public property | RowCount | Number of items in cursor.
Public property | Shared | (read-only) TRUE if category is shared in a workgroup.
Public property | View | Name of the View if cursor is based on a view.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Public implementation of Dispose pattern callable by consumers.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToFile | Exports current cursor to a file. WARNING: The cursor is disposed after this method!
Public method | GetAddRowSet | Create a rowset of new items to add to the database.
Public method | GetColumnNames | Get columnames from cursor. Defaults to fieldnames
Public method | GetDeleteRowSet(CmcOptionFlags) | Create a rowset of ALL existing items for deletion. Use with care!
Public method | GetDeleteRowSet(Int32, CmcOptionFlags) | Create a rowset of n items for deletion.
Public method | GetDeleteRowSetByID | Create a rowset for deleting a particular row.
Public method | GetEditRowSet(CmcOptionFlags) | Create a rowset of all existing items for editing. Be careful when handling very large rowsets.
Public method | GetEditRowSet(Int32, CmcOptionFlags) | Create a rowset of existing items for editing.
Public method | GetEditRowSetByID | Create a rowset for editing a particular row.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetQueryRowSet(CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSet(Int32, CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSetByID | Create a rowset object with a particular row loaded.
Public method | GetQueryRowSetByThid | Create a rowset object with a particular thid loaded. Only applies to shared items. Cursor must have the thids thids flag.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDuplicates | Checks if field contains duplicate values.
Public method | ReadAllRows | Read all data from a cursor. This method is just a convenient way to return data without having to create a ICommenceQueryRowSet. Keep in mind reading data from Commence is quite slow! For more advanced reading and export options see IExportEngine.
Public method | ReadRow | Reads specified row from the cursor. This method is just a convenient way to return data without having to create a ICommenceQueryRowSet. If you need to apply formatting, see the IExportEngine interface.
Public method | SeekRow | Seek to row in cursor.
Public method | SeekRowApprox | Move a fractional number of rows.
Public method | SetActiveDate | Set active date used for view cursors using a view linking filter.
Public method | SetActiveDateRange | Set active date range used for view cursors using a view linking filter.
Public method | SetActiveItem | Set active item used for view cursors using a view linking filter.
Public method | SetColumn | Defines the column set for the cursor
Public method | SetColumns | Allows for setting direct columns in batch-mode
Public method | SetFilter | Defines the filter for the cursor. Not recommended, use Filters instead.
Public method | SetLogic | Defines the filter logic for the cursor. Not recommended, use Filters instead.
Public method | SetRelatedColumn | Define column for a connected field. Allows for retrieving other than just the Name field from connections.
Public method | SetSort | Defines the sort criteria for the cursor. Use this only if you apply filters with the SetFilter method. You are strongly advised to use the Filters collection instead.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


CommenceCursor Properties

The CommenceCursor type exposes the following members.

Properties
 | Name | Description
Public property | Category | Name of the category this cursor is based on.
Public property | ColumnCount | Number of columns in cursor.
Public property | Columns | Allows for setting multiple direct and related columns at once.
Public property | Filters | Gets collection of filters to be applied on cursor. It is recommended you use this property over setting filterstrings directly.
Public property | MaxFieldSize | Maximum field size. Gets the maximum number of characters that can be read from a Commence field. Undocumented by Commence. The default value is 93750.
Public property | MaxRows | Maximum number of rows a cursor can contain. Undocumented by Commence. Effectively a measure for database capacity.
Public property | RowCount | Number of items in cursor.
Public property | Shared | (read-only) TRUE if category is shared in a workgroup.
Public property | View | Name of the View if cursor is based on a view.
Top
See Also

Reference

CommenceCursor Class


CommenceCursor.Category Property

CommenceCursorCategory Property

Name of the category this cursor is based on.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get

Property Value

Type: String

Implements

ICommenceCursorCategory
See Also

Reference

CommenceCursor Class


CommenceCursor.ColumnCount Property

CommenceCursorColumnCount Property

Number of columns in cursor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int ColumnCount { get; }
Public ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceCursorColumnCount
See Also

Reference

CommenceCursor Class


CommenceCursor.Columns Property

CommenceCursorColumns Property

Allows for setting multiple direct and related columns at once.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICursorColumns Columns { get; }
Public ReadOnly Property Columns As ICursorColumns
    Get

Property Value

Type: ICursorColumns

Implements

ICommenceCursorColumns
Remarks
Do not use this in conjunction with SetColumn or SetRelatedColumn methods. Set all columns at once using this property, or set them individually.

Only available for .NET applications.

See Also

Reference

CommenceCursor Class


CommenceCursor.Filters Property

CommenceCursorFilters Property

Gets collection of filters to be applied on cursor. It is recommended you use this property over setting filterstrings directly.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICursorFilters Filters { get; }
Public ReadOnly Property Filters As ICursorFilters
    Get

Property Value

Type: ICursorFilters

Implements

ICommenceCursorFilters
See Also

Reference

CommenceCursor Class


CommenceCursor.MaxFieldSize Property

CommenceCursorMaxFieldSize Property

Maximum field size. Gets the maximum number of characters that can be read from a Commence field. Undocumented by Commence. The default value is 93750.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int MaxFieldSize { get; set; }
Public Property MaxFieldSize As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICommenceCursorMaxFieldSize
Remarks
Be careful with setting this to a large value. It obviously impacts memory usage, and may make Commence go unresponsive for a long time, especially when you have columns defined with SetRelatedColumn(Int32, String, String, String, CmcOptionFlags)!

This property is not documented by Commence.

See Also

Reference

CommenceCursor Class


CommenceCursor.MaxRows Property

CommenceCursorMaxRows Property

Maximum number of rows a cursor can contain. Undocumented by Commence. Effectively a measure for database capacity.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int MaxRows { get; }
Public ReadOnly Property MaxRows As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceCursorMaxRows
Remarks
At least up until Commence version RM 6.0, a Commence category can hold up to 500.000 items.
See Also

Reference

CommenceCursor Class


CommenceCursor.RowCount Property

CommenceCursorRowCount Property

Number of items in cursor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int RowCount { get; }
Public ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceCursorRowCount
See Also

Reference

CommenceCursor Class


CommenceCursor.Shared Property

CommenceCursorShared Property

(read-only) TRUE if category is shared in a workgroup.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Shared { get; }
Public ReadOnly Property Shared As Boolean
    Get

Property Value

Type: Boolean

Implements

ICommenceCursorShared
See Also

Reference

CommenceCursor Class


CommenceCursor.View Property

CommenceCursorView Property

Name of the View if cursor is based on a view.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string View { get; }
Public ReadOnly Property View As String
    Get

Property Value

Type: String

Implements

ICommenceCursorView
See Also

Reference

CommenceCursor Class


CommenceCursor Methods

The CommenceCursor type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Public implementation of Dispose pattern callable by consumers.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToFile | Exports current cursor to a file. WARNING: The cursor is disposed after this method!
Public method | GetAddRowSet | Create a rowset of new items to add to the database.
Public method | GetColumnNames | Get columnames from cursor. Defaults to fieldnames
Public method | GetDeleteRowSet(CmcOptionFlags) | Create a rowset of ALL existing items for deletion. Use with care!
Public method | GetDeleteRowSet(Int32, CmcOptionFlags) | Create a rowset of n items for deletion.
Public method | GetDeleteRowSetByID | Create a rowset for deleting a particular row.
Public method | GetEditRowSet(CmcOptionFlags) | Create a rowset of all existing items for editing. Be careful when handling very large rowsets.
Public method | GetEditRowSet(Int32, CmcOptionFlags) | Create a rowset of existing items for editing.
Public method | GetEditRowSetByID | Create a rowset for editing a particular row.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetQueryRowSet(CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSet(Int32, CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSetByID | Create a rowset object with a particular row loaded.
Public method | GetQueryRowSetByThid | Create a rowset object with a particular thid loaded. Only applies to shared items. Cursor must have the thids thids flag.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasDuplicates | Checks if field contains duplicate values.
Public method | ReadAllRows | Read all data from a cursor. This method is just a convenient way to return data without having to create a ICommenceQueryRowSet. Keep in mind reading data from Commence is quite slow! For more advanced reading and export options see IExportEngine.
Public method | ReadRow | Reads specified row from the cursor. This method is just a convenient way to return data without having to create a ICommenceQueryRowSet. If you need to apply formatting, see the IExportEngine interface.
Public method | SeekRow | Seek to row in cursor.
Public method | SeekRowApprox | Move a fractional number of rows.
Public method | SetActiveDate | Set active date used for view cursors using a view linking filter.
Public method | SetActiveDateRange | Set active date range used for view cursors using a view linking filter.
Public method | SetActiveItem | Set active item used for view cursors using a view linking filter.
Public method | SetColumn | Defines the column set for the cursor
Public method | SetColumns | Allows for setting direct columns in batch-mode
Public method | SetFilter | Defines the filter for the cursor. Not recommended, use Filters instead.
Public method | SetLogic | Defines the filter logic for the cursor. Not recommended, use Filters instead.
Public method | SetRelatedColumn | Define column for a connected field. Allows for retrieving other than just the Name field from connections.
Public method | SetSort | Defines the sort criteria for the cursor. Use this only if you apply filters with the SetFilter method. You are strongly advised to use the Filters collection instead.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceCursor Class


CommenceCursor.Close Method

CommenceCursorClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

ICommenceCursorClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

CommenceCursor Class


CommenceCursor.Dispose Method

CommenceCursorDispose Method

Public implementation of Dispose pattern callable by consumers.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

CommenceCursor Class


CommenceCursor.ExportToFile Method

CommenceCursorExportToFile Method

Exports current cursor to a file. WARNING: The cursor is disposed after this method!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void ExportToFile(
    string fileName,
    IExportSettings settings = null
)
Public Sub ExportToFile (
    fileName As String,
    Optional settings As IExportSettings = Nothing
)

Parameters

fileName
Type: SystemString
(Fully qualified) filename. Overwrites existing file.
settings (Optional)
Type: Vovin.CmcLibNet.ExportIExportSettings
IExportSettings object.

Implements

ICommenceCursorExportToFile(String, IExportSettings)
Remarks
The PreserveAllConnections options is ignored in this method. Alternatively, but extremely slow, you can use either the UseDDE option or crank up the MaxFieldSize value and hope you have enough RAM memory.
See Also

Reference

CommenceCursor Class


CommenceCursor.GetAddRowSet Method

CommenceCursorGetAddRowSet Method

Create a rowset of new items to add to the database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceAddRowSet GetAddRowSet(
    int nRows,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetAddRowSet (
    nRows As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceAddRowSet

Parameters

nRows
Type: SystemInt32
Number of rows to create.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: Shared - all rows default to shared.

Return Value

Type: ICommenceAddRowSet
ICommenceAddRowSet object.

Implements

ICommenceCursorGetAddRowSet(Int32, CmcOptionFlags)
See Also

Reference

CommenceCursor Class


CommenceCursor.GetColumnNames Method

CommenceCursorGetColumnNames Method

Get columnames from cursor. Defaults to fieldnames

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IEnumerable<string> GetColumnNames(
    CmcOptionFlags flags = CmcOptionFlags.Fieldname
)
Public Function GetColumnNames (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Fieldname
) As IEnumerable(Of String)

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
CmcOptionFlags, defaults to Fieldname

Return Value

Type: IEnumerable String
List of columnames.

Implements

ICommenceCursorGetColumnNames(CmcOptionFlags)
Remarks

This method is only available in .NET.

Pass Default to retrieve fieldlabels instead of fieldnames.

See Also

Reference

CommenceCursor Class


CommenceCursor.GetDeleteRowSet Method

CommenceCursorGetDeleteRowSet Method

Overload List
 | Name | Description
Public method | GetDeleteRowSet(CmcOptionFlags) | Create a rowset of ALL existing items for deletion. Use with care!
Public method | GetDeleteRowSet(Int32, CmcOptionFlags) | Create a rowset of n items for deletion.
Top
See Also

Reference

CommenceCursor Class


CommenceCursor.GetDeleteRowSet Method (CmcOptionFlags)

CommenceCursorGetDeleteRowSet Method (CmcOptionFlags)

Create a rowset of ALL existing items for deletion. Use with care!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceDeleteRowSet GetDeleteRowSet(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetDeleteRowSet (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceDeleteRowSet

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceDeleteRowSet
ICommenceDeleteRowSet on success.

Implements

ICommenceCursorGetDeleteRowSet(CmcOptionFlags)
Remarks
This method is only available to .NET applications.
See Also

Reference

CommenceCursor Class
GetDeleteRowSet Overload


CommenceCursor.GetDeleteRowSet Method (Int32, CmcOptionFlags)

CommenceCursorGetDeleteRowSet Method (Int32, CmcOptionFlags)

Create a rowset of n items for deletion.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceDeleteRowSet GetDeleteRowSet(
    int nRows,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetDeleteRowSet (
    nRows As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceDeleteRowSet

Parameters

nRows
Type: SystemInt32
Number of rows to retrieve.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceDeleteRowSet
ICommenceDeleteRowSet on success.

Implements

ICommenceCursorGetDeleteRowSet(Int32, CmcOptionFlags)
See Also

Reference

CommenceCursor Class
GetDeleteRowSet Overload


CommenceCursor.GetDeleteRowSetByID Method

CommenceCursorGetDeleteRowSetByID Method

Create a rowset for deleting a particular row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceDeleteRowSet GetDeleteRowSetByID(
    string pRowID,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetDeleteRowSetByID (
    pRowID As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceDeleteRowSet

Parameters

pRowID
Type: SystemString
Unique ID string obtained from GetRowID().
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceDeleteRowSet
ICommenceDeleteRowSet on success.

Implements

ICommenceCursorGetDeleteRowSetByID(String, CmcOptionFlags)
See Also

Reference

CommenceCursor Class


CommenceCursor.GetEditRowSet Method

CommenceCursorGetEditRowSet Method

Overload List
 | Name | Description
Public method | GetEditRowSet(CmcOptionFlags) | Create a rowset of all existing items for editing. Be careful when handling very large rowsets.
Public method | GetEditRowSet(Int32, CmcOptionFlags) | Create a rowset of existing items for editing.
Top
See Also

Reference

CommenceCursor Class


CommenceCursor.GetEditRowSet Method (CmcOptionFlags)

CommenceCursorGetEditRowSet Method (CmcOptionFlags)

Create a rowset of all existing items for editing. Be careful when handling very large rowsets.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceEditRowSet GetEditRowSet(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetEditRowSet (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceEditRowSet

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceEditRowSet
ICommenceEditRowSet object on success.

Implements

ICommenceCursorGetEditRowSet(CmcOptionFlags)
Remarks
This method is only available for .Net consumers.
See Also

Reference

CommenceCursor Class
GetEditRowSet Overload


CommenceCursor.GetEditRowSet Method (Int32, CmcOptionFlags)

CommenceCursorGetEditRowSet Method (Int32, CmcOptionFlags)

Create a rowset of existing items for editing.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceEditRowSet GetEditRowSet(
    int nRows,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetEditRowSet (
    nRows As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceEditRowSet

Parameters

nRows
Type: SystemInt32
Number of rows to retrieve.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceEditRowSet
ICommenceEditRowSet object.

Implements

ICommenceCursorGetEditRowSet(Int32, CmcOptionFlags)
See Also

Reference

CommenceCursor Class
GetEditRowSet Overload


CommenceCursor.GetEditRowSetByID Method

CommenceCursorGetEditRowSetByID Method

Create a rowset for editing a particular row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceEditRowSet GetEditRowSetByID(
    string pRowID,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetEditRowSetByID (
    pRowID As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceEditRowSet

Parameters

pRowID
Type: SystemString
Unique ID string obtained from GetRowID().
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceEditRowSet
ICommenceEditRowSet object.

Implements

ICommenceCursorGetEditRowSetByID(String, CmcOptionFlags)
See Also

Reference

CommenceCursor Class


CommenceCursor.GetQueryRowSet Method

CommenceCursorGetQueryRowSet Method

Overload List
 | Name | Description
Public method | GetQueryRowSet(CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSet(Int32, CmcOptionFlags) | Create a rowset object with the results of a query.
Top
See Also

Reference

CommenceCursor Class


CommenceCursor.GetQueryRowSet Method (CmcOptionFlags)

CommenceCursorGetQueryRowSet Method (CmcOptionFlags)

Create a rowset object with the results of a query.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceQueryRowSet GetQueryRowSet(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetQueryRowSet (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceQueryRowSet

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceQueryRowSet
ICommenceQueryRowSet object on success.

Implements

ICommenceCursorGetQueryRowSet(CmcOptionFlags)
Remarks
This method is only available to .NET applications.
See Also

Reference

CommenceCursor Class
GetQueryRowSet Overload


CommenceCursor.GetQueryRowSet Method (Int32, CmcOptionFlags)

CommenceCursorGetQueryRowSet Method (Int32, CmcOptionFlags)

Create a rowset object with the results of a query.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceQueryRowSet GetQueryRowSet(
    int nRows,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetQueryRowSet (
    nRows As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceQueryRowSet

Parameters

nRows
Type: SystemInt32
Maximum number of rows to retrieve.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceQueryRowSet
ICommenceQueryRowSet object on success.

Implements

ICommenceCursorGetQueryRowSet(Int32, CmcOptionFlags)
See Also

Reference

CommenceCursor Class
GetQueryRowSet Overload


CommenceCursor.GetQueryRowSetByID Method

CommenceCursorGetQueryRowSetByID Method

Create a rowset object with a particular row loaded.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceQueryRowSet GetQueryRowSetByID(
    string pRowID,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetQueryRowSetByID (
    pRowID As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceQueryRowSet

Parameters

pRowID
Type: SystemString
Unique ID string obtained from GetRowID(Int32, CmcOptionFlags).
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceQueryRowSet
ICommenceQueryRowSet on success.

Implements

ICommenceCursorGetQueryRowSetByID(String, CmcOptionFlags)
See Also

Reference

CommenceCursor Class


CommenceCursor.GetQueryRowSetByThid Method

CommenceCursorGetQueryRowSetByThid Method

Create a rowset object with a particular thid loaded. Only applies to shared items. Cursor must have the thids thids flag.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceQueryRowSet GetQueryRowSetByThid(
    string pThid,
    CmcOptionFlags flags = CmcOptionFlags.UseThids
)
Public Function GetQueryRowSetByThid (
    pThid As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.UseThids
) As ICommenceQueryRowSet

Parameters

pThid
Type: SystemString
THID parts "thidId : thidSequence" (i.e., omit the leading category part).
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceQueryRowSet
ICommenceQueryRowSet on success

Implements

ICommenceCursorGetQueryRowSetByThid(String, CmcOptionFlags)
Remarks
Undocumented by Commence.
See Also

Reference

CommenceCursor Class


CommenceCursor.HasDuplicates Method

CommenceCursorHasDuplicates Method

Checks if field contains duplicate values.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool HasDuplicates(
    string columnName,
    bool caseSensitive = true
)
Public Function HasDuplicates (
    columnName As String,
    Optional caseSensitive As Boolean = true
) As Boolean

Parameters

columnName
Type: SystemString
Columname in cursor to compare. Column must exist in the cursor.
caseSensitive (Optional)
Type: SystemBoolean
Perform case-sensitive check, default is true.

Return Value

Type: Boolean
true if duplicates are found.

Implements

ICommenceCursorHasDuplicates(String, Boolean)
Exceptions
Exception | Condition
CommenceCOMException | Column not present in cursor.
See Also

Reference

CommenceCursor Class


CommenceCursor.ReadAllRows Method

CommenceCursorReadAllRows Method

Read all data from a cursor.

This method is just a convenient way to return data without having to create a ICommenceQueryRowSet.

Keep in mind reading data from Commence is quite slow!

For more advanced reading and export options see IExportEngine.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<List<string>> ReadAllRows(
    int batchRows = 1000
)
Public Function ReadAllRows (
    Optional batchRows As Integer = 1000
) As List(Of List(Of String))

Parameters

batchRows (Optional)
Type: SystemInt32
Number of rows to read per iteration.

Return Value

Type: List List String
List of lists containing commence rowvalues, null on error.

Implements

ICommenceCursorReadAllRows(Int32)
Remarks
This method is not available to COM clients.

If the cursor has the UseThids flag defined, the first element of the inner list will contain the thid. In that case the inner list count will be the number of columns in the category plus one.

See Also

Reference

CommenceCursor Class


CommenceCursor.ReadRow Method

CommenceCursorReadRow Method

Reads specified row from the cursor.

This method is just a convenient way to return data without having to create a ICommenceQueryRowSet.

If you need to apply formatting, see the IExportEngine interface.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> ReadRow(
    int lRow
)
Public Function ReadRow (
    lRow As Integer
) As List(Of String)

Parameters

lRow
Type: SystemInt32
Row to read. Row is 0-based, from beginning of cursor.

Return Value

Type: List String
List of rowvalues, null on error.

Implements

ICommenceCursorReadRow(Int32)
Remarks
This method is only available in .NET.

If the cursor has the UseThids flag defined, the first element of the inner list will contain the thid. In that case the inner list count will be the number of columns in the category plus one.

See Also

Reference

CommenceCursor Class


CommenceCursor.SeekRow Method

CommenceCursorSeekRow Method

Seek to row in cursor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int SeekRow(
    CmcCursorBookmark bkOrigin,
    int nRows
)
Public Function SeekRow (
    bkOrigin As CmcCursorBookmark,
    nRows As Integer
) As Integer

Parameters

bkOrigin
Type: Vovin.CmcLibNet.DatabaseCmcCursorBookmark
Starting row.
nRows
Type: SystemInt32
Number of rows to move pointer.

Return Value

Type: Int32
Number of rows moved, -1 on error.

Implements

ICommenceCursorSeekRow(CmcCursorBookmark, Int32)
See Also

Reference

CommenceCursor Class


CommenceCursor.SeekRowApprox Method

CommenceCursorSeekRowApprox Method

Move a fractional number of rows.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int SeekRowApprox(
    int nNumerator,
    int nDenominator
)
Public Function SeekRowApprox (
    nNumerator As Integer,
    nDenominator As Integer
) As Integer

Parameters

nNumerator
Type: SystemInt32
Numerator.
nDenominator
Type: SystemInt32
Denominator.

Return Value

Type: Int32
Number of rows moved, -1 on error.

Implements

ICommenceCursorSeekRowApprox(Int32, Int32)
See Also

Reference

CommenceCursor Class


CommenceCursor.SetActiveDate Method

CommenceCursorSetActiveDate Method

Set active date used for view cursors using a view linking filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetActiveDate(
    string sDate,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function SetActiveDate (
    sDate As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

sDate
Type: SystemString
Date (string).
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Option flags, must be 0.

Return Value

Type: Boolean
true on succes, false on error.

Implements

ICommenceCursorSetActiveDate(String, CmcOptionFlags)
See Also

Reference

CommenceCursor Class


CommenceCursor.SetActiveDateRange Method

CommenceCursorSetActiveDateRange Method

Set active date range used for view cursors using a view linking filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetActiveDateRange(
    string startDate,
    string endDate,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function SetActiveDateRange (
    startDate As String,
    endDate As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

startDate
Type: SystemString
Date (string)
endDate
Type: SystemString
Date (string)
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Option flags, must be 0.

Return Value

Type: Boolean
true on succes, false on error.

Implements

ICommenceCursorSetActiveDateRange(String, String, CmcOptionFlags)
See Also

Reference

CommenceCursor Class


CommenceCursor.SetActiveItem Method

CommenceCursorSetActiveItem Method

Set active item used for view cursors using a view linking filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetActiveItem(
    string pCategoryName,
    string pRowID,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function SetActiveItem (
    pCategoryName As String,
    pRowID As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

pCategoryName
Type: SystemString
Category name of the active item used with view linking filter.
pRowID
Type: SystemString
Unique ID string obtained from GetRowID() indicating the active item used with view linking filter.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0.

Return Value

Type: Boolean
true on succes, false on error.

Implements

ICommenceCursorSetActiveItem(String, String, CmcOptionFlags)
See Also

Reference

CommenceCursor Class


CommenceCursor.SetColumn Method

CommenceCursorSetColumn Method

Defines the column set for the cursor

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetColumn(
    int nColumn,
    string pName,
    CmcOptionFlags flags
)
Public Function SetColumn (
    nColumn As Integer,
    pName As String,
    flags As CmcOptionFlags
) As Boolean

Parameters

nColumn
Type: SystemInt32
The (0-based) index of the column to set.
pName
Type: SystemString
Name of the field to use in this column.
flags
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: All - create column set of all fields.

Return Value

Type: Boolean
true on succes, false on error.

Implements

ICommenceCursorSetColumn(Int32, String, CmcOptionFlags)
Remarks
Do not skip or duplicate indexes. Related columns must come after the direct columns.

Using SetColumns(Object) offers a more convenient way to set columns.

See Also

Reference

CommenceCursor Class


CommenceCursor.SetColumns Method

CommenceCursorSetColumns Method

Allows for setting direct columns in batch-mode

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetColumns(
    Object[] columnNames
)
Public Function SetColumns (
    columnNames As Object()
) As Boolean

Parameters

columnNames
Type: SystemObject
Object array of columnnames.

Return Value

Type: Boolean
true on succes, false on error.

Implements

ICommenceCursorSetColumns(Object)
Remarks
Note the object and not string type of the array, this is to accomodate COM clients.
See Also

Reference

CommenceCursor Class


CommenceCursor.SetFilter Method

CommenceCursorSetFilter Method

Defines the filter for the cursor. Not recommended, use Filters instead.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetFilter(
    string pFilter,
    CmcOptionFlags flags
)
Public Function SetFilter (
    pFilter As String,
    flags As CmcOptionFlags
) As Boolean

Parameters

pFilter
Type: SystemString
Fully formatted [ViewFilter()] DDE request command.
flags
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be Default

Return Value

Type: Boolean
true on succes, false on error.

Implements

ICommenceCursorSetFilter(String, CmcOptionFlags)
See Also

Reference

CommenceCursor Class
ICommenceCursorFilters


CommenceCursor.SetLogic Method

CommenceCursorSetLogic Method

Defines the filter logic for the cursor. Not recommended, use Filters instead.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetLogic(
    string pLogic,
    CmcOptionFlags flags
)
Public Function SetLogic (
    pLogic As String,
    flags As CmcOptionFlags
) As Boolean

Parameters

pLogic
Type: SystemString
Fully formatted [ViewConjunction()] DDE request command.
flags
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be CmcOptionFlags.Default

Return Value

Type: Boolean
true on succes, false on error.

Implements

ICommenceCursorSetLogic(String, CmcOptionFlags)
See Also

Reference

CommenceCursor Class


CommenceCursor.SetRelatedColumn Method

CommenceCursorSetRelatedColumn Method

Define column for a connected field. Allows for retrieving other than just the Name field from connections.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetRelatedColumn(
    int nColumn,
    string pConnName,
    string pCatName,
    string pName,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function SetRelatedColumn (
    nColumn As Integer,
    pConnName As String,
    pCatName As String,
    pName As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

nColumn
Type: SystemInt32
The (0-based) index of the column to set.
pConnName
Type: SystemString
Name of the connection to use in this column.
pCatName
Type: SystemString
Name of the connected Category to use in this column.
pName
Type: SystemString
Name of the field in the connected category to use in this column
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: All - create column set of all fields.

Return Value

Type: Boolean
true on succes, false on error.

Implements

ICommenceCursorSetRelatedColumn(Int32, String, String, String, CmcOptionFlags)
Remarks
Setting the CmcOptionFlags.All flag *only* affects direct fields in the cursor. It cannot be used to obtain all fields from the connected category.
See Also

Reference

CommenceCursor Class


CommenceCursor.SetSort Method

CommenceCursorSetSort Method

Defines the sort criteria for the cursor. Use this only if you apply filters with the SetFilter method. You are strongly advised to use the Filters collection instead.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetSort(
    string pSort,
    CmcOptionFlags flags
)
Public Function SetSort (
    pSort As String,
    flags As CmcOptionFlags
) As Boolean

Parameters

pSort
Type: SystemString
Text defining the new sort criteria. Syntax is identical to the one used by the DDE ViewSort request.
flags
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: Boolean
Returns true on succes, false on error.

Implements

ICommenceCursorSetSort(String, CmcOptionFlags)
See Also

Reference

CommenceCursor Class


CommenceDatabase Class

.Net Wrapper around the Commence database API.

COM clients can instantiate this by using the ProgId CmcLibNet.Database.

So from VBScript you would do:
VBScript
Copy
Dim db : Set db = CreateObject("CmcLibNet.Database")
'.. do stuff ..
db.Close
Set db = Nothing

When used fom a Commence Item Detail Form or Office VBA, be sure to read up on the Close method.

Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseCommenceDatabase

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class CommenceDatabase : ICommenceDatabase,
    IDisposable
Public Class CommenceDatabase
    Implements ICommenceDatabase, IDisposable

The CommenceDatabase type exposes the following members.

Constructors
 | Name | Description
Public method | CommenceDatabase | Public constructor.
Top
Properties
 | Name | Description
Public property | Delim | Delimiter used in DDE requests. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.
Public property | Delim2 | Secondary delimiter used in DDE requests that act on connections. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.
Public property | EncodeDDEArguments | Make assembly try to string-escape DDE arguments. Default is true.
Public property | Name | Name of currently open Commence database.
Public property | Path | Path of currently open Commence database.
Top
Methods
Name Description
Public method AddItem
Adds the indicated Item to the Category. Fields other than the Name field are set to their default values. (Default values for date fields must not specify date ranges, e.g., "every day"). By default, the new item is local (i.e., non-shared) CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled. Note: If a clarify field is defined for the category (but is not a Sequence Number field), the clarify field value can be specified using the optional third parameter, Clarify Value. Alternatively, the Item parameter can be a clarified item name. If the clarify field is a Sequence Number field, then the field value is determined automatically by Commence. An error results if the AddItem REQUEST tries to set a Sequence Number field. Use GetFieldDefinition to determine the Sequence Number field value so a clarified item name can be used with subsequent EditItems.
Public method AddSharedItem
Identical in function to AddItem except that it creates a shared item, provided that the database is connected and the category is shared. Otherwise a local item is created. CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled.
Public method AppendText
Appends text to an existing text Field. Use this command to overcome the 256 character maximum string limitation of certain macro languages (such as WordBasic). Whenever possible, use a clarified item name. You are strongly advised to use a ICommenceEditRowSet for editing fields instead.

When an item was just created with AddItem(String, String, String) or AddSharedItem(String, String, String), this is the item that will be used for appending. Otherwise, unless you specifically mark an item (using GetMarkItem(String, String, String) or MarkActiveItem(String)) the first match will be used.

Public method AssignConnection
Assigns a connection between two items.
Public method CheckInFormScript
Updates the detail form script with the text in the specified Filename.
Public method CheckOutFormScript
Saves the detail form script to file.
Public method ClarifyItemNames
Specifies whether Commence should return clarified item names, or leave bStatus empty to get the current status.
Public method Close
Close any references to Commence. The object should be disposed after this.
Public method DeleteItem
Deletes the indicated Item from the Category. This action cannot be undone. Whenever possible, use a clarified item name.
Public method DeleteView
Deletes the specified view. Use with caution! This action cannot be undone.
Public method Dispose
Dispose
Public method EditItem
Sets the value of Field to Value for the item identified by Item in Category. Field must not specify a Calculation field. Date fields may not specify a range, (e.g., "every day"). Whenever possible, use a clarified Item name.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method ExportDatabaseSchema
Exports the schema information to file. Defaults to Json.
Public method FieldValueExists
Checks to see if value is already present for given field.
FireTrigger
Fires the indicated Agent Trigger.
Public method GetActiveCategory
Gets the category of the active item or view.
Public method GetActiveItemName
Gets the itemname of the active item. Use MarkActiveItem(String) to try and get a clariefied itemname.
Public method GetActiveViewInfo
Returms information on the currently active view (if any).
Public method GetCallerID(String, String)
Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method GetCallerID(String, String, String)
Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method GetCategoryCount
Returns number of categories in the Commence database.
Public method GetCategoryDefinition
Returns information on the definition of the specified category.
Public method GetCategoryNames
Gets a list of categories in the current Commence database.
Public method GetCategoryNames(String)
Gets a list of category names.
Public method GetClarifiedItemName
Construct a clarified item name from the unclarified itemname, the clarify separator and the clarify value
Public method GetClarifyField
Gets the clarifyfield for the specified category.
Public method GetClarifySeparator
Gets the clarify separator for the specified category.
Public method GetConnectedItemCount
Gets the number of connected items in connected category for the specified item
Public method GetConnectedItemField
Returns the indirect field value(s) in connCategory that itemName of the categoryName is connected to via Connection. The order of the items in the list is arbitrary (i.e., not sorted).
Public method GetConnectedItemNames(String, String, String, String)
Gets a list of items connected to the specified item.
Public method GetConnectedItemNames(String, String, String, String, String)
Returns the list of items in category that named item is connected to. The order of the items in the list is arbitrary (i.e., not sorted).
Public method GetConnectionCount
Gets the number of connections from the specified category.
Public method GetConnectionNames(String)
Gets a list of connection names to the specified category.
Public method GetConnectionNames(String, String, String)
Gets the connection names for the specified category.
Public method GetCursor(String)
Get a CommenceCursor object that wraps the native FormOA.ICommenceCursor interface.
Public method GetCursor(String, CmcCursorType, CmcOptionFlags)
Get a CommenceCursor object that wraps the native FormOA.ICommenceCursor interface.
Public method GetDatabase Obsolete.
(Not implemented) Get the active Commence database name and path as delimited string. See Name and/or Path.
Public method GetDatabaseDefinition
Queries Commence for information on the database definition.
Public method GetDatabaseSchema
Gets a serializable object containnig the Commence schema definition.
Public method GetDesktopCount
Gets the number of Desktops in the Commence database.
Public method GetDesktopNames
Get a list of desktopnames.
Public method GetDesktopNames(String)
Gets the desktop names in the Commence database.
Public method GetField
Returns a fieldvalue from the specified Commence item.
Public method GetFieldCount
Gets the number of fields in the specified category.
Public method GetFieldDefinition
Queries Commence for information on the specified field definition.
Public method GetFieldNames(String)
Gets a list of fieldnames for the specified Commence category.
Public method GetFieldNames(String, String)
Gets the fieldnames for the specified category.
Public method GetFields(String, String, ListString)
Gets values of specified field(s) from specified item.
Public method GetFields(String, String, Object, String)
Gets values of specified field(s) from specified item.
Public method GetFieldToFile
Writes a single fieldvalue to file.
Public method GetFormCount
Gets the number of Item Detail Forms for the specified category.
Public method GetFormNames(String)
Gets a list of all Item Detail Form names in specified category.
Public method GetFormNames(String, String)
Gets the Item detail Form names for the specified category
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetImageFieldCount
Gets the number of image fields in specified category.
Public method GetImageFieldNames(String)
Gets a list of all field of type 'image' from the specified category.
Public method GetImageFieldNames(String, String)
Gets the image-type field names for the specified category.
Public method GetImageFieldToFile
Copies the image field identified by the named Category, Item, and Field to the specified Filename. Only bitmap (.BMP) format image fields are currently supported. Filename must be a fully qualified path including the drive letter (e.g. c:\tmp\data.bmp). If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten. It is the client’s responsibility to perform the necessary file cleanup. If the image field is blank, no file is written.
Public method GetItemCount
Gets the number of items in the specified category.
Public method GetItemNames(String)
Gets a list of all itemnames in the specified category.
Public method GetItemNames(String, String)
Gets the item names for the specified category
Public method GetLastError
Gets the last error that occurred during DDE conversation. Inspect this value if a call failed.
Public method GetLetterViewInfo
Returns information about the active view and selected letter template at the time the Tools-Send Letter or Customize-Database-Letter Template command was executed. This call is used by the Commence letter macros and has not been implemented here.
Public method GetMarkItem
"Marks" the specified item and makes it the default category and item for subsequent calls to: EditItem, DeleteItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands, and GetField, GetFieldToFile, GetFields, GetConnectedItemCount and GetConnectedItemNames REQUESTS. The category and item is marked only for the specific DDE conversation, not globally. that is, each DDE conversation can have a different marked item. Can be used to mark the (-Me-) item if one is defined. Syntax: [GetMarkItem("(-Me-)")] Note: If a Clarify Field is defined for the category, the value of the clarify field can be specified with an optional third paramter. Alternatively, the ItemName can be a clarified item name.
Public method GetMeField
Gets a fieldvalue from the item defined as (-Me-) item in Commence.
Public method GetNameField
Get the name of the namefield for the specified category.
Public method GetPhoneNumber
TAPI must be configured for GetPhoneNumber to work properly. TAPI is ancient, so this method is not implemented.
Public method GetPreference
Get preference settings.
Public method GetReverseName
Uses Commence preference information and reverses the name if appropriate.
Public method GetTriggerCount
Gets the number of DDE agent triggers defined in the database.
Public method GetTriggerNames
Get a list of Agent triggers.
Public method GetTriggerNames(String)
Gets the trigger names defined in the database.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetViewColumnNames
Gets the columnnames from a view provided a cursor can be created on them.
Public method GetViewCount
Gets the number of views in the specified category.
Public method GetViewDefinition
Get definition of a view
Public method GetViewNames(String)
Gets a list of all views for the specified category. Returns all categories if category is not specified.
Public method GetViewNames(String, String)
Gets a list of view names for the specified category.
Public method GetViewToFile
Saves the Commence View to a file in HTML format (similar to the File-Save As HTML menu command). If the file does not exist, Commence will create it; the drive and directory must exist. If the file exists, it will be overwritten.
Public method HasDuplicates
Checks if field contains duplicate values.
Public method LogPhoneCall
Launches an add tem detail window for an item in the Phone Log category (as specified in the Commence Customize-Preferences-Event Logs dialog box). One or more Category/Item pairs may be given as arguments; connections will be set between the new Phone Log item and these items. If no connection exists between the two categories, the pair is ignored and no error is given. The connection is set via all connections found between the two categories. If no Phone Log category is set, NACK error code 104 (DDE_ERROR_NOLOGCLASS) is returned. If there is no room to add an item in the Phone Log category, NACK error code 112 (DDE_ERROR_FULL) is returned.
Public method MarkActiveItem
Marks the active item for subsequent requests.
Public method MergeTemplateCreate
Creates a new template with the given parameters. If template exists, the call fails. This call returns the template filename assigned by Commence, including the full path and extension configured in Preferences-Letter dialog.
Public method MergeTemplateSave
Updates an existing template identified by the name parameter. Template must exist, else the call fails.
Public method PromoteItemToShared
Promotes a local item to shared status, provided the database is connected and the category is shared. If the item is already shared, its status is unchanged. Note that there is no way to demote an item from shared to local status. Whenever possible, use a clarified Item name.
Public method ShowDesktop
Opens the specified desktop in Commence.
Public method ShowItem
Opens an item detail window in Commence for the given Item in the given Category. If a detail is already open for the item, it will be brought to the top and given the focus.
Public method ShowView
Opens the specified view in Commence. If the view is already open, it will become the active view.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UnassignConnection
Unassigns a connection between two items.
Public method ViewCategory
Defines the category to be used. This must be the first message sent to Commence for a ViewData conversation. ViewCategory may be sent at any time to reset the ViewData conversation state. ViewData conversation topic has been obsolete since Commence 3.0 (1995 or so), so it is extremely unlikely you will ever need this method.
Public method ViewConjunction
Defines the logical operations that link the filter clauses specified with the ViewFilter request. Each parameter can be either "And" or "Or"; the default value is "And". AndOr12 defines the relationship between the filter clauses 1 and 2, AndOr34 for clauses 3 and 4, and AndOr13 for (1 and 2) and (3 and 4), etc. Note the special significance of AndOr48, which signifies the relationship between the two groups of 4 filters.

The logical precedence is: (Filter1 AndOr12 Filter2) AndOr13 (Filter3 AndOr34 Filter4) AndOr4to8 [repeat 5 to 8]

Public method ViewConnectedCount
Returns the number of items in the connCategory that the Indexth item is connected to via ConnectionName.
Public method ViewConnectedField
Returns the value of Field of the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.
Public method ViewConnectedFields(Int32, String, String, Int32, ListString, String)
Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method ViewConnectedFields(Int32, String, String, Int32, Object, String)
Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method ViewConnectedItem
Returns the ConnIndexth item in connCategory that the Indexth item is connected to via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value.
Public method ViewDeleteAllItems
USE WITH EXTREME CAUTION! Deletes all items that satisfy the currently defined filter. If no filter is defined, deletes all items in the previously named category, see ViewCategory(String). Fails without warning when no delete permissions were granted on the category.
Public method ViewField
Returns the value of Field of the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount REQUEST to determine the maximum Index value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.
Public method ViewFields(Int32, ListString, String)
Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method ViewFields(Int32, Object, String)
Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method ViewFieldToFile
Saves specified field to file
Public method ViewFilter
Defines the criteria for the multiple filter to be applied against the previously named category/view (see ViewCategory/ViewView). This is by far the most complicated API method to use. Unless you are actually creating views from code, you are strongly advised to use the Filters collection of the CommenceCursor class instead.
Public method ViewImageFieldToFile
Copies the image field data in Field from the Indexth item that satisfies the currently defined filter (if any) to the specified Filename.
Public method ViewItemCount
Returns the number of items that satisfy the currently defined filter (if any). If no filter is defined, this request returns the total number of items in the category
Public method ViewItemIndex
Returns the index of the item with the indicated name field value. The item must also satisfy the currently defined filter (if any). Use a clarified itemname if possible. Note: If the NameFieldValue is left blank, the marked item will be used. Returns the index of the marked item (if any).
Public method ViewItemName
Returns the itemname for the Indexth item. Different from ViewField(Index, Name) in that a clarified item name may be returned. The ClarifyItemNames request is used to enable or disable the use of clarified item names.
Public method ViewMarkItem
Marks the Indexth item in the view and makes it the default category and item for the EditItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands.
Public method ViewReverseName
Uses Commence preference information and reverses the name if appropriate.
Public method ViewSaveView
Saves the virtual DDE view already created with the ViewCategory, ViewFilter, ViewSort, etc., as an actual view in Commence, accessible via the normal user interface. The view will be saved using the specified New View Name. If the view already exists, it will be overwritten. Use GetViewNames to determine if the view name conflicts with an existing view.
Public method ViewSort
Defines the sort criteria for the view. Field1, Field2, Field3, and Field4 define the fields to sort by. Sort1, Sort2, Sort3, and Sort4 define the sort type and should be "Ascending" or "Descending". Unused sort pairs (i.e. FieldN, SortN) may be omitted.
Public method ViewView
Uses the category and filter criteria of a Commence View that has already be defined from the Commence menu interface. The ViewView REQUEST overrides any previously received ViewCategory, ViewConjunction, ViewFilter, and ViewSort REQUESTS. If the ViewName parameter is left blank, the active view will be used.
Top
Remarks
Most of the documentation on this interface was copied 'verbatim' from the Commence help files.
See Also

Reference


CommenceDatabase Constructor

Public constructor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceDatabase()
Public Sub New
See Also

Reference

CommenceDatabase Class


CommenceDatabase Properties

The CommenceDatabase type exposes the following members.

Properties
 | Name | Description
Public property | Delim | Delimiter used in DDE requests. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.
Public property | Delim2 | Secondary delimiter used in DDE requests that act on connections. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.
Public property | EncodeDDEArguments | Make assembly try to string-escape DDE arguments. Default is true.
Public property | Name | Name of currently open Commence database.
Public property | Path | Path of currently open Commence database.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.Delim Property

CommenceDatabaseDelim Property

Delimiter used in DDE requests. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Delim { get; set; }
Public Property Delim As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceDatabaseDelim
See Also

Reference

CommenceDatabase Class


CommenceDatabase.Delim2 Property

CommenceDatabaseDelim2 Property

Secondary delimiter used in DDE requests that act on connections. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Delim2 { get; set; }
Public Property Delim2 As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceDatabaseDelim2
See Also

Reference

CommenceDatabase Class


CommenceDatabase.EncodeDDEArguments Property

CommenceDatabaseEncodeDDEArguments Property

Make assembly try to string-escape DDE arguments. Default is true.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool EncodeDDEArguments { get; set; }
Public Property EncodeDDEArguments As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICommenceDatabaseEncodeDDEArguments
Remarks
By default, all arguments passed to DDE requests will be enclosed in double-quotes. Setting this to false allows you to have fine-grained control over the format of the parameters.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.Name Property

CommenceDatabaseName Property

Name of currently open Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Implements

ICommenceDatabaseName
See Also

Reference

CommenceDatabase Class


CommenceDatabase.Path Property

CommenceDatabasePath Property

Path of currently open Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String

Implements

ICommenceDatabasePath
See Also

Reference

CommenceDatabase Class


CommenceDatabase Methods

The CommenceDatabase type exposes the following members.

Methods
Name Description
Public method AddItem
Adds the indicated Item to the Category. Fields other than the Name field are set to their default values. (Default values for date fields must not specify date ranges, e.g., "every day"). By default, the new item is local (i.e., non-shared) CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled. Note: If a clarify field is defined for the category (but is not a Sequence Number field), the clarify field value can be specified using the optional third parameter, Clarify Value. Alternatively, the Item parameter can be a clarified item name. If the clarify field is a Sequence Number field, then the field value is determined automatically by Commence. An error results if the AddItem REQUEST tries to set a Sequence Number field. Use GetFieldDefinition to determine the Sequence Number field value so a clarified item name can be used with subsequent EditItems.
Public method AddSharedItem
Identical in function to AddItem except that it creates a shared item, provided that the database is connected and the category is shared. Otherwise a local item is created. CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled.
Public method AppendText
Appends text to an existing text Field. Use this command to overcome the 256 character maximum string limitation of certain macro languages (such as WordBasic). Whenever possible, use a clarified item name. You are strongly advised to use a ICommenceEditRowSet for editing fields instead.

When an item was just created with AddItem(String, String, String) or AddSharedItem(String, String, String), this is the item that will be used for appending. Otherwise, unless you specifically mark an item (using GetMarkItem(String, String, String) or MarkActiveItem(String)) the first match will be used.

Public method AssignConnection
Assigns a connection between two items.
Public method CheckInFormScript
Updates the detail form script with the text in the specified Filename.
Public method CheckOutFormScript
Saves the detail form script to file.
Public method ClarifyItemNames
Specifies whether Commence should return clarified item names, or leave bStatus empty to get the current status.
Public method Close
Close any references to Commence. The object should be disposed after this.
Public method DeleteItem
Deletes the indicated Item from the Category. This action cannot be undone. Whenever possible, use a clarified item name.
Public method DeleteView
Deletes the specified view. Use with caution! This action cannot be undone.
Public method Dispose
Dispose
Public method EditItem
Sets the value of Field to Value for the item identified by Item in Category. Field must not specify a Calculation field. Date fields may not specify a range, (e.g., "every day"). Whenever possible, use a clarified Item name.
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Public method ExportDatabaseSchema
Exports the schema information to file. Defaults to Json.
Public method FieldValueExists
Checks to see if value is already present for given field.
FireTrigger
Fires the indicated Agent Trigger.
Public method GetActiveCategory
Gets the category of the active item or view.
Public method GetActiveItemName
Gets the itemname of the active item. Use MarkActiveItem(String) to try and get a clariefied itemname.
Public method GetActiveViewInfo
Returms information on the currently active view (if any).
Public method GetCallerID(String, String)
Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method GetCallerID(String, String, String)
Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method GetCategoryCount
Returns number of categories in the Commence database.
Public method GetCategoryDefinition
Returns information on the definition of the specified category.
Public method GetCategoryNames
Gets a list of categories in the current Commence database.
Public method GetCategoryNames(String)
Gets a list of category names.
Public method GetClarifiedItemName
Construct a clarified item name from the unclarified itemname, the clarify separator and the clarify value
Public method GetClarifyField
Gets the clarifyfield for the specified category.
Public method GetClarifySeparator
Gets the clarify separator for the specified category.
Public method GetConnectedItemCount
Gets the number of connected items in connected category for the specified item
Public method GetConnectedItemField
Returns the indirect field value(s) in connCategory that itemName of the categoryName is connected to via Connection. The order of the items in the list is arbitrary (i.e., not sorted).
Public method GetConnectedItemNames(String, String, String, String)
Gets a list of items connected to the specified item.
Public method GetConnectedItemNames(String, String, String, String, String)
Returns the list of items in category that named item is connected to. The order of the items in the list is arbitrary (i.e., not sorted).
Public method GetConnectionCount
Gets the number of connections from the specified category.
Public method GetConnectionNames(String)
Gets a list of connection names to the specified category.
Public method GetConnectionNames(String, String, String)
Gets the connection names for the specified category.
Public method GetCursor(String)
Get a CommenceCursor object that wraps the native FormOA.ICommenceCursor interface.
Public method GetCursor(String, CmcCursorType, CmcOptionFlags)
Get a CommenceCursor object that wraps the native FormOA.ICommenceCursor interface.
Public method GetDatabase Obsolete.
(Not implemented) Get the active Commence database name and path as delimited string. See Name and/or Path.
Public method GetDatabaseDefinition
Queries Commence for information on the database definition.
Public method GetDatabaseSchema
Gets a serializable object containnig the Commence schema definition.
Public method GetDesktopCount
Gets the number of Desktops in the Commence database.
Public method GetDesktopNames
Get a list of desktopnames.
Public method GetDesktopNames(String)
Gets the desktop names in the Commence database.
Public method GetField
Returns a fieldvalue from the specified Commence item.
Public method GetFieldCount
Gets the number of fields in the specified category.
Public method GetFieldDefinition
Queries Commence for information on the specified field definition.
Public method GetFieldNames(String)
Gets a list of fieldnames for the specified Commence category.
Public method GetFieldNames(String, String)
Gets the fieldnames for the specified category.
Public method GetFields(String, String, ListString)
Gets values of specified field(s) from specified item.
Public method GetFields(String, String, Object, String)
Gets values of specified field(s) from specified item.
Public method GetFieldToFile
Writes a single fieldvalue to file.
Public method GetFormCount
Gets the number of Item Detail Forms for the specified category.
Public method GetFormNames(String)
Gets a list of all Item Detail Form names in specified category.
Public method GetFormNames(String, String)
Gets the Item detail Form names for the specified category
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetImageFieldCount
Gets the number of image fields in specified category.
Public method GetImageFieldNames(String)
Gets a list of all field of type 'image' from the specified category.
Public method GetImageFieldNames(String, String)
Gets the image-type field names for the specified category.
Public method GetImageFieldToFile
Copies the image field identified by the named Category, Item, and Field to the specified Filename. Only bitmap (.BMP) format image fields are currently supported. Filename must be a fully qualified path including the drive letter (e.g. c:\tmp\data.bmp). If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten. It is the client’s responsibility to perform the necessary file cleanup. If the image field is blank, no file is written.
Public method GetItemCount
Gets the number of items in the specified category.
Public method GetItemNames(String)
Gets a list of all itemnames in the specified category.
Public method GetItemNames(String, String)
Gets the item names for the specified category
Public method GetLastError
Gets the last error that occurred during DDE conversation. Inspect this value if a call failed.
Public method GetLetterViewInfo
Returns information about the active view and selected letter template at the time the Tools-Send Letter or Customize-Database-Letter Template command was executed. This call is used by the Commence letter macros and has not been implemented here.
Public method GetMarkItem
"Marks" the specified item and makes it the default category and item for subsequent calls to: EditItem, DeleteItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands, and GetField, GetFieldToFile, GetFields, GetConnectedItemCount and GetConnectedItemNames REQUESTS. The category and item is marked only for the specific DDE conversation, not globally. that is, each DDE conversation can have a different marked item. Can be used to mark the (-Me-) item if one is defined. Syntax: [GetMarkItem("(-Me-)")] Note: If a Clarify Field is defined for the category, the value of the clarify field can be specified with an optional third paramter. Alternatively, the ItemName can be a clarified item name.
Public method GetMeField
Gets a fieldvalue from the item defined as (-Me-) item in Commence.
Public method GetNameField
Get the name of the namefield for the specified category.
Public method GetPhoneNumber
TAPI must be configured for GetPhoneNumber to work properly. TAPI is ancient, so this method is not implemented.
Public method GetPreference
Get preference settings.
Public method GetReverseName
Uses Commence preference information and reverses the name if appropriate.
Public method GetTriggerCount
Gets the number of DDE agent triggers defined in the database.
Public method GetTriggerNames
Get a list of Agent triggers.
Public method GetTriggerNames(String)
Gets the trigger names defined in the database.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetViewColumnNames
Gets the columnnames from a view provided a cursor can be created on them.
Public method GetViewCount
Gets the number of views in the specified category.
Public method GetViewDefinition
Get definition of a view
Public method GetViewNames(String)
Gets a list of all views for the specified category. Returns all categories if category is not specified.
Public method GetViewNames(String, String)
Gets a list of view names for the specified category.
Public method GetViewToFile
Saves the Commence View to a file in HTML format (similar to the File-Save As HTML menu command). If the file does not exist, Commence will create it; the drive and directory must exist. If the file exists, it will be overwritten.
Public method HasDuplicates
Checks if field contains duplicate values.
Public method LogPhoneCall
Launches an add tem detail window for an item in the Phone Log category (as specified in the Commence Customize-Preferences-Event Logs dialog box). One or more Category/Item pairs may be given as arguments; connections will be set between the new Phone Log item and these items. If no connection exists between the two categories, the pair is ignored and no error is given. The connection is set via all connections found between the two categories. If no Phone Log category is set, NACK error code 104 (DDE_ERROR_NOLOGCLASS) is returned. If there is no room to add an item in the Phone Log category, NACK error code 112 (DDE_ERROR_FULL) is returned.
Public method MarkActiveItem
Marks the active item for subsequent requests.
Public method MergeTemplateCreate
Creates a new template with the given parameters. If template exists, the call fails. This call returns the template filename assigned by Commence, including the full path and extension configured in Preferences-Letter dialog.
Public method MergeTemplateSave
Updates an existing template identified by the name parameter. Template must exist, else the call fails.
Public method PromoteItemToShared
Promotes a local item to shared status, provided the database is connected and the category is shared. If the item is already shared, its status is unchanged. Note that there is no way to demote an item from shared to local status. Whenever possible, use a clarified Item name.
Public method ShowDesktop
Opens the specified desktop in Commence.
Public method ShowItem
Opens an item detail window in Commence for the given Item in the given Category. If a detail is already open for the item, it will be brought to the top and given the focus.
Public method ShowView
Opens the specified view in Commence. If the view is already open, it will become the active view.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Public method UnassignConnection
Unassigns a connection between two items.
Public method ViewCategory
Defines the category to be used. This must be the first message sent to Commence for a ViewData conversation. ViewCategory may be sent at any time to reset the ViewData conversation state. ViewData conversation topic has been obsolete since Commence 3.0 (1995 or so), so it is extremely unlikely you will ever need this method.
Public method ViewConjunction
Defines the logical operations that link the filter clauses specified with the ViewFilter request. Each parameter can be either "And" or "Or"; the default value is "And". AndOr12 defines the relationship between the filter clauses 1 and 2, AndOr34 for clauses 3 and 4, and AndOr13 for (1 and 2) and (3 and 4), etc. Note the special significance of AndOr48, which signifies the relationship between the two groups of 4 filters.

The logical precedence is: (Filter1 AndOr12 Filter2) AndOr13 (Filter3 AndOr34 Filter4) AndOr4to8 [repeat 5 to 8]

Public method ViewConnectedCount
Returns the number of items in the connCategory that the Indexth item is connected to via ConnectionName.
Public method ViewConnectedField
Returns the value of Field of the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.
Public method ViewConnectedFields(Int32, String, String, Int32, ListString, String)
Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method ViewConnectedFields(Int32, String, String, Int32, Object, String)
Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method ViewConnectedItem
Returns the ConnIndexth item in connCategory that the Indexth item is connected to via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value.
Public method ViewDeleteAllItems
USE WITH EXTREME CAUTION! Deletes all items that satisfy the currently defined filter. If no filter is defined, deletes all items in the previously named category, see ViewCategory(String). Fails without warning when no delete permissions were granted on the category.
Public method ViewField
Returns the value of Field of the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount REQUEST to determine the maximum Index value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.
Public method ViewFields(Int32, ListString, String)
Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method ViewFields(Int32, Object, String)
Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method ViewFieldToFile
Saves specified field to file
Public method ViewFilter
Defines the criteria for the multiple filter to be applied against the previously named category/view (see ViewCategory/ViewView). This is by far the most complicated API method to use. Unless you are actually creating views from code, you are strongly advised to use the Filters collection of the CommenceCursor class instead.
Public method ViewImageFieldToFile
Copies the image field data in Field from the Indexth item that satisfies the currently defined filter (if any) to the specified Filename.
Public method ViewItemCount
Returns the number of items that satisfy the currently defined filter (if any). If no filter is defined, this request returns the total number of items in the category
Public method ViewItemIndex
Returns the index of the item with the indicated name field value. The item must also satisfy the currently defined filter (if any). Use a clarified itemname if possible. Note: If the NameFieldValue is left blank, the marked item will be used. Returns the index of the marked item (if any).
Public method ViewItemName
Returns the itemname for the Indexth item. Different from ViewField(Index, Name) in that a clarified item name may be returned. The ClarifyItemNames request is used to enable or disable the use of clarified item names.
Public method ViewMarkItem
Marks the Indexth item in the view and makes it the default category and item for the EditItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands.
Public method ViewReverseName
Uses Commence preference information and reverses the name if appropriate.
Public method ViewSaveView
Saves the virtual DDE view already created with the ViewCategory, ViewFilter, ViewSort, etc., as an actual view in Commence, accessible via the normal user interface. The view will be saved using the specified New View Name. If the view already exists, it will be overwritten. Use GetViewNames to determine if the view name conflicts with an existing view.
Public method ViewSort
Defines the sort criteria for the view. Field1, Field2, Field3, and Field4 define the fields to sort by. Sort1, Sort2, Sort3, and Sort4 define the sort type and should be "Ascending" or "Descending". Unused sort pairs (i.e. FieldN, SortN) may be omitted.
Public method ViewView
Uses the category and filter criteria of a Commence View that has already be defined from the Commence menu interface. The ViewView REQUEST overrides any previously received ViewCategory, ViewConjunction, ViewFilter, and ViewSort REQUESTS. If the ViewName parameter is left blank, the active view will be used.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.AddItem Method

CommenceDatabaseAddItem Method

Adds the indicated Item to the Category. Fields other than the Name field are set to their default values. (Default values for date fields must not specify date ranges, e.g., "every day"). By default, the new item is local (i.e., non-shared) CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled. Note: If a clarify field is defined for the category (but is not a Sequence Number field), the clarify field value can be specified using the optional third parameter, Clarify Value. Alternatively, the Item parameter can be a clarified item name. If the clarify field is a Sequence Number field, then the field value is determined automatically by Commence. An error results if the AddItem REQUEST tries to set a Sequence Number field. Use GetFieldDefinition to determine the Sequence Number field value so a clarified item name can be used with subsequent EditItems.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool AddItem(
    string categoryName,
    string itemName,
    string clarifyValue = ""
)
Public Function AddItem (
    categoryName As String,
    itemName As String,
    Optional clarifyValue As String = ""
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to add.
clarifyValue (Optional)
Type: SystemString
Commence clarify value.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseAddItem(String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.AddSharedItem Method

CommenceDatabaseAddSharedItem Method

Identical in function to AddItem except that it creates a shared item, provided that the database is connected and the category is shared. Otherwise a local item is created. CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool AddSharedItem(
    string categoryName,
    string itemName,
    string clarifyValue = ""
)
Public Function AddSharedItem (
    categoryName As String,
    itemName As String,
    Optional clarifyValue As String = ""
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to add.
clarifyValue (Optional)
Type: SystemString
Commence clarify value.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseAddSharedItem(String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.AppendText Method

CommenceDatabaseAppendText Method

Appends text to an existing text Field. Use this command to overcome the 256 character maximum string limitation of certain macro languages (such as WordBasic). Whenever possible, use a clarified item name. You are strongly advised to use a ICommenceEditRowSet for editing fields instead.

When an item was just created with AddItem(String, String, String) or AddSharedItem(String, String, String), this is the item that will be used for appending. Otherwise, unless you specifically mark an item (using GetMarkItem(String, String, String) or MarkActiveItem(String)) the first match will be used.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool AppendText(
    string categoryName,
    string itemName,
    string fieldName,
    string text
)
Public Function AppendText (
    categoryName As String,
    itemName As String,
    fieldName As String,
    text As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to edit.
fieldName
Type: SystemString
Commence field to edit.
text
Type: SystemString
Textvalue to append.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseAppendText(String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.AssignConnection Method

CommenceDatabaseAssignConnection Method

Assigns a connection between two items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool AssignConnection(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory,
    string connItem
)
Public Function AssignConnection (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String,
    connItem As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence 'From' category.
itemName
Type: SystemString
Commence 'From' item. Use clarified names if possible.
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence 'To' category.
connItem
Type: SystemString
Commence 'To' item. Use clarified names if possible.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseAssignConnection(String, String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.CheckInFormScript Method

CommenceDatabaseCheckInFormScript Method

Updates the detail form script with the text in the specified Filename.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool CheckInFormScript(
    string categoryName,
    string formName,
    string fileName
)
Public Function CheckInFormScript (
    categoryName As String,
    formName As String,
    fileName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
formName
Type: SystemString
Commence Item Detail Form name.
fileName
Type: SystemString
Fully qualified path including the drive letter (e.g. c:\tmp\script.txt).

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseCheckInFormScript(String, String, String)
Remarks
Warning: this function will return true even if the user has no Author rights on the database. This is a limitation of Commence. If you are not an Author, the script will not be checked in!
See Also

Reference

CommenceDatabase Class


CommenceDatabase.CheckOutFormScript Method

CommenceDatabaseCheckOutFormScript Method

Saves the detail form script to file.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool CheckOutFormScript(
    string categoryName,
    string formName,
    string fileName
)
Public Function CheckOutFormScript (
    categoryName As String,
    formName As String,
    fileName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
formName
Type: SystemString
Commence Item Detail Form name.
fileName
Type: SystemString
Fully qualified path including the drive letter (e.g. c:\tmp\script.txt). If file already exists it is overwritten.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseCheckOutFormScript(String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ClarifyItemNames Method

CommenceDatabaseClarifyItemNames Method

Specifies whether Commence should return clarified item names, or leave bStatus empty to get the current status.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClarifyItemNames(
    string bStatus = null
)
Public Function ClarifyItemNames (
    Optional bStatus As String = Nothing
) As String

Parameters

bStatus (Optional)
Type: SystemString
"True" to set clarified itemnames, "False" for unclarified, leave empty to request current status.

Return Value

Type: String
"OK" if successful, inspect GetLastError on failure.

If bStatus was omitted this method returns "True" if clarified, "False" if not.

Implements

ICommenceDatabaseClarifyItemNames(String)
See Also

Reference

CommenceDatabase Class
ICommenceDatabaseGetLastError


CommenceDatabase.Close Method

CommenceDatabaseClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

ICommenceDatabaseClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

CommenceDatabase Class


CommenceDatabase.DeleteItem Method

CommenceDatabaseDeleteItem Method

Deletes the indicated Item from the Category. This action cannot be undone. Whenever possible, use a clarified item name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool DeleteItem(
    string categoryName,
    string itemName
)
Public Function DeleteItem (
    categoryName As String,
    itemName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to delete.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseDeleteItem(String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.DeleteView Method

CommenceDatabaseDeleteView Method

Deletes the specified view. Use with caution! This action cannot be undone.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool DeleteView(
    string viewName
)
Public Function DeleteView (
    viewName As String
) As Boolean

Parameters

viewName
Type: SystemString
Commence view name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseDeleteView(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.Dispose Method

CommenceDatabaseDispose Method

Dispose

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

CommenceDatabase Class


CommenceDatabase.EditItem Method

CommenceDatabaseEditItem Method

Sets the value of Field to Value for the item identified by Item in Category. Field must not specify a Calculation field. Date fields may not specify a range, (e.g., "every day"). Whenever possible, use a clarified Item name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool EditItem(
    string categoryName,
    string itemName,
    string fieldName,
    string fieldValue
)
Public Function EditItem (
    categoryName As String,
    itemName As String,
    fieldName As String,
    fieldValue As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to edit.
fieldName
Type: SystemString
Commence field to edit.
fieldValue
Type: SystemString
New fieldvalue. If Field is an image field, Value must specify the filename containing the image. Only .bmp files are supported.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseEditItem(String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ExportDatabaseSchema Method

CommenceDatabaseExportDatabaseSchema Method

Exports the schema information to file. Defaults to Json.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void ExportDatabaseSchema(
    string fileName,
    MetaDataOptions options = null
)
Public Sub ExportDatabaseSchema (
    fileName As String,
    Optional options As MetaDataOptions = Nothing
)

Parameters

fileName
Type: SystemString
Fully qualified filename.
options (Optional)
Type: Vovin.CmcLibNet.Database.MetadataMetaDataOptions
MetaDataOptions

Implements

ICommenceDatabaseExportDatabaseSchema(String, MetaDataOptions)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.FieldValueExists Method

CommenceDatabaseFieldValueExists Method

Checks to see if value is already present for given field.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool FieldValueExists(
    string categoryName,
    string fieldName,
    string fieldValue,
    bool caseSensitive = true
)
Public Function FieldValueExists (
    categoryName As String,
    fieldName As String,
    fieldValue As String,
    Optional caseSensitive As Boolean = true
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
fieldName
Type: SystemString
Commence fieldname.
fieldValue
Type: SystemString
Value to check.
caseSensitive (Optional)
Type: SystemBoolean
Compare case-sensitive. Defaults to true.

Return Value

Type: Boolean
true if value exists.

Implements

ICommenceDatabaseFieldValueExists(String, String, String, Boolean)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.FireTrigger Method

CommenceDatabaseFireTrigger Method

Fires the indicated Agent Trigger.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool FireTrigger(
    string trigger,
    Object[] args
)
Public Function FireTrigger (
    trigger As String,
    args As Object()
) As Boolean

Parameters

trigger
Type: SystemString
Trigger string.
args
Type: SystemObject
.NET clients can pass in a string[], from VBScript, VB etc. use Array(param1, param2, ... ParamN). Up to 9 parameters can be used. See the Commence helpfile under "Receive DDE Trigger" for implementation details.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseFireTrigger(String, Object)
Remarks
This is a very powerful command allowing you to make Commence perform agent actions.

Additional information from the Commence helpfile. Note that you do not have to worry about the syntax, it is taken care of internally in CmcLibNet. See examples below.

Commence can pass data from the Send DDE Action of one agent to the Receive DDE Trigger of another agent, or an agent can be triggered by code. The data can then be used by the Receive DDE agent’s actions. The arguments passed via a Receive DDE trigger are accessible using the following keyword strings: (-0-), (-1-), (-2-), (-3-), (-4-), (-5-), (-6-), (-7-), (-8-) and (-9-). These keywords (i.e. arguments) may be used just as field codes would be used to display the data in a message box or status bar action, to set values in an add or edit item action, or any other place that keyword replacement is allowed in agents. The following example illustrates how the DDE trigger arguments are mapped to keywords.

Usage:

Copy
[FireTrigger(TrigStr, Arg2, Arg3, Arg4, Arg5, Arg6, Arg7, Arg8, Arg9)]

(-0-) | Always "FireTrigger".
(-1-) | Trigger String, e.g., TrigStr
(-2-) through (-9-) | The string passed in that position, e.g. Arg2 through Arg9 respectively.

The Send DDE trigger also allows arguments 2 and 3 to be mapped to a category name and an item name respectively. Then If the "arg2 equals" check box is checked (in the DDE Trigger Definition dialog box of the Receive DDE agent), a category must be selected and Arg2 must equal that category name for that DDE trigger to fire. In addition, Arg3 must be the name of an item in the chosen category. If all these conditions are met, the trigger fires and values from that item will be available for use in the agent’s actions (using the field name keywords such as (%Name%) or using any of the arguments (-3-) through (-9-) that have been defined)

The corresponding agent with a Receive DDE trigger also allows you to define a filter for a DDE trigger using the item mapping option. If a filter is defined, not only do Arg2 and Arg3 have to match the category and an item name, but the item must also meet the filter criteria. If the item does not match the filter, the trigger will not fire.

Examples:

Execute: [FireTrigger("test", "Person", "Wilson", "908-552-0466")]

This is a generic example where all arguments are typed literally.

Execute: [FireTrigger("test",(-Category-),(%Last Name%),(%Business Phone%))]

This is an equivalent example where the agent trigger uses the Person category, so field codes can be used as arguments whenever necessary.

Examples
(C#)
Copy
string[] args = new string[] { "Company", "012-3456" };
            FireTrigger("DoSomething", args);
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetActiveCategory Method

CommenceDatabaseGetActiveCategory Method

Gets the category of the active item or view.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetActiveCategory()
Public Function GetActiveCategory As String

Return Value

Type: String
Active category or null if no active item or view could be retrieved.

Implements

ICommenceDatabaseGetActiveCategory
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetActiveItemName Method

CommenceDatabaseGetActiveItemName Method

Gets the itemname of the active item. Use MarkActiveItem(String) to try and get a clariefied itemname.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetActiveItemName()
Public Function GetActiveItemName As String

Return Value

Type: String
Active itemname, null if no active item could be retieved.

Implements

ICommenceDatabaseGetActiveItemName
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetActiveViewInfo Method

CommenceDatabaseGetActiveViewInfo Method

Returms information on the currently active view (if any).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IActiveViewInfo GetActiveViewInfo()
Public Function GetActiveViewInfo As IActiveViewInfo

Return Value

Type: IActiveViewInfo
ActiveViewInfo object holding information on the view, null if no view active.

Implements

ICommenceDatabaseGetActiveViewInfo
Remarks
Unlike it's Commence counterpart, this method returns a IActiveViewInfo object instead of a delimited string. Returns null if no view is active.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetCallerID Method

CommenceDatabaseGetCallerID Method

Overload List
 | Name | Description
Public method | GetCallerID(String, String) | Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method | GetCallerID(String, String, String) | Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetCallerID Method (String, String)

CommenceDatabaseGetCallerID Method (String, String)

Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetCallerID(
    string categoryName,
    string phoneNumber
)
Public Function GetCallerID (
    categoryName As String,
    phoneNumber As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence category name.
phoneNumber
Type: SystemString
Phonenumber to search.

Return Value

Type: List String
List of matching items.

Implements

ICommenceDatabaseGetCallerID(String, String)
See Also

Reference

CommenceDatabase Class
GetCallerID Overload


CommenceDatabase.GetCallerID Method (String, String, String)

CommenceDatabaseGetCallerID Method (String, String, String)

Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetCallerID(
    string categoryName,
    string phoneNumber,
    string delim = null
)
Public Function GetCallerID (
    categoryName As String,
    phoneNumber As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
phoneNumber
Type: SystemString
Phonenumber to search.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String of matching items delimited by delim of CR/LF if no delim specified.

Implements

ICommenceDatabaseGetCallerID(String, String, String)
See Also

Reference

CommenceDatabase Class
GetCallerID Overload


CommenceDatabase.GetCategoryCount Method

CommenceDatabaseGetCategoryCount Method

Returns number of categories in the Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetCategoryCount()
Public Function GetCategoryCount As Integer

Return Value

Type: Int32
Category count, -1 on error.

Implements

ICommenceDatabaseGetCategoryCount
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetCategoryDefinition Method

CommenceDatabaseGetCategoryDefinition Method

Returns information on the definition of the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICategoryDef GetCategoryDefinition(
    string categoryName
)
Public Function GetCategoryDefinition (
    categoryName As String
) As ICategoryDef

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: ICategoryDef
CategoryDef object exposing properties of the category.

Implements

ICommenceDatabaseGetCategoryDefinition(String)
Remarks
Unlike it's Commence counterpart, this method returns a ICategoryDef object instead of a delimited string. Returns null if category doesn't exist.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetCategoryNames Method

CommenceDatabaseGetCategoryNames Method

Overload List
 | Name | Description
Public method | GetCategoryNames | Gets a list of categories in the current Commence database.
Public method | GetCategoryNames(String) | Gets a list of category names.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetCategoryNames Method

CommenceDatabaseGetCategoryNames Method

Gets a list of categories in the current Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetCategoryNames()
Public Function GetCategoryNames As List(Of String)

Return Value

Type: List String
List of categories

Implements

ICommenceDatabaseGetCategoryNames
Remarks
This method is only available to .Net consumers.
See Also

Reference

CommenceDatabase Class
GetCategoryNames Overload


CommenceDatabase.GetCategoryNames Method (String)

CommenceDatabaseGetCategoryNames Method (String)

Gets a list of category names.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetCategoryNames(
    string delim = null
)
Public Function GetCategoryNames (
    Optional delim As String = Nothing
) As String

Parameters

delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the category names separated by delim, delim defaults to CR/LF.

Implements

ICommenceDatabaseGetCategoryNames(String)
See Also

Reference

CommenceDatabase Class
GetCategoryNames Overload


CommenceDatabase.GetClarifiedItemName Method

CommenceDatabaseGetClarifiedItemName Method

Construct a clarified item name from the unclarified itemname, the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetClarifiedItemName(
    string itemName,
    string clarifySeparator,
    string clarifyValue
)
Public Function GetClarifiedItemName (
    itemName As String,
    clarifySeparator As String,
    clarifyValue As String
) As String

Parameters

itemName
Type: SystemString
Unclarified itemname.
clarifySeparator
Type: SystemString
Clarify separator.
clarifyValue
Type: SystemString
Clarify value.

Return Value

Type: String
Clarified item name.

Implements

ICommenceDatabaseGetClarifiedItemName(String, String, String)
Remarks
This method does not query Commence.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetClarifyField Method

CommenceDatabaseGetClarifyField Method

Gets the clarifyfield for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetClarifyField(
    string categoryName
)
Public Function GetClarifyField (
    categoryName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: String
Clarify field name, null if no clarify field.

Implements

ICommenceDatabaseGetClarifyField(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetClarifySeparator Method

CommenceDatabaseGetClarifySeparator Method

Gets the clarify separator for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetClarifySeparator(
    string categoryName
)
Public Function GetClarifySeparator (
    categoryName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: String
Clarify separator, null if no separator.

Implements

ICommenceDatabaseGetClarifySeparator(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetConnectedItemCount Method

CommenceDatabaseGetConnectedItemCount Method

Gets the number of connected items in connected category for the specified item

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetConnectedItemCount(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory
)
Public Function GetConnectedItemCount (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to count from.
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence category name of connCategory

Return Value

Type: Int32
Number of connected items, -1 on error.

Implements

ICommenceDatabaseGetConnectedItemCount(String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetConnectedItemField Method

CommenceDatabaseGetConnectedItemField Method

Returns the indirect field value(s) in connCategory that itemName of the categoryName is connected to via Connection. The order of the items in the list is arbitrary (i.e., not sorted).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetConnectedItemField(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory,
    string fieldName,
    string delim = null
)
Public Function GetConnectedItemField (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String,
    fieldName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
categoryName.
itemName
Type: SystemString
itemName (use clarified if possible).
connectionName
Type: SystemString
Connection name (case-sensitive).
connCategory
Type: SystemString
connCategory.
fieldName
Type: SystemString
FieldName.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String of connected item fields. Text limitations imposed by Commence:
  • Limit to 256 chars.
  • First line of multiline field.
  • Returns string "(none)" if there are no connected items.

Implements

ICommenceDatabaseGetConnectedItemField(String, String, String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetConnectedItemNames Method

CommenceDatabaseGetConnectedItemNames Method

Overload List
 | Name | Description
Public method | GetConnectedItemNames(String, String, String, String) | Gets a list of items connected to the specified item.
Public method | GetConnectedItemNames(String, String, String, String, String) | Returns the list of items in category that named item is connected to. The order of the items in the list is arbitrary (i.e., not sorted).
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetConnectedItemNames Method (String, String, String, String)

CommenceDatabaseGetConnectedItemNames Method (String, String, String, String)

Gets a list of items connected to the specified item.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetConnectedItemNames(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory
)
Public Function GetConnectedItemNames (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.
itemName
Type: SystemString
Itemname.
connectionName
Type: SystemString
Connection name (case-sensitive).
connCategory
Type: SystemString
Connected categoryname.

Return Value

Type: List String
List of connected items.

Implements

ICommenceDatabaseGetConnectedItemNames(String, String, String, String)
Remarks
This method is only available to .Net consumers.
See Also

Reference

CommenceDatabase Class
GetConnectedItemNames Overload
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseClarifyItemNames(String)


CommenceDatabase.GetConnectedItemNames Method (String, String, String, String, String)

CommenceDatabaseGetConnectedItemNames Method (String, String, String, String, String)

Returns the list of items in category that named item is connected to. The order of the items in the list is arbitrary (i.e., not sorted).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetConnectedItemNames(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory,
    string delim = null
)
Public Function GetConnectedItemNames (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category containing item.
itemName
Type: SystemString
Commence item name to retrieve connected names from.
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connected category.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
Connected item names, "(none)" if no connected items.

Implements

ICommenceDatabaseGetConnectedItemNames(String, String, String, String, String)
See Also

Reference

CommenceDatabase Class
GetConnectedItemNames Overload


CommenceDatabase.GetConnectionCount Method

CommenceDatabaseGetConnectionCount Method

Gets the number of connections from the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetConnectionCount(
    string categoryName
)
Public Function GetConnectionCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category to count connections from.

Return Value

Type: Int32
Number of connections.

Implements

ICommenceDatabaseGetConnectionCount(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetConnectionNames Method

CommenceDatabaseGetConnectionNames Method

Overload List
 | Name | Description
Public method | GetConnectionNames(String) | Gets a list of connection names to the specified category.
Public method | GetConnectionNames(String, String, String) | Gets the connection names for the specified category.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetConnectionNames Method (String)

CommenceDatabaseGetConnectionNames Method (String)

Gets a list of connection names to the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IEnumerable<ICommenceConnection> GetConnectionNames(
    string categoryName
)
Public Function GetConnectionNames (
    categoryName As String
) As IEnumerable(Of ICommenceConnection)

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: IEnumerable ICommenceConnection
List of CommenceConnection objects.

Implements

ICommenceDatabaseGetConnectionNames(String)
Remarks
This method is only available to .Net consumers.
See Also

Reference

CommenceDatabase Class
GetConnectionNames Overload


CommenceDatabase.GetConnectionNames Method (String, String, String)

CommenceDatabaseGetConnectionNames Method (String, String, String)

Gets the connection names for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public Object GetConnectionNames(
    string categoryName,
    string delim1 = null,
    string delim2 = null
)
Public Function GetConnectionNames (
    categoryName As String,
    Optional delim1 As String = Nothing,
    Optional delim2 As String = Nothing
) As Object

Parameters

categoryName
Type: SystemString
Commence category name.
delim1 (Optional)
Type: SystemString
First delimiter, up to 8 chars.
delim2 (Optional)
Type: SystemString
Second delimiter, up to 8 chars.

Return Value

Type: Object
Array of ICommenceConnection objects

Implements

ICommenceDatabaseGetConnectionNames(String, String, String)
See Also

Reference

CommenceDatabase Class
GetConnectionNames Overload


CommenceDatabase.GetCursor Method

CommenceDatabaseGetCursor Method

Overload List
 | Name | Description
Public method | GetCursor(String) | Get a CommenceCursor object that wraps the native FormOA.ICommenceCursor interface.
Public method | GetCursor(String, CmcCursorType, CmcOptionFlags) | Get a CommenceCursor object that wraps the native FormOA.ICommenceCursor interface.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetCursor Method (String)

CommenceDatabaseGetCursor Method (String)

Get a CommenceCursor object that wraps the native FormOA.ICommenceCursor interface.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceCursor GetCursor(
    string categoryName
)
Public Function GetCursor (
    categoryName As String
) As ICommenceCursor

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: ICommenceCursor
CommenceCursor wrapping Commence ICommenceCursor with default settings
Exceptions
Exception | Condition
CommenceCOMException | Unable to create a cursor.
See Also

Reference

CommenceDatabase Class
GetCursor Overload


CommenceDatabase.GetCursor Method (String, CmcCursorType, CmcOptionFlags)

CommenceDatabaseGetCursor Method (String, CmcCursorType, CmcOptionFlags)

Get a CommenceCursor object that wraps the native FormOA.ICommenceCursor interface.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceCursor GetCursor(
    string pName,
    CmcCursorType pCursorType,
    CmcOptionFlags pCursorFlags
)
Public Function GetCursor (
    pName As String,
    pCursorType As CmcCursorType,
    pCursorFlags As CmcOptionFlags
) As ICommenceCursor

Parameters

pName
Type: SystemString
Commence category name.
pCursorType
Type: Vovin.CmcLibNet.DatabaseCmcCursorType
Type of Commence data to access with this cursor.
pCursorFlags
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of Option flags.

Return Value

Type: ICommenceCursor
CommenceCursor wrapping ICommenceCursor according to flags passed.

Implements

ICommenceDatabaseGetCursor(String, CmcCursorType, CmcOptionFlags)
Exceptions
Exception | Condition
ArgumentException | Viewtype cannot be used in a CommenceCursor.
CommenceCOMException | Commence could not create a cursor.
See Also

Reference

CommenceDatabase Class
GetCursor Overload


CommenceDatabase.GetDatabase Method

CommenceDatabaseGetDatabase Method

Note: This API is now obsolete.

(Not implemented) Get the active Commence database name and path as delimited string. See Name and/or Path.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use CmcLibNet.CommenceApp.Name and/or CmcLibNet.CommenceApp.Path.")]
public string GetDatabase()
<ObsoleteAttribute("Use CmcLibNet.CommenceApp.Name and/or CmcLibNet.CommenceApp.Path.")>
Public Function GetDatabase As String

Return Value

Type: String
NotImplementedException

Implements

ICommenceDatabaseGetDatabase
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
CommenceAppName
CommenceAppPath


CommenceDatabase.GetDatabaseDefinition Method

CommenceDatabaseGetDatabaseDefinition Method

Queries Commence for information on the database definition.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IDBDef GetDatabaseDefinition()
Public Function GetDatabaseDefinition As IDBDef

Return Value

Type: IDBDef
DBDef object that exposes Commence database definition properties, null on error.

Implements

ICommenceDatabaseGetDatabaseDefinition
Remarks
Unlike it's Commence counterpart, this method returns a IDBDef object instead of a delimited string.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetDatabaseSchema Method

CommenceDatabaseGetDatabaseSchema Method

Gets a serializable object containnig the Commence schema definition.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IDatabaseSchema GetDatabaseSchema(
    MetaDataOptions options = null
)
Public Function GetDatabaseSchema (
    Optional options As MetaDataOptions = Nothing
) As IDatabaseSchema

Parameters

options (Optional)
Type: Vovin.CmcLibNet.Database.MetadataMetaDataOptions
MetaDataOptions

Return Value

Type: IDatabaseSchema
DatabaseSchema

Implements

ICommenceDatabaseGetDatabaseSchema(MetaDataOptions)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetDesktopCount Method

CommenceDatabaseGetDesktopCount Method

Gets the number of Desktops in the Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetDesktopCount()
Public Function GetDesktopCount As Integer

Return Value

Type: Int32
Number of desktops, -1 on error.

Implements

ICommenceDatabaseGetDesktopCount
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetDesktopNames Method

CommenceDatabaseGetDesktopNames Method

Overload List
 | Name | Description
Public method | GetDesktopNames | Get a list of desktopnames.
Public method | GetDesktopNames(String) | Gets the desktop names in the Commence database.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetDesktopNames Method

CommenceDatabaseGetDesktopNames Method

Get a list of desktopnames.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetDesktopNames()
Public Function GetDesktopNames As List(Of String)

Return Value

Type: List String
List of desktopnames.

Implements

ICommenceDatabaseGetDesktopNames
Remarks
This method is only available to .Net consumers.
See Also

Reference

CommenceDatabase Class
GetDesktopNames Overload


CommenceDatabase.GetDesktopNames Method (String)

CommenceDatabaseGetDesktopNames Method (String)

Gets the desktop names in the Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetDesktopNames(
    string delim = null
)
Public Function GetDesktopNames (
    Optional delim As String = Nothing
) As String

Parameters

delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
Strings containing the desktop names delimited by delim of CR/LF if no delim supplied.

Implements

ICommenceDatabaseGetDesktopNames(String)
See Also

Reference

CommenceDatabase Class
GetDesktopNames Overload


CommenceDatabase.GetField Method

CommenceDatabaseGetField Method

Returns a fieldvalue from the specified Commence item.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetField(
    string categoryName,
    string itemName,
    string fieldName
)
Public Function GetField (
    categoryName As String,
    itemName As String,
    fieldName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
fieldName
Type: SystemString
Commence field name.

Return Value

Type: String
FieldValue, "(Active item not found)" on error.

Implements

ICommenceDatabaseGetField(String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetFieldCount Method

CommenceDatabaseGetFieldCount Method

Gets the number of fields in the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetFieldCount(
    string categoryName
)
Public Function GetFieldCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name

Return Value

Type: Int32
Number of fields, -1 on error.

Implements

ICommenceDatabaseGetFieldCount(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetFieldDefinition Method

CommenceDatabaseGetFieldDefinition Method

Queries Commence for information on the specified field definition.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ICommenceFieldDefinition GetFieldDefinition(
    string categoryName,
    string fieldName
)
Public Function GetFieldDefinition (
    categoryName As String,
    fieldName As String
) As ICommenceFieldDefinition

Parameters

categoryName
Type: SystemString
Commence category name.
fieldName
Type: SystemString
Commence field name.

Return Value

Type: ICommenceFieldDefinition
FieldDef object exposing properties of the field, null on error.

Implements

ICommenceDatabaseGetFieldDefinition(String, String)
Remarks
Unlike it's Commence counterpart, this method returns a ICommenceFieldDefinition object instead of a delimited string.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetFieldNames Method

CommenceDatabaseGetFieldNames Method

Overload List
 | Name | Description
Public method | GetFieldNames(String) | Gets a list of fieldnames for the specified Commence category.
Public method | GetFieldNames(String, String) | Gets the fieldnames for the specified category.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetFieldNames Method (String)

CommenceDatabaseGetFieldNames Method (String)

Gets a list of fieldnames for the specified Commence category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetFieldNames(
    string categoryName
)
Public Function GetFieldNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.

Return Value

Type: List String
List of fieldnames.

Implements

ICommenceDatabaseGetFieldNames(String)
Remarks
Does not return Image field names, see GetImageFieldNames(String).
See Also

Reference

CommenceDatabase Class
GetFieldNames Overload


CommenceDatabase.GetFieldNames Method (String, String)

CommenceDatabaseGetFieldNames Method (String, String)

Gets the fieldnames for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetFieldNames(
    string categoryName,
    string delim = null
)
Public Function GetFieldNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
string containing the field names delimited by delimiter delim, or CR/LF if delim is null.

Implements

ICommenceDatabaseGetFieldNames(String, String)
Remarks
Does not return Image field names, see GetImageFieldNames(String).
See Also

Reference

CommenceDatabase Class
GetFieldNames Overload


CommenceDatabase.GetFields Method

CommenceDatabaseGetFields Method

Overload List
 | Name | Description
Public method | GetFields(String, String, ListString) | Gets values of specified field(s) from specified item.
Public method | GetFields(String, String, Object, String) | Gets values of specified field(s) from specified item.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetFields Method (String, String, List(String))

CommenceDatabaseGetFields Method (String, String, ListString)

Gets values of specified field(s) from specified item.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetFields(
    string categoryName,
    string itemName,
    List<string> fieldNames
)
Public Function GetFields (
    categoryName As String,
    itemName As String,
    fieldNames As List(Of String)
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
fieldNames
Type: System.Collections.GenericList String
List of fields to request values from.

Return Value

Type: List String
List of fieldvalues.

Implements

ICommenceDatabaseGetFields(String, String, ListString)
See Also

Reference

CommenceDatabase Class
GetFields Overload


CommenceDatabase.GetFields Method (String, String, Object[], String)

CommenceDatabaseGetFields Method (String, String, Object, String)

Gets values of specified field(s) from specified item.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetFields(
    string categoryName,
    string itemName,
    Object[] fields,
    string delim = null
)
Public Function GetFields (
    categoryName As String,
    itemName As String,
    fields As Object(),
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
fields
Type: SystemObject
object array containing fieldnames. .Net consumers can simply supply a string[], from VBScript/VBA and such use Array(field1, field2,...fieldN)
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String with the fieldvalues of requested fields delimited by delim or CR/LF if delim not supplied.

Implements

ICommenceDatabaseGetFields(String, String, Object, String)
Remarks
This method may prove a little problematic. It takes a list of fieldnames; because we do not know in advance what fields will be specified, you have to pass in an array as parameter, however, for this to work from COM, this array has to be of type 'object'. Note that this function is obsolete in the sense that this can be done much faster using CommenceQueryRowSet It can be useful however for getting fieldvalues of the active item. sample usage from VBA:
Copy
GetFields("categoryName", "itemName", Array(fieldname1, fieldname2,..., fieldnameN))
See Also

Reference

CommenceDatabase Class
GetFields Overload


CommenceDatabase.GetFieldToFile Method

CommenceDatabaseGetFieldToFile Method

Writes a single fieldvalue to file.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool GetFieldToFile(
    string categoryName,
    string itemName,
    string fieldName,
    string fileName
)
Public Function GetFieldToFile (
    categoryName As String,
    itemName As String,
    fieldName As String,
    fileName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
fieldName
Type: SystemString
Commence field name.
fileName
Type: SystemString
fully qualified output file. If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseGetFieldToFile(String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetFormCount Method

CommenceDatabaseGetFormCount Method

Gets the number of Item Detail Forms for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetFormCount(
    string categoryName
)
Public Function GetFormCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: Int32
Number of Item Detail Forms, -1 on error.

Implements

ICommenceDatabaseGetFormCount(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetFormNames Method

CommenceDatabaseGetFormNames Method

Overload List
 | Name | Description
Public method | GetFormNames(String) | Gets a list of all Item Detail Form names in specified category.
Public method | GetFormNames(String, String) | Gets the Item detail Form names for the specified category
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetFormNames Method (String)

CommenceDatabaseGetFormNames Method (String)

Gets a list of all Item Detail Form names in specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetFormNames(
    string categoryName
)
Public Function GetFormNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.

Return Value

Type: List String
List of formnames.

Implements

ICommenceDatabaseGetFormNames(String)
Remarks
This method is only available to .Net consumers.
See Also

Reference

CommenceDatabase Class
GetFormNames Overload


CommenceDatabase.GetFormNames Method (String, String)

CommenceDatabaseGetFormNames Method (String, String)

Gets the Item detail Form names for the specified category

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetFormNames(
    string categoryName,
    string delim = null
)
Public Function GetFormNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the Item Detail Form names delimited by delim, or CR/LF if not supplied.

Implements

ICommenceDatabaseGetFormNames(String, String)
See Also

Reference

CommenceDatabase Class
GetFormNames Overload


CommenceDatabase.GetImageFieldCount Method

CommenceDatabaseGetImageFieldCount Method

Gets the number of image fields in specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetImageFieldCount(
    string categoryName
)
Public Function GetImageFieldCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: Int32
Number of image fields, -1 on error.

Implements

ICommenceDatabaseGetImageFieldCount(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetImageFieldNames Method

CommenceDatabaseGetImageFieldNames Method

Overload List
 | Name | Description
Public method | GetImageFieldNames(String) | Gets a list of all field of type 'image' from the specified category.
Public method | GetImageFieldNames(String, String) | Gets the image-type field names for the specified category.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetImageFieldNames Method (String)

CommenceDatabaseGetImageFieldNames Method (String)

Gets a list of all field of type 'image' from the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetImageFieldNames(
    string categoryName
)
Public Function GetImageFieldNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.

Return Value

Type: List String
List of imagefield names

Implements

ICommenceDatabaseGetImageFieldNames(String)
Remarks
This method is only available to .Net consumers.
See Also

Reference

CommenceDatabase Class
GetImageFieldNames Overload


CommenceDatabase.GetImageFieldNames Method (String, String)

CommenceDatabaseGetImageFieldNames Method (String, String)

Gets the image-type field names for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetImageFieldNames(
    string categoryName,
    string delim = null
)
Public Function GetImageFieldNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the image field names delimited by delim or CR/LF if not supplied.

Implements

ICommenceDatabaseGetImageFieldNames(String, String)
See Also

Reference

CommenceDatabase Class
GetImageFieldNames Overload


CommenceDatabase.GetImageFieldToFile Method

CommenceDatabaseGetImageFieldToFile Method

Copies the image field identified by the named Category, Item, and Field to the specified Filename. Only bitmap (.BMP) format image fields are currently supported. Filename must be a fully qualified path including the drive letter (e.g. c:\tmp\data.bmp). If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten. It is the client’s responsibility to perform the necessary file cleanup. If the image field is blank, no file is written.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool GetImageFieldToFile(
    string categoryName,
    string itemName,
    string fieldName,
    string fileName
)
Public Function GetImageFieldToFile (
    categoryName As String,
    itemName As String,
    fieldName As String,
    fileName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name
itemName
Type: SystemString
Commence item name
fieldName
Type: SystemString
Commence imagefield name
fileName
Type: SystemString
fully qualified filename

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseGetImageFieldToFile(String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetItemCount Method

CommenceDatabaseGetItemCount Method

Gets the number of items in the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetItemCount(
    string categoryName
)
Public Function GetItemCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: Int32
Number of items, -1 on error.

Implements

ICommenceDatabaseGetItemCount(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetItemNames Method

CommenceDatabaseGetItemNames Method

Overload List
 | Name | Description
Public method | GetItemNames(String) | Gets a list of all itemnames in the specified category.
Public method | GetItemNames(String, String) | Gets the item names for the specified category
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetItemNames Method (String)

CommenceDatabaseGetItemNames Method (String)

Gets a list of all itemnames in the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetItemNames(
    string categoryName
)
Public Function GetItemNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.

Return Value

Type: List String
List of itemnames.

Implements

ICommenceDatabaseGetItemNames(String)
Remarks
This method is only available to .Net consumers.
See Also

Reference

CommenceDatabase Class
GetItemNames Overload
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseClarifyItemNames(String)


CommenceDatabase.GetItemNames Method (String, String)

CommenceDatabaseGetItemNames Method (String, String)

Gets the item names for the specified category

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetItemNames(
    string categoryName,
    string delim = null
)
Public Function GetItemNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the item names delimited by delim or CR/LF if not supplied.

Implements

ICommenceDatabaseGetItemNames(String, String)
Remarks
Use clarified Itemnames whenever you can.
See Also

Reference

CommenceDatabase Class
GetItemNames Overload


CommenceDatabase.GetLastError Method

CommenceDatabaseGetLastError Method

Gets the last error that occurred during DDE conversation. Inspect this value if a call failed.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetLastError()
Public Function GetLastError As String

Return Value

Type: String
NACK code. If the NACK error code is less than 100, then that number indicates the position of the parameter that was invalid. For example, if the EXECUTE command [EditItem("Person", "John Doe", "Work Phone", "(123)555-1234")] returned a NACK error code of 2, then perhaps a John Doe does not exist in the Person category.
NACK codes | Error description.
100 (0x64) | Out of memory.
101 (0x65) | Internal error.
102 (0x66) | Wrong number of parameters.
103 (0x67) | Unknown conversation topic.
104 (0x68) | No Phone Log category has been set; returned by LogPhoneCall EXECUTE command. Use Customize-Preferences-Event Logs to select a category.
105 (0x69) | No category selected; returned by ViewData REQUESTS not preceded by a ViewCategory.
106 (0x6A) | Unsupported clipboard format.
107 (0x6B) | Unsupported field type.
108 (0x6C) | Field/qualifier mismatch; returned by ViewFilter REQUEST.
109 (0x6D) | Unknown EXECUTE command.
110 (0x6E) | Parsing error. Check syntax of DDE command.
111 (0x6F) | Unknown REQUEST item or parsing error.
112 (0x70) | Cannot add new item, category full; returned by AddItem, AddSharedItem and LogPhoneCall EXECUTE commands.
113 (0x71) | File I/O error. Is the disk full?
114 (0x72) | Connection already exists; returned by the AssignConnection EXECUTE command.
115 (0x73) | No such connection exists; returned by the UnassignConnection EXECUTE commands.
116 (0x74) | The category has been invalidated.
117 (0x75) | The item has been invalidated.
118 (0x76) | An "every" date was received, or is the default value for a date field. Date ranges are not supported via DDE; returned by the AddItem or EditItem EXECUTE commands.
119 (0x77) | Non-unique item name; returned by the AddItem or EditItem EXECUTE commands.
120 (0x78) | Parameter too long; returned by the AddItem, EditItem and AppendText EXECUTE commands.
121 (0x79) | No active child window or child window is unsupported; returned by the GetActiveViewInfo and GetLetterViewInfo REQUESTS.
122 (0x80) | Agents are currently disabled. Returned by FireTrigger.
123 (0x81) | No item has been marked. Use ViewMarkItem or AddItem to mark an item.
124 (0x82) | Incompatible image type. Returned by GetImageFieldToFile or ViewImageFieldToFile.
125 (0x83) | Permission denied. Workgroup client does not have correct permission level.
126 (0x84) | No (-Me-) item has been defined. Use Customize-Preferences-Personal Info.
127 (0x85) | TAPI error encountered.
128 (0x86) | An agent exists but it is currently inactive. Returned by FireTrigger.
201 (0xC9) | Filter 1 has been invalidated; this may occur if a connCategory item is deleted/modified.
202 (0xCA) | Filter 2 has been invalidated.
203 (0xCB) | Filter 3 has been invalidated.
204 (0xCC) | Filter 4 has been invalidated.

Implements

ICommenceDatabaseGetLastError
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetLetterViewInfo Method

CommenceDatabaseGetLetterViewInfo Method

Returns information about the active view and selected letter template at the time the Tools-Send Letter or Customize-Database-Letter Template command was executed. This call is used by the Commence letter macros and has not been implemented here.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetLetterViewInfo(
    string delim
)
Public Function GetLetterViewInfo (
    delim As String
) As String

Parameters

delim
Type: SystemString
Delimiter.

Return Value

Type: String
NotImplementedException.

Implements

ICommenceDatabaseGetLetterViewInfo(String)
Remarks
This method is not implemented.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetMarkItem Method

CommenceDatabaseGetMarkItem Method

"Marks" the specified item and makes it the default category and item for subsequent calls to: EditItem, DeleteItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands, and GetField, GetFieldToFile, GetFields, GetConnectedItemCount and GetConnectedItemNames REQUESTS. The category and item is marked only for the specific DDE conversation, not globally. that is, each DDE conversation can have a different marked item. Can be used to mark the (-Me-) item if one is defined. Syntax: [GetMarkItem("(-Me-)")] Note: If a Clarify Field is defined for the category, the value of the clarify field can be specified with an optional third paramter. Alternatively, the ItemName can be a clarified item name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool GetMarkItem(
    string categoryNameOrKeyword,
    string itemName = "",
    string clarifyValue = ""
)
Public Function GetMarkItem (
    categoryNameOrKeyword As String,
    Optional itemName As String = "",
    Optional clarifyValue As String = ""
) As Boolean

Parameters

categoryNameOrKeyword
Type: SystemString
Commence category name
itemName (Optional)
Type: SystemString
Commence item name
clarifyValue (Optional)
Type: SystemString
Commence clarify value

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseGetMarkItem(String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetMeField Method

CommenceDatabaseGetMeField Method

Gets a fieldvalue from the item defined as (-Me-) item in Commence.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetMeField(
    string fieldName
)
Public Function GetMeField (
    fieldName As String
) As String

Parameters

fieldName
Type: SystemString
Commence field name.

Return Value

Type: String
FieldValue, "(Field not found)" if field doesn't exist, "(ME item not found)" if no (-Me-) item is set. Or NACK 126?

Implements

ICommenceDatabaseGetMeField(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetNameField Method

CommenceDatabaseGetNameField Method

Get the name of the namefield for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetNameField(
    string categoryName
)
Public Function GetNameField (
    categoryName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: String
Fieldname of the Name field, null on error. (Does the category exist?)

Implements

ICommenceDatabaseGetNameField(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetPhoneNumber Method

CommenceDatabaseGetPhoneNumber Method

TAPI must be configured for GetPhoneNumber to work properly. TAPI is ancient, so this method is not implemented.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetPhoneNumber(
    string phoneNumber,
    string delim = null
)
Public Function GetPhoneNumber (
    phoneNumber As String,
    Optional delim As String = Nothing
) As String

Parameters

phoneNumber
Type: SystemString
phone number.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
NotImplementedException

Implements

ICommenceDatabaseGetPhoneNumber(String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetPreference Method

CommenceDatabaseGetPreference Method

Get preference settings.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetPreference(
    string preferenceSetting
)
Public Function GetPreference (
    preferenceSetting As String
) As String

Parameters

preferenceSetting
Type: SystemString
Setting to retrieve. Valid settings are "Me", "MeCategory", "LetterLogDir", "ExternalDir"

Return Value

Type: String
Commence Preferences setting.

Implements

ICommenceDatabaseGetPreference(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetReverseName Method

CommenceDatabaseGetReverseName Method

Uses Commence preference information and reverses the name if appropriate.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetReverseName(
    string itemName,
    int prefFlag = 0
)
Public Function GetReverseName (
    itemName As String,
    Optional prefFlag As Integer = 0
) As String

Parameters

itemName
Type: SystemString
Commence item name.
prefFlag (Optional)
Type: SystemInt32
If the PrefFlag parameter is 1, then the Customize / Preferences / Other / Name Field setting is used to determine if names should be reversed. If the PrefFlag parameter is left blank or is set to 0, then the command uses the Reverse Name checkbox value of the latest invocation of Tools-Send Letter and reverses the name if appropriate.

Return Value

Type: String
Reverse name, if applicable.

Implements

ICommenceDatabaseGetReverseName(String, Int32)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetTriggerCount Method

CommenceDatabaseGetTriggerCount Method

Gets the number of DDE agent triggers defined in the database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetTriggerCount()
Public Function GetTriggerCount As Integer

Return Value

Type: Int32
Number of items, -1 on error.

Implements

ICommenceDatabaseGetTriggerCount
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetTriggerNames Method

CommenceDatabaseGetTriggerNames Method

Overload List
 | Name | Description
Public method | GetTriggerNames | Get a list of Agent triggers.
Public method | GetTriggerNames(String) | Gets the trigger names defined in the database.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetTriggerNames Method

CommenceDatabaseGetTriggerNames Method

Get a list of Agent triggers.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetTriggerNames()
Public Function GetTriggerNames As List(Of String)

Return Value

Type: List String
List of agent triggers.

Implements

ICommenceDatabaseGetTriggerNames
Remarks
This method is only available to .Net consumers.
See Also

Reference

CommenceDatabase Class
GetTriggerNames Overload


CommenceDatabase.GetTriggerNames Method (String)

CommenceDatabaseGetTriggerNames Method (String)

Gets the trigger names defined in the database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetTriggerNames(
    string delim = null
)
Public Function GetTriggerNames (
    Optional delim As String = Nothing
) As String

Parameters

delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the trigger names delimited by delim or CR/LF if not supplied.

Implements

ICommenceDatabaseGetTriggerNames(String)
See Also

Reference

CommenceDatabase Class
GetTriggerNames Overload


CommenceDatabase.GetViewColumnNames Method

CommenceDatabaseGetViewColumnNames Method

Gets the columnnames from a view provided a cursor can be created on them.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IEnumerable<string> GetViewColumnNames(
    string viewName,
    CmcOptionFlags flags = CmcOptionFlags.Fieldname
)
Public Function GetViewColumnNames (
    viewName As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Fieldname
) As IEnumerable(Of String)

Parameters

viewName
Type: SystemString
Commence view name (case-sensitive).
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags

Return Value

Type: IEnumerable String
List of fieldnames or columnlabels for view.

Implements

ICommenceDatabaseGetViewColumnNames(String, CmcOptionFlags)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetViewCount Method

CommenceDatabaseGetViewCount Method

Gets the number of views in the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetViewCount(
    string categoryName
)
Public Function GetViewCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: Int32
Number of views, -1 on error.

Implements

ICommenceDatabaseGetViewCount(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetViewDefinition Method

CommenceDatabaseGetViewDefinition Method

Get definition of a view

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IViewDef GetViewDefinition(
    string viewName
)
Public Function GetViewDefinition (
    viewName As String
) As IViewDef

Parameters

viewName
Type: SystemString
Commence view name, case-sensitive.

Return Value

Type: IViewDef
ViewDef object that exposes properties of the view, null on error.

Implements

ICommenceDatabaseGetViewDefinition(String)
Exceptions
Exception | Condition
CommenceCOMException | View not found.
Remarks
Unlike it's (undocumented) Commence counterpart, this method returns a IViewDef object instead of a delimited string. Returns null on error. You cannot use this method on Multiviews.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetViewNames Method

CommenceDatabaseGetViewNames Method

Overload List
 | Name | Description
Public method | GetViewNames(String) | Gets a list of all views for the specified category. Returns all categories if category is not specified.
Public method | GetViewNames(String, String) | Gets a list of view names for the specified category.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.GetViewNames Method (String)

CommenceDatabaseGetViewNames Method (String)

Gets a list of all views for the specified category. Returns all categories if category is not specified.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<string> GetViewNames(
    string categoryName
)
Public Function GetViewNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence category name. Set to String.Empty (or it's equivalent for your language) to get all views in database.

Return Value

Type: List String
List of viewnames.

Implements

ICommenceDatabaseGetViewNames(String)
Remarks
This method is only available to .Net consumers.
See Also

Reference

CommenceDatabase Class
GetViewNames Overload


CommenceDatabase.GetViewNames Method (String, String)

CommenceDatabaseGetViewNames Method (String, String)

Gets a list of view names for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetViewNames(
    string categoryName,
    string delim = null
)
Public Function GetViewNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the view names delimited by delim or CR/LF if not supplied.

Implements

ICommenceDatabaseGetViewNames(String, String)
See Also

Reference

CommenceDatabase Class
GetViewNames Overload


CommenceDatabase.GetViewToFile Method

CommenceDatabaseGetViewToFile Method

Saves the Commence View to a file in HTML format (similar to the File-Save As HTML menu command). If the file does not exist, Commence will create it; the drive and directory must exist. If the file exists, it will be overwritten.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool GetViewToFile(
    string viewName,
    string fileName,
    CmcLinkMode linkMode = CmcLinkMode.None,
    string param1 = null,
    string param2 = null
)
Public Function GetViewToFile (
    viewName As String,
    fileName As String,
    Optional linkMode As CmcLinkMode = CmcLinkMode.None,
    Optional param1 As String = Nothing,
    Optional param2 As String = Nothing
) As Boolean

Parameters

viewName
Type: SystemString
Commence view name (case-sensitive)
fileName
Type: SystemString
(fully qualified) filename
linkMode (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcLinkMode
LINKMODE values0No view linking (default).1View linking on selected item; Param1 = category name; Param2 = Item name [clarify issues?]2View linking on selected date; Param1 = date string (including AI dates); Param2 = unused3View linking on selected date range; Param1 = start date string (including AI dates); Param2 = end date string (including AI dates)
param1 (Optional)
Type: SystemString
Used with view linking to identify the "active item/date/date range" when the view contains a "view linked" filter.
param2 (Optional)
Type: SystemString
Used with view linking to identify the "active item/date/date range" when the view contains a "view linked" filter.

Return Value

Type: Boolean
true on success. Use GetLastError on failure

Implements

ICommenceDatabaseGetViewToFile(String, String, CmcLinkMode, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.HasDuplicates Method

CommenceDatabaseHasDuplicates Method

Checks if field contains duplicate values.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool HasDuplicates(
    string categoryName,
    string fieldName,
    bool caseSensitive = true
)
Public Function HasDuplicates (
    categoryName As String,
    fieldName As String,
    Optional caseSensitive As Boolean = true
) As Boolean

Parameters

categoryName
Type: SystemString
Categoryname.
fieldName
Type: SystemString
Fieldname.
caseSensitive (Optional)
Type: SystemBoolean
Perform case-sensitive check, default is true.

Return Value

Type: Boolean
true if duplicates are found.

Implements

ICommenceDatabaseHasDuplicates(String, String, Boolean)
Remarks
Commence allows for filtering on duplicate Name field values only, this method allows for checking other fieldtypes as well.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.LogPhoneCall Method

CommenceDatabaseLogPhoneCall Method

Launches an add tem detail window for an item in the Phone Log category (as specified in the Commence Customize-Preferences-Event Logs dialog box). One or more Category/Item pairs may be given as arguments; connections will be set between the new Phone Log item and these items. If no connection exists between the two categories, the pair is ignored and no error is given. The connection is set via all connections found between the two categories. If no Phone Log category is set, NACK error code 104 (DDE_ERROR_NOLOGCLASS) is returned. If there is no room to add an item in the Phone Log category, NACK error code 112 (DDE_ERROR_FULL) is returned.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool LogPhoneCall(
    Object[] args
)
Public Function LogPhoneCall (
    args As Object()
) As Boolean

Parameters

args
Type: SystemObject
Category1, Item1, ..., Category n, Item n

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseLogPhoneCall(Object)
Remarks
Note: if Commence prompts for an Item Detail Form to use, this will halt the call (and subsequent code) until a form was chosen or the form selection window was cancelled.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.MarkActiveItem Method

CommenceDatabaseMarkActiveItem Method

Marks the active item for subsequent requests.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string MarkActiveItem(
    string delim = null
)
Public Function MarkActiveItem (
    Optional delim As String = Nothing
) As String

Parameters

delim (Optional)
Type: SystemString
Delimiter, up to 8 characters.

Return Value

Type: String
String with categoryname and item name, delimited by delim or CR/LF if not supplied, null if no item is active.

Implements

ICommenceDatabaseMarkActiveItem(String)
Remarks
Commence documentation does not specify a return value or delimiter for this request, but it does have a return value and can take a delimiter. Inspecting the return value can be useful for checking if the request was successful.
See Also

Reference

CommenceDatabase Class


CommenceDatabase.MergeTemplateCreate Method

CommenceDatabaseMergeTemplateCreate Method

Creates a new template with the given parameters. If template exists, the call fails. This call returns the template filename assigned by Commence, including the full path and extension configured in Preferences-Letter dialog.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string MergeTemplateCreate(
    string templateName,
    string categoryName,
    bool shared
)
Public Function MergeTemplateCreate (
    templateName As String,
    categoryName As String,
    shared As Boolean
) As String

Parameters

templateName
Type: SystemString
Name for new template.
categoryName
Type: SystemString
Commence category name.
shared
Type: SystemBoolean
true for shared template, ignored when database is stand-alone, fails if user has no author rights.

Return Value

Type: String
Template filename assigned by Commence, including the full path and extension.

Implements

ICommenceDatabaseMergeTemplateCreate(String, String, Boolean)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.MergeTemplateSave Method

CommenceDatabaseMergeTemplateSave Method

Updates an existing template identified by the name parameter. Template must exist, else the call fails.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string MergeTemplateSave(
    string templateName,
    bool shared
)
Public Function MergeTemplateSave (
    templateName As String,
    shared As Boolean
) As String

Parameters

templateName
Type: SystemString
Commence template name.
shared
Type: SystemBoolean
true for shared, ignored for stand-alone, fails when user is non-author.

Return Value

Type: String
Template filename assigned by Commence, including the full path and extension.

Implements

ICommenceDatabaseMergeTemplateSave(String, Boolean)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.PromoteItemToShared Method

CommenceDatabasePromoteItemToShared Method

Promotes a local item to shared status, provided the database is connected and the category is shared. If the item is already shared, its status is unchanged. Note that there is no way to demote an item from shared to local status. Whenever possible, use a clarified Item name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool PromoteItemToShared(
    string categoryName,
    string itemName
)
Public Function PromoteItemToShared (
    categoryName As String,
    itemName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabasePromoteItemToShared(String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ShowDesktop Method

CommenceDatabaseShowDesktop Method

Opens the specified desktop in Commence.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ShowDesktop(
    string desktopName
)
Public Function ShowDesktop (
    desktopName As String
) As Boolean

Parameters

desktopName
Type: SystemString
Commence desktop name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseShowDesktop(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ShowItem Method

CommenceDatabaseShowItem Method

Opens an item detail window in Commence for the given Item in the given Category. If a detail is already open for the item, it will be brought to the top and given the focus.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ShowItem(
    string categoryName,
    string itemName,
    string formName = null
)
Public Function ShowItem (
    categoryName As String,
    itemName As String,
    Optional formName As String = Nothing
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
formName (Optional)
Type: SystemString
Commence detail form name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseShowItem(String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ShowView Method

CommenceDatabaseShowView Method

Opens the specified view in Commence. If the view is already open, it will become the active view.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ShowView(
    string viewName,
    bool newCopy
)
Public Function ShowView (
    viewName As String,
    newCopy As Boolean
) As Boolean

Parameters

viewName
Type: SystemString
Commence view name.
newCopy
Type: SystemBoolean
Set to true to force a new copy of the view to be opened.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseShowView(String, Boolean)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.UnassignConnection Method

CommenceDatabaseUnassignConnection Method

Unassigns a connection between two items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool UnassignConnection(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory,
    string connItem
)
Public Function UnassignConnection (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String,
    connItem As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence 'From' category.
itemName
Type: SystemString
Commence 'From' item. Use clarified names if possible.
connectionName
Type: SystemString
Commence connection name (case-sensitive)
connCategory
Type: SystemString
Commence 'To' category
connItem
Type: SystemString
Commence 'To' item. Use clarified names if possible.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseUnassignConnection(String, String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewCategory Method

CommenceDatabaseViewCategory Method

Defines the category to be used. This must be the first message sent to Commence for a ViewData conversation. ViewCategory may be sent at any time to reset the ViewData conversation state. ViewData conversation topic has been obsolete since Commence 3.0 (1995 or so), so it is extremely unlikely you will ever need this method.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ViewCategory(
    string categoryName
)
Public Function ViewCategory (
    categoryName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: String
"OK" on success, NACK error code on failure, GetLastError.

Implements

ICommenceDatabaseViewCategory(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewConjunction Method

CommenceDatabaseViewConjunction Method

Defines the logical operations that link the filter clauses specified with the ViewFilter request. Each parameter can be either "And" or "Or"; the default value is "And". AndOr12 defines the relationship between the filter clauses 1 and 2, AndOr34 for clauses 3 and 4, and AndOr13 for (1 and 2) and (3 and 4), etc. Note the special significance of AndOr48, which signifies the relationship between the two groups of 4 filters.

The logical precedence is: (Filter1 AndOr12 Filter2) AndOr13 (Filter3 AndOr34 Filter4) AndOr4to8 [repeat 5 to 8]

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ViewConjunction(
    string AndOr12,
    string AndOr13,
    string AndOr34,
    string AndOr48,
    string AndOr56,
    string AndOr57,
    string AndOr78
)
Public Function ViewConjunction (
    AndOr12 As String,
    AndOr13 As String,
    AndOr34 As String,
    AndOr48 As String,
    AndOr56 As String,
    AndOr57 As String,
    AndOr78 As String
) As String

Parameters

AndOr12
Type: SystemString
string "And" or "Or".
AndOr13
Type: SystemString
string "And" or "Or".
AndOr34
Type: SystemString
string "And" or "Or".
AndOr48
Type: SystemString
string "And" or "Or".
AndOr56
Type: SystemString
string "And" or "Or".
AndOr57
Type: SystemString
string "And" or "Or".
AndOr78
Type: SystemString
string "And" or "Or".

Return Value

Type: String
"OK" on success, NACK error code on failure, GetLastError

Implements

ICommenceDatabaseViewConjunction(String, String, String, String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewConnectedCount Method

CommenceDatabaseViewConnectedCount Method

Returns the number of items in the connCategory that the Indexth item is connected to via ConnectionName.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int ViewConnectedCount(
    int index,
    string connectionName,
    string connCategory
)
Public Function ViewConnectedCount (
    index As Integer,
    connectionName As String,
    connCategory As String
) As Integer

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connected category.

Return Value

Type: Int32
Connected item count, -1 on error.

Implements

ICommenceDatabaseViewConnectedCount(Int32, String, String)
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetConnectedItemCount(String, String, String, String)


CommenceDatabase.ViewConnectedField Method

CommenceDatabaseViewConnectedField Method

Returns the value of Field of the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ViewConnectedField(
    int index,
    string connectionName,
    string connCategory,
    int connIndex,
    string fieldName
)
Public Function ViewConnectedField (
    index As Integer,
    connectionName As String,
    connCategory As String,
    connIndex As Integer,
    fieldName As String
) As String

Parameters

index
Type: SystemInt32
Index of item to query.
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connected category.
connIndex
Type: SystemInt32
Index of connected item.
fieldName
Type: SystemString
Commence fieldname to return from connCategory. Field cannot be of the field type Image.

Return Value

Type: String
Fieldvalue.

Implements

ICommenceDatabaseViewConnectedField(Int32, String, String, Int32, String)
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetConnectedItemField(String, String, String, String, String, String)


CommenceDatabase.ViewConnectedFields Method

CommenceDatabaseViewConnectedFields Method

Overload List
 | Name | Description
Public method | ViewConnectedFields(Int32, String, String, Int32, ListString, String) | Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method | ViewConnectedFields(Int32, String, String, Int32, Object, String) | Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewConnectedFields Method (Int32, String, String, Int32, List(String), String)

CommenceDatabaseViewConnectedFields Method (Int32, String, String, Int32, ListString, String)

Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string[] ViewConnectedFields(
    int index,
    string connectionName,
    string connCategory,
    int connIndex,
    List<string> fields,
    string delim = null
)
Public Function ViewConnectedFields (
    index As Integer,
    connectionName As String,
    connCategory As String,
    connIndex As Integer,
    fields As List(Of String),
    Optional delim As String = Nothing
) As String()

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connCategory name.
connIndex
Type: SystemInt32
Index of connected row.
fields
Type: System.Collections.GenericList String
List of fieldnames.
delim (Optional)
Type: SystemString
Delimiter, up to max 8 chars.

Return Value

Type: String
String array of fieldvalues for the requested fields.

Implements

ICommenceDatabaseViewConnectedFields(Int32, String, String, Int32, ListString, String)
See Also

Reference

CommenceDatabase Class
ViewConnectedFields Overload


CommenceDatabase.ViewConnectedFields Method (Int32, String, String, Int32, Object[], String)

CommenceDatabaseViewConnectedFields Method (Int32, String, String, Int32, Object, String)

Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ViewConnectedFields(
    int index,
    string connectionName,
    string connCategory,
    int connIndex,
    Object[] fields,
    string delim = null
)
Public Function ViewConnectedFields (
    index As Integer,
    connectionName As String,
    connCategory As String,
    connIndex As Integer,
    fields As Object(),
    Optional delim As String = Nothing
) As String

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connCategory name.
connIndex
Type: SystemInt32
Index of connected row.
fields
Type: SystemObject
Object array containg fieldnames.
delim (Optional)
Type: SystemString
Delimiter, up to max 8 chars.

Return Value

Type: String
String array of fieldvalues for the requested fields.

Implements

ICommenceDatabaseViewConnectedFields(Int32, String, String, Int32, Object, String)
See Also

Reference

CommenceDatabase Class
ViewConnectedFields Overload


CommenceDatabase.ViewConnectedItem Method

CommenceDatabaseViewConnectedItem Method

Returns the ConnIndexth item in connCategory that the Indexth item is connected to via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ViewConnectedItem(
    int index,
    string connectionName,
    string connCategory,
    int connIndex
)
Public Function ViewConnectedItem (
    index As Integer,
    connectionName As String,
    connCategory As String,
    connIndex As Integer
) As String

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connCategory name.
connIndex
Type: SystemInt32
Index of connected row.

Return Value

Type: String
ConnIndexth item in connCategory that the Indexth item is connected to via ConnectionName.

Implements

ICommenceDatabaseViewConnectedItem(Int32, String, String, Int32)
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetConnectedItemNames(String, String, String, String, String)


CommenceDatabase.ViewDeleteAllItems Method

CommenceDatabaseViewDeleteAllItems Method

USE WITH EXTREME CAUTION! Deletes all items that satisfy the currently defined filter. If no filter is defined, deletes all items in the previously named category, see ViewCategory(String). Fails without warning when no delete permissions were granted on the category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void ViewDeleteAllItems()
Public Sub ViewDeleteAllItems

Implements

ICommenceDatabaseViewDeleteAllItems
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewField Method

CommenceDatabaseViewField Method

Returns the value of Field of the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount REQUEST to determine the maximum Index value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ViewField(
    int index,
    string fieldName
)
Public Function ViewField (
    index As Integer,
    fieldName As String
) As String

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
fieldName
Type: SystemString
Commence field name.

Return Value

Type: String
FieldValue.

Implements

ICommenceDatabaseViewField(Int32, String)
Remarks
If the Name field is requested, the returned value is NOT clarified. Use ViewItemNameand ClarifyItemNames) to retrieve the clarified item name.
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetField(String, String, String)


CommenceDatabase.ViewFields Method

CommenceDatabaseViewFields Method

Overload List
 | Name | Description
Public method | ViewFields(Int32, ListString, String) | Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method | ViewFields(Int32, Object, String) | Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Top
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewFields Method (Int32, List(String), String)

CommenceDatabaseViewFields Method (Int32, ListString, String)

Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string[] ViewFields(
    int index,
    List<string> fields,
    string delim = null
)
Public Function ViewFields (
    index As Integer,
    fields As List(Of String),
    Optional delim As String = Nothing
) As String()

Parameters

index
Type: SystemInt32
Indexth item (1-based) that satisfies the currently defined filter (if any).
fields
Type: System.Collections.GenericList String
List of fields to retrieve.
delim (Optional)
Type: SystemString
Delimiter, up to max 8 chars.

Return Value

Type: String
String array of string representing the fieldvalues.

Implements

ICommenceDatabaseViewFields(Int32, ListString, String)
Remarks
Using a ICommenceQueryRowSet is usually faster and easier. This method is only available to .NET applications.
See Also

Reference

CommenceDatabase Class
ViewFields Overload
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetFields(String, String, Object, String)


CommenceDatabase.ViewFields Method (Int32, Object[], String)

CommenceDatabaseViewFields Method (Int32, Object, String)

Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ViewFields(
    int index,
    Object[] fields,
    string delim = null
)
Public Function ViewFields (
    index As Integer,
    fields As Object(),
    Optional delim As String = Nothing
) As String

Parameters

index
Type: SystemInt32
Indexth item (1-based) that satisfies the currently defined filter (if any).
fields
Type: SystemObject
Object array of fields to retrieve.
delim (Optional)
Type: SystemString
Delimiter, up to max 8 chars.

Return Value

Type: String
String array of string representing the fieldvalues.

Implements

ICommenceDatabaseViewFields(Int32, Object, String)
Remarks
Using a ICommenceQueryRowSet is usually faster and easier.
See Also

Reference

CommenceDatabase Class
ViewFields Overload
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetFields(String, String, Object, String)


CommenceDatabase.ViewFieldToFile Method

CommenceDatabaseViewFieldToFile Method

Saves specified field to file

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ViewFieldToFile(
    int index,
    string fieldName,
    string fileName
)
Public Function ViewFieldToFile (
    index As Integer,
    fieldName As String,
    fileName As String
) As Boolean

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
fieldName
Type: SystemString
Commence fieldName.
fileName
Type: SystemString
(fully qualified) filename. Existing files will be overwritten

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseViewFieldToFile(Int32, String, String)
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetFieldToFile(String, String, String, String)


CommenceDatabase.ViewFilter Method

CommenceDatabaseViewFilter Method

Defines the criteria for the multiple filter to be applied against the previously named category/view (see ViewCategory/ViewView). This is by far the most complicated API method to use. Unless you are actually creating views from code, you are strongly advised to use the Filters collection of the CommenceCursor class instead.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ViewFilter(
    int clauseNumber,
    string filterType,
    bool notFlag,
    Object args
)
Public Function ViewFilter (
    clauseNumber As Integer,
    filterType As String,
    notFlag As Boolean,
    args As Object
) As Boolean

Parameters

clauseNumber
Type: SystemInt32
ClauseNumber defines which filter clause is being defined, where ClauseNumber is between 1 and 8.
filterType
Type: SystemString
FilterType sets the type of the filter to apply. Valid filterTypes are F, CTCF, CTI and CTCTI.
notFlag
Type: SystemBoolean
NotFlag determines if a logical Not is applied against the entire clause.
args
Type: SystemObject
String array of filtertype parameters. See Commence DDE documentation

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseViewFilter(Int32, String, Boolean, Object)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewImageFieldToFile Method

CommenceDatabaseViewImageFieldToFile Method

Copies the image field data in Field from the Indexth item that satisfies the currently defined filter (if any) to the specified Filename.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ViewImageFieldToFile(
    int index,
    string fieldName,
    string fileName
)
Public Function ViewImageFieldToFile (
    index As Integer,
    fieldName As String,
    fileName As String
) As Boolean

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
fieldName
Type: SystemString
Commence field name.
fileName
Type: SystemString
Fully qualified path including the drive letter (e.g. c:\tmp\data.bmp). If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten. It is the client’s responsibility to perform the necessary file cleanup.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseViewImageFieldToFile(Int32, String, String)
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetImageFieldToFile(String, String, String, String)


CommenceDatabase.ViewItemCount Method

CommenceDatabaseViewItemCount Method

Returns the number of items that satisfy the currently defined filter (if any). If no filter is defined, this request returns the total number of items in the category

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int ViewItemCount()
Public Function ViewItemCount As Integer

Return Value

Type: Int32
Item count.

Implements

ICommenceDatabaseViewItemCount
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetItemCount(String)


CommenceDatabase.ViewItemIndex Method

CommenceDatabaseViewItemIndex Method

Returns the index of the item with the indicated name field value. The item must also satisfy the currently defined filter (if any). Use a clarified itemname if possible. Note: If the NameFieldValue is left blank, the marked item will be used. Returns the index of the marked item (if any).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int ViewItemIndex(
    string nameFieldValue
)
Public Function ViewItemIndex (
    nameFieldValue As String
) As Integer

Parameters

nameFieldValue
Type: SystemString
Commence Name field value. Note: it must be the fieldvalue, NOT the clarified itemname.

Return Value

Type: Int32
Index (1-based).

Implements

ICommenceDatabaseViewItemIndex(String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewItemName Method

CommenceDatabaseViewItemName Method

Returns the itemname for the Indexth item. Different from ViewField(Index, Name) in that a clarified item name may be returned. The ClarifyItemNames request is used to enable or disable the use of clarified item names.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ViewItemName(
    int index
)
Public Function ViewItemName (
    index As Integer
) As String

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).

Return Value

Type: String
Item name.

Implements

ICommenceDatabaseViewItemName(Int32)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewMarkItem Method

CommenceDatabaseViewMarkItem Method

Marks the Indexth item in the view and makes it the default category and item for the EditItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ViewMarkItem(
    int index
)
Public Function ViewMarkItem (
    index As Integer
) As Boolean

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).

Return Value

Type: Boolean
True on success, inspect GetLastError on failure

Implements

ICommenceDatabaseViewMarkItem(Int32)
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetMarkItem(String, String, String)


CommenceDatabase.ViewReverseName Method

CommenceDatabaseViewReverseName Method

Uses Commence preference information and reverses the name if appropriate.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ViewReverseName(
    string itemName,
    int prefFlag = 0
)
Public Function ViewReverseName (
    itemName As String,
    Optional prefFlag As Integer = 0
) As String

Parameters

itemName
Type: SystemString
Commence item name.
prefFlag (Optional)
Type: SystemInt32
If the optional PrefFlag parameter is 1, then the Customize-Preferences-Other-Name Field setting is used to determine if names should be reversed. If the PrefFlag parameter is left blank or is set to 0, then the command uses the Reverse Name checkbox value of the latest invocation of Tools-Send Letter and reverses the name if appropriate.

Return Value

Type: String
Reverse name, if applicable.

Implements

ICommenceDatabaseViewReverseName(String, Int32)
Remarks
This method is identical to GetReverseName.
See Also

Reference

CommenceDatabase Class
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetReverseName(String, Int32)


CommenceDatabase.ViewSaveView Method

CommenceDatabaseViewSaveView Method

Saves the virtual DDE view already created with the ViewCategory, ViewFilter, ViewSort, etc., as an actual view in Commence, accessible via the normal user interface. The view will be saved using the specified New View Name. If the view already exists, it will be overwritten. Use GetViewNames to determine if the view name conflicts with an existing view.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ViewSaveView(
    string newViewName,
    bool shared
)
Public Function ViewSaveView (
    newViewName As String,
    shared As Boolean
) As Boolean

Parameters

newViewName
Type: SystemString
new View Name to save.
shared
Type: SystemBoolean
Make view Shared. Ignored on stand-alone clients.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseViewSaveView(String, Boolean)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewSort Method

CommenceDatabaseViewSort Method

Defines the sort criteria for the view. Field1, Field2, Field3, and Field4 define the fields to sort by. Sort1, Sort2, Sort3, and Sort4 define the sort type and should be "Ascending" or "Descending". Unused sort pairs (i.e. FieldN, SortN) may be omitted.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ViewSort(
    string fieldName1,
    string sortOrder1,
    string fieldName2 = "",
    string sortOrder2 = "",
    string fieldName3 = "",
    string sortOrder3 = "",
    string fieldName4 = "",
    string sortOrder4 = ""
)
Public Function ViewSort (
    fieldName1 As String,
    sortOrder1 As String,
    Optional fieldName2 As String = "",
    Optional sortOrder2 As String = "",
    Optional fieldName3 As String = "",
    Optional sortOrder3 As String = "",
    Optional fieldName4 As String = "",
    Optional sortOrder4 As String = ""
) As Boolean

Parameters

fieldName1
Type: SystemString
Commence sort field name1
sortOrder1
Type: SystemString
Order, should be "Ascending" or "Descending".
fieldName2 (Optional)
Type: SystemString
Commence sort field name2
sortOrder2 (Optional)
Type: SystemString
Order, should be "Ascending" or "Descending".
fieldName3 (Optional)
Type: SystemString
Commence sort field name3
sortOrder3 (Optional)
Type: SystemString
Order, should be "Ascending" or "Descending".
fieldName4 (Optional)
Type: SystemString
Commence sort field name4
sortOrder4 (Optional)
Type: SystemString
Order, should be "Ascending" or "Descending".

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseViewSort(String, String, String, String, String, String, String, String)
See Also

Reference

CommenceDatabase Class


CommenceDatabase.ViewView Method

CommenceDatabaseViewView Method

Uses the category and filter criteria of a Commence View that has already be defined from the Commence menu interface. The ViewView REQUEST overrides any previously received ViewCategory, ViewConjunction, ViewFilter, and ViewSort REQUESTS. If the ViewName parameter is left blank, the active view will be used.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ViewView(
    string viewName = ""
)
Public Function ViewView (
    Optional viewName As String = ""
) As Boolean

Parameters

viewName (Optional)
Type: SystemString
Commence view name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.

Implements

ICommenceDatabaseViewView(String)
See Also

Reference

CommenceDatabase Class


CommenceDeleteRowSet Class

Represent a rowset of items to delete. Items are not deleted until Commit is called.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseRowSet
Vovin.CmcLibNet.DatabaseCommenceDeleteRowSet

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public sealed class CommenceDeleteRowSet : BaseRowSet,
    ICommenceDeleteRowSet, IBaseRowSet, IDisposable
Public NotInheritable Class CommenceDeleteRowSet
    Inherits BaseRowSet
    Implements ICommenceDeleteRowSet, IBaseRowSet, IDisposable

The CommenceDeleteRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset (Overrides BaseRowSetColumnCount.)
Public property | RowCount | Number of items in rowset. (Overrides BaseRowSetRowCount.)
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this. (Overrides BaseRowSetClose.)
Public method | Commit | Commit changes to disk.
Public method | DeleteRow | Mark a row for deletion.
Public method | Dispose | Dispose method (Inherited from BaseRowSet.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label (Overrides BaseRowSetGetColumnIndex(String, CmcOptionFlags).)
Public method | GetColumnLabel | Search the column set and return the column label or fieldname (Overrides BaseRowSetGetColumnLabel(Int32, CmcOptionFlags).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowValue | Get rowvalue for specified row/column (Overrides BaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags).)
Public method | GetShared | Gets the shared/local status of the row (Overrides BaseRowSetGetShared(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


CommenceDeleteRowSet Properties

The CommenceDeleteRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset (Overrides BaseRowSetColumnCount.)
Public property | RowCount | Number of items in rowset. (Overrides BaseRowSetRowCount.)
Top
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.ColumnCount Property

CommenceDeleteRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceDeleteRowSetColumnCount
IBaseRowSetColumnCount
IBaseRowSetColumnCount
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.RowCount Property

CommenceDeleteRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int RowCount { get; }
Public Overrides ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceDeleteRowSetRowCount
IBaseRowSetRowCount
IBaseRowSetRowCount
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet Methods

The CommenceDeleteRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this. (Overrides BaseRowSetClose.)
Public method | Commit | Commit changes to disk.
Public method | DeleteRow | Mark a row for deletion.
Public method | Dispose | Dispose method (Inherited from BaseRowSet.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label (Overrides BaseRowSetGetColumnIndex(String, CmcOptionFlags).)
Public method | GetColumnLabel | Search the column set and return the column label or fieldname (Overrides BaseRowSetGetColumnLabel(Int32, CmcOptionFlags).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowValue | Get rowvalue for specified row/column (Overrides BaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags).)
Public method | GetShared | Gets the shared/local status of the row (Overrides BaseRowSetGetShared(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.Close Method

CommenceDeleteRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override void Close()
Public Overrides Sub Close

Implements

ICommenceDeleteRowSetClose
IBaseRowSetClose
IBaseRowSetClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.Commit Method

CommenceDeleteRowSetCommit Method

Commit changes to disk.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int Commit(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function Commit (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.

Implements

ICommenceDeleteRowSetCommit(CmcOptionFlags)
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.DeleteRow Method

CommenceDeleteRowSetDeleteRow Method

Mark a row for deletion.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int DeleteRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function DeleteRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.

Implements

ICommenceDeleteRowSetDeleteRow(Int32, CmcOptionFlags)
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.GetColumnIndex Method

CommenceDeleteRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.

Implements

ICommenceDeleteRowSetGetColumnIndex(String, CmcOptionFlags)
IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.GetColumnLabel Method

CommenceDeleteRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.

Implements

ICommenceDeleteRowSetGetColumnLabel(Int32, CmcOptionFlags)
IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.GetRow Method

CommenceDeleteRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Top
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.GetRow Method (Int32, CmcOptionFlags)

CommenceDeleteRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

ICommenceDeleteRowSetGetRow(Int32, CmcOptionFlags)
IBaseRowSetGetRow(Int32, CmcOptionFlags)
IBaseRowSetGetRow(Int32, CmcOptionFlags)
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

CommenceDeleteRowSet Class
GetRow Overload


CommenceDeleteRowSet.GetRow Method (Int32, String, CmcOptionFlags)

CommenceDeleteRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

ICommenceDeleteRowSetGetRow(Int32, String, CmcOptionFlags)
IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
See Also

Reference

CommenceDeleteRowSet Class
GetRow Overload


CommenceDeleteRowSet.GetRowID Method

CommenceDeleteRowSetGetRowID Method

Returns a unique identifier for a row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetRowID(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetRowID (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: String
Returns a unique ID string (less than 100 chars) on success, null on error.

Implements

ICommenceDeleteRowSetGetRowID(Int32, CmcOptionFlags)
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.GetRowValue Method

CommenceDeleteRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.

Implements

ICommenceDeleteRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
See Also

Reference

CommenceDeleteRowSet Class


CommenceDeleteRowSet.GetShared Method

CommenceDeleteRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override bool GetShared(
    int nRow
)
Public Overrides Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.

Implements

ICommenceDeleteRowSetGetShared(Int32)
IBaseRowSetGetShared(Int32)
IBaseRowSetGetShared(Int32)
See Also

Reference

CommenceDeleteRowSet Class


CommenceEditRowSet Class

Represents a rowset of items to edit.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseRowSet
Vovin.CmcLibNet.DatabaseCommenceEditRowSet

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public sealed class CommenceEditRowSet : BaseRowSet,
    ICommenceEditRowSet, IBaseRowSet, IDisposable
Public NotInheritable Class CommenceEditRowSet
    Inherits BaseRowSet
    Implements ICommenceEditRowSet, IBaseRowSet, IDisposable

The CommenceEditRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset (Overrides BaseRowSetColumnCount.)
Public property | RowCount | Number of items in rowset. (Overrides BaseRowSetRowCount.)
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this. (Overrides BaseRowSetClose.)
Public method | Commit | Commit changes to disk.
Public method | CommitGetCursor | Make row modifications permanent (commit to disk) and return a cursor for the newly added data
Public method | Dispose | Dispose method (Inherited from BaseRowSet.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label (Overrides BaseRowSetGetColumnIndex(String, CmcOptionFlags).)
Public method | GetColumnLabel | Search the column set and return the column label or fieldname (Overrides BaseRowSetGetColumnLabel(Int32, CmcOptionFlags).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowValue | Get rowvalue for specified row/column (Overrides BaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags).)
Public method | GetShared | Gets the shared/local status of the row (Overrides BaseRowSetGetShared(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifyRow | Modify fieldvalue
Public method | SetShared | Sets the shared status of the row. Shared items cannot be made unshared.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


CommenceEditRowSet Properties

The CommenceEditRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset (Overrides BaseRowSetColumnCount.)
Public property | RowCount | Number of items in rowset. (Overrides BaseRowSetRowCount.)
Top
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.ColumnCount Property

CommenceEditRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceEditRowSetColumnCount
IBaseRowSetColumnCount
IBaseRowSetColumnCount
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.RowCount Property

CommenceEditRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int RowCount { get; }
Public Overrides ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceEditRowSetRowCount
IBaseRowSetRowCount
IBaseRowSetRowCount
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet Methods

The CommenceEditRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this. (Overrides BaseRowSetClose.)
Public method | Commit | Commit changes to disk.
Public method | CommitGetCursor | Make row modifications permanent (commit to disk) and return a cursor for the newly added data
Public method | Dispose | Dispose method (Inherited from BaseRowSet.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label (Overrides BaseRowSetGetColumnIndex(String, CmcOptionFlags).)
Public method | GetColumnLabel | Search the column set and return the column label or fieldname (Overrides BaseRowSetGetColumnLabel(Int32, CmcOptionFlags).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowValue | Get rowvalue for specified row/column (Overrides BaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags).)
Public method | GetShared | Gets the shared/local status of the row (Overrides BaseRowSetGetShared(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifyRow | Modify fieldvalue
Public method | SetShared | Sets the shared status of the row. Shared items cannot be made unshared.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.Close Method

CommenceEditRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override void Close()
Public Overrides Sub Close

Implements

ICommenceEditRowSetClose
IBaseRowSetClose
IBaseRowSetClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.Commit Method

CommenceEditRowSetCommit Method

Commit changes to disk.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int Commit(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function Commit (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.

Implements

ICommenceEditRowSetCommit(CmcOptionFlags)
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.CommitGetCursor Method

CommenceEditRowSetCommitGetCursor Method

Make row modifications permanent (commit to disk) and return a cursor for the newly added data

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceCursor CommitGetCursor(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function CommitGetCursor (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As CommenceCursor

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: CommenceCursor
CommenceCursor object reflecting the changes.

Implements

ICommenceEditRowSetCommitGetCursor(CmcOptionFlags)
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.GetColumnIndex Method

CommenceEditRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.

Implements

ICommenceEditRowSetGetColumnIndex(String, CmcOptionFlags)
IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.GetColumnLabel Method

CommenceEditRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.

Implements

ICommenceEditRowSetGetColumnLabel(Int32, CmcOptionFlags)
IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.GetRow Method

CommenceEditRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Top
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.GetRow Method (Int32, CmcOptionFlags)

CommenceEditRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

ICommenceEditRowSetGetRow(Int32, CmcOptionFlags)
IBaseRowSetGetRow(Int32, CmcOptionFlags)
IBaseRowSetGetRow(Int32, CmcOptionFlags)
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

CommenceEditRowSet Class
GetRow Overload


CommenceEditRowSet.GetRow Method (Int32, String, CmcOptionFlags)

CommenceEditRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

ICommenceEditRowSetGetRow(Int32, String, CmcOptionFlags)
IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
See Also

Reference

CommenceEditRowSet Class
GetRow Overload


CommenceEditRowSet.GetRowID Method

CommenceEditRowSetGetRowID Method

Returns a unique identifier for a row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetRowID(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetRowID (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: String
Returns a unique ID string (less than 100 chars) on success, null on error.

Implements

ICommenceEditRowSetGetRowID(Int32, CmcOptionFlags)
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.GetRowValue Method

CommenceEditRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.

Implements

ICommenceEditRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.GetShared Method

CommenceEditRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override bool GetShared(
    int nRow
)
Public Overrides Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.

Implements

ICommenceEditRowSetGetShared(Int32)
IBaseRowSetGetShared(Int32)
IBaseRowSetGetShared(Int32)
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.ModifyRow Method

CommenceEditRowSetModifyRow Method

Modify fieldvalue

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int ModifyRow(
    int nRow,
    int nCol,
    string fieldValue,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function ModifyRow (
    nRow As Integer,
    nCol As Integer,
    fieldValue As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
nCol
Type: SystemInt32
The (0-based) index of the column.
fieldValue
Type: SystemString
new fieldValue.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.

Implements

ICommenceEditRowSetModifyRow(Int32, Int32, String, CmcOptionFlags)
See Also

Reference

CommenceEditRowSet Class


CommenceEditRowSet.SetShared Method

CommenceEditRowSetSetShared Method

Sets the shared status of the row. Shared items cannot be made unshared.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SetShared(
    int nRow
)
Public Function SetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
True on success.

Implements

ICommenceEditRowSetSetShared(Int32)
See Also

Reference

CommenceEditRowSet Class


CommenceFieldType Enumeration

Commence field types.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum CommenceFieldType
Public Enumeration CommenceFieldType
Members
Member name | Value | Description
Text | 0 | Text field.
Number | 1 | Number field.
Date | 2 | Date field.
Telephone | 3 | Telephone field
Checkbox | 7 | Check Box field
Name | 11 | Name field (= primary key) .
Datafile | 12 | Data File field (= filepath).
Image | 13 | Image field.
Time | 14 | Time field.
ExcelCell | 15 | Excel cell. (OBSOLETE)
Calculation | 20 | Calculation field.
Sequence | 21 | Sequence number field.
Selection | 22 | Selection field.
Email | 23 | E-mail address field.
URL | 24 | Internet address field.
See Also

Reference


CommenceQueryRowSet Class

Represents a rowset of items to query.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseRowSet
Vovin.CmcLibNet.DatabaseCommenceQueryRowSet

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public sealed class CommenceQueryRowSet : BaseRowSet,
    ICommenceQueryRowSet, IBaseRowSet, IDisposable
Public NotInheritable Class CommenceQueryRowSet
    Inherits BaseRowSet
    Implements ICommenceQueryRowSet, IBaseRowSet, IDisposable

The CommenceQueryRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset (Overrides BaseRowSetColumnCount.)
Public property | RowCount | Number of items in rowset. (Overrides BaseRowSetRowCount.)
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this. (Overrides BaseRowSetClose.)
Public method | Dispose | Dispose method (Inherited from BaseRowSet.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label (Overrides BaseRowSetGetColumnIndex(String, CmcOptionFlags).)
Public method | GetColumnLabel | Search the column set and return the column label or fieldname (Overrides BaseRowSetGetColumnLabel(Int32, CmcOptionFlags).)
Public method | GetFieldToFile | Save the field value at the given (row,column) to a file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32) | GetRow implementation for .NET that gets the the Commence row as string values.
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowSequenceNumber | Gets the sequence number that Commence uses internally. Note: this is not a workgroup-wide number!
Public method | GetRowTimeStamp | Undocumented method, most likely returns a timestamp :).
Public method | GetRowValue | Get rowvalue for specified row/column (Overrides BaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags).)
Public method | GetShared | Gets the shared/local status of the row (Overrides BaseRowSetGetShared(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference


CommenceQueryRowSet Properties

The CommenceQueryRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset (Overrides BaseRowSetColumnCount.)
Public property | RowCount | Number of items in rowset. (Overrides BaseRowSetRowCount.)
Top
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.ColumnCount Property

CommenceQueryRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int ColumnCount { get; }
Public Overrides ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceQueryRowSetColumnCount
IBaseRowSetColumnCount
IBaseRowSetColumnCount
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.RowCount Property

CommenceQueryRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int RowCount { get; }
Public Overrides ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceQueryRowSetRowCount
IBaseRowSetRowCount
IBaseRowSetRowCount
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet Methods

The CommenceQueryRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this. (Overrides BaseRowSetClose.)
Public method | Dispose | Dispose method (Inherited from BaseRowSet.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label (Overrides BaseRowSetGetColumnIndex(String, CmcOptionFlags).)
Public method | GetColumnLabel | Search the column set and return the column label or fieldname (Overrides BaseRowSetGetColumnLabel(Int32, CmcOptionFlags).)
Public method | GetFieldToFile | Save the field value at the given (row,column) to a file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRow(Int32) | GetRow implementation for .NET that gets the the Commence row as string values.
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowSequenceNumber | Gets the sequence number that Commence uses internally. Note: this is not a workgroup-wide number!
Public method | GetRowTimeStamp | Undocumented method, most likely returns a timestamp :).
Public method | GetRowValue | Get rowvalue for specified row/column (Overrides BaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags).)
Public method | GetShared | Gets the shared/local status of the row (Overrides BaseRowSetGetShared(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.Close Method

CommenceQueryRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override void Close()
Public Overrides Sub Close

Implements

ICommenceQueryRowSetClose
IBaseRowSetClose
IBaseRowSetClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.GetColumnIndex Method

CommenceQueryRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.

Implements

ICommenceQueryRowSetGetColumnIndex(String, CmcOptionFlags)
IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.GetColumnLabel Method

CommenceQueryRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.

Implements

ICommenceQueryRowSetGetColumnLabel(Int32, CmcOptionFlags)
IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.GetFieldToFile Method

CommenceQueryRowSetGetFieldToFile Method

Save the field value at the given (row,column) to a file.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetFieldToFile(
    int nRow,
    int nCol,
    string filename,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetFieldToFile (
    nRow As Integer,
    nCol As Integer,
    filename As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
nCol
Type: SystemInt32
The (0-based) index of the column.
filename
Type: SystemString
(Fully qualified) Filename where the field value is written.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: Canonical - return field value in canonical form.

Return Value

Type: Int32
File size in bytes, -1 on error.

Implements

ICommenceQueryRowSetGetFieldToFile(Int32, Int32, String, CmcOptionFlags)
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.GetRow Method

CommenceQueryRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32) | GetRow implementation for .NET that gets the the Commence row as string values.
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, CmcOptionFlags).)
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string. (Overrides BaseRowSetGetRow(Int32, String, CmcOptionFlags).)
Top
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.GetRow Method (Int32)

CommenceQueryRowSetGetRow Method (Int32)

GetRow implementation for .NET that gets the the Commence row as string values.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string[] GetRow(
    int nRow
)
Public Function GetRow (
    nRow As Integer
) As String()

Parameters

nRow
Type: SystemInt32
Row pointer.

Return Value

Type: String
String array.

Implements

ICommenceQueryRowSetGetRow(Int32)
Remarks
The purpose of this method is primarily to avoid boxing in internal export methods.
See Also

Reference

CommenceQueryRowSet Class
GetRow Overload


CommenceQueryRowSet.GetRow Method (Int32, CmcOptionFlags)

CommenceQueryRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

ICommenceQueryRowSetGetRow(Int32, CmcOptionFlags)
IBaseRowSetGetRow(Int32, CmcOptionFlags)
IBaseRowSetGetRow(Int32, CmcOptionFlags)
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

CommenceQueryRowSet Class
GetRow Overload


CommenceQueryRowSet.GetRow Method (Int32, String, CmcOptionFlags)

CommenceQueryRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

ICommenceQueryRowSetGetRow(Int32, String, CmcOptionFlags)
IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
See Also

Reference

CommenceQueryRowSet Class
GetRow Overload


CommenceQueryRowSet.GetRowID Method

CommenceQueryRowSetGetRowID Method

Returns a unique identifier for a row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetRowID(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetRowID (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: String
Returns a unique ID string (less than 100 chars) on success, null on error.

Implements

ICommenceQueryRowSetGetRowID(Int32, CmcOptionFlags)
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.GetRowSequenceNumber Method

CommenceQueryRowSetGetRowSequenceNumber Method

Gets the sequence number that Commence uses internally. Note: this is not a workgroup-wide number!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int GetRowSequenceNumber(
    int nRow
)
Public Function GetRowSequenceNumber (
    nRow As Integer
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Int32
Sequence number that Commence uses internally.

Implements

ICommenceQueryRowSetGetRowSequenceNumber(Int32)
Remarks
Local categories do not have a THID. Local items in shared categories do have THIDs. If no there are THIDs this method will use the RowID instead.
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.GetRowTimeStamp Method

CommenceQueryRowSetGetRowTimeStamp Method

Undocumented method, most likely returns a timestamp :).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string GetRowTimeStamp(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Function GetRowTimeStamp (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
(Assumed) Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: String
some string with a timestamp? Who knows? Is it blue?

Implements

ICommenceQueryRowSetGetRowTimeStamp(Int32, CmcOptionFlags)
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.GetRowValue Method

CommenceQueryRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Public Overrides Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.

Implements

ICommenceQueryRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
See Also

Reference

CommenceQueryRowSet Class


CommenceQueryRowSet.GetShared Method

CommenceQueryRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override bool GetShared(
    int nRow
)
Public Overrides Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.

Implements

ICommenceQueryRowSetGetShared(Int32)
IBaseRowSetGetShared(Int32)
IBaseRowSetGetShared(Int32)
See Also

Reference

CommenceQueryRowSet Class


CursorColumns Class

Convenience class for setting multiple columns in a cursor. Should not be combined with the direct methods of setting columns in ICommenceCursor.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseCursorColumns

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class CursorColumns : ICursorColumns
Public Class CursorColumns
    Implements ICursorColumns

The CursorColumns type exposes the following members.

Methods
 | Name | Description
Public method | AddDirectColumn | Adds single fieldname to the collection of direct fields.
Public method | AddDirectColumns(Object) | Adds an array of direct fields to the collection of direct fields.
Public method | AddDirectColumns(String) | Adds an array of direct fields to the collection of direct fields.
Public method | AddRelatedColumn | Add a related field to the collection of related fields.
Public method | Apply | Set all direct and related columns. Duplicate columns are ignored.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Use of this class is recommended over setting columns directly. You cannot instantiate this class, it is automatically created when you call the Columns property.
See Also

Reference


CursorColumns Methods

The CursorColumns type exposes the following members.

Methods
 | Name | Description
Public method | AddDirectColumn | Adds single fieldname to the collection of direct fields.
Public method | AddDirectColumns(Object) | Adds an array of direct fields to the collection of direct fields.
Public method | AddDirectColumns(String) | Adds an array of direct fields to the collection of direct fields.
Public method | AddRelatedColumn | Add a related field to the collection of related fields.
Public method | Apply | Set all direct and related columns. Duplicate columns are ignored.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CursorColumns Class


CursorColumns.AddDirectColumn Method

CursorColumnsAddDirectColumn Method

Adds single fieldname to the collection of direct fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void AddDirectColumn(
    string fieldName
)
Public Sub AddDirectColumn (
    fieldName As String
)

Parameters

fieldName
Type: SystemString
Direct fieldname from the Cursor's category.

Implements

ICursorColumnsAddDirectColumn(String)
See Also

Reference

CursorColumns Class


CursorColumns.AddDirectColumns Method

CursorColumnsAddDirectColumns Method

Overload List
 | Name | Description
Public method | AddDirectColumns(Object) | Adds an array of direct fields to the collection of direct fields.
Public method | AddDirectColumns(String) | Adds an array of direct fields to the collection of direct fields.
Top
See Also

Reference

CursorColumns Class


CursorColumns.AddDirectColumns Method (Object[])

CursorColumnsAddDirectColumns Method (Object)

Adds an array of direct fields to the collection of direct fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void AddDirectColumns(
    params Object[] fieldNames
)
Public Sub AddDirectColumns (
    ParamArray fieldNames As Object()
)

Parameters

fieldNames
Type: SystemObject
Object array of fieldnames.

Implements

ICursorColumnsAddDirectColumns(Object)
See Also

Reference

CursorColumns Class
AddDirectColumns Overload


CursorColumns.AddDirectColumns Method (String[])

CursorColumnsAddDirectColumns Method (String)

Adds an array of direct fields to the collection of direct fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void AddDirectColumns(
    params string[] fieldNames
)
Public Sub AddDirectColumns (
    ParamArray fieldNames As String()
)

Parameters

fieldNames
Type: SystemString
Array of fieldnames, or a comma-separated list of fieldnames.

Implements

ICursorColumnsAddDirectColumns(String)
Remarks
This method is only available for .NET applications.
See Also

Reference

CursorColumns Class
AddDirectColumns Overload


CursorColumns.AddRelatedColumn Method

CursorColumnsAddRelatedColumn Method

Add a related field to the collection of related fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void AddRelatedColumn(
    string connectionName,
    string categoryName,
    string fieldName
)
Public Sub AddRelatedColumn (
    connectionName As String,
    categoryName As String,
    fieldName As String
)

Parameters

connectionName
Type: SystemString
Commence connection name (case-sensitive!).
categoryName
Type: SystemString
Commence connected category name.
fieldName
Type: SystemString
Commence connected category fieldname.

Implements

ICursorColumnsAddRelatedColumn(String, String, String)
See Also

Reference

CursorColumns Class


CursorColumns.Apply Method

CursorColumnsApply Method

Set all direct and related columns. Duplicate columns are ignored.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int Apply()
Public Function Apply As Integer

Return Value

Type: Int32
Number of columns set, -1 on error.

Implements

ICursorColumnsApply
See Also

Reference

CursorColumns Class


CursorFilters Class

Class for creating, removing and applying Cursor filters.

This is significantly different from the usual way of filtering in Commence API.

See code samples below.

Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseCursorFilters

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class CursorFilters : ICursorFilters,
    IEnumerable<ICursorFilter>, IEnumerable
Public Class CursorFilters
    Implements ICursorFilters, IEnumerable(Of ICursorFilter),
    IEnumerable

The CursorFilters type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets number of filters.
Top
Methods
 | Name | Description
Public method | Add | Add a filter to the filter collection.
Public method | Apply | Apply filters and return number of affected items.
Public method | Clear | Clear all filters from collection. The underlying cursor will be updated, there is no need to call Apply.
Public method | Create | Create new filter and add it to the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Enable enumeration.
Public method | GetFilter | Returns filter from collection.
Public method | GetFilterByClauseNumber | Get filter from collection based on clause number.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveFilter | Remove specified filter from collection. The underlying cursor will be updated, there is no need to call Apply.
Public method | RemoveFilterByClauseNumber | Remove filter from collection by clause number, if present. The underlying cursor is also updated, there is no need to call Apply.
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Public method | ValidateFilter(ICursorFilter) | Checks if filter will work.
 | ValidateFilter(String, ICursorFilter) | Checks if filter will work.
Top
Examples

Filtering cursors is a very complex affair in he Commence API, because it is done using DDE-style syntax. This syntax is convoluted and hard to remember.

Old-style DDE syntax can still be used in CmcLibNet, but you are strongly encouraged to use the CursorFilters class, exposed as Filters property of the CommenceCursor class. It is more verbose, but also more intuitive.

First you decide what type of filter you want to apply. Commence has 4 types of filters, which are defined in the FilterType enum. Once you know what filter you want to apply, you create it:

Copy
using Vovin.CmcLibNet
using Vovin.CmcLibNet.Database

namespace FilterExample
{
    class Main
        {
            // get a reference to CmcNetLib.
            ICommenceDatabase cmc = new CommenceDatabase();
            // get a cursor from Commence.
            ICommenceCursor cur = cmc.GetCursor("Account");
            // get a Field type filter
            ICursorFilterTypeF f = cur.Filters.Create(1, FilterType.Field);
        }
}

Step-through of above example: First, we get a reference to the CmcLibNet assembly, that will talk to Commence for you.

Then, we get a cursor, telling it we want to use data from the Account category. We want to filter that category on a fieldvalue.

We then define our filter as ICursorFilterTypeF.

We then ask CmcLibNet to get use a filter of that type, the 'FilterType.Field' parameter, and make it the first filter (the '1' parameter). The index number is mandatory, because of the way the and/or relations between filters in Commence work.

What happens is a filter object instance called 'f' of type CursorFilterTypeF is created.

It just exposes the properties pertaining to that particular filter-type. Have peek with Intellisense or the object-browser and you'll see what I mean. So now, you can set the filter parameters. Most are optional. Let's set them all (well, almost all):

Copy
f.FieldName = "accountKey"; // field to filter on
f.FieldValue = "Commence"; // value to filter on
f.Qualifier = FilterQualifier.Contains; // the Qualifier property sets the proper QualifierString internally.
f.CSFlag = true; // tell Commence we want to do a case-sensitive filter. You can omit this for a non-case-sensitive filter.
f.Except = true; // get us all results EXCEPT the ones matching our filter. This is equivalent to the checking the 'except' checkbox in the filter dialog in Commence
f.OrFlag = false; // we do not want to define this filter as an OR filter. Note that the filter logic is incorporated as a property of the individual filters, and not supplied separately by a SetLogic method.
This equates to the shorter:
Copy
cur.SetFilter("[ViewFilter(1,NOT,F,Contains," + "Commence" + ",1)]",0);
cur.SetLogic("[ViewConjunction(And,,,,,)]",0);
but is is easier to read and understand as well as less error-prone.

Note that the filter logic is incorporated as a property of the individual filters, and not supplied separately by a SetLogic method.

This was just 1 filter, you can set up to 8 of them. Once you are done with defining your filters, call the Apply method of the Filters class:

Copy
cur.Filters.Apply();
That's it for C# users.
Examples
For VBScript (e.g. an Item Detail Form Script), the procedure is much alike. The main difference is that it is probaly easiest to supply the filter qualifier as a string via QualifierString. (Although if you want to, you can supply the enum value to Qualifier):
VBScript
Copy
Dim cmc : Set db = CreateObject("CmcNetLib.Database")
Dim cur : Set cur = db.GetCursor("Account")
Dim filters : Set filters = cur.Filters ' you cannot simply use cur.Filters from VBScript, alas.
Dim f : Set f = filters.Create(1, 0) ' 0 is the enum value for FilterType.Field.
f.FieldName = "accountKey" ' field to filter on.
f.FieldValue = "Commence" ' value to filter on.
f.QualifierString = "contains" ' the qualifier, i.e., how to evaluate the filter value. You could have also used f.Qualifier with the enum value corresponding with 'contains', this is just a bit easier.
f.CSFlag = true ' tell Commence we want to do a case-sensitive filter. You can omit this for a non-case-sensitive filter.
f.Except = true ' get us all results EXCEPT the ones matching our filter. This is equivalent to the checking the 'except' checkbox in the filter dialog in Commence.
f.OrFlag = false ' we do not want to define this filter as an OR filter.
filters.Apply()
'...do something...
db.Close
See Also

Reference


CursorFilters Properties

The CursorFilters type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets number of filters.
Top
See Also

Reference

CursorFilters Class


CursorFilters.Count Property

CursorFiltersCount Property

Gets number of filters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICursorFiltersCount
See Also

Reference

CursorFilters Class


CursorFilters Methods

The CursorFilters type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a filter to the filter collection.
Public method | Apply | Apply filters and return number of affected items.
Public method | Clear | Clear all filters from collection. The underlying cursor will be updated, there is no need to call Apply.
Public method | Create | Create new filter and add it to the collection.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Enable enumeration.
Public method | GetFilter | Returns filter from collection.
Public method | GetFilterByClauseNumber | Get filter from collection based on clause number.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveFilter | Remove specified filter from collection. The underlying cursor will be updated, there is no need to call Apply.
Public method | RemoveFilterByClauseNumber | Remove filter from collection by clause number, if present. The underlying cursor is also updated, there is no need to call Apply.
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Public method | ValidateFilter(ICursorFilter) | Checks if filter will work.
 | ValidateFilter(String, ICursorFilter) | Checks if filter will work.
Top
See Also

Reference

CursorFilters Class


CursorFilters.Add Method

CursorFiltersAdd Method

Add a filter to the filter collection.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Add(
    ICursorFilter filter
)
Public Sub Add (
    filter As ICursorFilter
)

Parameters

filter
Type: Vovin.CmcLibNet.DatabaseICursorFilter
ICursorFilter object.

Implements

ICursorFiltersAdd(ICursorFilter)
See Also

Reference

CursorFilters Class


CursorFilters.Apply Method

CursorFiltersApply Method

Apply filters and return number of affected items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int Apply()
Public Function Apply As Integer

Return Value

Type: Int32
Number of items in cursor after applying filters.

Implements

ICursorFiltersApply
See Also

Reference

CursorFilters Class


CursorFilters.Clear Method

CursorFiltersClear Method

Clear all filters from collection. The underlying cursor will be updated, there is no need to call Apply.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICursorFiltersClear
See Also

Reference

CursorFilters Class


CursorFilters.Create Method

CursorFiltersCreate Method

Create new filter and add it to the collection.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public Object Create(
    int clauseNumber,
    FilterType filterType
)
Public Function Create (
    clauseNumber As Integer,
    filterType As FilterType
) As Object

Parameters

clauseNumber
Type: SystemInt32
Order of the filter, should be between 1-8.
filterType
Type: Vovin.CmcLibNet.DatabaseFilterType
The type of filter to create.

Return Value

Type: Object
Derived BaseFilter corresponding to either of ICursorFilterTypeF, ICursorFilterTypeCTI, ICursorFilterTypeCTCF, ICursorFilterTypeCTCTI.

Implements

ICursorFiltersCreate(Int32, FilterType)
See Also

Reference

CursorFilters Class


CursorFilters.GetEnumerator Method

CursorFiltersGetEnumerator Method

Enable enumeration.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IEnumerator<ICursorFilter> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of ICursorFilter)

Return Value

Type: IEnumerator ICursorFilter
ICursorFilter.

Implements

ICursorFiltersGetEnumerator
IEnumerableTGetEnumerator
See Also

Reference

CursorFilters Class


CursorFilters.GetFilter Method

CursorFiltersGetFilter Method

Returns filter from collection.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public Object GetFilter(
    int index
)
Public Function GetFilter (
    index As Integer
) As Object

Parameters

index
Type: SystemInt32
Index of filter (0-based).

Return Value

Type: Object
Derived BaseFilter object.

Implements

ICursorFiltersGetFilter(Int32)
See Also

Reference

CursorFilters Class


CursorFilters.GetFilterByClauseNumber Method

CursorFiltersGetFilterByClauseNumber Method

Get filter from collection based on clause number.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public Object GetFilterByClauseNumber(
    int clauseNumber
)
Public Function GetFilterByClauseNumber (
    clauseNumber As Integer
) As Object

Parameters

clauseNumber
Type: SystemInt32
ClauseNumber.

Return Value

Type: Object
CursorFilter.

Implements

ICursorFiltersGetFilterByClauseNumber(Int32)
See Also

Reference

CursorFilters Class


CursorFilters.RemoveFilter Method

CursorFiltersRemoveFilter Method

Remove specified filter from collection. The underlying cursor will be updated, there is no need to call Apply.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool RemoveFilter(
    BaseCursorFilter cf
)
Public Function RemoveFilter (
    cf As BaseCursorFilter
) As Boolean

Parameters

cf
Type: Vovin.CmcLibNet.DatabaseBaseCursorFilter
Filter to remove.

Return Value

Type: Boolean
true on success, false on error.

Implements

ICursorFiltersRemoveFilter(BaseCursorFilter)
See Also

Reference

CursorFilters Class


CursorFilters.RemoveFilterByClauseNumber Method

CursorFiltersRemoveFilterByClauseNumber Method

Remove filter from collection by clause number, if present. The underlying cursor is also updated, there is no need to call Apply.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool RemoveFilterByClauseNumber(
    int clauseNumber
)
Public Function RemoveFilterByClauseNumber (
    clauseNumber As Integer
) As Boolean

Parameters

clauseNumber
Type: SystemInt32
Clause number (1-8).

Return Value

Type: Boolean
true on success, false on error.

Implements

ICursorFiltersRemoveFilterByClauseNumber(Int32)
See Also

Reference

CursorFilters Class


CursorFilters.ToString Method

CursorFiltersToString Method

Returns a string that represents the current object.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string that represents the current object.

Implements

ICursorFiltersToString
See Also

Reference

CursorFilters Class


CursorFilters.ValidateFilter Method

CursorFiltersValidateFilter Method

Overload List
 | Name | Description
Public method | ValidateFilter(ICursorFilter) | Checks if filter will work.
 | ValidateFilter(String, ICursorFilter) | Checks if filter will work.
Top
See Also

Reference

CursorFilters Class


CursorFilters.ValidateFilter Method (ICursorFilter)

CursorFiltersValidateFilter Method (ICursorFilter)

Checks if filter will work.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ValidateFilter(
    ICursorFilter filter
)
Public Function ValidateFilter (
    filter As ICursorFilter
) As Boolean

Parameters

filter
Type: Vovin.CmcLibNet.DatabaseICursorFilter
ICursorFilter.

Return Value

Type: Boolean
True if filter succeeded, otherwise false.

Implements

ICursorFiltersValidateFilter(ICursorFilter)
Remarks
This is a very expensive call, it creates a dummy cursor and actually tries if the filter works.
See Also

Reference

CursorFilters Class
ValidateFilter Overload


CursorFilters.ValidateFilter Method (String, ICursorFilter)

CursorFiltersValidateFilter Method (String, ICursorFilter)

Checks if filter will work.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public static bool ValidateFilter(
    string categoryName,
    ICursorFilter filter
)
Public Shared Function ValidateFilter (
    categoryName As String,
    filter As ICursorFilter
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category to verify filter on.
filter
Type: Vovin.CmcLibNet.DatabaseICursorFilter
ICursorFilter.

Return Value

Type: Boolean
True if filter succeeded, otherwise false.
Remarks
This is a very expensive call, it creates a dummy cursor and actually tries if the filter works.
See Also

Reference

CursorFilters Class
ValidateFilter Overload


CursorFilterTypeCTCF Class

Represents a filter of type 'Connection To Category Field' (CTCF).
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseCursorFilter
Vovin.CmcLibNet.DatabaseCursorFilterTypeCTCF

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public sealed class CursorFilterTypeCTCF : BaseCursorFilter,
    ICursorFilterTypeCTCF, ICursorFilter
Public NotInheritable Class CursorFilterTypeCTCF
    Inherits BaseCursorFilter
    Implements ICursorFilterTypeCTCF, ICursorFilter

The CursorFilterTypeCTCF type exposes the following members.

Constructors
 | Name | Description
Public method | CursorFilterTypeCTCF | constructor.
Top
Properties
 | Name | Description
Public property | Category | Connected category name; case-sensitive!
Public property | ClauseNumber | Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8. (Inherited from BaseCursorFilter.)
Public property | Connection | Connection name; case-sensitive!
Public property | Except | Except flag. Set to true to create a Except (NOT) filter. (Inherited from BaseCursorFilter.)
Public property | FieldName | Field to evaluate.
Public property | FieldValue | Fieldvalue to evaluate. Ignored when Between qualifier is used.
Public property | FilterBetweenEndValue | End value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterStartEndValue.
Public property | FilterBetweenStartValue | Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterBetweenEndValue.
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request. (Overrides BaseCursorFilterFiltertypeIdentifier.)
Public property | MatchCase | Case-sensitive parameter. Set to true for case-sensitive filter.
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]]. (Inherited from BaseCursorFilter.)
Public property | Qualifier | Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.
Public property | QualifierString | See QualifierString
Public property | Shared | Filter for Local/Shared items.
Public property | SharedOptionSet | Keep track of whether the 'shared/local' option was set
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax. (Inherited from BaseCursorFilter.)
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference


CursorFilterTypeCTCF Constructor

constructor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CursorFilterTypeCTCF(
    int clauseNumber
)
Public Sub New (
    clauseNumber As Integer
)

Parameters

clauseNumber
Type: SystemInt32
filter clause, must be a number between 1 and 8.
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF Properties

The CursorFilterTypeCTCF type exposes the following members.

Properties
 | Name | Description
Public property | Category | Connected category name; case-sensitive!
Public property | ClauseNumber | Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8. (Inherited from BaseCursorFilter.)
Public property | Connection | Connection name; case-sensitive!
Public property | Except | Except flag. Set to true to create a Except (NOT) filter. (Inherited from BaseCursorFilter.)
Public property | FieldName | Field to evaluate.
Public property | FieldValue | Fieldvalue to evaluate. Ignored when Between qualifier is used.
Public property | FilterBetweenEndValue | End value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterStartEndValue.
Public property | FilterBetweenStartValue | Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterBetweenEndValue.
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request. (Overrides BaseCursorFilterFiltertypeIdentifier.)
Public property | MatchCase | Case-sensitive parameter. Set to true for case-sensitive filter.
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]]. (Inherited from BaseCursorFilter.)
Public property | Qualifier | Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.
Public property | QualifierString | See QualifierString
Public property | Shared | Filter for Local/Shared items.
Public property | SharedOptionSet | Keep track of whether the 'shared/local' option was set
Top
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.Category Property

CursorFilterTypeCTCFCategory Property

Connected category name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCFCategory
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.Connection Property

CursorFilterTypeCTCFConnection Property

Connection name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Connection { get; set; }
Public Property Connection As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCFConnection
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.FieldName Property

CursorFilterTypeCTCFFieldName Property

Field to evaluate.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCFFieldName
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.FieldValue Property

CursorFilterTypeCTCFFieldValue Property

Fieldvalue to evaluate. Ignored when Between qualifier is used.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FieldValue { get; set; }
Public Property FieldValue As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCFFieldValue
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.FilterBetweenEndValue Property

CursorFilterTypeCTCFFilterBetweenEndValue Property

End value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterStartEndValue.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FilterBetweenEndValue { get; set; }
Public Property FilterBetweenEndValue As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCFFilterBetweenEndValue
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.FilterBetweenStartValue Property

CursorFilterTypeCTCFFilterBetweenStartValue Property

Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterBetweenEndValue.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FilterBetweenStartValue { get; set; }
Public Property FilterBetweenStartValue As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCFFilterBetweenStartValue
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.FiltertypeIdentifier Property

CursorFilterTypeCTCFFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string FiltertypeIdentifier { get; }
Public Overrides ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String

Implements

ICursorFilterTypeCTCFFiltertypeIdentifier
ICursorFilterFiltertypeIdentifier
ICursorFilterFiltertypeIdentifier
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.MatchCase Property

CursorFilterTypeCTCFMatchCase Property

Case-sensitive parameter. Set to true for case-sensitive filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool MatchCase { get; set; }
Public Property MatchCase As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterTypeCTCFMatchCase
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.Qualifier Property

CursorFilterTypeCTCFQualifier Property

Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public FilterQualifier Qualifier { get; set; }
Public Property Qualifier As FilterQualifier
    Get
    Set

Property Value

Type: FilterQualifier

Implements

ICursorFilterTypeCTCFQualifier
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.QualifierString Property

CursorFilterTypeCTCFQualifierString Property

See QualifierString

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string QualifierString { get; set; }
Public Property QualifierString As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCFQualifierString
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.Shared Property

CursorFilterTypeCTCFShared Property

Filter for Local/Shared items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Shared { get; set; }
Public Property Shared As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterTypeCTCFShared
Remarks
When set, fieldvalues are ignored.
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.SharedOptionSet Property

CursorFilterTypeCTCFSharedOptionSet Property

Keep track of whether the 'shared/local' option was set

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SharedOptionSet { get; }
Public ReadOnly Property SharedOptionSet As Boolean
    Get

Property Value

Type: Boolean

Implements

ICursorFilterTypeCTCFSharedOptionSet
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF Methods

The CursorFilterTypeCTCF type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax. (Inherited from BaseCursorFilter.)
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.ToString Method

CursorFilterTypeCTCFToString Method

Overload List
 | Name | Description
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeCTCF Class


CursorFilterTypeCTCF.ToString Method

CursorFilterTypeCTCFToString Method

Creates the filter string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
Filter string.
See Also

Reference

CursorFilterTypeCTCF Class
ToString Overload


CursorFilterTypeCTCTI Class

Represents a filter of type 'Connection To Connected Item' (CTCTI).
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseCursorFilter
Vovin.CmcLibNet.DatabaseCursorFilterTypeCTCTI

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public sealed class CursorFilterTypeCTCTI : BaseCursorFilter,
    ICursorFilterTypeCTCTI, ICursorFilter
Public NotInheritable Class CursorFilterTypeCTCTI
    Inherits BaseCursorFilter
    Implements ICursorFilterTypeCTCTI, ICursorFilter

The CursorFilterTypeCTCTI type exposes the following members.

Constructors
 | Name | Description
Public method | CursorFilterTypeCTCTI | constructor.
Top
Properties
 | Name | Description
Public property | Category | Connected category name; case-sensitive!
Public property | Category2 | Connected category 2 name; case-sensitive!
Public property | ClarifySeparator | Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClarifyValue | Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClauseNumber | Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8. (Inherited from BaseCursorFilter.)
Public property | Connection | Connection name; case-sensitive!
Public property | Connection2 | Connection 2 name; case-sensitive!
Public property | Except | Except flag. Set to true to create a Except (NOT) filter. (Inherited from BaseCursorFilter.)
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request. (Overrides BaseCursorFilterFiltertypeIdentifier.)
Public property | Item | Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to use the fully qualified itemname here, including all the right the padding(!).
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]]. (Inherited from BaseCursorFilter.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax. (Inherited from BaseCursorFilter.)
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference


CursorFilterTypeCTCTI Constructor

constructor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CursorFilterTypeCTCTI(
    int clauseNumber
)
Public Sub New (
    clauseNumber As Integer
)

Parameters

clauseNumber
Type: SystemInt32
filter clause, must be a number between 1 and 8.
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI Properties

The CursorFilterTypeCTCTI type exposes the following members.

Properties
 | Name | Description
Public property | Category | Connected category name; case-sensitive!
Public property | Category2 | Connected category 2 name; case-sensitive!
Public property | ClarifySeparator | Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClarifyValue | Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClauseNumber | Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8. (Inherited from BaseCursorFilter.)
Public property | Connection | Connection name; case-sensitive!
Public property | Connection2 | Connection 2 name; case-sensitive!
Public property | Except | Except flag. Set to true to create a Except (NOT) filter. (Inherited from BaseCursorFilter.)
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request. (Overrides BaseCursorFilterFiltertypeIdentifier.)
Public property | Item | Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to use the fully qualified itemname here, including all the right the padding(!).
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]]. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.Category Property

CursorFilterTypeCTCTICategory Property

Connected category name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCTICategory
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.Category2 Property

CursorFilterTypeCTCTICategory2 Property

Connected category 2 name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Category2 { get; set; }
Public Property Category2 As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCTICategory2
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.ClarifySeparator Property

CursorFilterTypeCTCTIClarifySeparator Property

Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClarifySeparator { get; set; }
Public Property ClarifySeparator As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCTIClarifySeparator
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.ClarifyValue Property

CursorFilterTypeCTCTIClarifyValue Property

Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClarifyValue { get; set; }
Public Property ClarifyValue As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCTIClarifyValue
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.Connection Property

CursorFilterTypeCTCTIConnection Property

Connection name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Connection { get; set; }
Public Property Connection As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCTIConnection
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.Connection2 Property

CursorFilterTypeCTCTIConnection2 Property

Connection 2 name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Connection2 { get; set; }
Public Property Connection2 As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCTIConnection2
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.FiltertypeIdentifier Property

CursorFilterTypeCTCTIFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string FiltertypeIdentifier { get; }
Public Overrides ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String

Implements

ICursorFilterTypeCTCTIFiltertypeIdentifier
ICursorFilterFiltertypeIdentifier
ICursorFilterFiltertypeIdentifier
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.Item Property

CursorFilterTypeCTCTIItem Property

Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to use the fully qualified itemname here, including all the right the padding(!).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Item { get; set; }
Public Property Item As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTCTIItem
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI Methods

The CursorFilterTypeCTCTI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax. (Inherited from BaseCursorFilter.)
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.ToString Method

CursorFilterTypeCTCTIToString Method

Overload List
 | Name | Description
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeCTCTI Class


CursorFilterTypeCTCTI.ToString Method

CursorFilterTypeCTCTIToString Method

Creates the filter string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
Filter string.
See Also

Reference

CursorFilterTypeCTCTI Class
ToString Overload


CursorFilterTypeCTI Class

Represents a filter of type 'Item Connected To Item' (CTI).
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseCursorFilter
Vovin.CmcLibNet.DatabaseCursorFilterTypeCTI

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public sealed class CursorFilterTypeCTI : BaseCursorFilter,
    ICursorFilterTypeCTI, ICursorFilter
Public NotInheritable Class CursorFilterTypeCTI
    Inherits BaseCursorFilter
    Implements ICursorFilterTypeCTI, ICursorFilter

The CursorFilterTypeCTI type exposes the following members.

Constructors
 | Name | Description
Public method | CursorFilterTypeCTI | constructor.
Top
Properties
 | Name | Description
Public property | Category | Connected category name.
Public property | ClarifySeparator | Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClarifyValue | Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClauseNumber | Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8. (Inherited from BaseCursorFilter.)
Public property | Connection | Connection name; case-sensitive!
Public property | Except | Except flag. Set to true to create a Except (NOT) filter. (Inherited from BaseCursorFilter.)
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request. (Overrides BaseCursorFilterFiltertypeIdentifier.)
Public property | Item | Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to just use the fully qualified itemname here, including all the right the padding(!).
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]]. (Inherited from BaseCursorFilter.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax. (Inherited from BaseCursorFilter.)
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference


CursorFilterTypeCTI Constructor

constructor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CursorFilterTypeCTI(
    int clauseNumber
)
Public Sub New (
    clauseNumber As Integer
)

Parameters

clauseNumber
Type: SystemInt32
filter clause, must be a number between 1 and 8.
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI Properties

The CursorFilterTypeCTI type exposes the following members.

Properties
 | Name | Description
Public property | Category | Connected category name.
Public property | ClarifySeparator | Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClarifyValue | Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClauseNumber | Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8. (Inherited from BaseCursorFilter.)
Public property | Connection | Connection name; case-sensitive!
Public property | Except | Except flag. Set to true to create a Except (NOT) filter. (Inherited from BaseCursorFilter.)
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request. (Overrides BaseCursorFilterFiltertypeIdentifier.)
Public property | Item | Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to just use the fully qualified itemname here, including all the right the padding(!).
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]]. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI.Category Property

CursorFilterTypeCTICategory Property

Connected category name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTICategory
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI.ClarifySeparator Property

CursorFilterTypeCTIClarifySeparator Property

Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClarifySeparator { get; set; }
Public Property ClarifySeparator As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTIClarifySeparator
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI.ClarifyValue Property

CursorFilterTypeCTIClarifyValue Property

Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClarifyValue { get; set; }
Public Property ClarifyValue As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTIClarifyValue
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI.Connection Property

CursorFilterTypeCTIConnection Property

Connection name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Connection { get; set; }
Public Property Connection As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTIConnection
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI.FiltertypeIdentifier Property

CursorFilterTypeCTIFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string FiltertypeIdentifier { get; }
Public Overrides ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String

Implements

ICursorFilterTypeCTIFiltertypeIdentifier
ICursorFilterFiltertypeIdentifier
ICursorFilterFiltertypeIdentifier
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI.Item Property

CursorFilterTypeCTIItem Property

Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to just use the fully qualified itemname here, including all the right the padding(!).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Item { get; set; }
Public Property Item As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeCTIItem
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI Methods

The CursorFilterTypeCTI type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax. (Inherited from BaseCursorFilter.)
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI.ToString Method

CursorFilterTypeCTIToString Method

Overload List
 | Name | Description
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeCTI Class


CursorFilterTypeCTI.ToString Method

CursorFilterTypeCTIToString Method

Creates the filter string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
Filter string.
See Also

Reference

CursorFilterTypeCTI Class
ToString Overload


CursorFilterTypeF Class

Represents a filter of type 'Field' (F).
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.DatabaseBaseCursorFilter
Vovin.CmcLibNet.DatabaseCursorFilterTypeF

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public sealed class CursorFilterTypeF : BaseCursorFilter,
    ICursorFilterTypeF, ICursorFilter
Public NotInheritable Class CursorFilterTypeF
    Inherits BaseCursorFilter
    Implements ICursorFilterTypeF, ICursorFilter

The CursorFilterTypeF type exposes the following members.

Constructors
 | Name | Description
Public method | CursorFilterTypeF | constructor.
Top
Properties
Name Description
Public property ClauseNumber
Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8.
(Inherited from BaseCursorFilter.)
Public property Except
Except flag. Set to true to create a Except (NOT) filter.
(Inherited from BaseCursorFilter.)
Public property FieldName
Field to evaluate.
Public property FieldValue
Fieldvalue to evaluate. Ignored when Between qualifier is used.
Public property FilterBetweenEndValue
End value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterStartEndValue.
Public property FilterBetweenStartValue
Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterBetweenEndValue.
Public property FiltertypeIdentifier
String representing the filtertype identifier for use in a Commence DDE request.
(Overrides BaseCursorFilterFiltertypeIdentifier.)
Public property MatchCase
Case-sensitive parameter. Set to true for case-sensitive filter. Defaults to false.
Public property OrFilter
Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'.

The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items.

Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]].

(Inherited from BaseCursorFilter.)
Public property Qualifier
Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.
Public property QualifierString
String value specifying how to evaluate the filtervalue. Not all qualifiers can be used on all field-types. See Commence ViewFilter documentation in DDE helpfile.

If you use COM, either use this member with the strings listed below, or supply the FilterQualifier enum value to Qualifier. .NET users are strongly encouraged to use Qualifier.

List of valid qualifier strings and the fields they can be applied to.

Qualifier string | Applies to fieldtype(s)
Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Not Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Less Than | Calculation, Number, Sequence number fields.
Greater Than | Calculation, Number, Sequence number fields.
Between | Name, Calculation, Date, E-mail, URL, Number, Sequence number, Time fields.
True | Checkbox fields.
False | Checkbox fields.
Checked | Checkbox fields.
Not Checked | Checkbox fields.
Yes | Checkbox fields.
No | Checkbox fields.
Before | Date, Time fields.
On | Date fields.
At | Time fields.
After | Date, Time fields.
Contains | Name, E-mail, URL, Telephone, Text fields.
Doesn't Contain | Name, E-mail, URL, Telephone, Text fields.
Shared | N/A when used with fields.
Local | N/A when used with fields.
1 | Checkbox fields.
0 | Checkbox fields.
Public property Shared
Filter for Local/Shared items.
Public property SharedOptionSet
Keep track of whether the 'shared/local' option was set
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax. (Inherited from BaseCursorFilter.)
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference


CursorFilterTypeF Constructor

constructor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CursorFilterTypeF(
    int clauseNumber
)
Public Sub New (
    clauseNumber As Integer
)

Parameters

clauseNumber
Type: SystemInt32
filter clause, must be a number between 1 and 8.
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF Properties

The CursorFilterTypeF type exposes the following members.

Properties
Name Description
Public property ClauseNumber
Returns ClauseNumber for use in derived classes. Should be a value between 1 and 8.
(Inherited from BaseCursorFilter.)
Public property Except
Except flag. Set to true to create a Except (NOT) filter.
(Inherited from BaseCursorFilter.)
Public property FieldName
Field to evaluate.
Public property FieldValue
Fieldvalue to evaluate. Ignored when Between qualifier is used.
Public property FilterBetweenEndValue
End value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterStartEndValue.
Public property FilterBetweenStartValue
Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterBetweenEndValue.
Public property FiltertypeIdentifier
String representing the filtertype identifier for use in a Commence DDE request.
(Overrides BaseCursorFilterFiltertypeIdentifier.)
Public property MatchCase
Case-sensitive parameter. Set to true for case-sensitive filter. Defaults to false.
Public property OrFilter
Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'.

The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items.

Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]].

(Inherited from BaseCursorFilter.)
Public property Qualifier
Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.
Public property QualifierString
String value specifying how to evaluate the filtervalue. Not all qualifiers can be used on all field-types. See Commence ViewFilter documentation in DDE helpfile.

If you use COM, either use this member with the strings listed below, or supply the FilterQualifier enum value to Qualifier. .NET users are strongly encouraged to use Qualifier.

List of valid qualifier strings and the fields they can be applied to.

Qualifier string | Applies to fieldtype(s)
Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Not Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Less Than | Calculation, Number, Sequence number fields.
Greater Than | Calculation, Number, Sequence number fields.
Between | Name, Calculation, Date, E-mail, URL, Number, Sequence number, Time fields.
True | Checkbox fields.
False | Checkbox fields.
Checked | Checkbox fields.
Not Checked | Checkbox fields.
Yes | Checkbox fields.
No | Checkbox fields.
Before | Date, Time fields.
On | Date fields.
At | Time fields.
After | Date, Time fields.
Contains | Name, E-mail, URL, Telephone, Text fields.
Doesn't Contain | Name, E-mail, URL, Telephone, Text fields.
Shared | N/A when used with fields.
Local | N/A when used with fields.
1 | Checkbox fields.
0 | Checkbox fields.
Public property Shared
Filter for Local/Shared items.
Public property SharedOptionSet
Keep track of whether the 'shared/local' option was set
Top
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.FieldName Property

CursorFilterTypeFFieldName Property

Field to evaluate.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FieldName { get; set; }
Public Property FieldName As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeFFieldName
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.FieldValue Property

CursorFilterTypeFFieldValue Property

Fieldvalue to evaluate. Ignored when Between qualifier is used.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FieldValue { get; set; }
Public Property FieldValue As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeFFieldValue
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.FilterBetweenEndValue Property

CursorFilterTypeFFilterBetweenEndValue Property

End value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterStartEndValue.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FilterBetweenEndValue { get; set; }
Public Property FilterBetweenEndValue As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeFFilterBetweenEndValue
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.FilterBetweenStartValue Property

CursorFilterTypeFFilterBetweenStartValue Property

Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterBetweenEndValue.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FilterBetweenStartValue { get; set; }
Public Property FilterBetweenStartValue As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeFFilterBetweenStartValue
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.FiltertypeIdentifier Property

CursorFilterTypeFFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string FiltertypeIdentifier { get; }
Public Overrides ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String

Implements

ICursorFilterTypeFFiltertypeIdentifier
ICursorFilterFiltertypeIdentifier
ICursorFilterFiltertypeIdentifier
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.MatchCase Property

CursorFilterTypeFMatchCase Property

Case-sensitive parameter. Set to true for case-sensitive filter. Defaults to false.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool MatchCase { get; set; }
Public Property MatchCase As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterTypeFMatchCase
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.Qualifier Property

CursorFilterTypeFQualifier Property

Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public FilterQualifier Qualifier { get; set; }
Public Property Qualifier As FilterQualifier
    Get
    Set

Property Value

Type: FilterQualifier

Implements

ICursorFilterTypeFQualifier
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.QualifierString Property

CursorFilterTypeFQualifierString Property

String value specifying how to evaluate the filtervalue. Not all qualifiers can be used on all field-types. See Commence ViewFilter documentation in DDE helpfile.

If you use COM, either use this member with the strings listed below, or supply the FilterQualifier enum value to Qualifier. .NET users are strongly encouraged to use Qualifier.

List of valid qualifier strings and the fields they can be applied to.

Qualifier string | Applies to fieldtype(s)
Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Not Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Less Than | Calculation, Number, Sequence number fields.
Greater Than | Calculation, Number, Sequence number fields.
Between | Name, Calculation, Date, E-mail, URL, Number, Sequence number, Time fields.
True | Checkbox fields.
False | Checkbox fields.
Checked | Checkbox fields.
Not Checked | Checkbox fields.
Yes | Checkbox fields.
No | Checkbox fields.
Before | Date, Time fields.
On | Date fields.
At | Time fields.
After | Date, Time fields.
Contains | Name, E-mail, URL, Telephone, Text fields.
Doesn't Contain | Name, E-mail, URL, Telephone, Text fields.
Shared | N/A when used with fields.
Local | N/A when used with fields.
1 | Checkbox fields.
0 | Checkbox fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string QualifierString { get; set; }
Public Property QualifierString As String
    Get
    Set

Property Value

Type: String

Implements

ICursorFilterTypeFQualifierString
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.Shared Property

CursorFilterTypeFShared Property

Filter for Local/Shared items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Shared { get; set; }
Public Property Shared As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterTypeFShared
Remarks
When set, fieldvalues are ignored.
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.SharedOptionSet Property

CursorFilterTypeFSharedOptionSet Property

Keep track of whether the 'shared/local' option was set

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SharedOptionSet { get; }
Public ReadOnly Property SharedOptionSet As Boolean
    Get

Property Value

Type: Boolean

Implements

ICursorFilterTypeFSharedOptionSet
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF Methods

The CursorFilterTypeF type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax. (Inherited from BaseCursorFilter.)
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.ToString Method

CursorFilterTypeFToString Method

Overload List
 | Name | Description
Public method | ToString | Creates the filter string. (Overrides ObjectToString.)
Public method | ToString(FuncICursorFilter, String) | Overload allowing custom formatting. (Inherited from BaseCursorFilter.)
Top
See Also

Reference

CursorFilterTypeF Class


CursorFilterTypeF.ToString Method

CursorFilterTypeFToString Method

Creates the filter string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
Filter string.
See Also

Reference

CursorFilterTypeF Class
ToString Overload


FilterQualifier Enumeration

Valid qualifiers used in a Commence ViewFilter request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum FilterQualifier
Public Enumeration FilterQualifier
Members
Member name | Value | Description
Contains | 0 | "Contains" filter. Applies to: Name, E-mail, URL, Telephone, Text fields.
DoesNotContain | 1 | "Does Not Contain" filter. Applies to: Name, E-mail, URL, Telephone, Text fields.
On | 2 | "On" filter. Applies to: Date fields.
At | 3 | "At" filter. Applies to: Time fields.
EqualTo | 4 | "Equal To" filter. Applies to: Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
NotEqualTo | 5 | "Not Equal To" filter. Applies to: Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
LessThan | 6 | "Less Than" filter. Applies to: Calculation, Number, Sequence number fields.
GreaterThan | 7 | "Greater Than" filter. Applies to: Calculation, Number, Sequence number fields.
Between | 8 | "Between" filter. Applies to: Name, Calculation, Date, E-mail, URL, Number, Sequence number, Time fields.
True | 9 | "True" filter. Applies to: Checkbox fields.
False | 10 | "False" filter. Applies to: Checkbox fields.
Checked | 11 | "True" filter. Applies to: Checkbox fields.
NotChecked | 12 | "False" filter. Applies to: Checkbox fields.
Yes | 13 | "True" filter. Applies to: Checkbox fields.
No | 14 | "False" filter. Applies to: Checkbox fields.
Before | 15 | "Before" filter. Applies to: Date, Time fields.
After | 16 | "After" filter. Applies to: Date, Time fields.
Blank | 17 | "Blank" filter. Applies to Name fields, Date fields, E-mail fields, Telephone fields, URL fields, Time fields.
Shared | 18 | "Shared" filter. Applies to: N/A when used with fields.
Local | 19 | "Local" filter. Applies to: N/A when used with fields.
One | 20 | "True" filter. Applies to: Checkbox fields.
Zero | 21 | "False" filter. Applies to: Checkbox fields.
See Also

Reference


FilterType Enumeration

Filter Types that a Commence ViewFilter request can use, i.e. the filters you can apply to Commence.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum FilterType
Public Enumeration FilterType
Members
Member name | Value | Description
Field | 0 | Filter on fieldvalue.
ConnectionToItem | 1 | Filter on connection to specific item.
ConnectionToCategoryToItem | 2 | Filter on connected item to connected item.
ConnectionToCategoryField | 3 | Filter on fieldvalue in connected category.
See Also

Reference


IBaseRowSet Interface

Exposes methods and properties shared by all rowset types.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IBaseRowSet : IDisposable
Public Interface IBaseRowSet
    Inherits IDisposable

The IBaseRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Top
See Also

Reference


IBaseRowSet Properties

The IBaseRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
See Also

Reference

IBaseRowSet Interface


IBaseRowSet.ColumnCount Property

IBaseRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ColumnCount { get; }
ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IBaseRowSet Interface


IBaseRowSet.RowCount Property

IBaseRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int RowCount { get; }
ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IBaseRowSet Interface


IBaseRowSet Methods

The IBaseRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Top
See Also

Reference

IBaseRowSet Interface


IBaseRowSet.Close Method

IBaseRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

IBaseRowSet Interface


IBaseRowSet.GetColumnIndex Method

IBaseRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.
See Also

Reference

IBaseRowSet Interface


IBaseRowSet.GetColumnLabel Method

IBaseRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.
See Also

Reference

IBaseRowSet Interface


IBaseRowSet.GetRow Method

IBaseRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Top
See Also

Reference

IBaseRowSet Interface


IBaseRowSet.GetRow Method (Int32, CmcOptionFlags)

IBaseRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

IBaseRowSet Interface
GetRow Overload


IBaseRowSet.GetRow Method (Int32, String, CmcOptionFlags)

IBaseRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.
See Also

Reference

IBaseRowSet Interface
GetRow Overload


IBaseRowSet.GetRowValue Method

IBaseRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.
See Also

Reference

IBaseRowSet Interface


IBaseRowSet.GetShared Method

IBaseRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool GetShared(
    int nRow
)
Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.
See Also

Reference

IBaseRowSet Interface


ICommenceAddRowSet Interface

Interface for CommenceAddRowSet.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceAddRowSet : IBaseRowSet,
    IDisposable
Public Interface ICommenceAddRowSet
    Inherits IBaseRowSet, IDisposable

The ICommenceAddRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Commit | Commit changes to disk.
Public method | CommitGetCursor | Make row modifications permanent (commit to disk) and return a cursor for the newly added data. The CommenceAddRowSet should now be discarded.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Public method | ModifyRow | Modify fieldvalue
Public method | SetShared | Sets the shared status of the row. Shared items cannot be made unshared.
Top
See Also

Reference


ICommenceAddRowSet Properties

The ICommenceAddRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.ColumnCount Property

ICommenceAddRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ColumnCount { get; }
ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetColumnCount
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.RowCount Property

ICommenceAddRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int RowCount { get; }
ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetRowCount
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet Methods

The ICommenceAddRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Commit | Commit changes to disk.
Public method | CommitGetCursor | Make row modifications permanent (commit to disk) and return a cursor for the newly added data. The CommenceAddRowSet should now be discarded.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Public method | ModifyRow | Modify fieldvalue
Public method | SetShared | Sets the shared status of the row. Shared items cannot be made unshared.
Top
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.Close Method

ICommenceAddRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close

Implements

IBaseRowSetClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.Commit Method

ICommenceAddRowSetCommit Method

Commit changes to disk.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int Commit(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function Commit (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.CommitGetCursor Method

ICommenceAddRowSetCommitGetCursor Method

Make row modifications permanent (commit to disk) and return a cursor for the newly added data. The CommenceAddRowSet should now be discarded.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
CommenceCursor CommitGetCursor(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function CommitGetCursor (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As CommenceCursor

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: CommenceCursor
CommenceCursor object reflecting the changes.
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.GetColumnIndex Method

ICommenceAddRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.

Implements

IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.GetColumnLabel Method

ICommenceAddRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.

Implements

IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.GetRow Method

ICommenceAddRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Top
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.GetRow Method (Int32, CmcOptionFlags)

ICommenceAddRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, CmcOptionFlags)
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

ICommenceAddRowSet Interface
GetRow Overload


ICommenceAddRowSet.GetRow Method (Int32, String, CmcOptionFlags)

ICommenceAddRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
See Also

Reference

ICommenceAddRowSet Interface
GetRow Overload


ICommenceAddRowSet.GetRowValue Method

ICommenceAddRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.

Implements

IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.GetShared Method

ICommenceAddRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool GetShared(
    int nRow
)
Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.

Implements

IBaseRowSetGetShared(Int32)
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.ModifyRow Method

ICommenceAddRowSetModifyRow Method

Modify fieldvalue

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ModifyRow(
    int nRow,
    int nCol,
    string fieldValue,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function ModifyRow (
    nRow As Integer,
    nCol As Integer,
    fieldValue As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
nCol
Type: SystemInt32
The (0-based) index of the column.
fieldValue
Type: SystemString
new fieldValue.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.
See Also

Reference

ICommenceAddRowSet Interface


ICommenceAddRowSet.SetShared Method

ICommenceAddRowSetSetShared Method

Sets the shared status of the row. Shared items cannot be made unshared.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetShared(
    int nRow
)
Function SetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
True on success.
See Also

Reference

ICommenceAddRowSet Interface


ICommenceCursor Interface

CommenceCursor interface.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceCursor : IDisposable
Public Interface ICommenceCursor
    Inherits IDisposable

The ICommenceCursor type exposes the following members.

Properties
 | Name | Description
Public property | Category | Name of the category this cursor is based on.
Public property | ColumnCount | Number of columns in cursor.
Public property | Columns | Allows for setting multiple direct and related columns at once.
Public property | Filters | Gets collection of filters to be applied on cursor. It is recommended you use this property over setting filterstrings directly.
Public property | MaxFieldSize | Maximum field size. Gets the maximum number of characters that can be read from a Commence field. Undocumented by Commence. The default value is 93750.
Public property | MaxRows | Maximum number of rows a cursor can contain. Undocumented by Commence. Effectively a measure for database capacity.
Public property | RowCount | Number of items in cursor.
Public property | Shared | (read-only) TRUE if category is shared in a workgroup.
Public property | View | Name of the View if cursor is based on a view.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExportToFile | Exports current cursor to a file. WARNING: The cursor is disposed after this method!
Public method | GetAddRowSet | Create a rowset of new items to add to the database.
Public method | GetColumnNames | Get columnames from cursor. Defaults to fieldnames
Public method | GetDeleteRowSet(CmcOptionFlags) | Create a rowset of ALL existing items for deletion. Use with care!
Public method | GetDeleteRowSet(Int32, CmcOptionFlags) | Create a rowset of n items for deletion.
Public method | GetDeleteRowSetByID | Create a rowset for deleting a particular row.
Public method | GetEditRowSet(CmcOptionFlags) | Create a rowset of all existing items for editing. Be careful when handling very large rowsets.
Public method | GetEditRowSet(Int32, CmcOptionFlags) | Create a rowset of existing items for editing.
Public method | GetEditRowSetByID | Create a rowset for editing a particular row.
Public method | GetQueryRowSet(CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSet(Int32, CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSetByID | Create a rowset object with a particular row loaded.
Public method | GetQueryRowSetByThid | Create a rowset object with a particular thid loaded. Only applies to shared items. Cursor must have the thids thids flag.
Public method | HasDuplicates | Checks if field contains duplicate values.
Public method | ReadAllRows | Read all data from a cursor. This method is just a convenient way to return data without having to create a ICommenceQueryRowSet. Keep in mind reading data from Commence is quite slow! For more advanced reading and export options see IExportEngine.
Public method | ReadRow | Reads specified row from the cursor. This method is just a convenient way to return data without having to create a ICommenceQueryRowSet. If you need to apply formatting, see the IExportEngine interface.
Public method | SeekRow | Seek to row in cursor.
Public method | SeekRowApprox | Move a fractional number of rows.
Public method | SetActiveDate | Set active date used for view cursors using a view linking filter.
Public method | SetActiveDateRange | Set active date range used for view cursors using a view linking filter.
Public method | SetActiveItem | Set active item used for view cursors using a view linking filter.
Public method | SetColumn | Defines the column set for the cursor
Public method | SetColumns | Allows for setting direct columns in batch-mode
Public method | SetFilter | Defines the filter for the cursor. Not recommended, use Filters instead.
Public method | SetLogic | Defines the filter logic for the cursor. Not recommended, use Filters instead.
Public method | SetRelatedColumn | Define column for a connected field. Allows for retrieving other than just the Name field from connections.
Public method | SetSort | Defines the sort criteria for the cursor. Use this only if you apply filters with the SetFilter method. You are strongly advised to use the Filters collection instead.
Top
See Also

Reference


ICommenceCursor Properties

The ICommenceCursor type exposes the following members.

Properties
 | Name | Description
Public property | Category | Name of the category this cursor is based on.
Public property | ColumnCount | Number of columns in cursor.
Public property | Columns | Allows for setting multiple direct and related columns at once.
Public property | Filters | Gets collection of filters to be applied on cursor. It is recommended you use this property over setting filterstrings directly.
Public property | MaxFieldSize | Maximum field size. Gets the maximum number of characters that can be read from a Commence field. Undocumented by Commence. The default value is 93750.
Public property | MaxRows | Maximum number of rows a cursor can contain. Undocumented by Commence. Effectively a measure for database capacity.
Public property | RowCount | Number of items in cursor.
Public property | Shared | (read-only) TRUE if category is shared in a workgroup.
Public property | View | Name of the View if cursor is based on a view.
Top
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.Category Property

ICommenceCursorCategory Property

Name of the category this cursor is based on.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Category { get; }
ReadOnly Property Category As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.ColumnCount Property

ICommenceCursorColumnCount Property

Number of columns in cursor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ColumnCount { get; }
ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.Columns Property

ICommenceCursorColumns Property

Allows for setting multiple direct and related columns at once.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICursorColumns Columns { get; }
ReadOnly Property Columns As ICursorColumns
    Get

Property Value

Type: ICursorColumns
Remarks
Do not use this in conjunction with SetColumn or SetRelatedColumn methods. Set all columns at once using this property, or set them individually.

Only available for .NET applications.

See Also

Reference

ICommenceCursor Interface


ICommenceCursor.Filters Property

ICommenceCursorFilters Property

Gets collection of filters to be applied on cursor. It is recommended you use this property over setting filterstrings directly.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICursorFilters Filters { get; }
ReadOnly Property Filters As ICursorFilters
    Get

Property Value

Type: ICursorFilters
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.MaxFieldSize Property

ICommenceCursorMaxFieldSize Property

Maximum field size. Gets the maximum number of characters that can be read from a Commence field. Undocumented by Commence. The default value is 93750.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int MaxFieldSize { get; set; }
Property MaxFieldSize As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Be careful with setting this to a large value. It obviously impacts memory usage, and may make Commence go unresponsive for a long time, especially when you have columns defined with SetRelatedColumn(Int32, String, String, String, CmcOptionFlags)!

This property is not documented by Commence.

See Also

Reference

ICommenceCursor Interface


ICommenceCursor.MaxRows Property

ICommenceCursorMaxRows Property

Maximum number of rows a cursor can contain. Undocumented by Commence. Effectively a measure for database capacity.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int MaxRows { get; }
ReadOnly Property MaxRows As Integer
    Get

Property Value

Type: Int32
Remarks
At least up until Commence version RM 6.0, a Commence category can hold up to 500.000 items.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.RowCount Property

ICommenceCursorRowCount Property

Number of items in cursor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int RowCount { get; }
ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.Shared Property

ICommenceCursorShared Property

(read-only) TRUE if category is shared in a workgroup.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Shared { get; }
ReadOnly Property Shared As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.View Property

ICommenceCursorView Property

Name of the View if cursor is based on a view.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string View { get; }
ReadOnly Property View As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceCursor Interface


ICommenceCursor Methods

The ICommenceCursor type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExportToFile | Exports current cursor to a file. WARNING: The cursor is disposed after this method!
Public method | GetAddRowSet | Create a rowset of new items to add to the database.
Public method | GetColumnNames | Get columnames from cursor. Defaults to fieldnames
Public method | GetDeleteRowSet(CmcOptionFlags) | Create a rowset of ALL existing items for deletion. Use with care!
Public method | GetDeleteRowSet(Int32, CmcOptionFlags) | Create a rowset of n items for deletion.
Public method | GetDeleteRowSetByID | Create a rowset for deleting a particular row.
Public method | GetEditRowSet(CmcOptionFlags) | Create a rowset of all existing items for editing. Be careful when handling very large rowsets.
Public method | GetEditRowSet(Int32, CmcOptionFlags) | Create a rowset of existing items for editing.
Public method | GetEditRowSetByID | Create a rowset for editing a particular row.
Public method | GetQueryRowSet(CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSet(Int32, CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSetByID | Create a rowset object with a particular row loaded.
Public method | GetQueryRowSetByThid | Create a rowset object with a particular thid loaded. Only applies to shared items. Cursor must have the thids thids flag.
Public method | HasDuplicates | Checks if field contains duplicate values.
Public method | ReadAllRows | Read all data from a cursor. This method is just a convenient way to return data without having to create a ICommenceQueryRowSet. Keep in mind reading data from Commence is quite slow! For more advanced reading and export options see IExportEngine.
Public method | ReadRow | Reads specified row from the cursor. This method is just a convenient way to return data without having to create a ICommenceQueryRowSet. If you need to apply formatting, see the IExportEngine interface.
Public method | SeekRow | Seek to row in cursor.
Public method | SeekRowApprox | Move a fractional number of rows.
Public method | SetActiveDate | Set active date used for view cursors using a view linking filter.
Public method | SetActiveDateRange | Set active date range used for view cursors using a view linking filter.
Public method | SetActiveItem | Set active item used for view cursors using a view linking filter.
Public method | SetColumn | Defines the column set for the cursor
Public method | SetColumns | Allows for setting direct columns in batch-mode
Public method | SetFilter | Defines the filter for the cursor. Not recommended, use Filters instead.
Public method | SetLogic | Defines the filter logic for the cursor. Not recommended, use Filters instead.
Public method | SetRelatedColumn | Define column for a connected field. Allows for retrieving other than just the Name field from connections.
Public method | SetSort | Defines the sort criteria for the cursor. Use this only if you apply filters with the SetFilter method. You are strongly advised to use the Filters collection instead.
Top
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.Close Method

ICommenceCursorClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

ICommenceCursor Interface


ICommenceCursor.ExportToFile Method

ICommenceCursorExportToFile Method

Exports current cursor to a file. WARNING: The cursor is disposed after this method!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void ExportToFile(
    string fileName,
    IExportSettings settings = null
)
Sub ExportToFile (
    fileName As String,
    Optional settings As IExportSettings = Nothing
)

Parameters

fileName
Type: SystemString
(Fully qualified) filename. Overwrites existing file.
settings (Optional)
Type: Vovin.CmcLibNet.ExportIExportSettings
IExportSettings object.
Remarks
The PreserveAllConnections options is ignored in this method. Alternatively, but extremely slow, you can use either the UseDDE option or crank up the MaxFieldSize value and hope you have enough RAM memory.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.GetAddRowSet Method

ICommenceCursorGetAddRowSet Method

Create a rowset of new items to add to the database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceAddRowSet GetAddRowSet(
    int nRows,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetAddRowSet (
    nRows As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceAddRowSet

Parameters

nRows
Type: SystemInt32
Number of rows to create.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: Shared - all rows default to shared.

Return Value

Type: ICommenceAddRowSet
ICommenceAddRowSet object.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.GetColumnNames Method

ICommenceCursorGetColumnNames Method

Get columnames from cursor. Defaults to fieldnames

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IEnumerable<string> GetColumnNames(
    CmcOptionFlags flags = CmcOptionFlags.Fieldname
)
Function GetColumnNames (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Fieldname
) As IEnumerable(Of String)

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
CmcOptionFlags, defaults to Fieldname

Return Value

Type: IEnumerable String
List of columnames.
Remarks

This method is only available in .NET.

Pass Default to retrieve fieldlabels instead of fieldnames.

See Also

Reference

ICommenceCursor Interface


ICommenceCursor.GetDeleteRowSet Method

ICommenceCursorGetDeleteRowSet Method

Overload List
 | Name | Description
Public method | GetDeleteRowSet(CmcOptionFlags) | Create a rowset of ALL existing items for deletion. Use with care!
Public method | GetDeleteRowSet(Int32, CmcOptionFlags) | Create a rowset of n items for deletion.
Top
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.GetDeleteRowSet Method (CmcOptionFlags)

ICommenceCursorGetDeleteRowSet Method (CmcOptionFlags)

Create a rowset of ALL existing items for deletion. Use with care!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceDeleteRowSet GetDeleteRowSet(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetDeleteRowSet (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceDeleteRowSet

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceDeleteRowSet
ICommenceDeleteRowSet on success.
Remarks
This method is only available to .NET applications.
See Also

Reference

ICommenceCursor Interface
GetDeleteRowSet Overload


ICommenceCursor.GetDeleteRowSet Method (Int32, CmcOptionFlags)

ICommenceCursorGetDeleteRowSet Method (Int32, CmcOptionFlags)

Create a rowset of n items for deletion.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceDeleteRowSet GetDeleteRowSet(
    int nRows,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetDeleteRowSet (
    nRows As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceDeleteRowSet

Parameters

nRows
Type: SystemInt32
Number of rows to retrieve.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceDeleteRowSet
ICommenceDeleteRowSet on success.
See Also

Reference

ICommenceCursor Interface
GetDeleteRowSet Overload


ICommenceCursor.GetDeleteRowSetByID Method

ICommenceCursorGetDeleteRowSetByID Method

Create a rowset for deleting a particular row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceDeleteRowSet GetDeleteRowSetByID(
    string pRowID,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetDeleteRowSetByID (
    pRowID As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceDeleteRowSet

Parameters

pRowID
Type: SystemString
Unique ID string obtained from GetRowID().
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceDeleteRowSet
ICommenceDeleteRowSet on success.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.GetEditRowSet Method

ICommenceCursorGetEditRowSet Method

Overload List
 | Name | Description
Public method | GetEditRowSet(CmcOptionFlags) | Create a rowset of all existing items for editing. Be careful when handling very large rowsets.
Public method | GetEditRowSet(Int32, CmcOptionFlags) | Create a rowset of existing items for editing.
Top
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.GetEditRowSet Method (CmcOptionFlags)

ICommenceCursorGetEditRowSet Method (CmcOptionFlags)

Create a rowset of all existing items for editing. Be careful when handling very large rowsets.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceEditRowSet GetEditRowSet(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetEditRowSet (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceEditRowSet

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceEditRowSet
ICommenceEditRowSet object on success.
Remarks
This method is only available for .Net consumers.
Remarks
This method is only available to .NET applications.
See Also

Reference

ICommenceCursor Interface
GetEditRowSet Overload


ICommenceCursor.GetEditRowSet Method (Int32, CmcOptionFlags)

ICommenceCursorGetEditRowSet Method (Int32, CmcOptionFlags)

Create a rowset of existing items for editing.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceEditRowSet GetEditRowSet(
    int nRows,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetEditRowSet (
    nRows As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceEditRowSet

Parameters

nRows
Type: SystemInt32
Number of rows to retrieve.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceEditRowSet
ICommenceEditRowSet object.
See Also

Reference

ICommenceCursor Interface
GetEditRowSet Overload


ICommenceCursor.GetEditRowSetByID Method

ICommenceCursorGetEditRowSetByID Method

Create a rowset for editing a particular row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceEditRowSet GetEditRowSetByID(
    string pRowID,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetEditRowSetByID (
    pRowID As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceEditRowSet

Parameters

pRowID
Type: SystemString
Unique ID string obtained from GetRowID().
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceEditRowSet
ICommenceEditRowSet object.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.GetQueryRowSet Method

ICommenceCursorGetQueryRowSet Method

Overload List
 | Name | Description
Public method | GetQueryRowSet(CmcOptionFlags) | Create a rowset object with the results of a query.
Public method | GetQueryRowSet(Int32, CmcOptionFlags) | Create a rowset object with the results of a query.
Top
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.GetQueryRowSet Method (CmcOptionFlags)

ICommenceCursorGetQueryRowSet Method (CmcOptionFlags)

Create a rowset object with the results of a query.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceQueryRowSet GetQueryRowSet(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetQueryRowSet (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceQueryRowSet

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceQueryRowSet
ICommenceQueryRowSet object on success.
Remarks
This method is only available to .NET applications.
See Also

Reference

ICommenceCursor Interface
GetQueryRowSet Overload


ICommenceCursor.GetQueryRowSet Method (Int32, CmcOptionFlags)

ICommenceCursorGetQueryRowSet Method (Int32, CmcOptionFlags)

Create a rowset object with the results of a query.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceQueryRowSet GetQueryRowSet(
    int nRows,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetQueryRowSet (
    nRows As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceQueryRowSet

Parameters

nRows
Type: SystemInt32
Maximum number of rows to retrieve.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceQueryRowSet
ICommenceQueryRowSet object on success.
See Also

Reference

ICommenceCursor Interface
GetQueryRowSet Overload


ICommenceCursor.GetQueryRowSetByID Method

ICommenceCursorGetQueryRowSetByID Method

Create a rowset object with a particular row loaded.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceQueryRowSet GetQueryRowSetByID(
    string pRowID,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetQueryRowSetByID (
    pRowID As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceQueryRowSet

Parameters

pRowID
Type: SystemString
Unique ID string obtained from GetRowID(Int32, CmcOptionFlags).
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceQueryRowSet
ICommenceQueryRowSet on success.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.GetQueryRowSetByThid Method

ICommenceCursorGetQueryRowSetByThid Method

Create a rowset object with a particular thid loaded. Only applies to shared items. Cursor must have the thids thids flag.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceQueryRowSet GetQueryRowSetByThid(
    string pThid,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetQueryRowSetByThid (
    pThid As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceQueryRowSet

Parameters

pThid
Type: SystemString
THID parts "thidId : thidSequence" (i.e., omit the leading category part).
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: ICommenceQueryRowSet
ICommenceQueryRowSet on success
Remarks
Undocumented by Commence.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.HasDuplicates Method

ICommenceCursorHasDuplicates Method

Checks if field contains duplicate values.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool HasDuplicates(
    string columnName,
    bool caseSensitive = true
)
Function HasDuplicates (
    columnName As String,
    Optional caseSensitive As Boolean = true
) As Boolean

Parameters

columnName
Type: SystemString
Columname in cursor to compare. Column must exist in the cursor.
caseSensitive (Optional)
Type: SystemBoolean
Perform case-sensitive check, default is true.

Return Value

Type: Boolean
true if duplicates are found.
Exceptions
Exception | Condition
CommenceCOMException | Column not present in cursor.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.ReadAllRows Method

ICommenceCursorReadAllRows Method

Read all data from a cursor.

This method is just a convenient way to return data without having to create a ICommenceQueryRowSet.

Keep in mind reading data from Commence is quite slow!

For more advanced reading and export options see IExportEngine.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<List<string>> ReadAllRows(
    int batchRows = 1000
)
Function ReadAllRows (
    Optional batchRows As Integer = 1000
) As List(Of List(Of String))

Parameters

batchRows (Optional)
Type: SystemInt32
Number of rows to read per iteration.

Return Value

Type: List List String
List of lists containing commence rowvalues, null on error.
Remarks
This method is not available to COM clients.

If the cursor has the UseThids flag defined, the first element of the inner list will contain the thid. In that case the inner list count will be the number of columns in the category plus one.

See Also

Reference

ICommenceCursor Interface


ICommenceCursor.ReadRow Method

ICommenceCursorReadRow Method

Reads specified row from the cursor.

This method is just a convenient way to return data without having to create a ICommenceQueryRowSet.

If you need to apply formatting, see the IExportEngine interface.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> ReadRow(
    int lRow
)
Function ReadRow (
    lRow As Integer
) As List(Of String)

Parameters

lRow
Type: SystemInt32
Row to read. Row is 0-based, from beginning of cursor.

Return Value

Type: List String
List of rowvalues, null on error.
Remarks
This method is only available in .NET.

If the cursor has the UseThids flag defined, the first element of the inner list will contain the thid. In that case the inner list count will be the number of columns in the category plus one.

See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SeekRow Method

ICommenceCursorSeekRow Method

Seek to row in cursor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int SeekRow(
    CmcCursorBookmark bkOrigin,
    int nRows
)
Function SeekRow (
    bkOrigin As CmcCursorBookmark,
    nRows As Integer
) As Integer

Parameters

bkOrigin
Type: Vovin.CmcLibNet.DatabaseCmcCursorBookmark
Starting row.
nRows
Type: SystemInt32
Number of rows to move pointer.

Return Value

Type: Int32
Number of rows moved, -1 on error.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SeekRowApprox Method

ICommenceCursorSeekRowApprox Method

Move a fractional number of rows.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int SeekRowApprox(
    int nNumerator,
    int nDenominator
)
Function SeekRowApprox (
    nNumerator As Integer,
    nDenominator As Integer
) As Integer

Parameters

nNumerator
Type: SystemInt32
Numerator.
nDenominator
Type: SystemInt32
Denominator.

Return Value

Type: Int32
Number of rows moved, -1 on error.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SetActiveDate Method

ICommenceCursorSetActiveDate Method

Set active date used for view cursors using a view linking filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetActiveDate(
    string sDate,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function SetActiveDate (
    sDate As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

sDate
Type: SystemString
Date (string).
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Option flags, must be 0.

Return Value

Type: Boolean
true on succes, false on error.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SetActiveDateRange Method

ICommenceCursorSetActiveDateRange Method

Set active date range used for view cursors using a view linking filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetActiveDateRange(
    string startDate,
    string endDate,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function SetActiveDateRange (
    startDate As String,
    endDate As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

startDate
Type: SystemString
Date (string)
endDate
Type: SystemString
Date (string)
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Option flags, must be 0.

Return Value

Type: Boolean
true on succes, false on error.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SetActiveItem Method

ICommenceCursorSetActiveItem Method

Set active item used for view cursors using a view linking filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetActiveItem(
    string pCategoryName,
    string pRowID,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function SetActiveItem (
    pCategoryName As String,
    pRowID As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

pCategoryName
Type: SystemString
Category name of the active item used with view linking filter.
pRowID
Type: SystemString
Unique ID string obtained from GetRowID() indicating the active item used with view linking filter.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0.

Return Value

Type: Boolean
true on succes, false on error.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SetColumn Method

ICommenceCursorSetColumn Method

Defines the column set for the cursor

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetColumn(
    int nColumn,
    string pName,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function SetColumn (
    nColumn As Integer,
    pName As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

nColumn
Type: SystemInt32
The (0-based) index of the column to set.
pName
Type: SystemString
Name of the field to use in this column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: All - create column set of all fields.

Return Value

Type: Boolean
true on succes, false on error.
Remarks
Do not skip or duplicate indexes. Related columns must come after the direct columns.

Using SetColumns(Object) offers a more convenient way to set columns.

See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SetColumns Method

ICommenceCursorSetColumns Method

Allows for setting direct columns in batch-mode

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetColumns(
    Object[] columnNames
)
Function SetColumns (
    columnNames As Object()
) As Boolean

Parameters

columnNames
Type: SystemObject
Object array of columnnames.

Return Value

Type: Boolean
true on succes, false on error.
Remarks
Note the object and not string type of the array, this is to accomodate COM clients.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SetFilter Method

ICommenceCursorSetFilter Method

Defines the filter for the cursor. Not recommended, use Filters instead.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetFilter(
    string pFilter,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function SetFilter (
    pFilter As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

pFilter
Type: SystemString
Fully formatted [ViewFilter()] DDE request command.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be Default

Return Value

Type: Boolean
true on succes, false on error.
See Also

Reference

ICommenceCursor Interface
ICommenceCursorFilters


ICommenceCursor.SetLogic Method

ICommenceCursorSetLogic Method

Defines the filter logic for the cursor. Not recommended, use Filters instead.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetLogic(
    string pLogic,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function SetLogic (
    pLogic As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

pLogic
Type: SystemString
Fully formatted [ViewConjunction()] DDE request command.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be CmcOptionFlags.Default

Return Value

Type: Boolean
true on succes, false on error.
See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SetRelatedColumn Method

ICommenceCursorSetRelatedColumn Method

Define column for a connected field. Allows for retrieving other than just the Name field from connections.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetRelatedColumn(
    int nColumn,
    string pConnName,
    string pCatName,
    string pName,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function SetRelatedColumn (
    nColumn As Integer,
    pConnName As String,
    pCatName As String,
    pName As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Boolean

Parameters

nColumn
Type: SystemInt32
The (0-based) index of the column to set.
pConnName
Type: SystemString
Name of the connection to use in this column.
pCatName
Type: SystemString
Name of the connected Category to use in this column.
pName
Type: SystemString
Name of the field in the connected category to use in this column
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: All - create column set of all fields.

Return Value

Type: Boolean
true on succes, false on error.
Remarks
Setting the CmcOptionFlags.All flag *only* affects direct fields in the cursor. It cannot be used to obtain all fields from the connected category.
Remarks
Related columns must always come after the direct columns. Do not skip or duplicate an index.

Warning: related columns severely impact memory usage and processing time!

Using Columns offers a more convenient way to set related columns.

See Also

Reference

ICommenceCursor Interface


ICommenceCursor.SetSort Method

ICommenceCursorSetSort Method

Defines the sort criteria for the cursor. Use this only if you apply filters with the SetFilter method. You are strongly advised to use the Filters collection instead.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetSort(
    string pSort,
    CmcOptionFlags flags
)
Function SetSort (
    pSort As String,
    flags As CmcOptionFlags
) As Boolean

Parameters

pSort
Type: SystemString
Text defining the new sort criteria. Syntax is identical to the one used by the DDE ViewSort request.
flags
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: Boolean
Returns true on succes, false on error.
See Also

Reference

ICommenceCursor Interface


ICommenceDatabase Interface

Exposes all 'native' Commence API database functionality, including all functionality provided by the DDE interface (ICommenceConversation). There is no need to use DDE syntax with CmcLibNet, all DDE plumbing is hidden from the end user.

You cannot get a reference to FormOA.ICommenceConversation from CmcLibNet.

COM clients can reference this interface by using the ProgId CmcLibNet.Database.

VBScript:
VBScript
Copy
Dim db : Set db = CreateObject("CmcLibNet.Database")
'.. do stuff ..
db.Close
Set db = Nothing

When used fom a Commence Item Detail Form or Office VBA, be sure to read up on the Close method.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceDatabase : IDisposable
Public Interface ICommenceDatabase
    Inherits IDisposable

The ICommenceDatabase type exposes the following members.

Properties
 | Name | Description
Public property | Delim | Delimiter used in DDE requests. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.
Public property | Delim2 | Secondary delimiter used in DDE requests that act on connections. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.
Public property | EncodeDDEArguments | Make assembly try to string-escape DDE arguments. Default is true.
Public property | Name | Name of currently open Commence database.
Public property | Path | Path of currently open Commence database.
Top
Methods
Name Description
Public method AddItem
Adds the indicated Item to the Category. Fields other than the Name field are set to their default values. (Default values for date fields must not specify date ranges, e.g., "every day"). By default, the new item is local (i.e., non-shared) CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled. Note: If a clarify field is defined for the category (but is not a Sequence Number field), the clarify field value can be specified using the optional third parameter, Clarify Value. Alternatively, the Item parameter can be a clarified item name. If the clarify field is a Sequence Number field, then the field value is determined automatically by Commence. An error results if the AddItem REQUEST tries to set a Sequence Number field. Use GetFieldDefinition to determine the Sequence Number field value so a clarified item name can be used with subsequent EditItems.
Public method AddSharedItem
Identical in function to AddItem except that it creates a shared item, provided that the database is connected and the category is shared. Otherwise a local item is created. CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled.
Public method AppendText
Appends text to an existing text Field. Use this command to overcome the 256 character maximum string limitation of certain macro languages (such as WordBasic). Whenever possible, use a clarified item name. You are strongly advised to use a ICommenceEditRowSet for editing fields instead.

When an item was just created with AddItem(String, String, String) or AddSharedItem(String, String, String), this is the item that will be used for appending. Otherwise, unless you specifically mark an item (using GetMarkItem(String, String, String) or MarkActiveItem(String)) the first match will be used.

Public method AssignConnection
Assigns a connection between two items.
Public method CheckInFormScript
Updates the detail form script with the text in the specified Filename.
Public method CheckOutFormScript
Saves the detail form script to file.
Public method ClarifyItemNames
Specifies whether Commence should return clarified item names, or leave bStatus empty to get the current status.
Public method Close
Close any references to Commence. The object should be disposed after this.
Public method DeleteItem
Deletes the indicated Item from the Category. This action cannot be undone. Whenever possible, use a clarified item name.
Public method DeleteView
Deletes the specified view. Use with caution! This action cannot be undone.
Public method Dispose
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
(Inherited from IDisposable.)
Public method EditItem
Sets the value of Field to Value for the item identified by Item in Category. Field must not specify a Calculation field. Date fields may not specify a range, (e.g., "every day"). Whenever possible, use a clarified Item name.
Public method ExportDatabaseSchema
Exports the schema information to file. Defaults to Json.
Public method FieldValueExists
Checks to see if value is already present for given field.
FireTrigger
Fires the indicated Agent Trigger.
Public method GetActiveCategory
Gets the category of the active item or view.
Public method GetActiveItemName
Gets the itemname of the active item. Use MarkActiveItem(String) to try and get a clariefied itemname.
Public method GetActiveViewInfo
Returms information on the currently active view (if any).
Public method GetCallerID(String, String)
Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method GetCallerID(String, String, String)
Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method GetCategoryCount
Returns number of categories in the Commence database.
Public method GetCategoryDefinition
Returns information on the definition of the specified category.
Public method GetCategoryNames
Gets a list of categories in the current Commence database.
Public method GetCategoryNames(String)
Gets a list of category names.
Public method GetClarifiedItemName
Construct a clarified item name from the unclarified itemname, the clarify separator and the clarify value
Public method GetClarifyField
Gets the clarifyfield for the specified category.
Public method GetClarifySeparator
Gets the clarify separator for the specified category.
Public method GetConnectedItemCount
Gets the number of connected items in connected category for the specified item
Public method GetConnectedItemField
Returns the indirect field value(s) in connCategory that itemName of the categoryName is connected to via Connection. The order of the items in the list is arbitrary (i.e., not sorted).
Public method GetConnectedItemNames(String, String, String, String)
Gets a list of items connected to the specified item.
Public method GetConnectedItemNames(String, String, String, String, String)
Returns the list of items in category that named item is connected to. The order of the items in the list is arbitrary (i.e., not sorted).
Public method GetConnectionCount
Gets the number of connections from the specified category.
Public method GetConnectionNames(String)
Gets a list of connection names to the specified category.
Public method GetConnectionNames(String, String, String)
Gets the connection names for the specified category.
Public method GetCursor
Create a cursor.
Public method GetDatabase Obsolete.
(Not implemented) Get the active Commence database name and path as delimited string. See Name and/or Path.
Public method GetDatabaseDefinition
Queries Commence for information on the database definition.
Public method GetDatabaseSchema
Gets a serializable object containnig the Commence schema definition.
Public method GetDesktopCount
Gets the number of Desktops in the Commence database.
Public method GetDesktopNames
Get a list of desktopnames.
Public method GetDesktopNames(String)
Gets the desktop names in the Commence database.
Public method GetField
Returns a fieldvalue from the specified Commence item.
Public method GetFieldCount
Gets the number of fields in the specified category.
Public method GetFieldDefinition
Queries Commence for information on the specified field definition.
Public method GetFieldNames(String)
Gets a list of fieldnames for the specified Commence category.
Public method GetFieldNames(String, String)
Gets the fieldnames for the specified category.
Public method GetFields(String, String, ListString)
Gets values of specified field(s) from specified item.
Public method GetFields(String, String, Object, String)
Gets values of specified field(s) from specified item.
Public method GetFieldToFile
Writes a single fieldvalue to file.
Public method GetFormCount
Gets the number of Item Detail Forms for the specified category.
Public method GetFormNames(String)
Gets a list of all Item Detail Form names in specified category.
Public method GetFormNames(String, String)
Gets the Item detail Form names for the specified category
Public method GetImageFieldCount
Gets the number of image fields in specified category.
Public method GetImageFieldNames(String)
Gets a list of all field of type 'image' from the specified category.
Public method GetImageFieldNames(String, String)
Gets the image-type field names for the specified category.
Public method GetImageFieldToFile
Copies the image field identified by the named Category, Item, and Field to the specified Filename. Only bitmap (.BMP) format image fields are currently supported. Filename must be a fully qualified path including the drive letter (e.g. c:\tmp\data.bmp). If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten. It is the client’s responsibility to perform the necessary file cleanup. If the image field is blank, no file is written.
Public method GetItemCount
Gets the number of items in the specified category.
Public method GetItemNames(String)
Gets a list of all itemnames in the specified category.
Public method GetItemNames(String, String)
Gets the item names for the specified category
Public method GetLastError
Gets the last error that occurred during DDE conversation. Inspect this value if a call failed.
Public method GetLetterViewInfo
Returns information about the active view and selected letter template at the time the Tools-Send Letter or Customize-Database-Letter Template command was executed. This call is used by the Commence letter macros and has not been implemented here.
Public method GetMarkItem
"Marks" the specified item and makes it the default category and item for subsequent calls to: EditItem, DeleteItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands, and GetField, GetFieldToFile, GetFields, GetConnectedItemCount and GetConnectedItemNames REQUESTS. The category and item is marked only for the specific DDE conversation, not globally. that is, each DDE conversation can have a different marked item. Can be used to mark the (-Me-) item if one is defined. Syntax: [GetMarkItem("(-Me-)")] Note: If a Clarify Field is defined for the category, the value of the clarify field can be specified with an optional third paramter. Alternatively, the ItemName can be a clarified item name.
Public method GetMeField
Gets a fieldvalue from the item defined as (-Me-) item in Commence.
Public method GetNameField
Get the name of the namefield for the specified category.
Public method GetPhoneNumber
TAPI must be configured for GetPhoneNumber to work properly. TAPI is ancient, so this method is not implemented.
Public method GetPreference
Get preference settings.
Public method GetReverseName
Uses Commence preference information and reverses the name if appropriate.
Public method GetTriggerCount
Gets the number of DDE agent triggers defined in the database.
Public method GetTriggerNames
Get a list of Agent triggers.
Public method GetTriggerNames(String)
Gets the trigger names defined in the database.
Public method GetViewColumnNames
Gets the columnnames from a view provided a cursor can be created on them.
Public method GetViewCount
Gets the number of views in the specified category.
Public method GetViewDefinition
Get definition of a view
Public method GetViewNames(String)
Gets a list of all views for the specified category. Returns all categories if category is not specified.
Public method GetViewNames(String, String)
Gets a list of view names for the specified category.
Public method GetViewToFile
Saves the Commence View to a file in HTML format (similar to the File-Save As HTML menu command). If the file does not exist, Commence will create it; the drive and directory must exist. If the file exists, it will be overwritten.
Public method HasDuplicates
Checks if field contains duplicate values.
Public method LogPhoneCall
Launches an add tem detail window for an item in the Phone Log category (as specified in the Commence Customize-Preferences-Event Logs dialog box). One or more Category/Item pairs may be given as arguments; connections will be set between the new Phone Log item and these items. If no connection exists between the two categories, the pair is ignored and no error is given. The connection is set via all connections found between the two categories. If no Phone Log category is set, NACK error code 104 (DDE_ERROR_NOLOGCLASS) is returned. If there is no room to add an item in the Phone Log category, NACK error code 112 (DDE_ERROR_FULL) is returned.
Public method MarkActiveItem
Marks the active item for subsequent requests.
Public method MergeTemplateCreate
Creates a new template with the given parameters. If template exists, the call fails. This call returns the template filename assigned by Commence, including the full path and extension configured in Preferences-Letter dialog.
Public method MergeTemplateSave
Updates an existing template identified by the name parameter. Template must exist, else the call fails.
Public method PromoteItemToShared
Promotes a local item to shared status, provided the database is connected and the category is shared. If the item is already shared, its status is unchanged. Note that there is no way to demote an item from shared to local status. Whenever possible, use a clarified Item name.
Public method ShowDesktop
Opens the specified desktop in Commence.
Public method ShowItem
Opens an item detail window in Commence for the given Item in the given Category. If a detail is already open for the item, it will be brought to the top and given the focus.
Public method ShowView
Opens the specified view in Commence. If the view is already open, it will become the active view.
Public method UnassignConnection
Unassigns a connection between two items.
Public method ViewCategory
Defines the category to be used. This must be the first message sent to Commence for a ViewData conversation. ViewCategory may be sent at any time to reset the ViewData conversation state. ViewData conversation topic has been obsolete since Commence 3.0 (1995 or so), so it is extremely unlikely you will ever need this method.
Public method ViewConjunction
Defines the logical operations that link the filter clauses specified with the ViewFilter request. Each parameter can be either "And" or "Or"; the default value is "And". AndOr12 defines the relationship between the filter clauses 1 and 2, AndOr34 for clauses 3 and 4, and AndOr13 for (1 and 2) and (3 and 4), etc. Note the special significance of AndOr48, which signifies the relationship between the two groups of 4 filters.

The logical precedence is: (Filter1 AndOr12 Filter2) AndOr13 (Filter3 AndOr34 Filter4) AndOr4to8 [repeat 5 to 8]

Public method ViewConnectedCount
Returns the number of items in the connCategory that the Indexth item is connected to via ConnectionName.
Public method ViewConnectedField
Returns the value of Field of the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.
Public method ViewConnectedFields(Int32, String, String, Int32, ListString, String)
Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method ViewConnectedFields(Int32, String, String, Int32, Object, String)
Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method ViewConnectedItem
Returns the ConnIndexth item in connCategory that the Indexth item is connected to via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value.
Public method ViewDeleteAllItems
USE WITH EXTREME CAUTION! Deletes all items that satisfy the currently defined filter. If no filter is defined, deletes all items in the previously named category, see ViewCategory(String). Fails without warning when no delete permissions were granted on the category.
Public method ViewField
Returns the value of Field of the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount REQUEST to determine the maximum Index value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.
Public method ViewFields(Int32, ListString, String)
Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method ViewFields(Int32, Object, String)
Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method ViewFieldToFile
Saves specified field to file
Public method ViewFilter
Defines the criteria for the multiple filter to be applied against the previously named category/view (see ViewCategory/ViewView). This is by far the most complicated API method to use. Unless you are actually creating views from code, you are strongly advised to use the Filters collection of the CommenceCursor class instead.
Public method ViewImageFieldToFile
Copies the image field data in Field from the Indexth item that satisfies the currently defined filter (if any) to the specified Filename.
Public method ViewItemCount
Returns the number of items that satisfy the currently defined filter (if any). If no filter is defined, this request returns the total number of items in the category
Public method ViewItemIndex
Returns the index of the item with the indicated name field value. The item must also satisfy the currently defined filter (if any). Use a clarified itemname if possible. Note: If the NameFieldValue is left blank, the marked item will be used. Returns the index of the marked item (if any).
Public method ViewItemName
Returns the itemname for the Indexth item. Different from ViewField(Index, Name) in that a clarified item name may be returned. The ClarifyItemNames request is used to enable or disable the use of clarified item names.
Public method ViewMarkItem
Marks the Indexth item in the view and makes it the default category and item for the EditItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands.
Public method ViewReverseName
Uses Commence preference information and reverses the name if appropriate.
Public method ViewSaveView
Saves the virtual DDE view already created with the ViewCategory, ViewFilter, ViewSort, etc., as an actual view in Commence, accessible via the normal user interface. The view will be saved using the specified New View Name. If the view already exists, it will be overwritten. Use GetViewNames to determine if the view name conflicts with an existing view.
Public method ViewSort
Defines the sort criteria for the view. Field1, Field2, Field3, and Field4 define the fields to sort by. Sort1, Sort2, Sort3, and Sort4 define the sort type and should be "Ascending" or "Descending". Unused sort pairs (i.e. FieldN, SortN) may be omitted.
Public method ViewView
Uses the category and filter criteria of a Commence View that has already be defined from the Commence menu interface. The ViewView REQUEST overrides any previously received ViewCategory, ViewConjunction, ViewFilter, and ViewSort REQUESTS. If the ViewName parameter is left blank, the active view will be used.
Top
Remarks
A lot of the documentation on this interface comes 'verbatim' from the Commence help files.
See Also

Reference


ICommenceDatabase Properties

The ICommenceDatabase type exposes the following members.

Properties
 | Name | Description
Public property | Delim | Delimiter used in DDE requests. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.
Public property | Delim2 | Secondary delimiter used in DDE requests that act on connections. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.
Public property | EncodeDDEArguments | Make assembly try to string-escape DDE arguments. Default is true.
Public property | Name | Name of currently open Commence database.
Public property | Path | Path of currently open Commence database.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.Delim Property

ICommenceDatabaseDelim Property

Delimiter used in DDE requests. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Delim { get; set; }
Property Delim As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.Delim2 Property

ICommenceDatabaseDelim2 Property

Secondary delimiter used in DDE requests that act on connections. Use this only if the default delimiter does not suffice. This should be very rare. Supply up to 8 characters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Delim2 { get; set; }
Property Delim2 As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.EncodeDDEArguments Property

ICommenceDatabaseEncodeDDEArguments Property

Make assembly try to string-escape DDE arguments. Default is true.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool EncodeDDEArguments { get; set; }
Property EncodeDDEArguments As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
By default, all arguments passed to DDE requests will be enclosed in double-quotes. Setting this to false allows you to have fine-grained control over the format of the parameters.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.Name Property

ICommenceDatabaseName Property

Name of currently open Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.Path Property

ICommenceDatabasePath Property

Path of currently open Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Path { get; }
ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase Methods

The ICommenceDatabase type exposes the following members.

Methods
Name Description
Public method AddItem
Adds the indicated Item to the Category. Fields other than the Name field are set to their default values. (Default values for date fields must not specify date ranges, e.g., "every day"). By default, the new item is local (i.e., non-shared) CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled. Note: If a clarify field is defined for the category (but is not a Sequence Number field), the clarify field value can be specified using the optional third parameter, Clarify Value. Alternatively, the Item parameter can be a clarified item name. If the clarify field is a Sequence Number field, then the field value is determined automatically by Commence. An error results if the AddItem REQUEST tries to set a Sequence Number field. Use GetFieldDefinition to determine the Sequence Number field value so a clarified item name can be used with subsequent EditItems.
Public method AddSharedItem
Identical in function to AddItem except that it creates a shared item, provided that the database is connected and the category is shared. Otherwise a local item is created. CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled.
Public method AppendText
Appends text to an existing text Field. Use this command to overcome the 256 character maximum string limitation of certain macro languages (such as WordBasic). Whenever possible, use a clarified item name. You are strongly advised to use a ICommenceEditRowSet for editing fields instead.

When an item was just created with AddItem(String, String, String) or AddSharedItem(String, String, String), this is the item that will be used for appending. Otherwise, unless you specifically mark an item (using GetMarkItem(String, String, String) or MarkActiveItem(String)) the first match will be used.

Public method AssignConnection
Assigns a connection between two items.
Public method CheckInFormScript
Updates the detail form script with the text in the specified Filename.
Public method CheckOutFormScript
Saves the detail form script to file.
Public method ClarifyItemNames
Specifies whether Commence should return clarified item names, or leave bStatus empty to get the current status.
Public method Close
Close any references to Commence. The object should be disposed after this.
Public method DeleteItem
Deletes the indicated Item from the Category. This action cannot be undone. Whenever possible, use a clarified item name.
Public method DeleteView
Deletes the specified view. Use with caution! This action cannot be undone.
Public method Dispose
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
(Inherited from IDisposable.)
Public method EditItem
Sets the value of Field to Value for the item identified by Item in Category. Field must not specify a Calculation field. Date fields may not specify a range, (e.g., "every day"). Whenever possible, use a clarified Item name.
Public method ExportDatabaseSchema
Exports the schema information to file. Defaults to Json.
Public method FieldValueExists
Checks to see if value is already present for given field.
FireTrigger
Fires the indicated Agent Trigger.
Public method GetActiveCategory
Gets the category of the active item or view.
Public method GetActiveItemName
Gets the itemname of the active item. Use MarkActiveItem(String) to try and get a clariefied itemname.
Public method GetActiveViewInfo
Returms information on the currently active view (if any).
Public method GetCallerID(String, String)
Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method GetCallerID(String, String, String)
Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method GetCategoryCount
Returns number of categories in the Commence database.
Public method GetCategoryDefinition
Returns information on the definition of the specified category.
Public method GetCategoryNames
Gets a list of categories in the current Commence database.
Public method GetCategoryNames(String)
Gets a list of category names.
Public method GetClarifiedItemName
Construct a clarified item name from the unclarified itemname, the clarify separator and the clarify value
Public method GetClarifyField
Gets the clarifyfield for the specified category.
Public method GetClarifySeparator
Gets the clarify separator for the specified category.
Public method GetConnectedItemCount
Gets the number of connected items in connected category for the specified item
Public method GetConnectedItemField
Returns the indirect field value(s) in connCategory that itemName of the categoryName is connected to via Connection. The order of the items in the list is arbitrary (i.e., not sorted).
Public method GetConnectedItemNames(String, String, String, String)
Gets a list of items connected to the specified item.
Public method GetConnectedItemNames(String, String, String, String, String)
Returns the list of items in category that named item is connected to. The order of the items in the list is arbitrary (i.e., not sorted).
Public method GetConnectionCount
Gets the number of connections from the specified category.
Public method GetConnectionNames(String)
Gets a list of connection names to the specified category.
Public method GetConnectionNames(String, String, String)
Gets the connection names for the specified category.
Public method GetCursor
Create a cursor.
Public method GetDatabase Obsolete.
(Not implemented) Get the active Commence database name and path as delimited string. See Name and/or Path.
Public method GetDatabaseDefinition
Queries Commence for information on the database definition.
Public method GetDatabaseSchema
Gets a serializable object containnig the Commence schema definition.
Public method GetDesktopCount
Gets the number of Desktops in the Commence database.
Public method GetDesktopNames
Get a list of desktopnames.
Public method GetDesktopNames(String)
Gets the desktop names in the Commence database.
Public method GetField
Returns a fieldvalue from the specified Commence item.
Public method GetFieldCount
Gets the number of fields in the specified category.
Public method GetFieldDefinition
Queries Commence for information on the specified field definition.
Public method GetFieldNames(String)
Gets a list of fieldnames for the specified Commence category.
Public method GetFieldNames(String, String)
Gets the fieldnames for the specified category.
Public method GetFields(String, String, ListString)
Gets values of specified field(s) from specified item.
Public method GetFields(String, String, Object, String)
Gets values of specified field(s) from specified item.
Public method GetFieldToFile
Writes a single fieldvalue to file.
Public method GetFormCount
Gets the number of Item Detail Forms for the specified category.
Public method GetFormNames(String)
Gets a list of all Item Detail Form names in specified category.
Public method GetFormNames(String, String)
Gets the Item detail Form names for the specified category
Public method GetImageFieldCount
Gets the number of image fields in specified category.
Public method GetImageFieldNames(String)
Gets a list of all field of type 'image' from the specified category.
Public method GetImageFieldNames(String, String)
Gets the image-type field names for the specified category.
Public method GetImageFieldToFile
Copies the image field identified by the named Category, Item, and Field to the specified Filename. Only bitmap (.BMP) format image fields are currently supported. Filename must be a fully qualified path including the drive letter (e.g. c:\tmp\data.bmp). If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten. It is the client’s responsibility to perform the necessary file cleanup. If the image field is blank, no file is written.
Public method GetItemCount
Gets the number of items in the specified category.
Public method GetItemNames(String)
Gets a list of all itemnames in the specified category.
Public method GetItemNames(String, String)
Gets the item names for the specified category
Public method GetLastError
Gets the last error that occurred during DDE conversation. Inspect this value if a call failed.
Public method GetLetterViewInfo
Returns information about the active view and selected letter template at the time the Tools-Send Letter or Customize-Database-Letter Template command was executed. This call is used by the Commence letter macros and has not been implemented here.
Public method GetMarkItem
"Marks" the specified item and makes it the default category and item for subsequent calls to: EditItem, DeleteItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands, and GetField, GetFieldToFile, GetFields, GetConnectedItemCount and GetConnectedItemNames REQUESTS. The category and item is marked only for the specific DDE conversation, not globally. that is, each DDE conversation can have a different marked item. Can be used to mark the (-Me-) item if one is defined. Syntax: [GetMarkItem("(-Me-)")] Note: If a Clarify Field is defined for the category, the value of the clarify field can be specified with an optional third paramter. Alternatively, the ItemName can be a clarified item name.
Public method GetMeField
Gets a fieldvalue from the item defined as (-Me-) item in Commence.
Public method GetNameField
Get the name of the namefield for the specified category.
Public method GetPhoneNumber
TAPI must be configured for GetPhoneNumber to work properly. TAPI is ancient, so this method is not implemented.
Public method GetPreference
Get preference settings.
Public method GetReverseName
Uses Commence preference information and reverses the name if appropriate.
Public method GetTriggerCount
Gets the number of DDE agent triggers defined in the database.
Public method GetTriggerNames
Get a list of Agent triggers.
Public method GetTriggerNames(String)
Gets the trigger names defined in the database.
Public method GetViewColumnNames
Gets the columnnames from a view provided a cursor can be created on them.
Public method GetViewCount
Gets the number of views in the specified category.
Public method GetViewDefinition
Get definition of a view
Public method GetViewNames(String)
Gets a list of all views for the specified category. Returns all categories if category is not specified.
Public method GetViewNames(String, String)
Gets a list of view names for the specified category.
Public method GetViewToFile
Saves the Commence View to a file in HTML format (similar to the File-Save As HTML menu command). If the file does not exist, Commence will create it; the drive and directory must exist. If the file exists, it will be overwritten.
Public method HasDuplicates
Checks if field contains duplicate values.
Public method LogPhoneCall
Launches an add tem detail window for an item in the Phone Log category (as specified in the Commence Customize-Preferences-Event Logs dialog box). One or more Category/Item pairs may be given as arguments; connections will be set between the new Phone Log item and these items. If no connection exists between the two categories, the pair is ignored and no error is given. The connection is set via all connections found between the two categories. If no Phone Log category is set, NACK error code 104 (DDE_ERROR_NOLOGCLASS) is returned. If there is no room to add an item in the Phone Log category, NACK error code 112 (DDE_ERROR_FULL) is returned.
Public method MarkActiveItem
Marks the active item for subsequent requests.
Public method MergeTemplateCreate
Creates a new template with the given parameters. If template exists, the call fails. This call returns the template filename assigned by Commence, including the full path and extension configured in Preferences-Letter dialog.
Public method MergeTemplateSave
Updates an existing template identified by the name parameter. Template must exist, else the call fails.
Public method PromoteItemToShared
Promotes a local item to shared status, provided the database is connected and the category is shared. If the item is already shared, its status is unchanged. Note that there is no way to demote an item from shared to local status. Whenever possible, use a clarified Item name.
Public method ShowDesktop
Opens the specified desktop in Commence.
Public method ShowItem
Opens an item detail window in Commence for the given Item in the given Category. If a detail is already open for the item, it will be brought to the top and given the focus.
Public method ShowView
Opens the specified view in Commence. If the view is already open, it will become the active view.
Public method UnassignConnection
Unassigns a connection between two items.
Public method ViewCategory
Defines the category to be used. This must be the first message sent to Commence for a ViewData conversation. ViewCategory may be sent at any time to reset the ViewData conversation state. ViewData conversation topic has been obsolete since Commence 3.0 (1995 or so), so it is extremely unlikely you will ever need this method.
Public method ViewConjunction
Defines the logical operations that link the filter clauses specified with the ViewFilter request. Each parameter can be either "And" or "Or"; the default value is "And". AndOr12 defines the relationship between the filter clauses 1 and 2, AndOr34 for clauses 3 and 4, and AndOr13 for (1 and 2) and (3 and 4), etc. Note the special significance of AndOr48, which signifies the relationship between the two groups of 4 filters.

The logical precedence is: (Filter1 AndOr12 Filter2) AndOr13 (Filter3 AndOr34 Filter4) AndOr4to8 [repeat 5 to 8]

Public method ViewConnectedCount
Returns the number of items in the connCategory that the Indexth item is connected to via ConnectionName.
Public method ViewConnectedField
Returns the value of Field of the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.
Public method ViewConnectedFields(Int32, String, String, Int32, ListString, String)
Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method ViewConnectedFields(Int32, String, String, Int32, Object, String)
Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method ViewConnectedItem
Returns the ConnIndexth item in connCategory that the Indexth item is connected to via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value.
Public method ViewDeleteAllItems
USE WITH EXTREME CAUTION! Deletes all items that satisfy the currently defined filter. If no filter is defined, deletes all items in the previously named category, see ViewCategory(String). Fails without warning when no delete permissions were granted on the category.
Public method ViewField
Returns the value of Field of the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount REQUEST to determine the maximum Index value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.
Public method ViewFields(Int32, ListString, String)
Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method ViewFields(Int32, Object, String)
Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method ViewFieldToFile
Saves specified field to file
Public method ViewFilter
Defines the criteria for the multiple filter to be applied against the previously named category/view (see ViewCategory/ViewView). This is by far the most complicated API method to use. Unless you are actually creating views from code, you are strongly advised to use the Filters collection of the CommenceCursor class instead.
Public method ViewImageFieldToFile
Copies the image field data in Field from the Indexth item that satisfies the currently defined filter (if any) to the specified Filename.
Public method ViewItemCount
Returns the number of items that satisfy the currently defined filter (if any). If no filter is defined, this request returns the total number of items in the category
Public method ViewItemIndex
Returns the index of the item with the indicated name field value. The item must also satisfy the currently defined filter (if any). Use a clarified itemname if possible. Note: If the NameFieldValue is left blank, the marked item will be used. Returns the index of the marked item (if any).
Public method ViewItemName
Returns the itemname for the Indexth item. Different from ViewField(Index, Name) in that a clarified item name may be returned. The ClarifyItemNames request is used to enable or disable the use of clarified item names.
Public method ViewMarkItem
Marks the Indexth item in the view and makes it the default category and item for the EditItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands.
Public method ViewReverseName
Uses Commence preference information and reverses the name if appropriate.
Public method ViewSaveView
Saves the virtual DDE view already created with the ViewCategory, ViewFilter, ViewSort, etc., as an actual view in Commence, accessible via the normal user interface. The view will be saved using the specified New View Name. If the view already exists, it will be overwritten. Use GetViewNames to determine if the view name conflicts with an existing view.
Public method ViewSort
Defines the sort criteria for the view. Field1, Field2, Field3, and Field4 define the fields to sort by. Sort1, Sort2, Sort3, and Sort4 define the sort type and should be "Ascending" or "Descending". Unused sort pairs (i.e. FieldN, SortN) may be omitted.
Public method ViewView
Uses the category and filter criteria of a Commence View that has already be defined from the Commence menu interface. The ViewView REQUEST overrides any previously received ViewCategory, ViewConjunction, ViewFilter, and ViewSort REQUESTS. If the ViewName parameter is left blank, the active view will be used.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.AddItem Method

ICommenceDatabaseAddItem Method

Adds the indicated Item to the Category. Fields other than the Name field are set to their default values. (Default values for date fields must not specify date ranges, e.g., "every day"). By default, the new item is local (i.e., non-shared) CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled. Note: If a clarify field is defined for the category (but is not a Sequence Number field), the clarify field value can be specified using the optional third parameter, Clarify Value. Alternatively, the Item parameter can be a clarified item name. If the clarify field is a Sequence Number field, then the field value is determined automatically by Commence. An error results if the AddItem REQUEST tries to set a Sequence Number field. Use GetFieldDefinition to determine the Sequence Number field value so a clarified item name can be used with subsequent EditItems.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool AddItem(
    string categoryName,
    string itemName,
    string clarifyValue
)
Function AddItem (
    categoryName As String,
    itemName As String,
    clarifyValue As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to add.
clarifyValue
Type: SystemString
Commence clarify value.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.AddSharedItem Method

ICommenceDatabaseAddSharedItem Method

Identical in function to AddItem except that it creates a shared item, provided that the database is connected and the category is shared. Otherwise a local item is created. CAUTION: If the Category has mandatory fields, those fields must be filled in with subsequent EditItem commands. Use the GetFieldDefinition request to determine which fields are mandatory. Unpredictable results may follow if mandatory fields are left unfilled.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool AddSharedItem(
    string categoryName,
    string itemName,
    string clarifyValue
)
Function AddSharedItem (
    categoryName As String,
    itemName As String,
    clarifyValue As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to add.
clarifyValue
Type: SystemString
Commence clarify value.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.AppendText Method

ICommenceDatabaseAppendText Method

Appends text to an existing text Field. Use this command to overcome the 256 character maximum string limitation of certain macro languages (such as WordBasic). Whenever possible, use a clarified item name. You are strongly advised to use a ICommenceEditRowSet for editing fields instead.

When an item was just created with AddItem(String, String, String) or AddSharedItem(String, String, String), this is the item that will be used for appending. Otherwise, unless you specifically mark an item (using GetMarkItem(String, String, String) or MarkActiveItem(String)) the first match will be used.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool AppendText(
    string categoryName,
    string itemName,
    string fieldName,
    string text
)
Function AppendText (
    categoryName As String,
    itemName As String,
    fieldName As String,
    text As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to edit.
fieldName
Type: SystemString
Commence field to edit.
text
Type: SystemString
Textvalue to append.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.AssignConnection Method

ICommenceDatabaseAssignConnection Method

Assigns a connection between two items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool AssignConnection(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory,
    string connItem
)
Function AssignConnection (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String,
    connItem As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence 'From' category.
itemName
Type: SystemString
Commence 'From' item. Use clarified names if possible.
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence 'To' category.
connItem
Type: SystemString
Commence 'To' item. Use clarified names if possible.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.CheckInFormScript Method

ICommenceDatabaseCheckInFormScript Method

Updates the detail form script with the text in the specified Filename.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool CheckInFormScript(
    string categoryName,
    string formName,
    string fileName
)
Function CheckInFormScript (
    categoryName As String,
    formName As String,
    fileName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
formName
Type: SystemString
Commence Item Detail Form name.
fileName
Type: SystemString
Fully qualified path including the drive letter (e.g. c:\tmp\script.txt).

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
Remarks
Warning: this function will return true even if the user has no Author rights on the database. This is a limitation of Commence. If you are not an Author, the script will not be checked in!
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.CheckOutFormScript Method

ICommenceDatabaseCheckOutFormScript Method

Saves the detail form script to file.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool CheckOutFormScript(
    string categoryName,
    string formName,
    string fileName
)
Function CheckOutFormScript (
    categoryName As String,
    formName As String,
    fileName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
formName
Type: SystemString
Commence Item Detail Form name.
fileName
Type: SystemString
Fully qualified path including the drive letter (e.g. c:\tmp\script.txt). If file already exists it is overwritten.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ClarifyItemNames Method

ICommenceDatabaseClarifyItemNames Method

Specifies whether Commence should return clarified item names, or leave bStatus empty to get the current status.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ClarifyItemNames(
    string bStatus = null
)
Function ClarifyItemNames (
    Optional bStatus As String = Nothing
) As String

Parameters

bStatus (Optional)
Type: SystemString
"True" to set clarified itemnames, "False" for unclarified, leave empty to request current status.

Return Value

Type: String
"OK" if successful, inspect GetLastError on failure.

If bStatus was omitted this method returns "True" if clarified, "False" if not.

See Also

Reference

ICommenceDatabase Interface
ICommenceDatabaseGetLastError


ICommenceDatabase.Close Method

ICommenceDatabaseClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.DeleteItem Method

ICommenceDatabaseDeleteItem Method

Deletes the indicated Item from the Category. This action cannot be undone. Whenever possible, use a clarified item name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool DeleteItem(
    string categoryName,
    string itemName
)
Function DeleteItem (
    categoryName As String,
    itemName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to delete.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.DeleteView Method

ICommenceDatabaseDeleteView Method

Deletes the specified view. Use with caution! This action cannot be undone.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool DeleteView(
    string viewName
)
Function DeleteView (
    viewName As String
) As Boolean

Parameters

viewName
Type: SystemString
Commence view name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.EditItem Method

ICommenceDatabaseEditItem Method

Sets the value of Field to Value for the item identified by Item in Category. Field must not specify a Calculation field. Date fields may not specify a range, (e.g., "every day"). Whenever possible, use a clarified Item name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool EditItem(
    string categoryName,
    string itemName,
    string fieldName,
    string fieldValue
)
Function EditItem (
    categoryName As String,
    itemName As String,
    fieldName As String,
    fieldValue As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to edit.
fieldName
Type: SystemString
Commence field to edit.
fieldValue
Type: SystemString
New fieldvalue. If Field is an image field, Value must specify the filename containing the image. Only .bmp files are supported.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ExportDatabaseSchema Method

ICommenceDatabaseExportDatabaseSchema Method

Exports the schema information to file. Defaults to Json.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void ExportDatabaseSchema(
    string fileName,
    MetaDataOptions options = null
)
Sub ExportDatabaseSchema (
    fileName As String,
    Optional options As MetaDataOptions = Nothing
)

Parameters

fileName
Type: SystemString
Fully qualified filename.
options (Optional)
Type: Vovin.CmcLibNet.Database.MetadataMetaDataOptions
MetaDataOptions
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.FieldValueExists Method

ICommenceDatabaseFieldValueExists Method

Checks to see if value is already present for given field.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool FieldValueExists(
    string categoryName,
    string fieldName,
    string fieldValue,
    bool caseSensitive = true
)
Function FieldValueExists (
    categoryName As String,
    fieldName As String,
    fieldValue As String,
    Optional caseSensitive As Boolean = true
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
fieldName
Type: SystemString
Commence fieldname.
fieldValue
Type: SystemString
Value to check.
caseSensitive (Optional)
Type: SystemBoolean
Compare case-sensitive. Defaults to true.

Return Value

Type: Boolean
true if value exists.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.FireTrigger Method

ICommenceDatabaseFireTrigger Method

Fires the indicated Agent Trigger.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool FireTrigger(
    string trigger,
    Object[] args
)
Function FireTrigger (
    trigger As String,
    args As Object()
) As Boolean

Parameters

trigger
Type: SystemString
Trigger string.
args
Type: SystemObject
.NET clients can pass in a string[], from VBScript, VB etc. use Array(param1, param2, ... ParamN). Up to 9 parameters can be used. See the Commence helpfile under "Receive DDE Trigger" for implementation details.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
Remarks
This is a very powerful command allowing you to make Commence perform agent actions.

Additional information from the Commence helpfile. Note that you do not have to worry about the syntax, it is taken care of internally in CmcLibNet. See examples below.

Commence can pass data from the Send DDE Action of one agent to the Receive DDE Trigger of another agent, or an agent can be triggered by code. The data can then be used by the Receive DDE agent’s actions. The arguments passed via a Receive DDE trigger are accessible using the following keyword strings: (-0-), (-1-), (-2-), (-3-), (-4-), (-5-), (-6-), (-7-), (-8-) and (-9-). These keywords (i.e. arguments) may be used just as field codes would be used to display the data in a message box or status bar action, to set values in an add or edit item action, or any other place that keyword replacement is allowed in agents. The following example illustrates how the DDE trigger arguments are mapped to keywords.

Usage:

Copy
[FireTrigger(TrigStr, Arg2, Arg3, Arg4, Arg5, Arg6, Arg7, Arg8, Arg9)]

(-0-) | Always "FireTrigger".
(-1-) | Trigger String, e.g., TrigStr
(-2-) through (-9-) | The string passed in that position, e.g. Arg2 through Arg9 respectively.

The Send DDE trigger also allows arguments 2 and 3 to be mapped to a category name and an item name respectively. Then If the "arg2 equals" check box is checked (in the DDE Trigger Definition dialog box of the Receive DDE agent), a category must be selected and Arg2 must equal that category name for that DDE trigger to fire. In addition, Arg3 must be the name of an item in the chosen category. If all these conditions are met, the trigger fires and values from that item will be available for use in the agent’s actions (using the field name keywords such as (%Name%) or using any of the arguments (-3-) through (-9-) that have been defined)

The corresponding agent with a Receive DDE trigger also allows you to define a filter for a DDE trigger using the item mapping option. If a filter is defined, not only do Arg2 and Arg3 have to match the category and an item name, but the item must also meet the filter criteria. If the item does not match the filter, the trigger will not fire.

Examples:

Execute: [FireTrigger("test", "Person", "Wilson", "908-552-0466")]

This is a generic example where all arguments are typed literally.

Execute: [FireTrigger("test",(-Category-),(%Last Name%),(%Business Phone%))]

This is an equivalent example where the agent trigger uses the Person category, so field codes can be used as arguments whenever necessary.

Examples
(C#)
Copy
string[] args = new string[] { "Company", "012-3456" };
            FireTrigger("DoSomething", args);
Examples
(VBScript)
VBScript
Copy
Dim args : args = Array("Company", "012-3456")
            FireTrigger("DoSomething", args)
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetActiveCategory Method

ICommenceDatabaseGetActiveCategory Method

Gets the category of the active item or view.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetActiveCategory()
Function GetActiveCategory As String

Return Value

Type: String
Active category or null if no active item or view could be retrieved.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetActiveItemName Method

ICommenceDatabaseGetActiveItemName Method

Gets the itemname of the active item. Use MarkActiveItem(String) to try and get a clariefied itemname.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetActiveItemName()
Function GetActiveItemName As String

Return Value

Type: String
Active itemname, null if no active item could be retieved.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetActiveViewInfo Method

ICommenceDatabaseGetActiveViewInfo Method

Returms information on the currently active view (if any).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IActiveViewInfo GetActiveViewInfo()
Function GetActiveViewInfo As IActiveViewInfo

Return Value

Type: IActiveViewInfo
ActiveViewInfo object holding information on the view, null if no view active.
Remarks
Unlike it's Commence counterpart, this method returns a IActiveViewInfo object instead of a delimited string. Returns null if no view is active.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetCallerID Method

ICommenceDatabaseGetCallerID Method

Overload List
 | Name | Description
Public method | GetCallerID(String, String) | Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Public method | GetCallerID(String, String, String) | Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetCallerID Method (String, String)

ICommenceDatabaseGetCallerID Method (String, String)

Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetCallerID(
    string categoryName,
    string phoneNumber
)
Function GetCallerID (
    categoryName As String,
    phoneNumber As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence category name.
phoneNumber
Type: SystemString
Phonenumber to search.

Return Value

Type: List String
List of matching items.
See Also

Reference

ICommenceDatabase Interface
GetCallerID Overload


ICommenceDatabase.GetCallerID Method (String, String, String)

ICommenceDatabaseGetCallerID Method (String, String, String)

Returns a list of all items in the Category having the given phone number in a phone field. If Category is blank, searches all categories in the currently active database

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetCallerID(
    string categoryName,
    string phoneNumber,
    string delim = null
)
Function GetCallerID (
    categoryName As String,
    phoneNumber As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
phoneNumber
Type: SystemString
Phonenumber to search.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String of matching items delimited by delim of CR/LF if no delim specified.
See Also

Reference

ICommenceDatabase Interface
GetCallerID Overload


ICommenceDatabase.GetCategoryCount Method

ICommenceDatabaseGetCategoryCount Method

Returns number of categories in the Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetCategoryCount()
Function GetCategoryCount As Integer

Return Value

Type: Int32
Category count, -1 on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetCategoryDefinition Method

ICommenceDatabaseGetCategoryDefinition Method

Returns information on the definition of the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICategoryDef GetCategoryDefinition(
    string categoryName
)
Function GetCategoryDefinition (
    categoryName As String
) As ICategoryDef

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: ICategoryDef
CategoryDef object exposing properties of the category.
Remarks
Unlike it's Commence counterpart, this method returns a ICategoryDef object instead of a delimited string. Returns null if category doesn't exist.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetCategoryNames Method

ICommenceDatabaseGetCategoryNames Method

Overload List
 | Name | Description
Public method | GetCategoryNames | Gets a list of categories in the current Commence database.
Public method | GetCategoryNames(String) | Gets a list of category names.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetCategoryNames Method

ICommenceDatabaseGetCategoryNames Method

Gets a list of categories in the current Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetCategoryNames()
Function GetCategoryNames As List(Of String)

Return Value

Type: List String
List of categories
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetCategoryNames Overload


ICommenceDatabase.GetCategoryNames Method (String)

ICommenceDatabaseGetCategoryNames Method (String)

Gets a list of category names.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetCategoryNames(
    string delim = null
)
Function GetCategoryNames (
    Optional delim As String = Nothing
) As String

Parameters

delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the category names separated by delim, delim defaults to CR/LF.
See Also

Reference

ICommenceDatabase Interface
GetCategoryNames Overload


ICommenceDatabase.GetClarifiedItemName Method

ICommenceDatabaseGetClarifiedItemName Method

Construct a clarified item name from the unclarified itemname, the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetClarifiedItemName(
    string itemName,
    string clarifySeparator,
    string clarifyValue
)
Function GetClarifiedItemName (
    itemName As String,
    clarifySeparator As String,
    clarifyValue As String
) As String

Parameters

itemName
Type: SystemString
Unclarified itemname.
clarifySeparator
Type: SystemString
Clarify separator.
clarifyValue
Type: SystemString
Clarify value.

Return Value

Type: String
Clarified item name.
Remarks
This method does not query Commence.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetClarifyField Method

ICommenceDatabaseGetClarifyField Method

Gets the clarifyfield for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetClarifyField(
    string categoryName
)
Function GetClarifyField (
    categoryName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: String
Clarify field name, null if no clarify field.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetClarifySeparator Method

ICommenceDatabaseGetClarifySeparator Method

Gets the clarify separator for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetClarifySeparator(
    string categoryName
)
Function GetClarifySeparator (
    categoryName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: String
Clarify separator, null if no separator.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetConnectedItemCount Method

ICommenceDatabaseGetConnectedItemCount Method

Gets the number of connected items in connected category for the specified item

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetConnectedItemCount(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory
)
Function GetConnectedItemCount (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name to count from.
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence category name of connCategory

Return Value

Type: Int32
Number of connected items, -1 on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetConnectedItemField Method

ICommenceDatabaseGetConnectedItemField Method

Returns the indirect field value(s) in connCategory that itemName of the categoryName is connected to via Connection. The order of the items in the list is arbitrary (i.e., not sorted).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetConnectedItemField(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory,
    string fieldName,
    string delim = null
)
Function GetConnectedItemField (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String,
    fieldName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
categoryName.
itemName
Type: SystemString
itemName (use clarified if possible).
connectionName
Type: SystemString
Connection name (case-sensitive).
connCategory
Type: SystemString
connCategory.
fieldName
Type: SystemString
FieldName.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String of connected item fields. Text limitations imposed by Commence:
  • Limit to 256 chars.
  • First line of multiline field.
  • Returns string "(none)" if there are no connected items.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetConnectedItemNames Method

ICommenceDatabaseGetConnectedItemNames Method

Overload List
 | Name | Description
Public method | GetConnectedItemNames(String, String, String, String) | Gets a list of items connected to the specified item.
Public method | GetConnectedItemNames(String, String, String, String, String) | Returns the list of items in category that named item is connected to. The order of the items in the list is arbitrary (i.e., not sorted).
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetConnectedItemNames Method (String, String, String, String)

ICommenceDatabaseGetConnectedItemNames Method (String, String, String, String)

Gets a list of items connected to the specified item.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetConnectedItemNames(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory
)
Function GetConnectedItemNames (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.
itemName
Type: SystemString
Itemname.
connectionName
Type: SystemString
Connection name (case-sensitive).
connCategory
Type: SystemString
Connected categoryname.

Return Value

Type: List String
List of connected items.
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetConnectedItemNames Overload
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseClarifyItemNames(String)


ICommenceDatabase.GetConnectedItemNames Method (String, String, String, String, String)

ICommenceDatabaseGetConnectedItemNames Method (String, String, String, String, String)

Returns the list of items in category that named item is connected to. The order of the items in the list is arbitrary (i.e., not sorted).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetConnectedItemNames(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory,
    string delim = null
)
Function GetConnectedItemNames (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category containing item.
itemName
Type: SystemString
Commence item name to retrieve connected names from.
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connected category.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
Connected item names, "(none)" if no connected items.
See Also

Reference

ICommenceDatabase Interface
GetConnectedItemNames Overload


ICommenceDatabase.GetConnectionCount Method

ICommenceDatabaseGetConnectionCount Method

Gets the number of connections from the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetConnectionCount(
    string categoryName
)
Function GetConnectionCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category to count connections from.

Return Value

Type: Int32
Number of connections.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetConnectionNames Method

ICommenceDatabaseGetConnectionNames Method

Overload List
 | Name | Description
Public method | GetConnectionNames(String) | Gets a list of connection names to the specified category.
Public method | GetConnectionNames(String, String, String) | Gets the connection names for the specified category.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetConnectionNames Method (String)

ICommenceDatabaseGetConnectionNames Method (String)

Gets a list of connection names to the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IEnumerable<ICommenceConnection> GetConnectionNames(
    string categoryName
)
Function GetConnectionNames (
    categoryName As String
) As IEnumerable(Of ICommenceConnection)

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: IEnumerable ICommenceConnection
List of CommenceConnection objects.
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetConnectionNames Overload


ICommenceDatabase.GetConnectionNames Method (String, String, String)

ICommenceDatabaseGetConnectionNames Method (String, String, String)

Gets the connection names for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object GetConnectionNames(
    string categoryName,
    string delim1 = null,
    string delim2 = null
)
Function GetConnectionNames (
    categoryName As String,
    Optional delim1 As String = Nothing,
    Optional delim2 As String = Nothing
) As Object

Parameters

categoryName
Type: SystemString
Commence category name.
delim1 (Optional)
Type: SystemString
First delimiter, up to 8 chars.
delim2 (Optional)
Type: SystemString
Second delimiter, up to 8 chars.

Return Value

Type: Object
Array of ICommenceConnection objects
See Also

Reference

ICommenceDatabase Interface
GetConnectionNames Overload


ICommenceDatabase.GetCursor Method

ICommenceDatabaseGetCursor Method

Create a cursor.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceCursor GetCursor(
    string category,
    CmcCursorType pCursorType = CmcCursorType.Category,
    CmcOptionFlags pOptionFlags = CmcOptionFlags.Default
)
Function GetCursor (
    category As String,
    Optional pCursorType As CmcCursorType = CmcCursorType.Category,
    Optional pOptionFlags As CmcOptionFlags = CmcOptionFlags.Default
) As ICommenceCursor

Parameters

category
Type: SystemString
Commence category name.
pCursorType (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcCursorType
Cursor type.
pOptionFlags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Cursor flags.

Return Value

Type: ICommenceCursor
ICommenceCursor.
Remarks
Note the optional parameters this allows COM clients to use just the category name to get a default cursor but also not that because of the optional paramaters, which must come at the end, the order is different from what Commence developers are used to.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetDatabase Method

ICommenceDatabaseGetDatabase Method

Note: This API is now obsolete.

(Not implemented) Get the active Commence database name and path as delimited string. See Name and/or Path.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use CmcLibNet.CommenceApp.Name and/or CmcLibNet.CommenceApp.Path")]
string GetDatabase()
<ObsoleteAttribute("Use CmcLibNet.CommenceApp.Name and/or CmcLibNet.CommenceApp.Path")>
Function GetDatabase As String

Return Value

Type: String
NotImplementedException
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
CommenceAppName
CommenceAppPath


ICommenceDatabase.GetDatabaseDefinition Method

ICommenceDatabaseGetDatabaseDefinition Method

Queries Commence for information on the database definition.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IDBDef GetDatabaseDefinition()
Function GetDatabaseDefinition As IDBDef

Return Value

Type: IDBDef
DBDef object that exposes Commence database definition properties, null on error.
Remarks
Unlike it's Commence counterpart, this method returns a IDBDef object instead of a delimited string.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetDatabaseSchema Method

ICommenceDatabaseGetDatabaseSchema Method

Gets a serializable object containnig the Commence schema definition.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IDatabaseSchema GetDatabaseSchema(
    MetaDataOptions options = null
)
Function GetDatabaseSchema (
    Optional options As MetaDataOptions = Nothing
) As IDatabaseSchema

Parameters

options (Optional)
Type: Vovin.CmcLibNet.Database.MetadataMetaDataOptions
MetaDataOptions

Return Value

Type: IDatabaseSchema
DatabaseSchema
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetDesktopCount Method

ICommenceDatabaseGetDesktopCount Method

Gets the number of Desktops in the Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetDesktopCount()
Function GetDesktopCount As Integer

Return Value

Type: Int32
Number of desktops, -1 on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetDesktopNames Method

ICommenceDatabaseGetDesktopNames Method

Overload List
 | Name | Description
Public method | GetDesktopNames | Get a list of desktopnames.
Public method | GetDesktopNames(String) | Gets the desktop names in the Commence database.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetDesktopNames Method

ICommenceDatabaseGetDesktopNames Method

Get a list of desktopnames.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetDesktopNames()
Function GetDesktopNames As List(Of String)

Return Value

Type: List String
List of desktopnames.
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetDesktopNames Overload


ICommenceDatabase.GetDesktopNames Method (String)

ICommenceDatabaseGetDesktopNames Method (String)

Gets the desktop names in the Commence database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetDesktopNames(
    string delim = null
)
Function GetDesktopNames (
    Optional delim As String = Nothing
) As String

Parameters

delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
Strings containing the desktop names delimited by delim of CR/LF if no delim supplied.
See Also

Reference

ICommenceDatabase Interface
GetDesktopNames Overload


ICommenceDatabase.GetField Method

ICommenceDatabaseGetField Method

Returns a fieldvalue from the specified Commence item.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetField(
    string categoryName,
    string itemName,
    string fieldName
)
Function GetField (
    categoryName As String,
    itemName As String,
    fieldName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
fieldName
Type: SystemString
Commence field name.

Return Value

Type: String
FieldValue, "(Active item not found)" on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetFieldCount Method

ICommenceDatabaseGetFieldCount Method

Gets the number of fields in the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetFieldCount(
    string categoryName
)
Function GetFieldCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name

Return Value

Type: Int32
Number of fields, -1 on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetFieldDefinition Method

ICommenceDatabaseGetFieldDefinition Method

Queries Commence for information on the specified field definition.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ICommenceFieldDefinition GetFieldDefinition(
    string categoryName,
    string fieldName
)
Function GetFieldDefinition (
    categoryName As String,
    fieldName As String
) As ICommenceFieldDefinition

Parameters

categoryName
Type: SystemString
Commence category name.
fieldName
Type: SystemString
Commence field name.

Return Value

Type: ICommenceFieldDefinition
FieldDef object exposing properties of the field, null on error.
Remarks
Unlike it's Commence counterpart, this method returns a ICommenceFieldDefinition object instead of a delimited string.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetFieldNames Method

ICommenceDatabaseGetFieldNames Method

Overload List
 | Name | Description
Public method | GetFieldNames(String) | Gets a list of fieldnames for the specified Commence category.
Public method | GetFieldNames(String, String) | Gets the fieldnames for the specified category.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetFieldNames Method (String)

ICommenceDatabaseGetFieldNames Method (String)

Gets a list of fieldnames for the specified Commence category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetFieldNames(
    string categoryName
)
Function GetFieldNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.

Return Value

Type: List String
List of fieldnames.
Remarks
Does not return Image field names, see GetImageFieldNames(String).
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetFieldNames Overload


ICommenceDatabase.GetFieldNames Method (String, String)

ICommenceDatabaseGetFieldNames Method (String, String)

Gets the fieldnames for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetFieldNames(
    string categoryName,
    string delim = null
)
Function GetFieldNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
string containing the field names delimited by delimiter delim, or CR/LF if delim is null.
Remarks
Does not return Image field names, see GetImageFieldNames(String).
See Also

Reference

ICommenceDatabase Interface
GetFieldNames Overload


ICommenceDatabase.GetFields Method

ICommenceDatabaseGetFields Method

Overload List
 | Name | Description
Public method | GetFields(String, String, ListString) | Gets values of specified field(s) from specified item.
Public method | GetFields(String, String, Object, String) | Gets values of specified field(s) from specified item.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetFields Method (String, String, List(String))

ICommenceDatabaseGetFields Method (String, String, ListString)

Gets values of specified field(s) from specified item.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetFields(
    string categoryName,
    string itemName,
    List<string> fieldNames
)
Function GetFields (
    categoryName As String,
    itemName As String,
    fieldNames As List(Of String)
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
fieldNames
Type: System.Collections.GenericList String
List of fields to request values from.

Return Value

Type: List String
List of fieldvalues.
See Also

Reference

ICommenceDatabase Interface
GetFields Overload


ICommenceDatabase.GetFields Method (String, String, Object[], String)

ICommenceDatabaseGetFields Method (String, String, Object, String)

Gets values of specified field(s) from specified item.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetFields(
    string categoryName,
    string itemName,
    Object[] fields,
    string delim = null
)
Function GetFields (
    categoryName As String,
    itemName As String,
    fields As Object(),
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
fields
Type: SystemObject
object array containing fieldnames. .Net consumers can simply supply a string[], from VBScript/VBA and such use Array(field1, field2,...fieldN)
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String with the fieldvalues of requested fields delimited by delim or CR/LF if delim not supplied.
Remarks
This method may prove a little problematic. It takes a list of fieldnames; because we do not know in advance what fields will be specified, you have to pass in an array as parameter, however, for this to work from COM, this array has to be of type 'object'. Note that this function is obsolete in the sense that this can be done much faster using CommenceQueryRowSet It can be useful however for getting fieldvalues of the active item. sample usage from VBA:
Copy
GetFields("categoryName", "itemName", Array(fieldname1, fieldname2,..., fieldnameN))
See Also

Reference

ICommenceDatabase Interface
GetFields Overload


ICommenceDatabase.GetFieldToFile Method

ICommenceDatabaseGetFieldToFile Method

Writes a single fieldvalue to file.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool GetFieldToFile(
    string categoryName,
    string itemName,
    string fieldName,
    string fileName
)
Function GetFieldToFile (
    categoryName As String,
    itemName As String,
    fieldName As String,
    fileName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
fieldName
Type: SystemString
Commence field name.
fileName
Type: SystemString
fully qualified output file. If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetFormCount Method

ICommenceDatabaseGetFormCount Method

Gets the number of Item Detail Forms for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetFormCount(
    string categoryName
)
Function GetFormCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: Int32
Number of Item Detail Forms, -1 on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetFormNames Method

ICommenceDatabaseGetFormNames Method

Overload List
 | Name | Description
Public method | GetFormNames(String) | Gets a list of all Item Detail Form names in specified category.
Public method | GetFormNames(String, String) | Gets the Item detail Form names for the specified category
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetFormNames Method (String)

ICommenceDatabaseGetFormNames Method (String)

Gets a list of all Item Detail Form names in specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetFormNames(
    string categoryName
)
Function GetFormNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.

Return Value

Type: List String
List of formnames.
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetFormNames Overload


ICommenceDatabase.GetFormNames Method (String, String)

ICommenceDatabaseGetFormNames Method (String, String)

Gets the Item detail Form names for the specified category

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetFormNames(
    string categoryName,
    string delim = null
)
Function GetFormNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the Item Detail Form names delimited by delim, or CR/LF if not supplied.
See Also

Reference

ICommenceDatabase Interface
GetFormNames Overload


ICommenceDatabase.GetImageFieldCount Method

ICommenceDatabaseGetImageFieldCount Method

Gets the number of image fields in specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetImageFieldCount(
    string categoryName
)
Function GetImageFieldCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: Int32
Number of image fields, -1 on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetImageFieldNames Method

ICommenceDatabaseGetImageFieldNames Method

Overload List
 | Name | Description
Public method | GetImageFieldNames(String) | Gets a list of all field of type 'image' from the specified category.
Public method | GetImageFieldNames(String, String) | Gets the image-type field names for the specified category.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetImageFieldNames Method (String)

ICommenceDatabaseGetImageFieldNames Method (String)

Gets a list of all field of type 'image' from the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetImageFieldNames(
    string categoryName
)
Function GetImageFieldNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.

Return Value

Type: List String
List of imagefield names
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetImageFieldNames Overload


ICommenceDatabase.GetImageFieldNames Method (String, String)

ICommenceDatabaseGetImageFieldNames Method (String, String)

Gets the image-type field names for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetImageFieldNames(
    string categoryName,
    string delim = null
)
Function GetImageFieldNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the image field names delimited by delim or CR/LF if not supplied.
See Also

Reference

ICommenceDatabase Interface
GetImageFieldNames Overload


ICommenceDatabase.GetImageFieldToFile Method

ICommenceDatabaseGetImageFieldToFile Method

Copies the image field identified by the named Category, Item, and Field to the specified Filename. Only bitmap (.BMP) format image fields are currently supported. Filename must be a fully qualified path including the drive letter (e.g. c:\tmp\data.bmp). If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten. It is the client’s responsibility to perform the necessary file cleanup. If the image field is blank, no file is written.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool GetImageFieldToFile(
    string categoryName,
    string itemName,
    string fieldName,
    string fileName
)
Function GetImageFieldToFile (
    categoryName As String,
    itemName As String,
    fieldName As String,
    fileName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name
itemName
Type: SystemString
Commence item name
fieldName
Type: SystemString
Commence imagefield name
fileName
Type: SystemString
fully qualified filename

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetItemCount Method

ICommenceDatabaseGetItemCount Method

Gets the number of items in the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetItemCount(
    string categoryName
)
Function GetItemCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: Int32
Number of items, -1 on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetItemNames Method

ICommenceDatabaseGetItemNames Method

Overload List
 | Name | Description
Public method | GetItemNames(String) | Gets a list of all itemnames in the specified category.
Public method | GetItemNames(String, String) | Gets the item names for the specified category
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetItemNames Method (String)

ICommenceDatabaseGetItemNames Method (String)

Gets a list of all itemnames in the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetItemNames(
    string categoryName
)
Function GetItemNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence categoryname.

Return Value

Type: List String
List of itemnames.
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetItemNames Overload
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseClarifyItemNames(String)


ICommenceDatabase.GetItemNames Method (String, String)

ICommenceDatabaseGetItemNames Method (String, String)

Gets the item names for the specified category

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetItemNames(
    string categoryName,
    string delim = null
)
Function GetItemNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the item names delimited by delim or CR/LF if not supplied.
Remarks
Use clarified Itemnames whenever you can.
See Also

Reference

ICommenceDatabase Interface
GetItemNames Overload


ICommenceDatabase.GetLastError Method

ICommenceDatabaseGetLastError Method

Gets the last error that occurred during DDE conversation. Inspect this value if a call failed.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetLastError()
Function GetLastError As String

Return Value

Type: String
NACK code. If the NACK error code is less than 100, then that number indicates the position of the parameter that was invalid. For example, if the EXECUTE command [EditItem("Person", "John Doe", "Work Phone", "(123)555-1234")] returned a NACK error code of 2, then perhaps a John Doe does not exist in the Person category.
NACK codes | Error description.
100 (0x64) | Out of memory.
101 (0x65) | Internal error.
102 (0x66) | Wrong number of parameters.
103 (0x67) | Unknown conversation topic.
104 (0x68) | No Phone Log category has been set; returned by LogPhoneCall EXECUTE command. Use Customize-Preferences-Event Logs to select a category.
105 (0x69) | No category selected; returned by ViewData REQUESTS not preceded by a ViewCategory.
106 (0x6A) | Unsupported clipboard format.
107 (0x6B) | Unsupported field type.
108 (0x6C) | Field/qualifier mismatch; returned by ViewFilter REQUEST.
109 (0x6D) | Unknown EXECUTE command.
110 (0x6E) | Parsing error. Check syntax of DDE command.
111 (0x6F) | Unknown REQUEST item or parsing error.
112 (0x70) | Cannot add new item, category full; returned by AddItem, AddSharedItem and LogPhoneCall EXECUTE commands.
113 (0x71) | File I/O error. Is the disk full?
114 (0x72) | Connection already exists; returned by the AssignConnection EXECUTE command.
115 (0x73) | No such connection exists; returned by the UnassignConnection EXECUTE commands.
116 (0x74) | The category has been invalidated.
117 (0x75) | The item has been invalidated.
118 (0x76) | An "every" date was received, or is the default value for a date field. Date ranges are not supported via DDE; returned by the AddItem or EditItem EXECUTE commands.
119 (0x77) | Non-unique item name; returned by the AddItem or EditItem EXECUTE commands.
120 (0x78) | Parameter too long; returned by the AddItem, EditItem and AppendText EXECUTE commands.
121 (0x79) | No active child window or child window is unsupported; returned by the GetActiveViewInfo and GetLetterViewInfo REQUESTS.
122 (0x80) | Agents are currently disabled. Returned by FireTrigger.
123 (0x81) | No item has been marked. Use ViewMarkItem or AddItem to mark an item.
124 (0x82) | Incompatible image type. Returned by GetImageFieldToFile or ViewImageFieldToFile.
125 (0x83) | Permission denied. Workgroup client does not have correct permission level.
126 (0x84) | No (-Me-) item has been defined. Use Customize-Preferences-Personal Info.
127 (0x85) | TAPI error encountered.
128 (0x86) | An agent exists but it is currently inactive. Returned by FireTrigger.
201 (0xC9) | Filter 1 has been invalidated; this may occur if a connCategory item is deleted/modified.
202 (0xCA) | Filter 2 has been invalidated.
203 (0xCB) | Filter 3 has been invalidated.
204 (0xCC) | Filter 4 has been invalidated.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetLetterViewInfo Method

ICommenceDatabaseGetLetterViewInfo Method

Returns information about the active view and selected letter template at the time the Tools-Send Letter or Customize-Database-Letter Template command was executed. This call is used by the Commence letter macros and has not been implemented here.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetLetterViewInfo(
    string delim = null
)
Function GetLetterViewInfo (
    Optional delim As String = Nothing
) As String

Parameters

delim (Optional)
Type: SystemString
Delimiter.

Return Value

Type: String
NotImplementedException.
Remarks
This method is not implemented.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetMarkItem Method

ICommenceDatabaseGetMarkItem Method

"Marks" the specified item and makes it the default category and item for subsequent calls to: EditItem, DeleteItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands, and GetField, GetFieldToFile, GetFields, GetConnectedItemCount and GetConnectedItemNames REQUESTS. The category and item is marked only for the specific DDE conversation, not globally. that is, each DDE conversation can have a different marked item. Can be used to mark the (-Me-) item if one is defined. Syntax: [GetMarkItem("(-Me-)")] Note: If a Clarify Field is defined for the category, the value of the clarify field can be specified with an optional third paramter. Alternatively, the ItemName can be a clarified item name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool GetMarkItem(
    string categoryNameOrKeyword,
    string itemName,
    string clarifyValue
)
Function GetMarkItem (
    categoryNameOrKeyword As String,
    itemName As String,
    clarifyValue As String
) As Boolean

Parameters

categoryNameOrKeyword
Type: SystemString
Commence category name
itemName
Type: SystemString
Commence item name
clarifyValue
Type: SystemString
Commence clarify value

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetMeField Method

ICommenceDatabaseGetMeField Method

Gets a fieldvalue from the item defined as (-Me-) item in Commence.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetMeField(
    string fieldName
)
Function GetMeField (
    fieldName As String
) As String

Parameters

fieldName
Type: SystemString
Commence field name.

Return Value

Type: String
FieldValue, "(Field not found)" if field doesn't exist, "(ME item not found)" if no (-Me-) item is set. Or NACK 126?
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetNameField Method

ICommenceDatabaseGetNameField Method

Get the name of the namefield for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetNameField(
    string categoryName
)
Function GetNameField (
    categoryName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: String
Fieldname of the Name field, null on error. (Does the category exist?)
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetPhoneNumber Method

ICommenceDatabaseGetPhoneNumber Method

TAPI must be configured for GetPhoneNumber to work properly. TAPI is ancient, so this method is not implemented.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetPhoneNumber(
    string phoneNumber,
    string delim = null
)
Function GetPhoneNumber (
    phoneNumber As String,
    Optional delim As String = Nothing
) As String

Parameters

phoneNumber
Type: SystemString
phone number.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
NotImplementedException
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetPreference Method

ICommenceDatabaseGetPreference Method

Get preference settings.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetPreference(
    string preferenceSetting
)
Function GetPreference (
    preferenceSetting As String
) As String

Parameters

preferenceSetting
Type: SystemString
Setting to retrieve. Valid settings are "Me", "MeCategory", "LetterLogDir", "ExternalDir"

Return Value

Type: String
Commence Preferences setting.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetReverseName Method

ICommenceDatabaseGetReverseName Method

Uses Commence preference information and reverses the name if appropriate.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetReverseName(
    string itemName,
    int prefFlag
)
Function GetReverseName (
    itemName As String,
    prefFlag As Integer
) As String

Parameters

itemName
Type: SystemString
Commence item name.
prefFlag
Type: SystemInt32
If the PrefFlag parameter is 1, then the Customize / Preferences / Other / Name Field setting is used to determine if names should be reversed. If the PrefFlag parameter is left blank or is set to 0, then the command uses the Reverse Name checkbox value of the latest invocation of Tools-Send Letter and reverses the name if appropriate.

Return Value

Type: String
Reverse name, if applicable.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetTriggerCount Method

ICommenceDatabaseGetTriggerCount Method

Gets the number of DDE agent triggers defined in the database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetTriggerCount()
Function GetTriggerCount As Integer

Return Value

Type: Int32
Number of items, -1 on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetTriggerNames Method

ICommenceDatabaseGetTriggerNames Method

Overload List
 | Name | Description
Public method | GetTriggerNames | Get a list of Agent triggers.
Public method | GetTriggerNames(String) | Gets the trigger names defined in the database.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetTriggerNames Method

ICommenceDatabaseGetTriggerNames Method

Get a list of Agent triggers.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetTriggerNames()
Function GetTriggerNames As List(Of String)

Return Value

Type: List String
List of agent triggers.
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetTriggerNames Overload


ICommenceDatabase.GetTriggerNames Method (String)

ICommenceDatabaseGetTriggerNames Method (String)

Gets the trigger names defined in the database.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetTriggerNames(
    string delim = null
)
Function GetTriggerNames (
    Optional delim As String = Nothing
) As String

Parameters

delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the trigger names delimited by delim or CR/LF if not supplied.
See Also

Reference

ICommenceDatabase Interface
GetTriggerNames Overload


ICommenceDatabase.GetViewColumnNames Method

ICommenceDatabaseGetViewColumnNames Method

Gets the columnnames from a view provided a cursor can be created on them.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IEnumerable<string> GetViewColumnNames(
    string viewName,
    CmcOptionFlags flags = CmcOptionFlags.Fieldname
)
Function GetViewColumnNames (
    viewName As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Fieldname
) As IEnumerable(Of String)

Parameters

viewName
Type: SystemString
Commence view name (case-sensitive).
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags

Return Value

Type: IEnumerable String
List of fieldnames or columnlabels for view.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetViewCount Method

ICommenceDatabaseGetViewCount Method

Gets the number of views in the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetViewCount(
    string categoryName
)
Function GetViewCount (
    categoryName As String
) As Integer

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: Int32
Number of views, -1 on error.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetViewDefinition Method

ICommenceDatabaseGetViewDefinition Method

Get definition of a view

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IViewDef GetViewDefinition(
    string viewName
)
Function GetViewDefinition (
    viewName As String
) As IViewDef

Parameters

viewName
Type: SystemString
Commence view name, case-sensitive.

Return Value

Type: IViewDef
ViewDef object that exposes properties of the view, null on error.
Exceptions
Exception | Condition
CommenceCOMException | View not found.
Remarks
Unlike it's (undocumented) Commence counterpart, this method returns a IViewDef object instead of a delimited string. Returns null on error. You cannot use this method on Multiviews.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetViewNames Method

ICommenceDatabaseGetViewNames Method

Overload List
 | Name | Description
Public method | GetViewNames(String) | Gets a list of all views for the specified category. Returns all categories if category is not specified.
Public method | GetViewNames(String, String) | Gets a list of view names for the specified category.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.GetViewNames Method (String)

ICommenceDatabaseGetViewNames Method (String)

Gets a list of all views for the specified category. Returns all categories if category is not specified.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<string> GetViewNames(
    string categoryName
)
Function GetViewNames (
    categoryName As String
) As List(Of String)

Parameters

categoryName
Type: SystemString
Commence category name. Set to String.Empty (or it's equivalent for your language) to get all views in database.

Return Value

Type: List String
List of viewnames.
Remarks
This method is only available to .Net consumers.
See Also

Reference

ICommenceDatabase Interface
GetViewNames Overload


ICommenceDatabase.GetViewNames Method (String, String)

ICommenceDatabaseGetViewNames Method (String, String)

Gets a list of view names for the specified category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetViewNames(
    string categoryName,
    string delim = null
)
Function GetViewNames (
    categoryName As String,
    Optional delim As String = Nothing
) As String

Parameters

categoryName
Type: SystemString
Commence category name.
delim (Optional)
Type: SystemString
Delimiter, up to 8 chars.

Return Value

Type: String
String containing the view names delimited by delim or CR/LF if not supplied.
See Also

Reference

ICommenceDatabase Interface
GetViewNames Overload


ICommenceDatabase.GetViewToFile Method

ICommenceDatabaseGetViewToFile Method

Saves the Commence View to a file in HTML format (similar to the File-Save As HTML menu command). If the file does not exist, Commence will create it; the drive and directory must exist. If the file exists, it will be overwritten.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool GetViewToFile(
    string viewName,
    string fileName,
    CmcLinkMode linkMode = CmcLinkMode.None,
    string param1 = null,
    string param2 = null
)
Function GetViewToFile (
    viewName As String,
    fileName As String,
    Optional linkMode As CmcLinkMode = CmcLinkMode.None,
    Optional param1 As String = Nothing,
    Optional param2 As String = Nothing
) As Boolean

Parameters

viewName
Type: SystemString
Commence view name (case-sensitive)
fileName
Type: SystemString
(fully qualified) filename
linkMode (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcLinkMode
LINKMODE values0No view linking (default).1View linking on selected item; Param1 = category name; Param2 = Item name [clarify issues?]2View linking on selected date; Param1 = date string (including AI dates); Param2 = unused3View linking on selected date range; Param1 = start date string (including AI dates); Param2 = end date string (including AI dates)
param1 (Optional)
Type: SystemString
Used with view linking to identify the "active item/date/date range" when the view contains a "view linked" filter.
param2 (Optional)
Type: SystemString
Used with view linking to identify the "active item/date/date range" when the view contains a "view linked" filter.

Return Value

Type: Boolean
true on success. Use GetLastError on failure
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.HasDuplicates Method

ICommenceDatabaseHasDuplicates Method

Checks if field contains duplicate values.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool HasDuplicates(
    string categoryName,
    string fieldName,
    bool caseSensitive = true
)
Function HasDuplicates (
    categoryName As String,
    fieldName As String,
    Optional caseSensitive As Boolean = true
) As Boolean

Parameters

categoryName
Type: SystemString
Categoryname.
fieldName
Type: SystemString
Fieldname.
caseSensitive (Optional)
Type: SystemBoolean
Perform case-sensitive check, default is true.

Return Value

Type: Boolean
true if duplicates are found.
Remarks
Commence allows for filtering on duplicate Name field values only, this method allows for checking other fieldtypes as well.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.LogPhoneCall Method

ICommenceDatabaseLogPhoneCall Method

Launches an add tem detail window for an item in the Phone Log category (as specified in the Commence Customize-Preferences-Event Logs dialog box). One or more Category/Item pairs may be given as arguments; connections will be set between the new Phone Log item and these items. If no connection exists between the two categories, the pair is ignored and no error is given. The connection is set via all connections found between the two categories. If no Phone Log category is set, NACK error code 104 (DDE_ERROR_NOLOGCLASS) is returned. If there is no room to add an item in the Phone Log category, NACK error code 112 (DDE_ERROR_FULL) is returned.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool LogPhoneCall(
    Object[] args
)
Function LogPhoneCall (
    args As Object()
) As Boolean

Parameters

args
Type: SystemObject
Category1, Item1, ..., Category n, Item n

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
Remarks
Note: if Commence prompts for an Item Detail Form to use, this will halt the call (and subsequent code) until a form was chosen or the form selection window was cancelled.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.MarkActiveItem Method

ICommenceDatabaseMarkActiveItem Method

Marks the active item for subsequent requests.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string MarkActiveItem(
    string delim = null
)
Function MarkActiveItem (
    Optional delim As String = Nothing
) As String

Parameters

delim (Optional)
Type: SystemString
Delimiter, up to 8 characters.

Return Value

Type: String
String with categoryname and item name, delimited by delim or CR/LF if not supplied, null if no item is active.
Remarks
Commence documentation does not specify a return value or delimiter for this request, but it does have a return value and can take a delimiter. Inspecting the return value can be useful for checking if the request was successful.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.MergeTemplateCreate Method

ICommenceDatabaseMergeTemplateCreate Method

Creates a new template with the given parameters. If template exists, the call fails. This call returns the template filename assigned by Commence, including the full path and extension configured in Preferences-Letter dialog.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string MergeTemplateCreate(
    string templateName,
    string categoryName,
    bool shared
)
Function MergeTemplateCreate (
    templateName As String,
    categoryName As String,
    shared As Boolean
) As String

Parameters

templateName
Type: SystemString
Name for new template.
categoryName
Type: SystemString
Commence category name.
shared
Type: SystemBoolean
true for shared template, ignored when database is stand-alone, fails if user has no author rights.

Return Value

Type: String
Template filename assigned by Commence, including the full path and extension.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.MergeTemplateSave Method

ICommenceDatabaseMergeTemplateSave Method

Updates an existing template identified by the name parameter. Template must exist, else the call fails.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string MergeTemplateSave(
    string templateName,
    bool shared
)
Function MergeTemplateSave (
    templateName As String,
    shared As Boolean
) As String

Parameters

templateName
Type: SystemString
Commence template name.
shared
Type: SystemBoolean
true for shared, ignored for stand-alone, fails when user is non-author.

Return Value

Type: String
Template filename assigned by Commence, including the full path and extension.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.PromoteItemToShared Method

ICommenceDatabasePromoteItemToShared Method

Promotes a local item to shared status, provided the database is connected and the category is shared. If the item is already shared, its status is unchanged. Note that there is no way to demote an item from shared to local status. Whenever possible, use a clarified Item name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool PromoteItemToShared(
    string categoryName,
    string itemName
)
Function PromoteItemToShared (
    categoryName As String,
    itemName As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ShowDesktop Method

ICommenceDatabaseShowDesktop Method

Opens the specified desktop in Commence.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ShowDesktop(
    string desktopName
)
Function ShowDesktop (
    desktopName As String
) As Boolean

Parameters

desktopName
Type: SystemString
Commence desktop name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ShowItem Method

ICommenceDatabaseShowItem Method

Opens an item detail window in Commence for the given Item in the given Category. If a detail is already open for the item, it will be brought to the top and given the focus.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ShowItem(
    string categoryName,
    string itemName,
    string formName = null
)
Function ShowItem (
    categoryName As String,
    itemName As String,
    Optional formName As String = Nothing
) As Boolean

Parameters

categoryName
Type: SystemString
Commence category name.
itemName
Type: SystemString
Commence item name.
formName (Optional)
Type: SystemString
Commence detail form name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ShowView Method

ICommenceDatabaseShowView Method

Opens the specified view in Commence. If the view is already open, it will become the active view.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ShowView(
    string viewName,
    bool newCopy
)
Function ShowView (
    viewName As String,
    newCopy As Boolean
) As Boolean

Parameters

viewName
Type: SystemString
Commence view name.
newCopy
Type: SystemBoolean
Set to true to force a new copy of the view to be opened.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.UnassignConnection Method

ICommenceDatabaseUnassignConnection Method

Unassigns a connection between two items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool UnassignConnection(
    string categoryName,
    string itemName,
    string connectionName,
    string connCategory,
    string connItem
)
Function UnassignConnection (
    categoryName As String,
    itemName As String,
    connectionName As String,
    connCategory As String,
    connItem As String
) As Boolean

Parameters

categoryName
Type: SystemString
Commence 'From' category.
itemName
Type: SystemString
Commence 'From' item. Use clarified names if possible.
connectionName
Type: SystemString
Commence connection name (case-sensitive)
connCategory
Type: SystemString
Commence 'To' category
connItem
Type: SystemString
Commence 'To' item. Use clarified names if possible.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewCategory Method

ICommenceDatabaseViewCategory Method

Defines the category to be used. This must be the first message sent to Commence for a ViewData conversation. ViewCategory may be sent at any time to reset the ViewData conversation state. ViewData conversation topic has been obsolete since Commence 3.0 (1995 or so), so it is extremely unlikely you will ever need this method.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ViewCategory(
    string categoryName
)
Function ViewCategory (
    categoryName As String
) As String

Parameters

categoryName
Type: SystemString
Commence category name.

Return Value

Type: String
"OK" on success, NACK error code on failure, GetLastError.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewConjunction Method

ICommenceDatabaseViewConjunction Method

Defines the logical operations that link the filter clauses specified with the ViewFilter request. Each parameter can be either "And" or "Or"; the default value is "And". AndOr12 defines the relationship between the filter clauses 1 and 2, AndOr34 for clauses 3 and 4, and AndOr13 for (1 and 2) and (3 and 4), etc. Note the special significance of AndOr48, which signifies the relationship between the two groups of 4 filters.

The logical precedence is: (Filter1 AndOr12 Filter2) AndOr13 (Filter3 AndOr34 Filter4) AndOr4to8 [repeat 5 to 8]

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ViewConjunction(
    string AndOr12,
    string AndOr13,
    string AndOr34,
    string AndOr48,
    string AndOr56,
    string AndOr57,
    string AndOr78
)
Function ViewConjunction (
    AndOr12 As String,
    AndOr13 As String,
    AndOr34 As String,
    AndOr48 As String,
    AndOr56 As String,
    AndOr57 As String,
    AndOr78 As String
) As String

Parameters

AndOr12
Type: SystemString
string "And" or "Or".
AndOr13
Type: SystemString
string "And" or "Or".
AndOr34
Type: SystemString
string "And" or "Or".
AndOr48
Type: SystemString
string "And" or "Or".
AndOr56
Type: SystemString
string "And" or "Or".
AndOr57
Type: SystemString
string "And" or "Or".
AndOr78
Type: SystemString
string "And" or "Or".

Return Value

Type: String
"OK" on success, NACK error code on failure, GetLastError
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewConnectedCount Method

ICommenceDatabaseViewConnectedCount Method

Returns the number of items in the connCategory that the Indexth item is connected to via ConnectionName.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ViewConnectedCount(
    int index,
    string connectionName,
    string connCategory
)
Function ViewConnectedCount (
    index As Integer,
    connectionName As String,
    connCategory As String
) As Integer

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connected category.

Return Value

Type: Int32
Connected item count, -1 on error.
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetConnectedItemCount(String, String, String, String)


ICommenceDatabase.ViewConnectedField Method

ICommenceDatabaseViewConnectedField Method

Returns the value of Field of the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ViewConnectedField(
    int index,
    string connectionName,
    string connCategory,
    int connIndex,
    string fieldName
)
Function ViewConnectedField (
    index As Integer,
    connectionName As String,
    connCategory As String,
    connIndex As Integer,
    fieldName As String
) As String

Parameters

index
Type: SystemInt32
Index of item to query.
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connected category.
connIndex
Type: SystemInt32
Index of connected item.
fieldName
Type: SystemString
Commence fieldname to return from connCategory. Field cannot be of the field type Image.

Return Value

Type: String
Fieldvalue.
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetConnectedItemField(String, String, String, String, String, String)


ICommenceDatabase.ViewConnectedFields Method

ICommenceDatabaseViewConnectedFields Method

Overload List
 | Name | Description
Public method | ViewConnectedFields(Int32, String, String, Int32, ListString, String) | Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Public method | ViewConnectedFields(Int32, String, String, Int32, Object, String) | Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewConnectedFields Method (Int32, String, String, Int32, List(String), String)

ICommenceDatabaseViewConnectedFields Method (Int32, String, String, Int32, ListString, String)

Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string[] ViewConnectedFields(
    int index,
    string connectionName,
    string connCategory,
    int connIndex,
    List<string> fields,
    string delim = null
)
Function ViewConnectedFields (
    index As Integer,
    connectionName As String,
    connCategory As String,
    connIndex As Integer,
    fields As List(Of String),
    Optional delim As String = Nothing
) As String()

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connCategory name.
connIndex
Type: SystemInt32
Index of connected row.
fields
Type: System.Collections.GenericList String
List of fieldnames.
delim (Optional)
Type: SystemString
Delimiter, up to max 8 chars.

Return Value

Type: String
String array of fieldvalues for the requested fields.
See Also

Reference

ICommenceDatabase Interface
ViewConnectedFields Overload


ICommenceDatabase.ViewConnectedFields Method (Int32, String, String, Int32, Object[], String)

ICommenceDatabaseViewConnectedFields Method (Int32, String, String, Int32, Object, String)

Returns multiple field values (Field_1 through Field_n) in the ConnIndexth item in the connCategory that is connected to the Indexth item via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Field cannot be of the fieldtype Image.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ViewConnectedFields(
    int index,
    string connectionName,
    string connCategory,
    int connIndex,
    Object[] fields,
    string delim = null
)
Function ViewConnectedFields (
    index As Integer,
    connectionName As String,
    connCategory As String,
    connIndex As Integer,
    fields As Object(),
    Optional delim As String = Nothing
) As String

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connCategory name.
connIndex
Type: SystemInt32
Index of connected row.
fields
Type: SystemObject
Object array containg fieldnames.
delim (Optional)
Type: SystemString
Delimiter, up to max 8 chars.

Return Value

Type: String
String array of fieldvalues for the requested fields.
See Also

Reference

ICommenceDatabase Interface
ViewConnectedFields Overload


ICommenceDatabase.ViewConnectedItem Method

ICommenceDatabaseViewConnectedItem Method

Returns the ConnIndexth item in connCategory that the Indexth item is connected to via ConnectionName. Use the ViewConnectedCount REQUEST to determine the maximum ConnIndex value.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ViewConnectedItem(
    int index,
    string connectionName,
    string connCategory,
    int connIndex
)
Function ViewConnectedItem (
    index As Integer,
    connectionName As String,
    connCategory As String,
    connIndex As Integer
) As String

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
connectionName
Type: SystemString
Commence connection name (case-sensitive).
connCategory
Type: SystemString
Commence connCategory name.
connIndex
Type: SystemInt32
Index of connected row.

Return Value

Type: String
ConnIndexth item in connCategory that the Indexth item is connected to via ConnectionName.
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetConnectedItemNames(String, String, String, String, String)


ICommenceDatabase.ViewDeleteAllItems Method

ICommenceDatabaseViewDeleteAllItems Method

USE WITH EXTREME CAUTION! Deletes all items that satisfy the currently defined filter. If no filter is defined, deletes all items in the previously named category, see ViewCategory(String). Fails without warning when no delete permissions were granted on the category.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void ViewDeleteAllItems()
Sub ViewDeleteAllItems
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewField Method

ICommenceDatabaseViewField Method

Returns the value of Field of the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount REQUEST to determine the maximum Index value. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ViewField(
    int index,
    string fieldName
)
Function ViewField (
    index As Integer,
    fieldName As String
) As String

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
fieldName
Type: SystemString
Commence field name.

Return Value

Type: String
FieldValue.
Remarks
If the Name field is requested, the returned value is NOT clarified. Use ViewItemNameand ClarifyItemNames) to retrieve the clarified item name.
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetField(String, String, String)


ICommenceDatabase.ViewFields Method

ICommenceDatabaseViewFields Method

Overload List
 | Name | Description
Public method | ViewFields(Int32, ListString, String) | Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Public method | ViewFields(Int32, Object, String) | Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.
Top
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewFields Method (Int32, List(String), String)

ICommenceDatabaseViewFields Method (Int32, ListString, String)

Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string[] ViewFields(
    int index,
    List<string> fields,
    string delim = null
)
Function ViewFields (
    index As Integer,
    fields As List(Of String),
    Optional delim As String = Nothing
) As String()

Parameters

index
Type: SystemInt32
Indexth item (1-based) that satisfies the currently defined filter (if any).
fields
Type: System.Collections.GenericList String
List of fields to retrieve.
delim (Optional)
Type: SystemString
Delimiter, up to max 8 chars.

Return Value

Type: String
String array of string representing the fieldvalues.
Remarks
Using a ICommenceQueryRowSet is usually faster and easier. This method is only available to .NET applications.
See Also

Reference

ICommenceDatabase Interface
ViewFields Overload
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetFields(String, String, Object, String)


ICommenceDatabase.ViewFields Method (Int32, Object[], String)

ICommenceDatabaseViewFields Method (Int32, Object, String)

Returns multiple field values (n) for the Indexth item that satisfies the currently defined filter (if any). Use the ViewItemCount request to determine that maximum Index value. Use the GetFieldNames request to determine valid field names. The string "(deleted)" will be returned if the requested item is deleted after the ViewData snapshot is taken. Image type fields are not allowed in the Field_ parameters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ViewFields(
    int index,
    Object[] fields,
    string delim = null
)
Function ViewFields (
    index As Integer,
    fields As Object(),
    Optional delim As String = Nothing
) As String

Parameters

index
Type: SystemInt32
Indexth item (1-based) that satisfies the currently defined filter (if any).
fields
Type: SystemObject
Object array of fields to retrieve.
delim (Optional)
Type: SystemString
Delimiter, up to max 8 chars.

Return Value

Type: String
String array of string representing the fieldvalues.
Remarks
Using a ICommenceQueryRowSet is usually faster and easier.
See Also

Reference

ICommenceDatabase Interface
ViewFields Overload
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetFields(String, String, Object, String)


ICommenceDatabase.ViewFieldToFile Method

ICommenceDatabaseViewFieldToFile Method

Saves specified field to file

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ViewFieldToFile(
    int index,
    string fieldName,
    string fileName
)
Function ViewFieldToFile (
    index As Integer,
    fieldName As String,
    fileName As String
) As Boolean

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
fieldName
Type: SystemString
Commence fieldName.
fileName
Type: SystemString
(fully qualified) filename. Existing files will be overwritten

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetFieldToFile(String, String, String, String)


ICommenceDatabase.ViewFilter Method

ICommenceDatabaseViewFilter Method

Defines the criteria for the multiple filter to be applied against the previously named category/view (see ViewCategory/ViewView). This is by far the most complicated API method to use. Unless you are actually creating views from code, you are strongly advised to use the Filters collection of the CommenceCursor class instead.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ViewFilter(
    int clauseNumber,
    string filterType,
    bool notFlag,
    Object args
)
Function ViewFilter (
    clauseNumber As Integer,
    filterType As String,
    notFlag As Boolean,
    args As Object
) As Boolean

Parameters

clauseNumber
Type: SystemInt32
ClauseNumber defines which filter clause is being defined, where ClauseNumber is between 1 and 8.
filterType
Type: SystemString
FilterType sets the type of the filter to apply. Valid filterTypes are F, CTCF, CTI and CTCTI.
notFlag
Type: SystemBoolean
NotFlag determines if a logical Not is applied against the entire clause.
args
Type: SystemObject
String array of filtertype parameters. See Commence DDE documentation

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewImageFieldToFile Method

ICommenceDatabaseViewImageFieldToFile Method

Copies the image field data in Field from the Indexth item that satisfies the currently defined filter (if any) to the specified Filename.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ViewImageFieldToFile(
    int index,
    string fieldName,
    string fileName
)
Function ViewImageFieldToFile (
    index As Integer,
    fieldName As String,
    fileName As String
) As Boolean

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).
fieldName
Type: SystemString
Commence field name.
fileName
Type: SystemString
Fully qualified path including the drive letter (e.g. c:\tmp\data.bmp). If the file does not exist, Commence will create it; the drive and directory, however, must already exist. If the file exists, it will be overwritten. It is the client’s responsibility to perform the necessary file cleanup.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetImageFieldToFile(String, String, String, String)


ICommenceDatabase.ViewItemCount Method

ICommenceDatabaseViewItemCount Method

Returns the number of items that satisfy the currently defined filter (if any). If no filter is defined, this request returns the total number of items in the category

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ViewItemCount()
Function ViewItemCount As Integer

Return Value

Type: Int32
Item count.
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetItemCount(String)


ICommenceDatabase.ViewItemIndex Method

ICommenceDatabaseViewItemIndex Method

Returns the index of the item with the indicated name field value. The item must also satisfy the currently defined filter (if any). Use a clarified itemname if possible. Note: If the NameFieldValue is left blank, the marked item will be used. Returns the index of the marked item (if any).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ViewItemIndex(
    string nameFieldValue
)
Function ViewItemIndex (
    nameFieldValue As String
) As Integer

Parameters

nameFieldValue
Type: SystemString
Commence Name field value. Note: it must be the fieldvalue, NOT the clarified itemname.

Return Value

Type: Int32
Index (1-based).
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewItemName Method

ICommenceDatabaseViewItemName Method

Returns the itemname for the Indexth item. Different from ViewField(Index, Name) in that a clarified item name may be returned. The ClarifyItemNames request is used to enable or disable the use of clarified item names.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ViewItemName(
    int index
)
Function ViewItemName (
    index As Integer
) As String

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).

Return Value

Type: String
Item name.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewMarkItem Method

ICommenceDatabaseViewMarkItem Method

Marks the Indexth item in the view and makes it the default category and item for the EditItem, AppendText, AssignConnection, UnassignConnection, PromoteItemToShared and ShowItem EXECUTE commands.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ViewMarkItem(
    int index
)
Function ViewMarkItem (
    index As Integer
) As Boolean

Parameters

index
Type: SystemInt32
Index of Nth item (1-based).

Return Value

Type: Boolean
True on success, inspect GetLastError on failure
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetMarkItem(String, String, String)


ICommenceDatabase.ViewReverseName Method

ICommenceDatabaseViewReverseName Method

Uses Commence preference information and reverses the name if appropriate.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ViewReverseName(
    string itemName,
    int prefFlag
)
Function ViewReverseName (
    itemName As String,
    prefFlag As Integer
) As String

Parameters

itemName
Type: SystemString
Commence item name.
prefFlag
Type: SystemInt32
If the optional PrefFlag parameter is 1, then the Customize-Preferences-Other-Name Field setting is used to determine if names should be reversed. If the PrefFlag parameter is left blank or is set to 0, then the command uses the Reverse Name checkbox value of the latest invocation of Tools-Send Letter and reverses the name if appropriate.

Return Value

Type: String
Reverse name, if applicable.
Remarks
This method is identical to GetReverseName.
See Also

Reference

ICommenceDatabase Interface
Vovin.CmcLibNet.Database Namespace
ICommenceDatabaseGetReverseName(String, Int32)


ICommenceDatabase.ViewSaveView Method

ICommenceDatabaseViewSaveView Method

Saves the virtual DDE view already created with the ViewCategory, ViewFilter, ViewSort, etc., as an actual view in Commence, accessible via the normal user interface. The view will be saved using the specified New View Name. If the view already exists, it will be overwritten. Use GetViewNames to determine if the view name conflicts with an existing view.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ViewSaveView(
    string newViewName,
    bool shared
)
Function ViewSaveView (
    newViewName As String,
    shared As Boolean
) As Boolean

Parameters

newViewName
Type: SystemString
new View Name to save.
shared
Type: SystemBoolean
Make view Shared. Ignored on stand-alone clients.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewSort Method

ICommenceDatabaseViewSort Method

Defines the sort criteria for the view. Field1, Field2, Field3, and Field4 define the fields to sort by. Sort1, Sort2, Sort3, and Sort4 define the sort type and should be "Ascending" or "Descending". Unused sort pairs (i.e. FieldN, SortN) may be omitted.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ViewSort(
    string fieldName1,
    string sortOrder1,
    string fieldName2,
    string sortOrder2,
    string fieldName3,
    string sortOrder3,
    string fieldName4,
    string sortOrder4
)
Function ViewSort (
    fieldName1 As String,
    sortOrder1 As String,
    fieldName2 As String,
    sortOrder2 As String,
    fieldName3 As String,
    sortOrder3 As String,
    fieldName4 As String,
    sortOrder4 As String
) As Boolean

Parameters

fieldName1
Type: SystemString
Commence sort field name1
sortOrder1
Type: SystemString
Order, should be "Ascending" or "Descending".
fieldName2
Type: SystemString
Commence sort field name2
sortOrder2
Type: SystemString
Order, should be "Ascending" or "Descending".
fieldName3
Type: SystemString
Commence sort field name3
sortOrder3
Type: SystemString
Order, should be "Ascending" or "Descending".
fieldName4
Type: SystemString
Commence sort field name4
sortOrder4
Type: SystemString
Order, should be "Ascending" or "Descending".

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDatabase.ViewView Method

ICommenceDatabaseViewView Method

Uses the category and filter criteria of a Commence View that has already be defined from the Commence menu interface. The ViewView REQUEST overrides any previously received ViewCategory, ViewConjunction, ViewFilter, and ViewSort REQUESTS. If the ViewName parameter is left blank, the active view will be used.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ViewView(
    string viewName
)
Function ViewView (
    viewName As String
) As Boolean

Parameters

viewName
Type: SystemString
Commence view name.

Return Value

Type: Boolean
true on success, inspect GetLastError on failure.
See Also

Reference

ICommenceDatabase Interface


ICommenceDeleteRowSet Interface

Interface for CommenceDeleteRowSet

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceDeleteRowSet : IBaseRowSet,
    IDisposable
Public Interface ICommenceDeleteRowSet
    Inherits IBaseRowSet, IDisposable

The ICommenceDeleteRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Commit | Commit changes to disk.
Public method | DeleteRow | Mark a row for deletion.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Top
See Also

Reference


ICommenceDeleteRowSet Properties

The ICommenceDeleteRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.ColumnCount Property

ICommenceDeleteRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ColumnCount { get; }
ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetColumnCount
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.RowCount Property

ICommenceDeleteRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int RowCount { get; }
ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetRowCount
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet Methods

The ICommenceDeleteRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Commit | Commit changes to disk.
Public method | DeleteRow | Mark a row for deletion.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Top
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.Close Method

ICommenceDeleteRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close

Implements

IBaseRowSetClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.Commit Method

ICommenceDeleteRowSetCommit Method

Commit changes to disk.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int Commit(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function Commit (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.DeleteRow Method

ICommenceDeleteRowSetDeleteRow Method

Mark a row for deletion.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int DeleteRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function DeleteRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.GetColumnIndex Method

ICommenceDeleteRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.

Implements

IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.GetColumnLabel Method

ICommenceDeleteRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.

Implements

IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.GetRow Method

ICommenceDeleteRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Top
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.GetRow Method (Int32, CmcOptionFlags)

ICommenceDeleteRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, CmcOptionFlags)
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

ICommenceDeleteRowSet Interface
GetRow Overload


ICommenceDeleteRowSet.GetRow Method (Int32, String, CmcOptionFlags)

ICommenceDeleteRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
See Also

Reference

ICommenceDeleteRowSet Interface
GetRow Overload


ICommenceDeleteRowSet.GetRowID Method

ICommenceDeleteRowSetGetRowID Method

Returns a unique identifier for a row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetRowID(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRowID (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: String
Returns a unique ID string (less than 100 chars) on success, null on error.
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.GetRowValue Method

ICommenceDeleteRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.

Implements

IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceDeleteRowSet.GetShared Method

ICommenceDeleteRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool GetShared(
    int nRow
)
Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.

Implements

IBaseRowSetGetShared(Int32)
See Also

Reference

ICommenceDeleteRowSet Interface


ICommenceEditRowSet Interface

interface for CommenceEditRowSet

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceEditRowSet : IBaseRowSet,
    IDisposable
Public Interface ICommenceEditRowSet
    Inherits IBaseRowSet, IDisposable

The ICommenceEditRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Commit | Commit changes to disk.
Public method | CommitGetCursor | Make row modifications permanent (commit to disk) and return a cursor for the newly added data
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Public method | ModifyRow | Modify fieldvalue
Public method | SetShared | Sets the shared status of the row. Shared items cannot be made unshared.
Top
See Also

Reference


ICommenceEditRowSet Properties

The ICommenceEditRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.ColumnCount Property

ICommenceEditRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ColumnCount { get; }
ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetColumnCount
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.RowCount Property

ICommenceEditRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int RowCount { get; }
ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetRowCount
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet Methods

The ICommenceEditRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Commit | Commit changes to disk.
Public method | CommitGetCursor | Make row modifications permanent (commit to disk) and return a cursor for the newly added data
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Public method | ModifyRow | Modify fieldvalue
Public method | SetShared | Sets the shared status of the row. Shared items cannot be made unshared.
Top
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.Close Method

ICommenceEditRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close

Implements

IBaseRowSetClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.Commit Method

ICommenceEditRowSetCommit Method

Commit changes to disk.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int Commit(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function Commit (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.CommitGetCursor Method

ICommenceEditRowSetCommitGetCursor Method

Make row modifications permanent (commit to disk) and return a cursor for the newly added data

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
CommenceCursor CommitGetCursor(
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function CommitGetCursor (
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As CommenceCursor

Parameters

flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: CommenceCursor
CommenceCursor object reflecting the changes.
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.GetColumnIndex Method

ICommenceEditRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.

Implements

IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.GetColumnLabel Method

ICommenceEditRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.

Implements

IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.GetRow Method

ICommenceEditRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Top
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.GetRow Method (Int32, CmcOptionFlags)

ICommenceEditRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, CmcOptionFlags)
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

ICommenceEditRowSet Interface
GetRow Overload


ICommenceEditRowSet.GetRow Method (Int32, String, CmcOptionFlags)

ICommenceEditRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
See Also

Reference

ICommenceEditRowSet Interface
GetRow Overload


ICommenceEditRowSet.GetRowID Method

ICommenceEditRowSetGetRowID Method

Returns a unique identifier for a row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetRowID(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRowID (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: String
Returns a unique ID string (less than 100 chars) on success, null on error.
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.GetRowValue Method

ICommenceEditRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.

Implements

IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.GetShared Method

ICommenceEditRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool GetShared(
    int nRow
)
Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.

Implements

IBaseRowSetGetShared(Int32)
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.ModifyRow Method

ICommenceEditRowSetModifyRow Method

Modify fieldvalue

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ModifyRow(
    int nRow,
    int nCol,
    string fieldValue,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function ModifyRow (
    nRow As Integer,
    nCol As Integer,
    fieldValue As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
nCol
Type: SystemInt32
The (0-based) index of the column.
fieldValue
Type: SystemString
new fieldValue.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused, must be 0

Return Value

Type: Int32
0 on success, -1 on error.
See Also

Reference

ICommenceEditRowSet Interface


ICommenceEditRowSet.SetShared Method

ICommenceEditRowSetSetShared Method

Sets the shared status of the row. Shared items cannot be made unshared.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SetShared(
    int nRow
)
Function SetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
True on success.
See Also

Reference

ICommenceEditRowSet Interface


ICommenceQueryRowSet Interface

Interface for CommenceQueryRowSet

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceQueryRowSet : IBaseRowSet,
    IDisposable
Public Interface ICommenceQueryRowSet
    Inherits IBaseRowSet, IDisposable

The ICommenceQueryRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetFieldToFile | Save the field value at the given (row,column) to a file.
Public method | GetRow(Int32) | GetRow implementation for .NET that gets the the Commence row as string values.
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowSequenceNumber | Gets the sequence number that Commence uses internally. Note: this is not a workgroup-wide number!
Public method | GetRowTimeStamp | Undocumented method, most likely returns a timestamp :).
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Top
See Also

Reference


ICommenceQueryRowSet Properties

The ICommenceQueryRowSet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnCount | Number of columns in rowset
Public property | RowCount | Number of items in rowset.
Top
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.ColumnCount Property

ICommenceQueryRowSetColumnCount Property

Number of columns in rowset

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ColumnCount { get; }
ReadOnly Property ColumnCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetColumnCount
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.RowCount Property

ICommenceQueryRowSetRowCount Property

Number of items in rowset.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int RowCount { get; }
ReadOnly Property RowCount As Integer
    Get

Property Value

Type: Int32

Implements

IBaseRowSetRowCount
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet Methods

The ICommenceQueryRowSet type exposes the following members.

Methods
 | Name | Description
Public method | Close | Close any references to Commence. The object should be disposed after this.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetColumnIndex | Search the column set and return the index of the column with the given label
Public method | GetColumnLabel | Search the column set and return the column label or fieldname
Public method | GetFieldToFile | Save the field value at the given (row,column) to a file.
Public method | GetRow(Int32) | GetRow implementation for .NET that gets the the Commence row as string values.
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRowID | Returns a unique identifier for a row.
Public method | GetRowSequenceNumber | Gets the sequence number that Commence uses internally. Note: this is not a workgroup-wide number!
Public method | GetRowTimeStamp | Undocumented method, most likely returns a timestamp :).
Public method | GetRowValue | Get rowvalue for specified row/column
Public method | GetShared | Gets the shared/local status of the row
Top
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.Close Method

ICommenceQueryRowSetClose Method

Close any references to Commence. The object should be disposed after this.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close

Implements

IBaseRowSetClose
Remarks
When used from within a Commence Form Script, failing to call the Close method will leave the commence.exe process running in the background when the user closes Commence. IMPORTANT: this also happens when an unhandled exception (a 'script error') occurs. The Commence process then has to be closed manually from the Windows Task Manager. Be careful to implement proper error handling.

When the assembly is called from a.NET application, there is rarely a need to call this method, unless you want to explicitly release COM references and/or release memory. It can be useful in some cases, because Commence may complain about running out of memory before the Garbage Collector has a chance to kick in.

Technical details: calling this method tells the assembly to release all COM handles (called 'RCW' for 'runtime callable wrapper') to Commence that are open. This is needed because when the object reference to this assembly is set to Nothing (in VB), the .NET assembly may not be notified and will think they are still in use. Garbage Collection will therefore not release them, and the commence.exe process will not be terminated.

See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.GetColumnIndex Method

ICommenceQueryRowSetGetColumnIndex Method

Search the column set and return the index of the column with the given label

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetColumnIndex(
    string pLabel,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnIndex (
    pLabel As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

pLabel
Type: SystemString
The column label to map.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels).

Return Value

Type: Int32
0-based column index on success, -1 on error.

Implements

IBaseRowSetGetColumnIndex(String, CmcOptionFlags)
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.GetColumnLabel Method

ICommenceQueryRowSetGetColumnLabel Method

Search the column set and return the column label or fieldname

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetColumnLabel(
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetColumnLabel (
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Fieldname - return field label (ignore view labels)

Return Value

Type: String
Column label on success, -1 on error.

Implements

IBaseRowSetGetColumnLabel(Int32, CmcOptionFlags)
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.GetFieldToFile Method

ICommenceQueryRowSetGetFieldToFile Method

Save the field value at the given (row,column) to a file.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetFieldToFile(
    int nRow,
    int nCol,
    string filename,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetFieldToFile (
    nRow As Integer,
    nCol As Integer,
    filename As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
nCol
Type: SystemInt32
The (0-based) index of the column.
filename
Type: SystemString
(Fully qualified) Filename where the field value is written.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: Canonical - return field value in canonical form.

Return Value

Type: Int32
File size in bytes, -1 on error.
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.GetRow Method

ICommenceQueryRowSetGetRow Method

Overload List
 | Name | Description
Public method | GetRow(Int32) | GetRow implementation for .NET that gets the the Commence row as string values.
Public method | GetRow(Int32, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Public method | GetRow(Int32, String, CmcOptionFlags) | Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.
Top
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.GetRow Method (Int32)

ICommenceQueryRowSetGetRow Method (Int32)

GetRow implementation for .NET that gets the the Commence row as string values.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string[] GetRow(
    int nRow
)
Function GetRow (
    nRow As Integer
) As String()

Parameters

nRow
Type: SystemInt32
Row pointer.

Return Value

Type: String
String array.
Remarks
The purpose of this method is primarily to avoid boxing in internal export methods.
See Also

Reference

ICommenceQueryRowSet Interface
GetRow Overload


ICommenceQueryRowSet.GetRow Method (Int32, CmcOptionFlags)

ICommenceQueryRowSetGetRow Method (Int32, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, CmcOptionFlags)
Remarks
The return type is an object array, not a string array, even though Commence always returns values as string. That may seem counterintuitive. The reason for this is COM. I have not found a way to marshal a string array as variant. It is possible to marshal a string[], but accessing it will raise a type mismatch error in VBScript.
See Also

Reference

ICommenceQueryRowSet Interface
GetRow Overload


ICommenceQueryRowSet.GetRow Method (Int32, String, CmcOptionFlags)

ICommenceQueryRowSetGetRow Method (Int32, String, CmcOptionFlags)

Returns an entire row's field values. Note that this method returns an array, whereas the native Commence method returns a delimited string.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] GetRow(
    int nRow,
    string delim,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRow (
    nRow As Integer,
    delim As String,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As Object()

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
delim
Type: SystemString
Delimiter in case the default delimiter does not suffice.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: Object
Object array of strings containing the row's values, null on error.

Implements

IBaseRowSetGetRow(Int32, String, CmcOptionFlags)
See Also

Reference

ICommenceQueryRowSet Interface
GetRow Overload


ICommenceQueryRowSet.GetRowID Method

ICommenceQueryRowSetGetRowID Method

Returns a unique identifier for a row.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetRowID(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRowID (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Unused at present, must be 0.

Return Value

Type: String
Returns a unique ID string (less than 100 chars) on success, null on error.
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.GetRowSequenceNumber Method

ICommenceQueryRowSetGetRowSequenceNumber Method

Gets the sequence number that Commence uses internally. Note: this is not a workgroup-wide number!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int GetRowSequenceNumber(
    int nRow
)
Function GetRowSequenceNumber (
    nRow As Integer
) As Integer

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Int32
Sequence number that Commence uses internally.
Remarks
Local categories do not have a THID. Local items in shared categories do have THIDs. If no there are THIDs this method will use the RowID instead.
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.GetRowTimeStamp Method

ICommenceQueryRowSetGetRowTimeStamp Method

Undocumented method, most likely returns a timestamp :).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetRowTimeStamp(
    int nRow,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRowTimeStamp (
    nRow As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
(Assumed) Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form.

Return Value

Type: String
some string with a timestamp? Who knows? Is it blue?
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.GetRowValue Method

ICommenceQueryRowSetGetRowValue Method

Get rowvalue for specified row/column

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetRowValue(
    int nRow,
    int nCol,
    CmcOptionFlags flags = CmcOptionFlags.Default
)
Function GetRowValue (
    nRow As Integer,
    nCol As Integer,
    Optional flags As CmcOptionFlags = CmcOptionFlags.Default
) As String

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row
nCol
Type: SystemInt32
The (0-based) index of the column.
flags (Optional)
Type: Vovin.CmcLibNet.DatabaseCmcOptionFlags
Logical OR of following option flags: CmcOptionFlags.Canonical - return field value in canonical form

Return Value

Type: String
rowvalue, null on error.

Implements

IBaseRowSetGetRowValue(Int32, Int32, CmcOptionFlags)
See Also

Reference

ICommenceQueryRowSet Interface


ICommenceQueryRowSet.GetShared Method

ICommenceQueryRowSetGetShared Method

Gets the shared/local status of the row

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool GetShared(
    int nRow
)
Function GetShared (
    nRow As Integer
) As Boolean

Parameters

nRow
Type: SystemInt32
The (0-based) index of the row.

Return Value

Type: Boolean
true if shared.

Implements

IBaseRowSetGetShared(Int32)
See Also

Reference

ICommenceQueryRowSet Interface


ICursorColumns Interface

Interface for CursorColumns, allows for a convenient way of setting direct and related columns.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICursorColumns
Public Interface ICursorColumns

The ICursorColumns type exposes the following members.

Methods
 | Name | Description
Public method | AddDirectColumn | Adds single fieldname to the collection of direct fields.
Public method | AddDirectColumns(Object) | Adds an array of direct fields to the collection of direct fields.
Public method | AddDirectColumns(String) | Adds an array of direct fields to the collection of direct fields.
Public method | AddRelatedColumn | Add a related field to the collection of related fields.
Public method | Apply | Set all direct and related columns. Duplicate columns are ignored.
Top
See Also

Reference


ICursorColumns Methods

The ICursorColumns type exposes the following members.

Methods
 | Name | Description
Public method | AddDirectColumn | Adds single fieldname to the collection of direct fields.
Public method | AddDirectColumns(Object) | Adds an array of direct fields to the collection of direct fields.
Public method | AddDirectColumns(String) | Adds an array of direct fields to the collection of direct fields.
Public method | AddRelatedColumn | Add a related field to the collection of related fields.
Public method | Apply | Set all direct and related columns. Duplicate columns are ignored.
Top
See Also

Reference

ICursorColumns Interface


ICursorColumns.AddDirectColumn Method

ICursorColumnsAddDirectColumn Method

Adds single fieldname to the collection of direct fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void AddDirectColumn(
    string fieldName
)
Sub AddDirectColumn (
    fieldName As String
)

Parameters

fieldName
Type: SystemString
Direct fieldname from the Cursor's category.
See Also

Reference

ICursorColumns Interface


ICursorColumns.AddDirectColumns Method

ICursorColumnsAddDirectColumns Method

Overload List
 | Name | Description
Public method | AddDirectColumns(Object) | Adds an array of direct fields to the collection of direct fields.
Public method | AddDirectColumns(String) | Adds an array of direct fields to the collection of direct fields.
Top
See Also

Reference

ICursorColumns Interface


ICursorColumns.AddDirectColumns Method (Object[])

ICursorColumnsAddDirectColumns Method (Object)

Adds an array of direct fields to the collection of direct fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void AddDirectColumns(
    params Object[] fieldNames
)
Sub AddDirectColumns (
    ParamArray fieldNames As Object()
)

Parameters

fieldNames
Type: SystemObject
Object array of fieldnames.
See Also

Reference

ICursorColumns Interface
AddDirectColumns Overload


ICursorColumns.AddDirectColumns Method (String[])

ICursorColumnsAddDirectColumns Method (String)

Adds an array of direct fields to the collection of direct fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void AddDirectColumns(
    params string[] fieldNames
)
Sub AddDirectColumns (
    ParamArray fieldNames As String()
)

Parameters

fieldNames
Type: SystemString
Array of fieldnames, or a comma-separated list of fieldnames.
Remarks
This method is only available for .NET applications.
See Also

Reference

ICursorColumns Interface
AddDirectColumns Overload


ICursorColumns.AddRelatedColumn Method

ICursorColumnsAddRelatedColumn Method

Add a related field to the collection of related fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void AddRelatedColumn(
    string connectionName,
    string categoryName,
    string fieldName
)
Sub AddRelatedColumn (
    connectionName As String,
    categoryName As String,
    fieldName As String
)

Parameters

connectionName
Type: SystemString
Commence connection name (case-sensitive!).
categoryName
Type: SystemString
Commence connected category name.
fieldName
Type: SystemString
Commence connected category fieldname.
See Also

Reference

ICursorColumns Interface


ICursorColumns.Apply Method

ICursorColumnsApply Method

Set all direct and related columns. Duplicate columns are ignored.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int Apply()
Function Apply As Integer

Return Value

Type: Int32
Number of columns set, -1 on error.
See Also

Reference

ICursorColumns Interface


ICursorFilter Interface

Exposes members of CursorFilter, a base class for all filters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICursorFilter
Public Interface ICursorFilter

The ICursorFilter type exposes the following members.

Properties
 | Name | Description
Public property | ClauseNumber | Filter clause number. Should be a number between 1 and 8.
Public property | Except | Except flag. Set to true to create a Except (NOT) filter.
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]].
Top
Methods
 | Name | Description
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax.
Public method | ToString | Overload allowing custom formatting.
Top
See Also

Reference


ICursorFilter Properties

The ICursorFilter type exposes the following members.

Properties
 | Name | Description
Public property | ClauseNumber | Filter clause number. Should be a number between 1 and 8.
Public property | Except | Except flag. Set to true to create a Except (NOT) filter.
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | OrFilter | Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'. The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items. Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]].
Top
See Also

Reference

ICursorFilter Interface


ICursorFilter.ClauseNumber Property

ICursorFilterClauseNumber Property

Filter clause number. Should be a number between 1 and 8.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ClauseNumber { get; set; }
Property ClauseNumber As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ICursorFilter Interface


ICursorFilter.Except Property

ICursorFilterExcept Property

Except flag. Set to true to create a Except (NOT) filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Except { get; set; }
Property Except As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ICursorFilter Interface


ICursorFilter.FiltertypeIdentifier Property

ICursorFilterFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FiltertypeIdentifier { get; }
ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String
See Also

Reference

ICursorFilter Interface


ICursorFilter.OrFilter Property

ICursorFilterOrFilter Property

Defines AND/OR filter logic. Set to true to make filter an OR filter. Defaults to 'AND'.

The relationship applies to the next filter you set (just like in the Commence UI) so do not set to true unless you define an additional filter, otherwise your will get all items.

Keep in mind the special grouping Commence uses for filters: [[1 and/or2] and/or [3 and/or 4]] and/or [[5 and/or 6] and/or [7 and/or 8]].

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool OrFilter { get; set; }
Property OrFilter As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ICursorFilter Interface


ICursorFilter Methods

The ICursorFilter type exposes the following members.

Methods
 | Name | Description
Public method | GetViewFilterString | Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax.
Public method | ToString | Overload allowing custom formatting.
Top
See Also

Reference

ICursorFilter Interface


ICursorFilter.GetViewFilterString Method

ICursorFilterGetViewFilterString Method

Convenience method mainly for COM Interop; returns ViewFilter string as you would use it in DDE syntax.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetViewFilterString()
Function GetViewFilterString As String

Return Value

Type: String
ViewFilter string.
Remarks
If you use CmcLibNet through COM Interop, for instance in Commence Form Script, you may have no way of inspecting the filter in an IDE. This method returns the string representation of the filter.
See Also

Reference

ICursorFilter Interface


ICursorFilter.ToString Method

ICursorFilterToString Method

Overload allowing custom formatting.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ToString(
    Func<ICursorFilter, string> formatter
)
Function ToString (
    formatter As Func(Of ICursorFilter, String)
) As String

Parameters

formatter
Type: SystemFunc ICursorFilter, String
Func<IbaseCusrorFilter, string>.

Return Value

Type: String
Output of Func
Remarks
Only available to .Net clients.
See Also

Reference

ICursorFilter Interface


ICursorFilters Interface

Exposes members of the CursorFilters class. For code examples see CursorFilters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICursorFilters
Public Interface ICursorFilters

The ICursorFilters type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets number of filters.
Top
Methods
 | Name | Description
Public method | Add | Add a filter to the filter collection.
Public method | Apply | Apply filters and return number of affected items.
Public method | Clear | Clear all filters from collection. The underlying cursor will be updated, there is no need to call Apply.
Public method | Create | Create new filter and add it to the collection.
Public method | GetEnumerator | Enable enumeration.
Public method | GetFilter | Returns filter from collection.
Public method | GetFilterByClauseNumber | Get filter from collection based on clause number.
Public method | RemoveFilter | Remove specified filter from collection. The underlying cursor will be updated, there is no need to call Apply.
Public method | RemoveFilterByClauseNumber | Remove filter from collection by clause number, if present. The underlying cursor is also updated, there is no need to call Apply.
Public method | ToString | Summarizes filters set so far. Useful for COM Interop clients.
Public method | ValidateFilter | Checks if filter will work.
Top
See Also

Reference


ICursorFilters Properties

The ICursorFilters type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets number of filters.
Top
See Also

Reference

ICursorFilters Interface


ICursorFilters.Count Property

ICursorFiltersCount Property

Gets number of filters.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ICursorFilters Interface


ICursorFilters Methods

The ICursorFilters type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add a filter to the filter collection.
Public method | Apply | Apply filters and return number of affected items.
Public method | Clear | Clear all filters from collection. The underlying cursor will be updated, there is no need to call Apply.
Public method | Create | Create new filter and add it to the collection.
Public method | GetEnumerator | Enable enumeration.
Public method | GetFilter | Returns filter from collection.
Public method | GetFilterByClauseNumber | Get filter from collection based on clause number.
Public method | RemoveFilter | Remove specified filter from collection. The underlying cursor will be updated, there is no need to call Apply.
Public method | RemoveFilterByClauseNumber | Remove filter from collection by clause number, if present. The underlying cursor is also updated, there is no need to call Apply.
Public method | ToString | Summarizes filters set so far. Useful for COM Interop clients.
Public method | ValidateFilter | Checks if filter will work.
Top
See Also

Reference

ICursorFilters Interface


ICursorFilters.Add Method

ICursorFiltersAdd Method

Add a filter to the filter collection.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Add(
    ICursorFilter filter
)
Sub Add (
    filter As ICursorFilter
)

Parameters

filter
Type: Vovin.CmcLibNet.DatabaseICursorFilter
ICursorFilter object.
See Also

Reference

ICursorFilters Interface


ICursorFilters.Apply Method

ICursorFiltersApply Method

Apply filters and return number of affected items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int Apply()
Function Apply As Integer

Return Value

Type: Int32
Number of items in cursor after applying filters.
See Also

Reference

ICursorFilters Interface


ICursorFilters.Clear Method

ICursorFiltersClear Method

Clear all filters from collection. The underlying cursor will be updated, there is no need to call Apply.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Clear()
Sub Clear
See Also

Reference

ICursorFilters Interface


ICursorFilters.Create Method

ICursorFiltersCreate Method

Create new filter and add it to the collection.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object Create(
    int clauseNumber,
    FilterType filterType
)
Function Create (
    clauseNumber As Integer,
    filterType As FilterType
) As Object

Parameters

clauseNumber
Type: SystemInt32
Order of the filter, should be between 1-8.
filterType
Type: Vovin.CmcLibNet.DatabaseFilterType
The type of filter to create.

Return Value

Type: Object
Derived BaseFilter corresponding to either of ICursorFilterTypeF, ICursorFilterTypeCTI, ICursorFilterTypeCTCF, ICursorFilterTypeCTCTI.
See Also

Reference

ICursorFilters Interface


ICursorFilters.GetEnumerator Method

ICursorFiltersGetEnumerator Method

Enable enumeration.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IEnumerator<ICursorFilter> GetEnumerator()
Function GetEnumerator As IEnumerator(Of ICursorFilter)

Return Value

Type: IEnumerator ICursorFilter
ICursorFilter.
See Also

Reference

ICursorFilters Interface


ICursorFilters.GetFilter Method

ICursorFiltersGetFilter Method

Returns filter from collection.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object GetFilter(
    int index
)
Function GetFilter (
    index As Integer
) As Object

Parameters

index
Type: SystemInt32
Index of filter (0-based).

Return Value

Type: Object
Derived BaseFilter object.
See Also

Reference

ICursorFilters Interface


ICursorFilters.GetFilterByClauseNumber Method

ICursorFiltersGetFilterByClauseNumber Method

Get filter from collection based on clause number.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object GetFilterByClauseNumber(
    int clauseNumber
)
Function GetFilterByClauseNumber (
    clauseNumber As Integer
) As Object

Parameters

clauseNumber
Type: SystemInt32
ClauseNumber.

Return Value

Type: Object
CursorFilter.
See Also

Reference

ICursorFilters Interface


ICursorFilters.RemoveFilter Method

ICursorFiltersRemoveFilter Method

Remove specified filter from collection. The underlying cursor will be updated, there is no need to call Apply.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool RemoveFilter(
    BaseCursorFilter cf
)
Function RemoveFilter (
    cf As BaseCursorFilter
) As Boolean

Parameters

cf
Type: Vovin.CmcLibNet.DatabaseBaseCursorFilter
Filter to remove.

Return Value

Type: Boolean
true on success, false on error.
See Also

Reference

ICursorFilters Interface


ICursorFilters.RemoveFilterByClauseNumber Method

ICursorFiltersRemoveFilterByClauseNumber Method

Remove filter from collection by clause number, if present. The underlying cursor is also updated, there is no need to call Apply.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool RemoveFilterByClauseNumber(
    int clauseNumber
)
Function RemoveFilterByClauseNumber (
    clauseNumber As Integer
) As Boolean

Parameters

clauseNumber
Type: SystemInt32
Clause number (1-8).

Return Value

Type: Boolean
true on success, false on error.
See Also

Reference

ICursorFilters Interface


ICursorFilters.ToString Method

ICursorFiltersToString Method

Summarizes filters set so far. Useful for COM Interop clients.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ToString()
Function ToString As String

Return Value

Type: String
Single string of filterstrings for all filters in the collection.
See Also

Reference

ICursorFilters Interface


ICursorFilters.ValidateFilter Method

ICursorFiltersValidateFilter Method

Checks if filter will work.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ValidateFilter(
    ICursorFilter filter
)
Function ValidateFilter (
    filter As ICursorFilter
) As Boolean

Parameters

filter
Type: Vovin.CmcLibNet.DatabaseICursorFilter
ICursorFilter.

Return Value

Type: Boolean
True if filter succeeded, otherwise false.
Remarks
This is a very expensive call, it creates a dummy cursor and actually tries if the filter works.
See Also

Reference

ICursorFilters Interface


ICursorFilterTypeCTCF Interface

Interface for CursorFilterTypeCTCF.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICursorFilterTypeCTCF : ICursorFilter
Public Interface ICursorFilterTypeCTCF
    Inherits ICursorFilter

The ICursorFilterTypeCTCF type exposes the following members.

Properties
 | Name | Description
Public property | Category | Connected category name; case-sensitive!
Public property | ClauseNumber | Filter clause number. Should be a number between 1 and 8.
Public property | Connection | Connection name; case-sensitive!
Public property | Except | Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog
Public property | FieldName | Field to evaluate.
Public property | FieldValue | Fieldvalue to evaluate. Ignored when Between qualifier is used.
Public property | FilterBetweenEndValue | End value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterStartEndValue.
Public property | FilterBetweenStartValue | Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterBetweenEndValue.
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | MatchCase | Case-sensitive parameter. Set to true for case-sensitive filter.
Public property | OrFilter | Specify if this filter must be treated as an Or filter. Default is false.
Public property | Qualifier | Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.
Public property | QualifierString | See QualifierString
Public property | Shared | Filter for Local/Shared items.
Public property | SharedOptionSet | Keep track of whether the 'shared/local' option was set
Top
Methods
 | Name | Description
Public method | GetViewFilterString | Returns the ViewFilter string, useful for debugging.
Public method | ToString | Overload allowing custom formatting. (Inherited from ICursorFilter.)
Top
See Also

Reference


ICursorFilterTypeCTCF Properties

The ICursorFilterTypeCTCF type exposes the following members.

Properties
 | Name | Description
Public property | Category | Connected category name; case-sensitive!
Public property | ClauseNumber | Filter clause number. Should be a number between 1 and 8.
Public property | Connection | Connection name; case-sensitive!
Public property | Except | Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog
Public property | FieldName | Field to evaluate.
Public property | FieldValue | Fieldvalue to evaluate. Ignored when Between qualifier is used.
Public property | FilterBetweenEndValue | End value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterStartEndValue.
Public property | FilterBetweenStartValue | Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterBetweenEndValue.
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | MatchCase | Case-sensitive parameter. Set to true for case-sensitive filter.
Public property | OrFilter | Specify if this filter must be treated as an Or filter. Default is false.
Public property | Qualifier | Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.
Public property | QualifierString | See QualifierString
Public property | Shared | Filter for Local/Shared items.
Public property | SharedOptionSet | Keep track of whether the 'shared/local' option was set
Top
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.Category Property

ICursorFilterTypeCTCFCategory Property

Connected category name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Category { get; set; }
Property Category As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.ClauseNumber Property

ICursorFilterTypeCTCFClauseNumber Property

Filter clause number. Should be a number between 1 and 8.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ClauseNumber { get; set; }
Property ClauseNumber As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICursorFilterClauseNumber
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.Connection Property

ICursorFilterTypeCTCFConnection Property

Connection name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Connection { get; set; }
Property Connection As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.Except Property

ICursorFilterTypeCTCFExcept Property

Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Except { get; set; }
Property Except As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterExcept
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.FieldName Property

ICursorFilterTypeCTCFFieldName Property

Field to evaluate.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FieldName { get; set; }
Property FieldName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.FieldValue Property

ICursorFilterTypeCTCFFieldValue Property

Fieldvalue to evaluate. Ignored when Between qualifier is used.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FieldValue { get; set; }
Property FieldValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.FilterBetweenEndValue Property

ICursorFilterTypeCTCFFilterBetweenEndValue Property

End value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterStartEndValue.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FilterBetweenEndValue { get; set; }
Property FilterBetweenEndValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.FilterBetweenStartValue Property

ICursorFilterTypeCTCFFilterBetweenStartValue Property

Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier on F and CTCF filters, otherwise ignored. When this property is set, you must also set FilterBetweenEndValue.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FilterBetweenStartValue { get; set; }
Property FilterBetweenStartValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.FiltertypeIdentifier Property

ICursorFilterTypeCTCFFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FiltertypeIdentifier { get; }
ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String

Implements

ICursorFilterFiltertypeIdentifier
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.MatchCase Property

ICursorFilterTypeCTCFMatchCase Property

Case-sensitive parameter. Set to true for case-sensitive filter.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool MatchCase { get; set; }
Property MatchCase As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.OrFilter Property

ICursorFilterTypeCTCFOrFilter Property

Specify if this filter must be treated as an Or filter. Default is false.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool OrFilter { get; set; }
Property OrFilter As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterOrFilter
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.Qualifier Property

ICursorFilterTypeCTCFQualifier Property

Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
FilterQualifier Qualifier { get; set; }
Property Qualifier As FilterQualifier
    Get
    Set

Property Value

Type: FilterQualifier
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.QualifierString Property

ICursorFilterTypeCTCFQualifierString Property

See QualifierString

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string QualifierString { get; set; }
Property QualifierString As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.Shared Property

ICursorFilterTypeCTCFShared Property

Filter for Local/Shared items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Shared { get; set; }
Property Shared As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When set, fieldvalues are ignored.
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.SharedOptionSet Property

ICursorFilterTypeCTCFSharedOptionSet Property

Keep track of whether the 'shared/local' option was set

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SharedOptionSet { get; }
ReadOnly Property SharedOptionSet As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF Methods

The ICursorFilterTypeCTCF type exposes the following members.

Methods
 | Name | Description
Public method | GetViewFilterString | Returns the ViewFilter string, useful for debugging.
Public method | ToString | Overload allowing custom formatting. (Inherited from ICursorFilter.)
Top
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCF.GetViewFilterString Method

ICursorFilterTypeCTCFGetViewFilterString Method

Returns the ViewFilter string, useful for debugging.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetViewFilterString()
Function GetViewFilterString As String

Return Value

Type: String
fully formatted ViewFilter DDE command constructed by the ToString

Implements

ICursorFilterGetViewFilterString
See Also

Reference

ICursorFilterTypeCTCF Interface


ICursorFilterTypeCTCTI Interface

interface for CursorFilterTypeCTCTI.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICursorFilterTypeCTCTI : ICursorFilter
Public Interface ICursorFilterTypeCTCTI
    Inherits ICursorFilter

The ICursorFilterTypeCTCTI type exposes the following members.

Properties
 | Name | Description
Public property | Category | Connected category name; case-sensitive!
Public property | Category2 | Connected category 2 name; case-sensitive!
Public property | ClarifySeparator | Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClarifyValue | Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClauseNumber | Filter clause number. Should be a number between 1 and 8.
Public property | Connection | Connection name; case-sensitive!
Public property | Connection2 | Connection 2 name; case-sensitive!
Public property | Except | Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | Item | Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to use the fully qualified itemname here, including all the right the padding(!).
Public property | OrFilter | Specify if this filter must be treated as an Or filter. Default is false.
Top
Methods
 | Name | Description
Public method | GetViewFilterString | Returns the ViewFilter string, useful for debugging.
Public method | ToString | Overload allowing custom formatting. (Inherited from ICursorFilter.)
Top
See Also

Reference


ICursorFilterTypeCTCTI Properties

The ICursorFilterTypeCTCTI type exposes the following members.

Properties
 | Name | Description
Public property | Category | Connected category name; case-sensitive!
Public property | Category2 | Connected category 2 name; case-sensitive!
Public property | ClarifySeparator | Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClarifyValue | Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClauseNumber | Filter clause number. Should be a number between 1 and 8.
Public property | Connection | Connection name; case-sensitive!
Public property | Connection2 | Connection 2 name; case-sensitive!
Public property | Except | Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | Item | Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to use the fully qualified itemname here, including all the right the padding(!).
Public property | OrFilter | Specify if this filter must be treated as an Or filter. Default is false.
Top
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.Category Property

ICursorFilterTypeCTCTICategory Property

Connected category name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Category { get; set; }
Property Category As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.Category2 Property

ICursorFilterTypeCTCTICategory2 Property

Connected category 2 name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Category2 { get; set; }
Property Category2 As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.ClarifySeparator Property

ICursorFilterTypeCTCTIClarifySeparator Property

Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ClarifySeparator { get; set; }
Property ClarifySeparator As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.ClarifyValue Property

ICursorFilterTypeCTCTIClarifyValue Property

Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ClarifyValue { get; set; }
Property ClarifyValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.ClauseNumber Property

ICursorFilterTypeCTCTIClauseNumber Property

Filter clause number. Should be a number between 1 and 8.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ClauseNumber { get; set; }
Property ClauseNumber As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICursorFilterClauseNumber
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.Connection Property

ICursorFilterTypeCTCTIConnection Property

Connection name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Connection { get; set; }
Property Connection As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.Connection2 Property

ICursorFilterTypeCTCTIConnection2 Property

Connection 2 name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Connection2 { get; set; }
Property Connection2 As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.Except Property

ICursorFilterTypeCTCTIExcept Property

Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Except { get; set; }
Property Except As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterExcept
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.FiltertypeIdentifier Property

ICursorFilterTypeCTCTIFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FiltertypeIdentifier { get; }
ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String

Implements

ICursorFilterFiltertypeIdentifier
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.Item Property

ICursorFilterTypeCTCTIItem Property

Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to use the fully qualified itemname here, including all the right the padding(!).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Item { get; set; }
Property Item As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.OrFilter Property

ICursorFilterTypeCTCTIOrFilter Property

Specify if this filter must be treated as an Or filter. Default is false.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool OrFilter { get; set; }
Property OrFilter As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterOrFilter
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI Methods

The ICursorFilterTypeCTCTI type exposes the following members.

Methods
 | Name | Description
Public method | GetViewFilterString | Returns the ViewFilter string, useful for debugging.
Public method | ToString | Overload allowing custom formatting. (Inherited from ICursorFilter.)
Top
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTCTI.GetViewFilterString Method

ICursorFilterTypeCTCTIGetViewFilterString Method

Returns the ViewFilter string, useful for debugging.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetViewFilterString()
Function GetViewFilterString As String

Return Value

Type: String
fully formatted ViewFilter DDE command constructed by the ToString

Implements

ICursorFilterGetViewFilterString
See Also

Reference

ICursorFilterTypeCTCTI Interface


ICursorFilterTypeCTI Interface

Interface for CursorFilterTypeCTI.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICursorFilterTypeCTI : ICursorFilter
Public Interface ICursorFilterTypeCTI
    Inherits ICursorFilter

The ICursorFilterTypeCTI type exposes the following members.

Properties
 | Name | Description
Public property | Category | Connected category name.
Public property | ClarifySeparator | Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClarifyValue | Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClauseNumber | Filter clause number. Should be a number between 1 and 8.
Public property | Connection | Connection name; case-sensitive!
Public property | Except | Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | Item | Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to just use the fully qualified itemname here, including all the right the padding(!).
Public property | OrFilter | Specify if this filter must be treated as an Or filter. Default is false.
Top
Methods
 | Name | Description
Public method | GetViewFilterString | Returns the ViewFilter string, useful for debugging.
Public method | ToString | Overload allowing custom formatting. (Inherited from ICursorFilter.)
Top
See Also

Reference


ICursorFilterTypeCTI Properties

The ICursorFilterTypeCTI type exposes the following members.

Properties
 | Name | Description
Public property | Category | Connected category name.
Public property | ClarifySeparator | Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClarifyValue | Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value
Public property | ClauseNumber | Filter clause number. Should be a number between 1 and 8.
Public property | Connection | Connection name; case-sensitive!
Public property | Except | Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog
Public property | FiltertypeIdentifier | String representing the filtertype identifier for use in a Commence DDE request.
Public property | Item | Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to just use the fully qualified itemname here, including all the right the padding(!).
Public property | OrFilter | Specify if this filter must be treated as an Or filter. Default is false.
Top
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.Category Property

ICursorFilterTypeCTICategory Property

Connected category name.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Category { get; set; }
Property Category As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.ClarifySeparator Property

ICursorFilterTypeCTIClarifySeparator Property

Clarify separator. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ClarifySeparator { get; set; }
Property ClarifySeparator As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.ClarifyValue Property

ICursorFilterTypeCTIClarifyValue Property

Clarify value. If the filter is on a Commence category that is clarified, you must provide both the clarify separator and the clarify value

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ClarifyValue { get; set; }
Property ClarifyValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.ClauseNumber Property

ICursorFilterTypeCTIClauseNumber Property

Filter clause number. Should be a number between 1 and 8.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ClauseNumber { get; set; }
Property ClauseNumber As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICursorFilterClauseNumber
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.Connection Property

ICursorFilterTypeCTIConnection Property

Connection name; case-sensitive!

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Connection { get; set; }
Property Connection As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.Except Property

ICursorFilterTypeCTIExcept Property

Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Except { get; set; }
Property Except As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterExcept
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.FiltertypeIdentifier Property

ICursorFilterTypeCTIFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FiltertypeIdentifier { get; }
ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String

Implements

ICursorFilterFiltertypeIdentifier
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.Item Property

ICursorFilterTypeCTIItem Property

Connected itemname. If the filter is on a Commence category that is clarified, it is recommended you provide both the clarify separator and the clarify value. However, it is possible to just use the fully qualified itemname here, including all the right the padding(!).

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Item { get; set; }
Property Item As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.OrFilter Property

ICursorFilterTypeCTIOrFilter Property

Specify if this filter must be treated as an Or filter. Default is false.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool OrFilter { get; set; }
Property OrFilter As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterOrFilter
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI Methods

The ICursorFilterTypeCTI type exposes the following members.

Methods
 | Name | Description
Public method | GetViewFilterString | Returns the ViewFilter string, useful for debugging.
Public method | ToString | Overload allowing custom formatting. (Inherited from ICursorFilter.)
Top
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeCTI.GetViewFilterString Method

ICursorFilterTypeCTIGetViewFilterString Method

Returns the ViewFilter string, useful for debugging.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetViewFilterString()
Function GetViewFilterString As String

Return Value

Type: String
fully formatted ViewFilter DDE command constructed by the ToString

Implements

ICursorFilterGetViewFilterString
See Also

Reference

ICursorFilterTypeCTI Interface


ICursorFilterTypeF Interface

Interface for CursorFilterTypeF.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICursorFilterTypeF : ICursorFilter
Public Interface ICursorFilterTypeF
    Inherits ICursorFilter

The ICursorFilterTypeF type exposes the following members.

Properties
Name Description
Public property ClauseNumber
Filter clause number. Should be a number between 1 and 8.
Public property Except
Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog
Public property FieldName
Field to evaluate.
Public property FieldValue
Fieldvalue to evaluate. Ignored when Between qualifier is used.
Public property FilterBetweenEndValue
End value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterStartEndValue.
Public property FilterBetweenStartValue
Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterBetweenEndValue.
Public property FiltertypeIdentifier
String representing the filtertype identifier for use in a Commence DDE request.
Public property MatchCase
Case-sensitive parameter. Set to true for case-sensitive filter. Defaults to false.
Public property OrFilter
Specify if this filter must be treated as an Or filter. Default is false.
Public property Qualifier
Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.
Public property QualifierString
String value specifying how to evaluate the filtervalue. Not all qualifiers can be used on all field-types. See Commence ViewFilter documentation in DDE helpfile.

If you use COM, either use this member with the strings listed below, or supply the FilterQualifier enum value to Qualifier. .NET users are strongly encouraged to use Qualifier.

List of valid qualifier strings and the fields they can be applied to.

Qualifier string | Applies to fieldtype(s)
Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Not Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Less Than | Calculation, Number, Sequence number fields.
Greater Than | Calculation, Number, Sequence number fields.
Between | Name, Calculation, Date, E-mail, URL, Number, Sequence number, Time fields.
True | Checkbox fields.
False | Checkbox fields.
Checked | Checkbox fields.
Not Checked | Checkbox fields.
Yes | Checkbox fields.
No | Checkbox fields.
Before | Date, Time fields.
On | Date fields.
At | Time fields.
After | Date, Time fields.
Contains | Name, E-mail, URL, Telephone, Text fields.
Doesn't Contain | Name, E-mail, URL, Telephone, Text fields.
Shared | N/A when used with fields.
Local | N/A when used with fields.
1 | Checkbox fields.
0 | Checkbox fields.
Public property Shared
Filter for Local/Shared items.
Public property SharedOptionSet
Keep track of whether the 'shared/local' option was set
Top
Methods
 | Name | Description
Public method | GetViewFilterString | Returns the ViewFilter string, useful for debugging.
Public method | ToString | Overload allowing custom formatting. (Inherited from ICursorFilter.)
Top
See Also

Reference


ICursorFilterTypeF Properties

The ICursorFilterTypeF type exposes the following members.

Properties
Name Description
Public property ClauseNumber
Filter clause number. Should be a number between 1 and 8.
Public property Except
Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog
Public property FieldName
Field to evaluate.
Public property FieldValue
Fieldvalue to evaluate. Ignored when Between qualifier is used.
Public property FilterBetweenEndValue
End value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterStartEndValue.
Public property FilterBetweenStartValue
Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterBetweenEndValue.
Public property FiltertypeIdentifier
String representing the filtertype identifier for use in a Commence DDE request.
Public property MatchCase
Case-sensitive parameter. Set to true for case-sensitive filter. Defaults to false.
Public property OrFilter
Specify if this filter must be treated as an Or filter. Default is false.
Public property Qualifier
Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.
Public property QualifierString
String value specifying how to evaluate the filtervalue. Not all qualifiers can be used on all field-types. See Commence ViewFilter documentation in DDE helpfile.

If you use COM, either use this member with the strings listed below, or supply the FilterQualifier enum value to Qualifier. .NET users are strongly encouraged to use Qualifier.

List of valid qualifier strings and the fields they can be applied to.

Qualifier string | Applies to fieldtype(s)
Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Not Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Less Than | Calculation, Number, Sequence number fields.
Greater Than | Calculation, Number, Sequence number fields.
Between | Name, Calculation, Date, E-mail, URL, Number, Sequence number, Time fields.
True | Checkbox fields.
False | Checkbox fields.
Checked | Checkbox fields.
Not Checked | Checkbox fields.
Yes | Checkbox fields.
No | Checkbox fields.
Before | Date, Time fields.
On | Date fields.
At | Time fields.
After | Date, Time fields.
Contains | Name, E-mail, URL, Telephone, Text fields.
Doesn't Contain | Name, E-mail, URL, Telephone, Text fields.
Shared | N/A when used with fields.
Local | N/A when used with fields.
1 | Checkbox fields.
0 | Checkbox fields.
Public property Shared
Filter for Local/Shared items.
Public property SharedOptionSet
Keep track of whether the 'shared/local' option was set
Top
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.ClauseNumber Property

ICursorFilterTypeFClauseNumber Property

Filter clause number. Should be a number between 1 and 8.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int ClauseNumber { get; set; }
Property ClauseNumber As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICursorFilterClauseNumber
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.Except Property

ICursorFilterTypeFExcept Property

Specify Not-filter. Equivalent to the 'Except' chekbox in a filtyer dialog

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Except { get; set; }
Property Except As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterExcept
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.FieldName Property

ICursorFilterTypeFFieldName Property

Field to evaluate.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FieldName { get; set; }
Property FieldName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.FieldValue Property

ICursorFilterTypeFFieldValue Property

Fieldvalue to evaluate. Ignored when Between qualifier is used.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FieldValue { get; set; }
Property FieldValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.FilterBetweenEndValue Property

ICursorFilterTypeFFilterBetweenEndValue Property

End value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterStartEndValue.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FilterBetweenEndValue { get; set; }
Property FilterBetweenEndValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.FilterBetweenStartValue Property

ICursorFilterTypeFFilterBetweenStartValue Property

Start value (inclusive) for filters with Between qualifier. Used only with Between qualifier. When this property is set, you must also set FilterBetweenEndValue.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FilterBetweenStartValue { get; set; }
Property FilterBetweenStartValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.FiltertypeIdentifier Property

ICursorFilterTypeFFiltertypeIdentifier Property

String representing the filtertype identifier for use in a Commence DDE request.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FiltertypeIdentifier { get; }
ReadOnly Property FiltertypeIdentifier As String
    Get

Property Value

Type: String

Implements

ICursorFilterFiltertypeIdentifier
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.MatchCase Property

ICursorFilterTypeFMatchCase Property

Case-sensitive parameter. Set to true for case-sensitive filter. Defaults to false.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool MatchCase { get; set; }
Property MatchCase As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.OrFilter Property

ICursorFilterTypeFOrFilter Property

Specify if this filter must be treated as an Or filter. Default is false.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool OrFilter { get; set; }
Property OrFilter As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICursorFilterOrFilter
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.Qualifier Property

ICursorFilterTypeFQualifier Property

Convenience property for the qualifier for in .NET applications. This property takes precedence over QualifierString.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
FilterQualifier Qualifier { get; set; }
Property Qualifier As FilterQualifier
    Get
    Set

Property Value

Type: FilterQualifier
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.QualifierString Property

ICursorFilterTypeFQualifierString Property

String value specifying how to evaluate the filtervalue. Not all qualifiers can be used on all field-types. See Commence ViewFilter documentation in DDE helpfile.

If you use COM, either use this member with the strings listed below, or supply the FilterQualifier enum value to Qualifier. .NET users are strongly encouraged to use Qualifier.

List of valid qualifier strings and the fields they can be applied to.

Qualifier string | Applies to fieldtype(s)
Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Not Equal To | Name, Calculation, E-mail, URL, Number, Selection, Sequence, Telephone, Text fields.
Less Than | Calculation, Number, Sequence number fields.
Greater Than | Calculation, Number, Sequence number fields.
Between | Name, Calculation, Date, E-mail, URL, Number, Sequence number, Time fields.
True | Checkbox fields.
False | Checkbox fields.
Checked | Checkbox fields.
Not Checked | Checkbox fields.
Yes | Checkbox fields.
No | Checkbox fields.
Before | Date, Time fields.
On | Date fields.
At | Time fields.
After | Date, Time fields.
Contains | Name, E-mail, URL, Telephone, Text fields.
Doesn't Contain | Name, E-mail, URL, Telephone, Text fields.
Shared | N/A when used with fields.
Local | N/A when used with fields.
1 | Checkbox fields.
0 | Checkbox fields.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string QualifierString { get; set; }
Property QualifierString As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.Shared Property

ICursorFilterTypeFShared Property

Filter for Local/Shared items.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Shared { get; set; }
Property Shared As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When set, fieldvalues are ignored.
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.SharedOptionSet Property

ICursorFilterTypeFSharedOptionSet Property

Keep track of whether the 'shared/local' option was set

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SharedOptionSet { get; }
ReadOnly Property SharedOptionSet As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF Methods

The ICursorFilterTypeF type exposes the following members.

Methods
 | Name | Description
Public method | GetViewFilterString | Returns the ViewFilter string, useful for debugging.
Public method | ToString | Overload allowing custom formatting. (Inherited from ICursorFilter.)
Top
See Also

Reference

ICursorFilterTypeF Interface


ICursorFilterTypeF.GetViewFilterString Method

ICursorFilterTypeFGetViewFilterString Method

Returns the ViewFilter string, useful for debugging.

Namespace: Vovin.CmcLibNet.Database
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string GetViewFilterString()
Function GetViewFilterString As String

Return Value

Type: String
fully formatted ViewFilter DDE command constructed by the ToString

Implements

ICursorFilterGetViewFilterString
See Also

Reference

ICursorFilterTypeF Interface


Vovin.CmcLibNet.Database.Metadata Namespace

Contains everything pertaining to metadata (schema) of the database.
Classes
 | Class | Description
Public class | ActiveViewInfo | Exposes properties of the currently active Commence view.
Public class | CategoryDef | Contains the category definition.
Public class | CommenceCategoryMetaData | Commence category metadata.
Public class | CommenceConnection | Describes a Commence connection.
Public class | CommenceFieldDefinition | Holds information on the field definition.
Public class | CommenceFieldMetaData | Commence field metadata.
Public class | CommenceFormMetaData | Commence Item detail form metadata.
Public class | CommenceViewMetaData | Commence view information.
Public class | DatabaseSchema | Schema information
Public class | DBDef | Holds information on the database definition.
Public class | MetaDataOptions | Options for generating metadata file.
Public class | ViewDef | Holds information on the view definition.
Interfaces
 | Interface | Description
Public interface | IActiveViewInfo | Exposes properties of the currently active Commence view.
Public interface | ICategoryDef | Exposes the category definition.
Public interface | ICommenceCategoryMetaData | Commence category metadata.
Public interface | ICommenceConnection | Describes a Commence connection.
Public interface | ICommenceFieldDefinition | Interface for the field definition.
Public interface | ICommenceFieldMetaData | Commence field metadata.
Public interface | ICommenceFormMetaData | Commence Item detail form metadata.
Public interface | ICommenceViewMetaData | Metadata of Commence view.
Public interface | IDatabaseSchema | Schema information
Public interface | IDBDef | Exposes members of the database definition.
Public interface | IMetaDataOptions | Options for generating metadata file.
Public interface | IViewDef | Exposes view definition.
Enumerations
 | Enumeration | Description
Public enumeration | MetaDataFormat | Formats that schema information can be written to.


ActiveViewInfo Class

Exposes properties of the currently active Commence view.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataActiveViewInfo

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class ActiveViewInfo : IActiveViewInfo
Public Class ActiveViewInfo
    Implements IActiveViewInfo

The ActiveViewInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying view category.
Public property | Field | Currently active fieldname (if view is a detail form).
Public property | Item | Current itemname (if view is a detail form).
Public property | Name | Name of the view.
Public property | Type | Type of the view.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


ActiveViewInfo Properties

The ActiveViewInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying view category.
Public property | Field | Currently active fieldname (if view is a detail form).
Public property | Item | Current itemname (if view is a detail form).
Public property | Name | Name of the view.
Public property | Type | Type of the view.
Top
See Also

Reference

ActiveViewInfo Class
Vovin.CmcLibNet.Database.Metadata Namespace


ActiveViewInfo.Category Property

ActiveViewInfoCategory Property

Underlying view category.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get

Property Value

Type: String

Implements

IActiveViewInfoCategory
See Also

Reference

ActiveViewInfo Class
Vovin.CmcLibNet.Database.Metadata Namespace


ActiveViewInfo.Field Property

ActiveViewInfoField Property

Currently active fieldname (if view is a detail form).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Field { get; }
Public ReadOnly Property Field As String
    Get

Property Value

Type: String

Implements

IActiveViewInfoField
See Also

Reference

ActiveViewInfo Class
Vovin.CmcLibNet.Database.Metadata Namespace


ActiveViewInfo.Item Property

ActiveViewInfoItem Property

Current itemname (if view is a detail form).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Item { get; }
Public ReadOnly Property Item As String
    Get

Property Value

Type: String

Implements

IActiveViewInfoItem
See Also

Reference

ActiveViewInfo Class
Vovin.CmcLibNet.Database.Metadata Namespace


ActiveViewInfo.Name Property

ActiveViewInfoName Property

Name of the view.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Implements

IActiveViewInfoName
See Also

Reference

ActiveViewInfo Class
Vovin.CmcLibNet.Database.Metadata Namespace


ActiveViewInfo.Type Property

ActiveViewInfoType Property

Type of the view.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Type { get; }
Public ReadOnly Property Type As String
    Get

Property Value

Type: String

Implements

IActiveViewInfoType
See Also

Reference

ActiveViewInfo Class
Vovin.CmcLibNet.Database.Metadata Namespace


ActiveViewInfo Methods

The ActiveViewInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActiveViewInfo Class
Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef Class

Contains the category definition.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataCategoryDef

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CategoryDef : ICategoryDef
<SerializableAttribute>
Public Class CategoryDef
    Implements ICategoryDef

The CategoryDef type exposes the following members.

Properties
 | Name | Description
Public property | CategoryID | Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items.
Public property | Clarified | Indicates if the category is defines to use a clarifier.
Public property | ClarifyField | Returns the clarify field (if any).
Public property | ClarifySeparator | Returns the clarify separator (if any).
Public property | Duplicates | Indicates if the category allows duplicate items.
Public property | MaxItems | Number of items a category can hold.
Public property | Shared | Indicates whether the category is shared.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef Properties

The CategoryDef type exposes the following members.

Properties
 | Name | Description
Public property | CategoryID | Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items.
Public property | Clarified | Indicates if the category is defines to use a clarifier.
Public property | ClarifyField | Returns the clarify field (if any).
Public property | ClarifySeparator | Returns the clarify separator (if any).
Public property | Duplicates | Indicates if the category allows duplicate items.
Public property | MaxItems | Number of items a category can hold.
Public property | Shared | Indicates whether the category is shared.
Top
See Also

Reference

CategoryDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef.CategoryID Property

CategoryDefCategoryID Property

Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int CategoryID { get; }
Public ReadOnly Property CategoryID As Integer
    Get

Property Value

Type: Int32

Implements

ICategoryDefCategoryID
Remarks
The category ID returned by this call is always a snapshot value and it is only valid for the current database even when it is part of a workgroup.

Example: A 'Person' category in one client may have a different id on another client, even when they are in the same workgroup.

Category IDs are reused in Commence. Examples:

If you delete category X and recreate it with the same name, it may get another id than it had before. If you delete category X and create another category Y, it may get the id category X had.

Do not build persistent key-value pairs of categories and ids but always use whatever Commence provides. As part of the synchronization process (in a workgroup) it will provide several files which will contain the current lookup tables.

There is an edge situation in which the ID will not be obtainable: if a category is intentionally empty and 'protected' by a Commence Agent that automatically deletes new items as soon as they are created, this property will always return -1.

An intentionally empty category is not as exotic as it may seem. An example of such a category is one that is one that only contains Item Detail Forms that perform specialized scripting, or a category that contains highly customized Report Viewer reports.

When the ID cannot be obtained by CategoryID, the only way to get the ID is to manually look it up in Help | System Information | Category Information.

See Also

Reference

CategoryDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef.Clarified Property

CategoryDefClarified Property

Indicates if the category is defines to use a clarifier.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Clarified { get; }
Public ReadOnly Property Clarified As Boolean
    Get

Property Value

Type: Boolean

Implements

ICategoryDefClarified
See Also

Reference

CategoryDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef.ClarifyField Property

CategoryDefClarifyField Property

Returns the clarify field (if any).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClarifyField { get; }
Public ReadOnly Property ClarifyField As String
    Get

Property Value

Type: String

Implements

ICategoryDefClarifyField
See Also

Reference

CategoryDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef.ClarifySeparator Property

CategoryDefClarifySeparator Property

Returns the clarify separator (if any).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClarifySeparator { get; }
Public ReadOnly Property ClarifySeparator As String
    Get

Property Value

Type: String

Implements

ICategoryDefClarifySeparator
See Also

Reference

CategoryDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef.Duplicates Property

CategoryDefDuplicates Property

Indicates if the category allows duplicate items.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Duplicates { get; }
Public ReadOnly Property Duplicates As Boolean
    Get

Property Value

Type: Boolean

Implements

ICategoryDefDuplicates
See Also

Reference

CategoryDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef.MaxItems Property

CategoryDefMaxItems Property

Number of items a category can hold.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int MaxItems { get; }
Public ReadOnly Property MaxItems As Integer
    Get

Property Value

Type: Int32

Implements

ICategoryDefMaxItems
Remarks
Up until at least Commence RM 6.1, Commence has a hardcoded limit of 500.000 items per category, no matter what this property will report.
See Also

Reference

CategoryDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef.Shared Property

CategoryDefShared Property

Indicates whether the category is shared.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Shared { get; }
Public ReadOnly Property Shared As Boolean
    Get

Property Value

Type: Boolean

Implements

ICategoryDefShared
See Also

Reference

CategoryDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


CategoryDef Methods

The CategoryDef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CategoryDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData Class

Commence category metadata.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataCommenceCategoryMetaData

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommenceCategoryMetaData : ICommenceCategoryMetaData,
    ICategoryDef
<SerializableAttribute>
Public Class CommenceCategoryMetaData
    Implements ICommenceCategoryMetaData, ICategoryDef

The CommenceCategoryMetaData type exposes the following members.

Properties
 | Name | Description
Public property | CategoryID | Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items.
Public property | Clarified | Indicates if the category is defines to use a clarifier.
Public property | ClarifyField | Returns the clarify field (if any).
Public property | ClarifySeparator | Returns the clarify separator (if any).
Public property | Connections | Connections.
Public property | Duplicates | Indicates if the category allows duplicate items.
Public property | Fields | Fields.
Public property | Forms | Forms.
Public property | Items | Number of items.
Public property | MaxItems | Number of items a category can hold.
Public property | Name | Category name.
Public property | Shared | Indicates whether the category is shared.
Public property | Views | Views.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData Properties

The CommenceCategoryMetaData type exposes the following members.

Properties
 | Name | Description
Public property | CategoryID | Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items.
Public property | Clarified | Indicates if the category is defines to use a clarifier.
Public property | ClarifyField | Returns the clarify field (if any).
Public property | ClarifySeparator | Returns the clarify separator (if any).
Public property | Connections | Connections.
Public property | Duplicates | Indicates if the category allows duplicate items.
Public property | Fields | Fields.
Public property | Forms | Forms.
Public property | Items | Number of items.
Public property | MaxItems | Number of items a category can hold.
Public property | Name | Category name.
Public property | Shared | Indicates whether the category is shared.
Public property | Views | Views.
Top
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.CategoryID Property

CommenceCategoryMetaDataCategoryID Property

Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int CategoryID { get; set; }
Public Property CategoryID As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICategoryDefCategoryID
Remarks
The category ID returned by this call is always a snapshot value and it is only valid for the current database even when it is part of a workgroup.

Example: A 'Person' category in one client may have a different id on another client, even when they are in the same workgroup.

Category IDs are reused in Commence. Examples:

If you delete category X and recreate it with the same name, it may get another id than it had before. If you delete category X and create another category Y, it may get the id category X had.

Do not build persistent key-value pairs of categories and ids but always use whatever Commence provides. As part of the synchronization process (in a workgroup) it will provide several files which will contain the current lookup tables.

There is an edge situation in which the ID will not be obtainable: if a category is intentionally empty and 'protected' by a Commence Agent that automatically deletes new items as soon as they are created, this property will always return -1.

An intentionally empty category is not as exotic as it may seem. An example of such a category is one that is one that only contains Item Detail Forms that perform specialized scripting, or a category that contains highly customized Report Viewer reports.

When the ID cannot be obtained by CategoryID, the only way to get the ID is to manually look it up in Help | System Information | Category Information.

See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.Clarified Property

CommenceCategoryMetaDataClarified Property

Indicates if the category is defines to use a clarifier.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Clarified { get; set; }
Public Property Clarified As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICategoryDefClarified
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.ClarifyField Property

CommenceCategoryMetaDataClarifyField Property

Returns the clarify field (if any).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClarifyField { get; set; }
Public Property ClarifyField As String
    Get
    Set

Property Value

Type: String

Implements

ICategoryDefClarifyField
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.ClarifySeparator Property

CommenceCategoryMetaDataClarifySeparator Property

Returns the clarify separator (if any).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ClarifySeparator { get; set; }
Public Property ClarifySeparator As String
    Get
    Set

Property Value

Type: String

Implements

ICategoryDefClarifySeparator
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.Connections Property

CommenceCategoryMetaDataConnections Property

Connections.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<CommenceConnection> Connections { get; set; }
Public Property Connections As List(Of CommenceConnection)
    Get
    Set

Property Value

Type: List CommenceConnection

Implements

ICommenceCategoryMetaDataConnections
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.Duplicates Property

CommenceCategoryMetaDataDuplicates Property

Indicates if the category allows duplicate items.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Duplicates { get; set; }
Public Property Duplicates As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICategoryDefDuplicates
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.Fields Property

CommenceCategoryMetaDataFields Property

Fields.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<CommenceFieldMetaData> Fields { get; set; }
Public Property Fields As List(Of CommenceFieldMetaData)
    Get
    Set

Property Value

Type: List CommenceFieldMetaData

Implements

ICommenceCategoryMetaDataFields
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.Forms Property

CommenceCategoryMetaDataForms Property

Forms.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<CommenceFormMetaData> Forms { get; set; }
Public Property Forms As List(Of CommenceFormMetaData)
    Get
    Set

Property Value

Type: List CommenceFormMetaData

Implements

ICommenceCategoryMetaDataForms
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.Items Property

CommenceCategoryMetaDataItems Property

Number of items.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int Items { get; set; }
Public Property Items As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICommenceCategoryMetaDataItems
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.MaxItems Property

CommenceCategoryMetaDataMaxItems Property

Number of items a category can hold.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int MaxItems { get; set; }
Public Property MaxItems As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICategoryDefMaxItems
Remarks
Up until at least Commence RM 6.1, Commence has a hardcoded limit of 500.000 items per category, no matter what this property will report.
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.Name Property

CommenceCategoryMetaDataName Property

Category name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceCategoryMetaDataName
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.Shared Property

CommenceCategoryMetaDataShared Property

Indicates whether the category is shared.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Shared { get; set; }
Public Property Shared As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICategoryDefShared
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData.Views Property

CommenceCategoryMetaDataViews Property

Views.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<CommenceViewMetaData> Views { get; set; }
Public Property Views As List(Of CommenceViewMetaData)
    Get
    Set

Property Value

Type: List CommenceViewMetaData

Implements

ICommenceCategoryMetaDataViews
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceCategoryMetaData Methods

The CommenceCategoryMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceCategoryMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceConnection Class

Describes a Commence connection.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataCommenceConnection

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommenceConnection : ICommenceConnection
<SerializableAttribute>
Public Class CommenceConnection
    Implements ICommenceConnection

The CommenceConnection type exposes the following members.

Constructors
 | Name | Description
Public method | CommenceConnection | Initializes a new instance of the CommenceConnection class
Top
Properties
 | Name | Description
Public property | FullName | Fully qualified name
Public property | Name | Name of connection.
Public property | ToCategory | Connected category name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


CommenceConnection Constructor

Initializes a new instance of the CommenceConnection class

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceConnection()
Public Sub New
See Also

Reference

CommenceConnection Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceConnection Properties

The CommenceConnection type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Fully qualified name
Public property | Name | Name of connection.
Public property | ToCategory | Connected category name.
Top
See Also

Reference

CommenceConnection Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceConnection.FullName Property

CommenceConnectionFullName Property

Fully qualified name

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceConnectionFullName
Exceptions
Exception | Condition
NullReferenceException | Name or ToCategory not specfied.
See Also

Reference

CommenceConnection Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceConnection.Name Property

CommenceConnectionName Property

Name of connection.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceConnectionName
See Also

Reference

CommenceConnection Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceConnection.ToCategory Property

CommenceConnectionToCategory Property

Connected category name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ToCategory { get; set; }
Public Property ToCategory As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceConnectionToCategory
See Also

Reference

CommenceConnection Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceConnection Methods

The CommenceConnection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceConnection Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition Class

Holds information on the field definition.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataCommenceFieldDefinition

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class CommenceFieldDefinition : ICommenceFieldDefinition
Public Class CommenceFieldDefinition
    Implements ICommenceFieldDefinition

The CommenceFieldDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Combobox | Indicates if field is a combobox.
Public property | DefaultString | Default fielvalue (if any).
Public property | Mandatory | Indicates if field is mandatory.
Public property | MaxChars | Maximum number of characters field can hold.
Public property | Recurring | Indicates if field is a recurring date field.
Public property | Shared | Indicates if field is shared.
Public property | Type | Field type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition Properties

The CommenceFieldDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Combobox | Indicates if field is a combobox.
Public property | DefaultString | Default fielvalue (if any).
Public property | Mandatory | Indicates if field is mandatory.
Public property | MaxChars | Maximum number of characters field can hold.
Public property | Recurring | Indicates if field is a recurring date field.
Public property | Shared | Indicates if field is shared.
Public property | Type | Field type.
Top
See Also

Reference

CommenceFieldDefinition Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition.Combobox Property

CommenceFieldDefinitionCombobox Property

Indicates if field is a combobox.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Combobox { get; }
Public ReadOnly Property Combobox As Boolean
    Get

Property Value

Type: Boolean

Implements

ICommenceFieldDefinitionCombobox
See Also

Reference

CommenceFieldDefinition Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition.DefaultString Property

CommenceFieldDefinitionDefaultString Property

Default fielvalue (if any).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string DefaultString { get; }
Public ReadOnly Property DefaultString As String
    Get

Property Value

Type: String

Implements

ICommenceFieldDefinitionDefaultString
See Also

Reference

CommenceFieldDefinition Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition.Mandatory Property

CommenceFieldDefinitionMandatory Property

Indicates if field is mandatory.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Mandatory { get; }
Public ReadOnly Property Mandatory As Boolean
    Get

Property Value

Type: Boolean

Implements

ICommenceFieldDefinitionMandatory
See Also

Reference

CommenceFieldDefinition Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition.MaxChars Property

CommenceFieldDefinitionMaxChars Property

Maximum number of characters field can hold.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int MaxChars { get; }
Public ReadOnly Property MaxChars As Integer
    Get

Property Value

Type: Int32

Implements

ICommenceFieldDefinitionMaxChars
See Also

Reference

CommenceFieldDefinition Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition.Recurring Property

CommenceFieldDefinitionRecurring Property

Indicates if field is a recurring date field.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Recurring { get; }
Public ReadOnly Property Recurring As Boolean
    Get

Property Value

Type: Boolean

Implements

ICommenceFieldDefinitionRecurring
See Also

Reference

CommenceFieldDefinition Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition.Shared Property

CommenceFieldDefinitionShared Property

Indicates if field is shared.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Shared { get; }
Public ReadOnly Property Shared As Boolean
    Get

Property Value

Type: Boolean

Implements

ICommenceFieldDefinitionShared
See Also

Reference

CommenceFieldDefinition Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition.Type Property

CommenceFieldDefinitionType Property

Field type.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceFieldType Type { get; }
Public ReadOnly Property Type As CommenceFieldType
    Get

Property Value

Type: CommenceFieldType

Implements

ICommenceFieldDefinitionType
See Also

Reference

CommenceFieldDefinition Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldDefinition Methods

The CommenceFieldDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceFieldDefinition Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData Class

Commence field metadata.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataCommenceFieldMetaData

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommenceFieldMetaData : ICommenceFieldMetaData,
    ICommenceFieldDefinition
<SerializableAttribute>
Public Class CommenceFieldMetaData
    Implements ICommenceFieldMetaData, ICommenceFieldDefinition

The CommenceFieldMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Combobox | Indicates if field is a combobox.
Public property | DefaultString | Default fielvalue (if any).
Public property | Mandatory | Indicates if field is mandatory.
Public property | MaxChars | Maximum number of characters field can hold.
Public property | Name | Field name.
Public property | Recurring | Indicates if field is a recurring date field.
Public property | Shared | Indicates if field is shared.
Public property | Type | Field type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData Properties

The CommenceFieldMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Combobox | Indicates if field is a combobox.
Public property | DefaultString | Default fielvalue (if any).
Public property | Mandatory | Indicates if field is mandatory.
Public property | MaxChars | Maximum number of characters field can hold.
Public property | Name | Field name.
Public property | Recurring | Indicates if field is a recurring date field.
Public property | Shared | Indicates if field is shared.
Public property | Type | Field type.
Top
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData.Combobox Property

CommenceFieldMetaDataCombobox Property

Indicates if field is a combobox.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Combobox { get; set; }
Public Property Combobox As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICommenceFieldDefinitionCombobox
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData.DefaultString Property

CommenceFieldMetaDataDefaultString Property

Default fielvalue (if any).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string DefaultString { get; set; }
Public Property DefaultString As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceFieldDefinitionDefaultString
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData.Mandatory Property

CommenceFieldMetaDataMandatory Property

Indicates if field is mandatory.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Mandatory { get; set; }
Public Property Mandatory As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICommenceFieldDefinitionMandatory
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData.MaxChars Property

CommenceFieldMetaDataMaxChars Property

Maximum number of characters field can hold.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int MaxChars { get; set; }
Public Property MaxChars As Integer
    Get
    Set

Property Value

Type: Int32

Implements

ICommenceFieldDefinitionMaxChars
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData.Name Property

CommenceFieldMetaDataName Property

Field name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceFieldMetaDataName
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData.Recurring Property

CommenceFieldMetaDataRecurring Property

Indicates if field is a recurring date field.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Recurring { get; set; }
Public Property Recurring As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICommenceFieldDefinitionRecurring
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData.Shared Property

CommenceFieldMetaDataShared Property

Indicates if field is shared.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Shared { get; set; }
Public Property Shared As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

ICommenceFieldDefinitionShared
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData.Type Property

CommenceFieldMetaDataType Property

Field type.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public CommenceFieldType Type { get; }
Public ReadOnly Property Type As CommenceFieldType
    Get

Property Value

Type: CommenceFieldType

Implements

ICommenceFieldDefinitionType
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFieldMetaData Methods

The CommenceFieldMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceFieldMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFormMetaData Class

Commence Item detail form metadata.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataCommenceFormMetaData

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommenceFormMetaData : ICommenceFormMetaData
<SerializableAttribute>
Public Class CommenceFormMetaData
    Implements ICommenceFormMetaData

The CommenceFormMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Category | Categoryname.
Public property | Name | Form name.
Public property | Path | Form filepath.
Public property | Script | Form script.
Public property | Xml | Form XML.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFormMetaData Properties

The CommenceFormMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Category | Categoryname.
Public property | Name | Form name.
Public property | Path | Form filepath.
Public property | Script | Form script.
Public property | Xml | Form XML.
Top
See Also

Reference

CommenceFormMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFormMetaData.Category Property

CommenceFormMetaDataCategory Property

Categoryname.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceFormMetaDataCategory
See Also

Reference

CommenceFormMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFormMetaData.Name Property

CommenceFormMetaDataName Property

Form name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceFormMetaDataName
See Also

Reference

CommenceFormMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFormMetaData.Path Property

CommenceFormMetaDataPath Property

Form filepath.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceFormMetaDataPath
See Also

Reference

CommenceFormMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFormMetaData.Script Property

CommenceFormMetaDataScript Property

Form script.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Script { get; set; }
Public Property Script As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceFormMetaDataScript
See Also

Reference

CommenceFormMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFormMetaData.Xml Property

CommenceFormMetaDataXml Property

Form XML.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Xml { get; set; }
Public Property Xml As String
    Get
    Set

Property Value

Type: String

Implements

ICommenceFormMetaDataXml
See Also

Reference

CommenceFormMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceFormMetaData Methods

The CommenceFormMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceFormMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceViewMetaData Class

Commence view information.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataCommenceViewMetaData

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommenceViewMetaData : ICommenceViewMetaData,
    IViewDef
<SerializableAttribute>
Public Class CommenceViewMetaData
    Implements ICommenceViewMetaData, IViewDef

The CommenceViewMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying Commence category.
Public property | FileName | Filename (e.g. for Report Views).
Public property | Name | View name.
Public property | Type | View Type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


CommenceViewMetaData Properties

The CommenceViewMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying Commence category.
Public property | FileName | Filename (e.g. for Report Views).
Public property | Name | View name.
Public property | Type | View Type.
Top
See Also

Reference

CommenceViewMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceViewMetaData.Category Property

CommenceViewMetaDataCategory Property

Underlying Commence category.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set

Property Value

Type: String

Implements

IViewDefCategory
See Also

Reference

CommenceViewMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceViewMetaData.FileName Property

CommenceViewMetaDataFileName Property

Filename (e.g. for Report Views).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String

Implements

IViewDefFileName
See Also

Reference

CommenceViewMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceViewMetaData.Name Property

CommenceViewMetaDataName Property

View name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

IViewDefName
See Also

Reference

CommenceViewMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceViewMetaData.Type Property

CommenceViewMetaDataType Property

View Type.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set

Property Value

Type: String

Implements

IViewDefType
See Also

Reference

CommenceViewMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


CommenceViewMetaData Methods

The CommenceViewMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommenceViewMetaData Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema Class

Schema information
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataDatabaseSchema

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DatabaseSchema : IDatabaseSchema,
    IDBDef
<SerializableAttribute>
Public Class DatabaseSchema
    Implements IDatabaseSchema, IDBDef

The DatabaseSchema type exposes the following members.

Properties
 | Name | Description
Public property | Attached | Indicates if database is attached, whatever that may mean.
Public property | Categories | Categories.
Public property | Connected | Indicates if field is connected, whatever that may mean.
Public property | IsClient | Indicates if database is a client in a workgroup.
Public property | IsServer | Indicates if database is a server in a workgroup.
Public property | Name | Database name.
Public property | Path | Database path.
Public property | Size | Database size (combined size of database directory)
Public property | Spoolpath | Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set.
Public property | Username | Login name of the user (only applies to password-protected databases).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
Exposes concrete objects and not interfaces because of XML serialization requirement.
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema Properties

The DatabaseSchema type exposes the following members.

Properties
 | Name | Description
Public property | Attached | Indicates if database is attached, whatever that may mean.
Public property | Categories | Categories.
Public property | Connected | Indicates if field is connected, whatever that may mean.
Public property | IsClient | Indicates if database is a client in a workgroup.
Public property | IsServer | Indicates if database is a server in a workgroup.
Public property | Name | Database name.
Public property | Path | Database path.
Public property | Size | Database size (combined size of database directory)
Public property | Spoolpath | Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set.
Public property | Username | Login name of the user (only applies to password-protected databases).
Top
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.Attached Property

DatabaseSchemaAttached Property

Indicates if database is attached, whatever that may mean.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Attached { get; set; }
Public Property Attached As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IDBDefAttached
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.Categories Property

DatabaseSchemaCategories Property

Categories.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public List<CommenceCategoryMetaData> Categories { get; }
Public ReadOnly Property Categories As List(Of CommenceCategoryMetaData)
    Get

Property Value

Type: List CommenceCategoryMetaData

Implements

IDatabaseSchemaCategories
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.Connected Property

DatabaseSchemaConnected Property

Indicates if field is connected, whatever that may mean.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Connected { get; set; }
Public Property Connected As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IDBDefConnected
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.IsClient Property

DatabaseSchemaIsClient Property

Indicates if database is a client in a workgroup.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool IsClient { get; set; }
Public Property IsClient As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IDBDefIsClient
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.IsServer Property

DatabaseSchemaIsServer Property

Indicates if database is a server in a workgroup.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool IsServer { get; set; }
Public Property IsServer As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IDBDefIsServer
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.Name Property

DatabaseSchemaName Property

Database name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

IDBDefName
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.Path Property

DatabaseSchemaPath Property

Database path.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set

Property Value

Type: String

Implements

IDBDefPath
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.Size Property

DatabaseSchemaSize Property

Database size (combined size of database directory)

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public long Size { get; set; }
Public Property Size As Long
    Get
    Set

Property Value

Type: Int64

Implements

IDatabaseSchemaSize
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.Spoolpath Property

DatabaseSchemaSpoolpath Property

Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Spoolpath { get; set; }
Public Property Spoolpath As String
    Get
    Set

Property Value

Type: String

Implements

IDBDefSpoolpath
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema.Username Property

DatabaseSchemaUsername Property

Login name of the user (only applies to password-protected databases).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Username { get; set; }
Public Property Username As String
    Get
    Set

Property Value

Type: String

Implements

IDBDefUsername
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DatabaseSchema Methods

The DatabaseSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DatabaseSchema Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef Class

Holds information on the database definition.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataDBDef

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DBDef : IDBDef
<SerializableAttribute>
Public Class DBDef
    Implements IDBDef

The DBDef type exposes the following members.

Properties
 | Name | Description
Public property | Attached | Indicates if database is attached, whatever that may mean.
Public property | Connected | Indicates if field is connected, whatever that may mean.
Public property | IsClient | Indicates if database is a client in a workgroup.
Public property | IsServer | Indicates if database is a server in a workgroup.
Public property | Name | Database name.
Public property | Path | Database path.
Public property | Spoolpath | Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set.
Public property | Username | Login name of the user (only applies to password-protected databases).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


DBDef Properties

The DBDef type exposes the following members.

Properties
 | Name | Description
Public property | Attached | Indicates if database is attached, whatever that may mean.
Public property | Connected | Indicates if field is connected, whatever that may mean.
Public property | IsClient | Indicates if database is a client in a workgroup.
Public property | IsServer | Indicates if database is a server in a workgroup.
Public property | Name | Database name.
Public property | Path | Database path.
Public property | Spoolpath | Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set.
Public property | Username | Login name of the user (only applies to password-protected databases).
Top
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef.Attached Property

DBDefAttached Property

Indicates if database is attached, whatever that may mean.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Attached { get; }
Public ReadOnly Property Attached As Boolean
    Get

Property Value

Type: Boolean

Implements

IDBDefAttached
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef.Connected Property

DBDefConnected Property

Indicates if field is connected, whatever that may mean.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Connected { get; }
Public ReadOnly Property Connected As Boolean
    Get

Property Value

Type: Boolean

Implements

IDBDefConnected
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef.IsClient Property

DBDefIsClient Property

Indicates if database is a client in a workgroup.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool IsClient { get; }
Public ReadOnly Property IsClient As Boolean
    Get

Property Value

Type: Boolean

Implements

IDBDefIsClient
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef.IsServer Property

DBDefIsServer Property

Indicates if database is a server in a workgroup.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool IsServer { get; }
Public ReadOnly Property IsServer As Boolean
    Get

Property Value

Type: Boolean

Implements

IDBDefIsServer
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef.Name Property

DBDefName Property

Database name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Implements

IDBDefName
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef.Path Property

DBDefPath Property

Database path.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get

Property Value

Type: String

Implements

IDBDefPath
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef.Spoolpath Property

DBDefSpoolpath Property

Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Spoolpath { get; }
Public ReadOnly Property Spoolpath As String
    Get

Property Value

Type: String

Implements

IDBDefSpoolpath
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef.Username Property

DBDefUsername Property

Login name of the user (only applies to password-protected databases).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Username { get; }
Public ReadOnly Property Username As String
    Get

Property Value

Type: String

Implements

IDBDefUsername
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


DBDef Methods

The DBDef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DBDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


IActiveViewInfo Interface

Exposes properties of the currently active Commence view.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IActiveViewInfo
Public Interface IActiveViewInfo

The IActiveViewInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying view category.
Public property | Field | Currently active fieldname (if view is a detail form).
Public property | Item | Current itemname (if view is a detail form).
Public property | Name | Name of the view.
Public property | Type | Type of the view.
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


IActiveViewInfo Properties

The IActiveViewInfo type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying view category.
Public property | Field | Currently active fieldname (if view is a detail form).
Public property | Item | Current itemname (if view is a detail form).
Public property | Name | Name of the view.
Public property | Type | Type of the view.
Top
See Also

Reference

IActiveViewInfo Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IActiveViewInfo.Category Property

IActiveViewInfoCategory Property

Underlying view category.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Category { get; }
ReadOnly Property Category As String
    Get

Property Value

Type: String
See Also

Reference

IActiveViewInfo Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IActiveViewInfo.Field Property

IActiveViewInfoField Property

Currently active fieldname (if view is a detail form).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Field { get; }
ReadOnly Property Field As String
    Get

Property Value

Type: String
See Also

Reference

IActiveViewInfo Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IActiveViewInfo.Item Property

IActiveViewInfoItem Property

Current itemname (if view is a detail form).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Item { get; }
ReadOnly Property Item As String
    Get

Property Value

Type: String
See Also

Reference

IActiveViewInfo Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IActiveViewInfo.Name Property

IActiveViewInfoName Property

Name of the view.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

IActiveViewInfo Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IActiveViewInfo.Type Property

IActiveViewInfoType Property

Type of the view.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Type { get; }
ReadOnly Property Type As String
    Get

Property Value

Type: String
See Also

Reference

IActiveViewInfo Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICategoryDef Interface

Exposes the category definition.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICategoryDef
Public Interface ICategoryDef

The ICategoryDef type exposes the following members.

Properties
 | Name | Description
Public property | CategoryID | Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items.
Public property | Clarified | Indicates if the category is defines to use a clarifier.
Public property | ClarifyField | Returns the clarify field (if any).
Public property | ClarifySeparator | Returns the clarify separator (if any).
Public property | Duplicates | Indicates if the category allows duplicate items.
Public property | MaxItems | Number of items a category can hold.
Public property | Shared | Indicates whether the category is shared.
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


ICategoryDef Properties

The ICategoryDef type exposes the following members.

Properties
 | Name | Description
Public property | CategoryID | Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items.
Public property | Clarified | Indicates if the category is defines to use a clarifier.
Public property | ClarifyField | Returns the clarify field (if any).
Public property | ClarifySeparator | Returns the clarify separator (if any).
Public property | Duplicates | Indicates if the category allows duplicate items.
Public property | MaxItems | Number of items a category can hold.
Public property | Shared | Indicates whether the category is shared.
Top
See Also

Reference

ICategoryDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICategoryDef.CategoryID Property

ICategoryDefCategoryID Property

Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int CategoryID { get; }
ReadOnly Property CategoryID As Integer
    Get

Property Value

Type: Int32
Remarks
The category ID returned by this call is always a snapshot value and it is only valid for the current database even when it is part of a workgroup.

Example: A 'Person' category in one client may have a different id on another client, even when they are in the same workgroup.

Category IDs are reused in Commence. Examples:

If you delete category X and recreate it with the same name, it may get another id than it had before. If you delete category X and create another category Y, it may get the id category X had.

Do not build persistent key-value pairs of categories and ids but always use whatever Commence provides. As part of the synchronization process (in a workgroup) it will provide several files which will contain the current lookup tables.

There is an edge situation in which the ID will not be obtainable: if a category is intentionally empty and 'protected' by a Commence Agent that automatically deletes new items as soon as they are created, this property will always return -1.

An intentionally empty category is not as exotic as it may seem. An example of such a category is one that is one that only contains Item Detail Forms that perform specialized scripting, or a category that contains highly customized Report Viewer reports.

When the ID cannot be obtained by CategoryID, the only way to get the ID is to manually look it up in Help | System Information | Category Information.

See Also

Reference

ICategoryDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICategoryDef.Clarified Property

ICategoryDefClarified Property

Indicates if the category is defines to use a clarifier.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Clarified { get; }
ReadOnly Property Clarified As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICategoryDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICategoryDef.ClarifyField Property

ICategoryDefClarifyField Property

Returns the clarify field (if any).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ClarifyField { get; }
ReadOnly Property ClarifyField As String
    Get

Property Value

Type: String
See Also

Reference

ICategoryDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICategoryDef.ClarifySeparator Property

ICategoryDefClarifySeparator Property

Returns the clarify separator (if any).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ClarifySeparator { get; }
ReadOnly Property ClarifySeparator As String
    Get

Property Value

Type: String
See Also

Reference

ICategoryDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICategoryDef.Duplicates Property

ICategoryDefDuplicates Property

Indicates if the category allows duplicate items.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Duplicates { get; }
ReadOnly Property Duplicates As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICategoryDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICategoryDef.MaxItems Property

ICategoryDefMaxItems Property

Number of items a category can hold.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int MaxItems { get; }
ReadOnly Property MaxItems As Integer
    Get

Property Value

Type: Int32
Remarks
Up until at least Commence RM 6.1, Commence has a hardcoded limit of 500.000 items per category, no matter what this property will report.
See Also

Reference

ICategoryDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICategoryDef.Shared Property

ICategoryDefShared Property

Indicates whether the category is shared.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Shared { get; }
ReadOnly Property Shared As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICategoryDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceCategoryMetaData Interface

Commence category metadata.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceCategoryMetaData : ICategoryDef
Public Interface ICommenceCategoryMetaData
    Inherits ICategoryDef

The ICommenceCategoryMetaData type exposes the following members.

Properties
 | Name | Description
Public property | CategoryID | Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items. (Inherited from ICategoryDef.)
Public property | Clarified | Indicates if the category is defines to use a clarifier. (Inherited from ICategoryDef.)
Public property | ClarifyField | Returns the clarify field (if any). (Inherited from ICategoryDef.)
Public property | ClarifySeparator | Returns the clarify separator (if any). (Inherited from ICategoryDef.)
Public property | Connections | Connections.
Public property | Duplicates | Indicates if the category allows duplicate items. (Inherited from ICategoryDef.)
Public property | Fields | Fields.
Public property | Forms | Forms.
Public property | Items | Number of items.
Public property | MaxItems | Number of items a category can hold. (Inherited from ICategoryDef.)
Public property | Name | Category name.
Public property | Shared | Indicates whether the category is shared. (Inherited from ICategoryDef.)
Public property | Views | Views.
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceCategoryMetaData Properties

The ICommenceCategoryMetaData type exposes the following members.

Properties
 | Name | Description
Public property | CategoryID | Returns the category ID, -1 on error. The ID is a sequence number Commence uses to identify categories. No ID can be obtained if the category contains no items. (Inherited from ICategoryDef.)
Public property | Clarified | Indicates if the category is defines to use a clarifier. (Inherited from ICategoryDef.)
Public property | ClarifyField | Returns the clarify field (if any). (Inherited from ICategoryDef.)
Public property | ClarifySeparator | Returns the clarify separator (if any). (Inherited from ICategoryDef.)
Public property | Connections | Connections.
Public property | Duplicates | Indicates if the category allows duplicate items. (Inherited from ICategoryDef.)
Public property | Fields | Fields.
Public property | Forms | Forms.
Public property | Items | Number of items.
Public property | MaxItems | Number of items a category can hold. (Inherited from ICategoryDef.)
Public property | Name | Category name.
Public property | Shared | Indicates whether the category is shared. (Inherited from ICategoryDef.)
Public property | Views | Views.
Top
See Also

Reference

ICommenceCategoryMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceCategoryMetaData.Connections Property

ICommenceCategoryMetaDataConnections Property

Connections.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<CommenceConnection> Connections { get; }
ReadOnly Property Connections As List(Of CommenceConnection)
    Get

Property Value

Type: List CommenceConnection
See Also

Reference

ICommenceCategoryMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceCategoryMetaData.Fields Property

ICommenceCategoryMetaDataFields Property

Fields.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<CommenceFieldMetaData> Fields { get; }
ReadOnly Property Fields As List(Of CommenceFieldMetaData)
    Get

Property Value

Type: List CommenceFieldMetaData
See Also

Reference

ICommenceCategoryMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceCategoryMetaData.Forms Property

ICommenceCategoryMetaDataForms Property

Forms.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<CommenceFormMetaData> Forms { get; }
ReadOnly Property Forms As List(Of CommenceFormMetaData)
    Get

Property Value

Type: List CommenceFormMetaData
See Also

Reference

ICommenceCategoryMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceCategoryMetaData.Items Property

ICommenceCategoryMetaDataItems Property

Number of items.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int Items { get; }
ReadOnly Property Items As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ICommenceCategoryMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceCategoryMetaData.Name Property

ICommenceCategoryMetaDataName Property

Category name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceCategoryMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceCategoryMetaData.Views Property

ICommenceCategoryMetaDataViews Property

Views.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<CommenceViewMetaData> Views { get; }
ReadOnly Property Views As List(Of CommenceViewMetaData)
    Get

Property Value

Type: List CommenceViewMetaData
See Also

Reference

ICommenceCategoryMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceConnection Interface

Describes a Commence connection.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceConnection
Public Interface ICommenceConnection

The ICommenceConnection type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Fully qualified name
Public property | Name | Name of connection.
Public property | ToCategory | Connected category name.
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceConnection Properties

The ICommenceConnection type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Fully qualified name
Public property | Name | Name of connection.
Public property | ToCategory | Connected category name.
Top
See Also

Reference

ICommenceConnection Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceConnection.FullName Property

ICommenceConnectionFullName Property

Fully qualified name

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Property Value

Type: String
Exceptions
Exception | Condition
NullReferenceException | Name or ToCategory not specfied.
See Also

Reference

ICommenceConnection Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceConnection.Name Property

ICommenceConnectionName Property

Name of connection.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICommenceConnection Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceConnection.ToCategory Property

ICommenceConnectionToCategory Property

Connected category name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ToCategory { get; set; }
Property ToCategory As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICommenceConnection Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldDefinition Interface

Interface for the field definition.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceFieldDefinition
Public Interface ICommenceFieldDefinition

The ICommenceFieldDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Combobox | Indicates if field is a combobox.
Public property | DefaultString | Default fielvalue (if any).
Public property | Mandatory | Indicates if field is mandatory.
Public property | MaxChars | Maximum number of characters field can hold.
Public property | Recurring | Indicates if field is a recurring date field.
Public property | Shared | Indicates if field is shared.
Public property | Type | Field type.
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldDefinition Properties

The ICommenceFieldDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Combobox | Indicates if field is a combobox.
Public property | DefaultString | Default fielvalue (if any).
Public property | Mandatory | Indicates if field is mandatory.
Public property | MaxChars | Maximum number of characters field can hold.
Public property | Recurring | Indicates if field is a recurring date field.
Public property | Shared | Indicates if field is shared.
Public property | Type | Field type.
Top
See Also

Reference

ICommenceFieldDefinition Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldDefinition.Combobox Property

ICommenceFieldDefinitionCombobox Property

Indicates if field is a combobox.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Combobox { get; }
ReadOnly Property Combobox As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICommenceFieldDefinition Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldDefinition.DefaultString Property

ICommenceFieldDefinitionDefaultString Property

Default fielvalue (if any).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string DefaultString { get; }
ReadOnly Property DefaultString As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceFieldDefinition Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldDefinition.Mandatory Property

ICommenceFieldDefinitionMandatory Property

Indicates if field is mandatory.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Mandatory { get; }
ReadOnly Property Mandatory As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICommenceFieldDefinition Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldDefinition.MaxChars Property

ICommenceFieldDefinitionMaxChars Property

Maximum number of characters field can hold.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int MaxChars { get; }
ReadOnly Property MaxChars As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ICommenceFieldDefinition Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldDefinition.Recurring Property

ICommenceFieldDefinitionRecurring Property

Indicates if field is a recurring date field.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Recurring { get; }
ReadOnly Property Recurring As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICommenceFieldDefinition Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldDefinition.Shared Property

ICommenceFieldDefinitionShared Property

Indicates if field is shared.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Shared { get; }
ReadOnly Property Shared As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ICommenceFieldDefinition Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldDefinition.Type Property

ICommenceFieldDefinitionType Property

Field type.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
CommenceFieldType Type { get; }
ReadOnly Property Type As CommenceFieldType
    Get

Property Value

Type: CommenceFieldType
See Also

Reference

ICommenceFieldDefinition Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldMetaData Interface

Commence field metadata.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceFieldMetaData : ICommenceFieldDefinition
Public Interface ICommenceFieldMetaData
    Inherits ICommenceFieldDefinition

The ICommenceFieldMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Combobox | Indicates if field is a combobox. (Inherited from ICommenceFieldDefinition.)
Public property | DefaultString | Default fielvalue (if any). (Inherited from ICommenceFieldDefinition.)
Public property | Mandatory | Indicates if field is mandatory. (Inherited from ICommenceFieldDefinition.)
Public property | MaxChars | Maximum number of characters field can hold. (Inherited from ICommenceFieldDefinition.)
Public property | Name | Field name.
Public property | Recurring | Indicates if field is a recurring date field. (Inherited from ICommenceFieldDefinition.)
Public property | Shared | Indicates if field is shared. (Inherited from ICommenceFieldDefinition.)
Public property | Type | Field type. (Inherited from ICommenceFieldDefinition.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldMetaData Properties

The ICommenceFieldMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Combobox | Indicates if field is a combobox. (Inherited from ICommenceFieldDefinition.)
Public property | DefaultString | Default fielvalue (if any). (Inherited from ICommenceFieldDefinition.)
Public property | Mandatory | Indicates if field is mandatory. (Inherited from ICommenceFieldDefinition.)
Public property | MaxChars | Maximum number of characters field can hold. (Inherited from ICommenceFieldDefinition.)
Public property | Name | Field name.
Public property | Recurring | Indicates if field is a recurring date field. (Inherited from ICommenceFieldDefinition.)
Public property | Shared | Indicates if field is shared. (Inherited from ICommenceFieldDefinition.)
Public property | Type | Field type. (Inherited from ICommenceFieldDefinition.)
Top
See Also

Reference

ICommenceFieldMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFieldMetaData.Name Property

ICommenceFieldMetaDataName Property

Field name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ICommenceFieldMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFormMetaData Interface

Commence Item detail form metadata.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceFormMetaData
Public Interface ICommenceFormMetaData

The ICommenceFormMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Category | Categoryname.
Public property | Name | Form name.
Public property | Path | Form filepath.
Public property | Script | Form script.
Public property | Xml | Form XML.
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFormMetaData Properties

The ICommenceFormMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Category | Categoryname.
Public property | Name | Form name.
Public property | Path | Form filepath.
Public property | Script | Form script.
Public property | Xml | Form XML.
Top
See Also

Reference

ICommenceFormMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFormMetaData.Category Property

ICommenceFormMetaDataCategory Property

Categoryname.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Category { get; }
ReadOnly Property Category As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceFormMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFormMetaData.Name Property

ICommenceFormMetaDataName Property

Form name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceFormMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFormMetaData.Path Property

ICommenceFormMetaDataPath Property

Form filepath.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Path { get; }
ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceFormMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFormMetaData.Script Property

ICommenceFormMetaDataScript Property

Form script.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Script { get; }
ReadOnly Property Script As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceFormMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceFormMetaData.Xml Property

ICommenceFormMetaDataXml Property

Form XML.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Xml { get; }
ReadOnly Property Xml As String
    Get

Property Value

Type: String
See Also

Reference

ICommenceFormMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceViewMetaData Interface

Metadata of Commence view.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface ICommenceViewMetaData : IViewDef
Public Interface ICommenceViewMetaData
    Inherits IViewDef

The ICommenceViewMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying Commence category. (Inherited from IViewDef.)
Public property | FileName | Filename (e.g. for Report Views). (Inherited from IViewDef.)
Public property | Name | View name. (Inherited from IViewDef.)
Public property | Type | View Type. (Inherited from IViewDef.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


ICommenceViewMetaData Properties

The ICommenceViewMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying Commence category. (Inherited from IViewDef.)
Public property | FileName | Filename (e.g. for Report Views). (Inherited from IViewDef.)
Public property | Name | View name. (Inherited from IViewDef.)
Public property | Type | View Type. (Inherited from IViewDef.)
Top
See Also

Reference

ICommenceViewMetaData Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDatabaseSchema Interface

Schema information

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IDatabaseSchema : IDBDef
Public Interface IDatabaseSchema
    Inherits IDBDef

The IDatabaseSchema type exposes the following members.

Properties
 | Name | Description
Public property | Attached | Indicates if database is attached, whatever that may mean. (Inherited from IDBDef.)
Public property | Categories | Categories.
Public property | Connected | Indicates if field is connected, whatever that may mean. (Inherited from IDBDef.)
Public property | IsClient | Indicates if database is a client in a workgroup. (Inherited from IDBDef.)
Public property | IsServer | Indicates if database is a server in a workgroup. (Inherited from IDBDef.)
Public property | Name | Database name. (Inherited from IDBDef.)
Public property | Path | Database path. (Inherited from IDBDef.)
Public property | Size | Database size (combined size of database directory)
Public property | Spoolpath | Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set. (Inherited from IDBDef.)
Public property | Username | Login name of the user (only applies to password-protected databases). (Inherited from IDBDef.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


IDatabaseSchema Properties

The IDatabaseSchema type exposes the following members.

Properties
 | Name | Description
Public property | Attached | Indicates if database is attached, whatever that may mean. (Inherited from IDBDef.)
Public property | Categories | Categories.
Public property | Connected | Indicates if field is connected, whatever that may mean. (Inherited from IDBDef.)
Public property | IsClient | Indicates if database is a client in a workgroup. (Inherited from IDBDef.)
Public property | IsServer | Indicates if database is a server in a workgroup. (Inherited from IDBDef.)
Public property | Name | Database name. (Inherited from IDBDef.)
Public property | Path | Database path. (Inherited from IDBDef.)
Public property | Size | Database size (combined size of database directory)
Public property | Spoolpath | Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set. (Inherited from IDBDef.)
Public property | Username | Login name of the user (only applies to password-protected databases). (Inherited from IDBDef.)
Top
See Also

Reference

IDatabaseSchema Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDatabaseSchema.Categories Property

IDatabaseSchemaCategories Property

Categories.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
List<CommenceCategoryMetaData> Categories { get; }
ReadOnly Property Categories As List(Of CommenceCategoryMetaData)
    Get

Property Value

Type: List CommenceCategoryMetaData
See Also

Reference

IDatabaseSchema Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDatabaseSchema.Size Property

IDatabaseSchemaSize Property

Database size (combined size of database directory)

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
long Size { get; }
ReadOnly Property Size As Long
    Get

Property Value

Type: Int64
See Also

Reference

IDatabaseSchema Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef Interface

Exposes members of the database definition.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IDBDef
Public Interface IDBDef

The IDBDef type exposes the following members.

Properties
 | Name | Description
Public property | Attached | Indicates if database is attached, whatever that may mean.
Public property | Connected | Indicates if field is connected, whatever that may mean.
Public property | IsClient | Indicates if database is a client in a workgroup.
Public property | IsServer | Indicates if database is a server in a workgroup.
Public property | Name | Database name.
Public property | Path | Database path.
Public property | Spoolpath | Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set.
Public property | Username | Login name of the user (only applies to password-protected databases).
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef Properties

The IDBDef type exposes the following members.

Properties
 | Name | Description
Public property | Attached | Indicates if database is attached, whatever that may mean.
Public property | Connected | Indicates if field is connected, whatever that may mean.
Public property | IsClient | Indicates if database is a client in a workgroup.
Public property | IsServer | Indicates if database is a server in a workgroup.
Public property | Name | Database name.
Public property | Path | Database path.
Public property | Spoolpath | Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set.
Public property | Username | Login name of the user (only applies to password-protected databases).
Top
See Also

Reference

IDBDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef.Attached Property

IDBDefAttached Property

Indicates if database is attached, whatever that may mean.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Attached { get; }
ReadOnly Property Attached As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IDBDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef.Connected Property

IDBDefConnected Property

Indicates if field is connected, whatever that may mean.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Connected { get; }
ReadOnly Property Connected As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IDBDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef.IsClient Property

IDBDefIsClient Property

Indicates if database is a client in a workgroup.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool IsClient { get; }
ReadOnly Property IsClient As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IDBDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef.IsServer Property

IDBDefIsServer Property

Indicates if database is a server in a workgroup.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool IsServer { get; }
ReadOnly Property IsServer As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IDBDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef.Name Property

IDBDefName Property

Database name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

IDBDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef.Path Property

IDBDefPath Property

Database path.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Path { get; }
ReadOnly Property Path As String
    Get

Property Value

Type: String
See Also

Reference

IDBDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef.Spoolpath Property

IDBDefSpoolpath Property

Path where synchronization packets exchanged. WARNING: Commence does not properly return this value if client is set to sync by any means other than Shared LAN. If it syncs via FTP, you will still erronously get a Shared LAN location if one was ever set.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Spoolpath { get; }
ReadOnly Property Spoolpath As String
    Get

Property Value

Type: String
See Also

Reference

IDBDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IDBDef.Username Property

IDBDefUsername Property

Login name of the user (only applies to password-protected databases).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Username { get; }
ReadOnly Property Username As String
    Get

Property Value

Type: String
See Also

Reference

IDBDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IMetaDataOptions Interface

Options for generating metadata file.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IMetaDataOptions
Public Interface IMetaDataOptions

The IMetaDataOptions type exposes the following members.

Properties
 | Name | Description
Public property | Format | MetaDataFormat
Public property | IncludeFormScript | Include form script.
Public property | IncludeFormXml | Include form xml.
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


IMetaDataOptions Properties

The IMetaDataOptions type exposes the following members.

Properties
 | Name | Description
Public property | Format | MetaDataFormat
Public property | IncludeFormScript | Include form script.
Public property | IncludeFormXml | Include form xml.
Top
See Also

Reference

IMetaDataOptions Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IMetaDataOptions.Format Property

IMetaDataOptionsFormat Property

MetaDataFormat

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
MetaDataFormat Format { get; set; }
Property Format As MetaDataFormat
    Get
    Set

Property Value

Type: MetaDataFormat
See Also

Reference

IMetaDataOptions Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IMetaDataOptions.IncludeFormScript Property

IMetaDataOptionsIncludeFormScript Property

Include form script.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool IncludeFormScript { get; set; }
Property IncludeFormScript As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Will be included as CData in XML.
See Also

Reference

IMetaDataOptions Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IMetaDataOptions.IncludeFormXml Property

IMetaDataOptionsIncludeFormXml Property

Include form xml.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool IncludeFormXml { get; set; }
Property IncludeFormXml As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Will be included as CData in XML.
See Also

Reference

IMetaDataOptions Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IViewDef Interface

Exposes view definition.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IViewDef
Public Interface IViewDef

The IViewDef type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying Commence category.
Public property | FileName | Filename (e.g. for Report Views).
Public property | Name | View name.
Public property | Type | View Type.
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


IViewDef Properties

The IViewDef type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying Commence category.
Public property | FileName | Filename (e.g. for Report Views).
Public property | Name | View name.
Public property | Type | View Type.
Top
See Also

Reference

IViewDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IViewDef.Category Property

IViewDefCategory Property

Underlying Commence category.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Category { get; }
ReadOnly Property Category As String
    Get

Property Value

Type: String
See Also

Reference

IViewDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IViewDef.FileName Property

IViewDefFileName Property

Filename (e.g. for Report Views).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string FileName { get; }
ReadOnly Property FileName As String
    Get

Property Value

Type: String
See Also

Reference

IViewDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IViewDef.Name Property

IViewDefName Property

View name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

IViewDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


IViewDef.Type Property

IViewDefType Property

View Type.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Type { get; }
ReadOnly Property Type As String
    Get

Property Value

Type: String
See Also

Reference

IViewDef Interface
Vovin.CmcLibNet.Database.Metadata Namespace


MetaDataFormat Enumeration

Formats that schema information can be written to.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum MetaDataFormat
Public Enumeration MetaDataFormat
Members
Member name | Value | Description
Json | 0 | JSON
Xml | 1 | XML
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


MetaDataOptions Class

Options for generating metadata file.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataMetaDataOptions

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class MetaDataOptions : IMetaDataOptions
Public Class MetaDataOptions
    Implements IMetaDataOptions

The MetaDataOptions type exposes the following members.

Constructors
 | Name | Description
Public method | MetaDataOptions | Initializes a new instance of the MetaDataOptions class
Top
Properties
 | Name | Description
Public property | Format | MetaDataFormat
Public property | IncludeFormScript | Include form script.
Public property | IncludeFormXml | Include form xml.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


MetaDataOptions Constructor

Initializes a new instance of the MetaDataOptions class

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public MetaDataOptions()
Public Sub New
See Also

Reference

MetaDataOptions Class
Vovin.CmcLibNet.Database.Metadata Namespace


MetaDataOptions Properties

The MetaDataOptions type exposes the following members.

Properties
 | Name | Description
Public property | Format | MetaDataFormat
Public property | IncludeFormScript | Include form script.
Public property | IncludeFormXml | Include form xml.
Top
See Also

Reference

MetaDataOptions Class
Vovin.CmcLibNet.Database.Metadata Namespace


MetaDataOptions.Format Property

MetaDataOptionsFormat Property

MetaDataFormat

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public MetaDataFormat Format { get; set; }
Public Property Format As MetaDataFormat
    Get
    Set

Property Value

Type: MetaDataFormat

Implements

IMetaDataOptionsFormat
See Also

Reference

MetaDataOptions Class
Vovin.CmcLibNet.Database.Metadata Namespace


MetaDataOptions.IncludeFormScript Property

MetaDataOptionsIncludeFormScript Property

Include form script.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool IncludeFormScript { get; set; }
Public Property IncludeFormScript As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IMetaDataOptionsIncludeFormScript
Remarks
Will be included as CData in XML.
See Also

Reference

MetaDataOptions Class
Vovin.CmcLibNet.Database.Metadata Namespace


MetaDataOptions.IncludeFormXml Property

MetaDataOptionsIncludeFormXml Property

Include form xml.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool IncludeFormXml { get; set; }
Public Property IncludeFormXml As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IMetaDataOptionsIncludeFormXml
Remarks
Will be included as CData in XML.
See Also

Reference

MetaDataOptions Class
Vovin.CmcLibNet.Database.Metadata Namespace


MetaDataOptions Methods

The MetaDataOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MetaDataOptions Class
Vovin.CmcLibNet.Database.Metadata Namespace


ViewDef Class

Holds information on the view definition.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Database.MetadataViewDef

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ViewDef : IViewDef
<SerializableAttribute>
Public Class ViewDef
    Implements IViewDef

The ViewDef type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying Commence category.
Public property | FileName | Filename (e.g. for Report Views).
Public property | Name | View name.
Public property | Type | View Type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Database.Metadata Namespace


ViewDef Properties

The ViewDef type exposes the following members.

Properties
 | Name | Description
Public property | Category | Underlying Commence category.
Public property | FileName | Filename (e.g. for Report Views).
Public property | Name | View name.
Public property | Type | View Type.
Top
See Also

Reference

ViewDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


ViewDef.Category Property

ViewDefCategory Property

Underlying Commence category.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get

Property Value

Type: String

Implements

IViewDefCategory
See Also

Reference

ViewDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


ViewDef.FileName Property

ViewDefFileName Property

Filename (e.g. for Report Views).

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String

Implements

IViewDefFileName
See Also

Reference

ViewDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


ViewDef.Name Property

ViewDefName Property

View name.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Implements

IViewDefName
See Also

Reference

ViewDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


ViewDef.Type Property

ViewDefType Property

View Type.

Namespace: Vovin.CmcLibNet.Database.Metadata
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Type { get; }
Public ReadOnly Property Type As String
    Get

Property Value

Type: String

Implements

IViewDefType
See Also

Reference

ViewDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


ViewDef Methods

The ViewDef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ViewDef Class
Vovin.CmcLibNet.Database.Metadata Namespace


Vovin.CmcLibNet.Export Namespace

Contains the export methods.
Classes
 | Class | Description
Public class | ExportCompleteArgs | Passed when export has completed.
Public class | ExportEngine | Export engine for exporting data from Commence.
Public class | ExportProgressChangedArgs | ExportProgressAsStringChangedArgs class. Reports export progress and data to outside the assembly.
Public class | ExportSettings | Class to hold export settings for export engine.
Interfaces
 | Interface | Description
Public interface | IExportCompleteArgs | Interface for ExportCompleted, primarily for use with COM Interop.
Public interface | IExportEngine | interface for ExportEngine.
Public interface | IExportEngineCOMEvents | Interface for COM clients to implement events raised by this asssembly.
Public interface | IExportEngineEvents | Interface for exposing events.
Public interface | IExportProgressChangedArgs | Interface for ExportProgressChanged, primarily for use with COM Interop.
Public interface | IExportSettings | Interface for ExportSettings.
Delegates
 | Delegate | Description
Public delegate | ExportCompletedHandler | Delegate for the ExportCompleted event to deal with batches of rows. For use by external assemblies.
Public delegate | ExportProgressChangedHandler | Delegate for the ExportProgressChanged event to deal with batches of rows. For use by external assemblies.
Enumerations
 | Enumeration | Description
Public enumeration | ExcelUpdateOptions | Enum specifying the update options for exporting to Excel
Public enumeration | ExportFormat | Enum specifying the export format.
Public enumeration | HeaderMode | Enum specifying what headers (or nodenames) to use.


ExcelUpdateOptions Enumeration

Enum specifying the update options for exporting to Excel

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum ExcelUpdateOptions
Public Enumeration ExcelUpdateOptions
Members
Member name | Value | Description
CreateNewWorkbook | 0 | Create a new workbook. Overwrites existing workbook with same name!
CreateNewWorksheet | 1 | Create new sheet in workbook.
ReplaceWorksheet | 2 | (Default) Replaces the workheet. Overwrites existing worksheet.
AppendToWorksheet | 3 | Append data to the worksheet.
See Also

Reference

Vovin.CmcLibNet.Export Namespace


ExportCompleteArgs Class

Passed when export has completed.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Vovin.CmcLibNet.ExportExportCompleteArgs

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class ExportCompleteArgs : EventArgs,
    IExportCompleteArgs
Public Class ExportCompleteArgs
    Inherits EventArgs
    Implements IExportCompleteArgs

The ExportCompleteArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ExportCompleteArgs | Constructor
Top
Properties
 | Name | Description
Public property | Rows | Number of rows
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Export Namespace


ExportCompleteArgs Constructor

Constructor

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ExportCompleteArgs(
    int rows
)
Public Sub New (
    rows As Integer
)

Parameters

rows
Type: SystemInt32
Rows
See Also

Reference

ExportCompleteArgs Class
Vovin.CmcLibNet.Export Namespace


ExportCompleteArgs Properties

The ExportCompleteArgs type exposes the following members.

Properties
 | Name | Description
Public property | Rows | Number of rows
Top
See Also

Reference

ExportCompleteArgs Class
Vovin.CmcLibNet.Export Namespace


ExportCompleteArgs.Rows Property

ExportCompleteArgsRows Property

Number of rows

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get

Property Value

Type: Int32

Implements

IExportCompleteArgsRows
See Also

Reference

ExportCompleteArgs Class
Vovin.CmcLibNet.Export Namespace


ExportCompleteArgs Methods

The ExportCompleteArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExportCompleteArgs Class
Vovin.CmcLibNet.Export Namespace


ExportCompletedHandler Delegate

Delegate for the ExportCompleted event to deal with batches of rows. For use by external assemblies.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public delegate void ExportCompletedHandler(
    Object sender,
    ExportCompleteArgs e
)
Public Delegate Sub ExportCompletedHandler (
    sender As Object,
    e As ExportCompleteArgs
)

Parameters

sender
Type: SystemObject
sender object.
e
Type: Vovin.CmcLibNet.ExportExportCompleteArgs
ExportCompleteArgs.
See Also

Reference

Vovin.CmcLibNet.Export Namespace


ExportEngine Class

Export engine for exporting data from Commence.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.ExportExportEngine

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class ExportEngine : IExportEngine,
    IExportEngineEvents
Public Class ExportEngine
    Implements IExportEngine, IExportEngineEvents

The ExportEngine type exposes the following members.

Constructors
 | Name | Description
Public method | ExportEngine | Constructor.
Top
Properties
 | Name | Description
Public property | Settings | Controls the export settings.
Top
Methods
 | Name | Description
Public method | Close | Not needed, does nothing.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportCategory(String, String, IExportSettings) | Export a category.
Public method | ExportCategory(String, IEnumerableICursorFilter, String, IExportSettings) | Export a filtered category.
Public method | ExportView | Export a view.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleExportCompleted | Event handler for the ExportCompleted event
Public method | HandleExportProgressChanged | Event handler for the ExportProgressChanged event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ExportCompleted | ExportCompleted event raised when Commence data reading has completed.
Public event | ExportProgressChanged | ExportProgressChanged event raised when (batch of) Commence data has been read.
Top
Remarks

Please note: the export engine tries to treat connected items as separate entities where possible - it is one of its core features. It relies on delimiters baked into the Commence API (either newline \n (not \r\n!) or a comma, depending on the situation.). The Commence Text field, when set to Large, and the URL field *can* contain embedded newline characters. When exporting those field-types, you may get unexpected results if they do. In that case you options are either to simply not include them in your export, or to disable the splitting of connected items.

Usage: .NET users can simply create an instance, COM clients can instantiate this by using the ProgId CmcLibNet.Export. VBScript example:

VBScript
Copy
Dim export : Set export = CreateObject("CmcLibNet.Export")
            '.. do stuff ..
Notice that contrary to e.g. ICommenceCursor or ICommenceDatabase, the IExportEngine does not require explicit closing.

See Also

Reference

Vovin.CmcLibNet.Export Namespace
IExportSettingsSplitConnectedItems
IExportEngineClose


ExportEngine Constructor

Constructor.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ExportEngine()
Public Sub New
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine Properties

The ExportEngine type exposes the following members.

Properties
 | Name | Description
Public property | Settings | Controls the export settings.
Top
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine.Settings Property

ExportEngineSettings Property

Controls the export settings.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public IExportSettings Settings { get; }
Public ReadOnly Property Settings As IExportSettings
    Get

Property Value

Type: IExportSettings

Implements

IExportEngineSettings
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine Methods

The ExportEngine type exposes the following members.

Methods
 | Name | Description
Public method | Close | Not needed, does nothing.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportCategory(String, String, IExportSettings) | Export a category.
Public method | ExportCategory(String, IEnumerableICursorFilter, String, IExportSettings) | Export a filtered category.
Public method | ExportView | Export a view.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleExportCompleted | Event handler for the ExportCompleted event
Public method | HandleExportProgressChanged | Event handler for the ExportProgressChanged event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine.Close Method

ExportEngineClose Method

Not needed, does nothing.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

IExportEngineClose
Remarks
This method is only there to make the COM-creatable classes consistent.
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine.ExportCategory Method

ExportEngineExportCategory Method

Overload List
 | Name | Description
Public method | ExportCategory(String, String, IExportSettings) | Export a category.
Public method | ExportCategory(String, IEnumerableICursorFilter, String, IExportSettings) | Export a filtered category.
Top
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine.ExportCategory Method (String, String, IExportSettings)

ExportEngineExportCategory Method (String, String, IExportSettings)

Export a category.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void ExportCategory(
    string categoryName,
    string fileName,
    IExportSettings settings = null
)
Public Sub ExportCategory (
    categoryName As String,
    fileName As String,
    Optional settings As IExportSettings = Nothing
)

Parameters

categoryName
Type: SystemString
Commence category name.
fileName
Type: SystemString
Fully qualified filename.
settings (Optional)
Type: Vovin.CmcLibNet.ExportIExportSettings
IExportSettings

Implements

IExportEngineExportCategory(String, String, IExportSettings)
See Also

Reference

ExportEngine Class
ExportCategory Overload
Vovin.CmcLibNet.Export Namespace


ExportEngine.ExportCategory Method (String, IEnumerable(ICursorFilter), String, IExportSettings)

ExportEngineExportCategory Method (String, IEnumerableICursorFilter, String, IExportSettings)

Export a filtered category.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void ExportCategory(
    string categoryName,
    IEnumerable<ICursorFilter> filters,
    string fileName,
    IExportSettings settings = null
)
Public Sub ExportCategory (
    categoryName As String,
    filters As IEnumerable(Of ICursorFilter),
    fileName As String,
    Optional settings As IExportSettings = Nothing
)

Parameters

categoryName
Type: SystemString
Commence category name.
filters
Type: System.Collections.GenericIEnumerable ICursorFilter
Filter(s) to apply to category
fileName
Type: SystemString
Fully qualified filename.
settings (Optional)
Type: Vovin.CmcLibNet.ExportIExportSettings
IExportSettings

Implements

IExportEngineExportCategory(String, IEnumerableICursorFilter, String, IExportSettings)
See Also

Reference

ExportEngine Class
ExportCategory Overload
Vovin.CmcLibNet.Export Namespace


ExportEngine.ExportView Method

ExportEngineExportView Method

Export a view.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void ExportView(
    string viewName,
    string fileName,
    IExportSettings settings = null
)
Public Sub ExportView (
    viewName As String,
    fileName As String,
    Optional settings As IExportSettings = Nothing
)

Parameters

viewName
Type: SystemString
Commence view name (case-sensitive). Pass an empty string to use the active view, if any. Note that not all view types can be exported.
fileName
Type: SystemString
Fully qualified filename.
settings (Optional)
Type: Vovin.CmcLibNet.ExportIExportSettings
IExportSettings

Implements

IExportEngineExportView(String, String, IExportSettings)
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine.HandleExportCompleted Method

ExportEngineHandleExportCompleted Method

Event handler for the ExportCompleted event

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public virtual void HandleExportCompleted(
    Object sender,
    ExportCompleteArgs e
)
Public Overridable Sub HandleExportCompleted (
    sender As Object,
    e As ExportCompleteArgs
)

Parameters

sender
Type: SystemObject
sender object.
e
Type: Vovin.CmcLibNet.ExportExportCompleteArgs
ExportCompleteArgs
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine.HandleExportProgressChanged Method

ExportEngineHandleExportProgressChanged Method

Event handler for the ExportProgressChanged event.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public virtual void HandleExportProgressChanged(
    Object sender,
    ExportProgressChangedArgs e
)
Public Overridable Sub HandleExportProgressChanged (
    sender As Object,
    e As ExportProgressChangedArgs
)

Parameters

sender
Type: SystemObject
sender object.
e
Type: Vovin.CmcLibNet.ExportExportProgressChangedArgs
ExportProgressAsJsonChangedArgs object.
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine Events

The ExportEngine type exposes the following members.

Events
 | Name | Description
Public event | ExportCompleted | ExportCompleted event raised when Commence data reading has completed.
Public event | ExportProgressChanged | ExportProgressChanged event raised when (batch of) Commence data has been read.
Top
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine.ExportCompleted Event

ExportEngineExportCompleted Event

ExportCompleted event raised when Commence data reading has completed.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public event ExportCompletedHandler ExportCompleted
Public Event ExportCompleted As ExportCompletedHandler

Value

Type: Vovin.CmcLibNet.ExportExportCompletedHandler

Implements

IExportEngineEventsExportCompleted
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportEngine.ExportProgressChanged Event

ExportEngineExportProgressChanged Event

ExportProgressChanged event raised when (batch of) Commence data has been read.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public event ExportProgressChangedHandler ExportProgressChanged
Public Event ExportProgressChanged As ExportProgressChangedHandler

Value

Type: Vovin.CmcLibNet.ExportExportProgressChangedHandler

Implements

IExportEngineEventsExportProgressChanged
See Also

Reference

ExportEngine Class
Vovin.CmcLibNet.Export Namespace


ExportFormat Enumeration

Enum specifying the export format.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum ExportFormat
Public Enumeration ExportFormat
Members
Member name | Value | Description
Xml | 0 | Export to XML format (default). Fastest and most reliable.
Json | 1 | Export to JSON format.
Html | 2 | Export to HTML format. Note that the resulting HTML will be decorated with class attributes to allow custom formatting via CSS.
Text | 3 | Export to plain text format.
Excel | 4 | Export to Microsoft Excel xslx format.
GoogleSheets | 5 | Export to Google Sheets. Requires Google account. Not implemented, may well be too slow anyway.
Event | 6 | Just reads the data and emits a ExportProgressChanged event that you can subscribe to. The RowValues property will contain Json-formatted data. The filename argument is ignored when using this setting.
See Also

Reference

Vovin.CmcLibNet.Export Namespace


ExportProgressChangedArgs Class

ExportProgressAsStringChangedArgs class. Reports export progress and data to outside the assembly.
Inheritance Hierarchy
SystemObject
SystemEventArgs
Vovin.CmcLibNet.ExportExportProgressChangedArgs

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class ExportProgressChangedArgs : EventArgs,
    IExportProgressChangedArgs
Public Class ExportProgressChangedArgs
    Inherits EventArgs
    Implements IExportProgressChangedArgs

The ExportProgressChangedArgs type exposes the following members.

Properties
 | Name | Description
Public property | CurrentIteration | Current iteration
Public property | IterationCount | Total number of iterations.
Public property | RowsProcessed | Rows processed.
Public property | RowsTotal | Total number of rows to process.
Public property | RowValues | Rowdata in structured string representation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Export Namespace


ExportProgressChangedArgs Properties

The ExportProgressChangedArgs type exposes the following members.

Properties
 | Name | Description
Public property | CurrentIteration | Current iteration
Public property | IterationCount | Total number of iterations.
Public property | RowsProcessed | Rows processed.
Public property | RowsTotal | Total number of rows to process.
Public property | RowValues | Rowdata in structured string representation.
Top
See Also

Reference

ExportProgressChangedArgs Class
Vovin.CmcLibNet.Export Namespace


ExportProgressChangedArgs.CurrentIteration Property

ExportProgressChangedArgsCurrentIteration Property

Current iteration

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int CurrentIteration { get; }
Public ReadOnly Property CurrentIteration As Integer
    Get

Property Value

Type: Int32

Implements

IExportProgressChangedArgsCurrentIteration
See Also

Reference

ExportProgressChangedArgs Class
Vovin.CmcLibNet.Export Namespace


ExportProgressChangedArgs.IterationCount Property

ExportProgressChangedArgsIterationCount Property

Total number of iterations.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int IterationCount { get; }
Public ReadOnly Property IterationCount As Integer
    Get

Property Value

Type: Int32

Implements

IExportProgressChangedArgsIterationCount
Remarks
When PreserveAllConnections is set, there may be multiple iterations.
See Also

Reference

ExportProgressChangedArgs Class
Vovin.CmcLibNet.Export Namespace


ExportProgressChangedArgs.RowsProcessed Property

ExportProgressChangedArgsRowsProcessed Property

Rows processed.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int RowsProcessed { get; }
Public ReadOnly Property RowsProcessed As Integer
    Get

Property Value

Type: Int32

Implements

IExportProgressChangedArgsRowsProcessed
See Also

Reference

ExportProgressChangedArgs Class
Vovin.CmcLibNet.Export Namespace


ExportProgressChangedArgs.RowsTotal Property

ExportProgressChangedArgsRowsTotal Property

Total number of rows to process.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int RowsTotal { get; }
Public ReadOnly Property RowsTotal As Integer
    Get

Property Value

Type: Int32

Implements

IExportProgressChangedArgsRowsTotal
See Also

Reference

ExportProgressChangedArgs Class
Vovin.CmcLibNet.Export Namespace


ExportProgressChangedArgs.RowValues Property

ExportProgressChangedArgsRowValues Property

Rowdata in structured string representation.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string RowValues { get; }
Public ReadOnly Property RowValues As String
    Get

Property Value

Type: String

Implements

IExportProgressChangedArgsRowValues
Remarks
Only contains data when ExportFormat is set to Event.
See Also

Reference

ExportProgressChangedArgs Class
Vovin.CmcLibNet.Export Namespace


ExportProgressChangedArgs Methods

The ExportProgressChangedArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExportProgressChangedArgs Class
Vovin.CmcLibNet.Export Namespace


ExportProgressChangedHandler Delegate

Delegate for the ExportProgressChanged event to deal with batches of rows. For use by external assemblies.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public delegate void ExportProgressChangedHandler(
    Object sender,
    ExportProgressChangedArgs e
)
Public Delegate Sub ExportProgressChangedHandler (
    sender As Object,
    e As ExportProgressChangedArgs
)

Parameters

sender
Type: SystemObject
sender object.
e
Type: Vovin.CmcLibNet.ExportExportProgressChangedArgs
ExportProgressChangedArgs.
See Also

Reference

Vovin.CmcLibNet.Export Namespace


ExportSettings Class

Class to hold export settings for export engine.
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.ExportExportSettings

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class ExportSettings : IExportSettings
Public Class ExportSettings
    Implements IExportSettings

The ExportSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ExportSettings | Initializes a new instance of the ExportSettings class
Top
Properties
 | Name | Description
Public property | Canonical | Return data in a canonical format. Default is false.
Public property | CSSFile | External CSS file to be linked with an HTML export. Location is the output path. Only applies to HTML exports. Default is empty (no CSSFile).
Public property | CustomHeaders | Use custom columnheaders.
Public property | CustomRootNode | Custom root node for Xml, Json, Excel.
Public property | DeleteExcelFileBeforeExport | Obsolete. Delete and recreate Excel file when exporting. Only applies to Excel. Default is true.
Public property | ExportFormat | Data format the export engine should generate. Default is Xml.
Public property | HeaderMode | Headermode, i.e. what to use for columnames (Text, Html, Excel) or nodenames (Xml, Json). Default is Fieldname.
Public property | HeadersOnFirstRow | Use headers on the first row in table-like exports (like Text, Html, Excel). Default is true.
Public property | IncludeConnectionInfo | Include additional connection information. Only applies to Json. Default is true.
Public property | ISO8601Format | Make dates return in ISO8601 format.
Public property | MaxFieldSize | Maximum number of characters to retrieve from fields. This includes connected fields. The default is ~500.000, skabout five times the Commence default.
Public property | NestConnectedItems | Only applies to Json. Splits connection information into distinct elements/nodes.
Public property | NumRows | Specify the number of rows to export at a time. Default is 1024.
Public property | PreserveAllConnections | Include all connected items. Supported only for Xml, Json, Excel Overrides Canonical, ISO8601Format, SkipConnectedItems, SplitConnectedItems, ExcelUpdateOptions.
Public property | ReadCommenceDataAsync | Read Commence data in an asynchronous way. Async can be slightly faster, but it depends on a number of things, such as NumRows and MaxFieldSize. When you export to Excel or use PreserveAllConnections there is a performance gain. Default is true.
Public property | RemoveCurrencySymbol | Used in conjunction with Canonical, allows removal of the currency symbol that Commence will include when numeric fields were set to 'Display as currency' Default is false.
Public property | SkipConnectedItems | Ignore connected items.
Public property | SplitConnectedItems | Split connected values into separate nodes/elements. Only applies to Json and Xml. Default is true. If set to false, connected values are not split and you will get the data as Commence returns them.
Public property | TextDelimiter | Text-delimiter used in a Text export. Only applies to Text and Html exports. Default is tab character.
Public property | TextDelimiterConnections | Text-delimiter used for connected values. Only applies to Text and Html exports. Default is newline character (same as Commence uses).
Public property | TextQualifier | Text-qualifier. Only applies to Text and Html exports. Default is " (double-quote).
Public property | UseDDE | Make Commence use DDE calls to retrieve data. WARNING: extremely slow!
Public property | UseThids | Include additional column holding the item's THID and return THIDs instead of Name field values for connected items. (XML and Json). For text-based exports, connected items are not returned as thids. Default is false.
Public property | WriteSchema | Get serialized XML with a XmlSchema (XSD). Only applies to PreserveAllConnections in combination with Xml. Default is false.
Public property | XlUpdateOptions | Update options when exporting to Microsoft Excel. See ExcelUpdateOptions.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Export Namespace


ExportSettings Constructor

Initializes a new instance of the ExportSettings class

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ExportSettings()
Public Sub New
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings Properties

The ExportSettings type exposes the following members.

Properties
 | Name | Description
Public property | Canonical | Return data in a canonical format. Default is false.
Public property | CSSFile | External CSS file to be linked with an HTML export. Location is the output path. Only applies to HTML exports. Default is empty (no CSSFile).
Public property | CustomHeaders | Use custom columnheaders.
Public property | CustomRootNode | Custom root node for Xml, Json, Excel.
Public property | DeleteExcelFileBeforeExport | Obsolete. Delete and recreate Excel file when exporting. Only applies to Excel. Default is true.
Public property | ExportFormat | Data format the export engine should generate. Default is Xml.
Public property | HeaderMode | Headermode, i.e. what to use for columnames (Text, Html, Excel) or nodenames (Xml, Json). Default is Fieldname.
Public property | HeadersOnFirstRow | Use headers on the first row in table-like exports (like Text, Html, Excel). Default is true.
Public property | IncludeConnectionInfo | Include additional connection information. Only applies to Json. Default is true.
Public property | ISO8601Format | Make dates return in ISO8601 format.
Public property | MaxFieldSize | Maximum number of characters to retrieve from fields. This includes connected fields. The default is ~500.000, skabout five times the Commence default.
Public property | NestConnectedItems | Only applies to Json. Splits connection information into distinct elements/nodes.
Public property | NumRows | Specify the number of rows to export at a time. Default is 1024.
Public property | PreserveAllConnections | Include all connected items. Supported only for Xml, Json, Excel Overrides Canonical, ISO8601Format, SkipConnectedItems, SplitConnectedItems, ExcelUpdateOptions.
Public property | ReadCommenceDataAsync | Read Commence data in an asynchronous way. Async can be slightly faster, but it depends on a number of things, such as NumRows and MaxFieldSize. When you export to Excel or use PreserveAllConnections there is a performance gain. Default is true.
Public property | RemoveCurrencySymbol | Used in conjunction with Canonical, allows removal of the currency symbol that Commence will include when numeric fields were set to 'Display as currency' Default is false.
Public property | SkipConnectedItems | Ignore connected items.
Public property | SplitConnectedItems | Split connected values into separate nodes/elements. Only applies to Json and Xml. Default is true. If set to false, connected values are not split and you will get the data as Commence returns them.
Public property | TextDelimiter | Text-delimiter used in a Text export. Only applies to Text and Html exports. Default is tab character.
Public property | TextDelimiterConnections | Text-delimiter used for connected values. Only applies to Text and Html exports. Default is newline character (same as Commence uses).
Public property | TextQualifier | Text-qualifier. Only applies to Text and Html exports. Default is " (double-quote).
Public property | UseDDE | Make Commence use DDE calls to retrieve data. WARNING: extremely slow!
Public property | UseThids | Include additional column holding the item's THID and return THIDs instead of Name field values for connected items. (XML and Json). For text-based exports, connected items are not returned as thids. Default is false.
Public property | WriteSchema | Get serialized XML with a XmlSchema (XSD). Only applies to PreserveAllConnections in combination with Xml. Default is false.
Public property | XlUpdateOptions | Update options when exporting to Microsoft Excel. See ExcelUpdateOptions.
Top
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.Canonical Property

ExportSettingsCanonical Property

Return data in a canonical format. Default is false.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool Canonical { get; set; }
Public Property Canonical As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsCanonical
Remarks
Date | yyyymmdd
Time | hh:mm military time, 24 hour clock
Number | 123456.78 no separator, period for decimal delimiter. Note that when a field is defined as 'Show as currency' in the Commence UI, numerical values are prepended with a '$' sign.
Checkbox | TRUE or FALSE (English)
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.CSSFile Property

ExportSettingsCSSFile Property

External CSS file to be linked with an HTML export. Location is the output path. Only applies to HTML exports. Default is empty (no CSSFile).

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string CSSFile { get; set; }
Public Property CSSFile As String
    Get
    Set

Property Value

Type: String

Implements

IExportSettingsCSSFile
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.CustomHeaders Property

ExportSettingsCustomHeaders Property

Use custom columnheaders.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public Object[] CustomHeaders { get; set; }
Public Property CustomHeaders As Object()
    Get
    Set

Property Value

Type: Object

Implements

IExportSettingsCustomHeaders
Remarks
You cannot use custom headers in combination with NestConnectedItems.

You must supply custom headers for all columns in the cursor, even when you have set SkipConnectedItems to true.

Type is object[] for compatibility with COM.

See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.CustomRootNode Property

ExportSettingsCustomRootNode Property

Custom root node for Xml, Json, Excel.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string CustomRootNode { get; set; }
Public Property CustomRootNode As String
    Get
    Set

Property Value

Type: String

Implements

IExportSettingsCustomRootNode
Remarks
For Text, Html and Event writers this property is ignored
Export format | Notes
Excel | Custom sheetname
Json | Custom top-level node name
Xml | Custom root element name

Defaults to the datasource name. For a view that is the viewname, for a category or custom cursor that is the category name.

See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.DeleteExcelFileBeforeExport Property

ExportSettingsDeleteExcelFileBeforeExport Property

Note: This API is now obsolete.

Delete and recreate Excel file when exporting. Only applies to Excel. Default is true.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[ObsoleteAttribute]
public bool DeleteExcelFileBeforeExport { get; set; }
<ObsoleteAttribute>
Public Property DeleteExcelFileBeforeExport As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsDeleteExcelFileBeforeExport
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.ExportFormat Property

ExportSettingsExportFormat Property

Data format the export engine should generate. Default is Xml.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ExportFormat ExportFormat { get; set; }
Public Property ExportFormat As ExportFormat
    Get
    Set

Property Value

Type: ExportFormat

Implements

IExportSettingsExportFormat
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.HeaderMode Property

ExportSettingsHeaderMode Property

Headermode, i.e. what to use for columnames (Text, Html, Excel) or nodenames (Xml, Json). Default is Fieldname.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public HeaderMode HeaderMode { get; set; }
Public Property HeaderMode As HeaderMode
    Get
    Set

Property Value

Type: HeaderMode

Implements

IExportSettingsHeaderMode
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.HeadersOnFirstRow Property

ExportSettingsHeadersOnFirstRow Property

Use headers on the first row in table-like exports (like Text, Html, Excel). Default is true.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool HeadersOnFirstRow { get; set; }
Public Property HeadersOnFirstRow As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsHeadersOnFirstRow
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.IncludeConnectionInfo Property

ExportSettingsIncludeConnectionInfo Property

Include additional connection information. Only applies to Json. Default is true.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool IncludeConnectionInfo { get; set; }
Public Property IncludeConnectionInfo As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsIncludeConnectionInfo
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.ISO8601Format Property

ExportSettingsISO8601Format Property

Make dates return in ISO8601 format.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ISO8601Format { get; set; }
Public Property ISO8601Format As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsISO8601Format
Remarks
Dates are returned as "yyyy-mm-dd", times are returned as "hh-mm-ss". Commence does not store seconds, so "ss" will always be "00".

Setting this option to true will return numeric values in Canonical format.

See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.MaxFieldSize Property

ExportSettingsMaxFieldSize Property

Maximum number of characters to retrieve from fields. This includes connected fields. The default is ~500.000, skabout five times the Commence default.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int MaxFieldSize { get; set; }
Public Property MaxFieldSize As Integer
    Get
    Set

Property Value

Type: Int32

Implements

IExportSettingsMaxFieldSize
Remarks
Severely impacts memory usage. When set to >2^20, NumRows may be overridden to prevent your system from exploding.
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.NestConnectedItems Property

ExportSettingsNestConnectedItems Property

Only applies to Json. Splits connection information into distinct elements/nodes.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool NestConnectedItems { get; set; }
Public Property NestConnectedItems As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsNestConnectedItems
Remarks
This is not the same as SplitConnectedItems; that has to do with the data.
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.NumRows Property

ExportSettingsNumRows Property

Specify the number of rows to export at a time. Default is 1024.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int NumRows { get; set; }
Public Property NumRows As Integer
    Get
    Set

Property Value

Type: Int32

Implements

IExportSettingsNumRows
Remarks
This setting may be overridden internally for performance reasons.
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.PreserveAllConnections Property

ExportSettingsPreserveAllConnections Property

Include all connected items. Supported only for Xml, Json, Excel Overrides Canonical, ISO8601Format, SkipConnectedItems, SplitConnectedItems, ExcelUpdateOptions.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool PreserveAllConnections { get; set; }
Public Property PreserveAllConnections As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsPreserveAllConnections
Remarks
The Commence API returns connected field values as a string, subject to MaxFieldSize . This means that if there are a large number of connected items, not all data may be retrieved. PreserveAllConnections will ensure all connected data are read. There is a performance penalty involved because it will perform multiple reads.

Alternatively, you can try adjust the MaxFieldSize parameter. Which setting is faster depends on the data. A high MaxFieldSize also significantly degrades Commence performance.

There is no golden rule to this, but for production environment exports you probably want to set this to true just to be safe.

See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.ReadCommenceDataAsync Property

ExportSettingsReadCommenceDataAsync Property

Read Commence data in an asynchronous way. Async can be slightly faster, but it depends on a number of things, such as NumRows and MaxFieldSize.

When you export to Excel or use PreserveAllConnections there is a performance gain.

Default is true.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool ReadCommenceDataAsync { get; set; }
Public Property ReadCommenceDataAsync As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsReadCommenceDataAsync
Remarks
When true, errors are collected in a AggregateException. They are harder to debug. Set this to false if you want the immediate exception.
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.RemoveCurrencySymbol Property

ExportSettingsRemoveCurrencySymbol Property

Used in conjunction with Canonical, allows removal of the currency symbol that Commence will include when numeric fields were set to 'Display as currency' Default is false.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool RemoveCurrencySymbol { get; set; }
Public Property RemoveCurrencySymbol As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsRemoveCurrencySymbol
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.SkipConnectedItems Property

ExportSettingsSkipConnectedItems Property

Ignore connected items.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SkipConnectedItems { get; set; }
Public Property SkipConnectedItems As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsSkipConnectedItems
Remarks
Note that connected data will still be read if defined, just ignored in the output.

Not all exports respect this setting.

For best performance create a custom cursor or view that does not include connected columns.

See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.SplitConnectedItems Property

ExportSettingsSplitConnectedItems Property

Split connected values into separate nodes/elements. Only applies to Json and Xml. Default is true. If set to false, connected values are not split and you will get the data as Commence returns them.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool SplitConnectedItems { get; set; }
Public Property SplitConnectedItems As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsSplitConnectedItems
Remarks
This setting may be overridden internally if there is no meaningful way of splitting the items.
Category | If the connected field(s) were defined using SetRelatedColumn(Int32, String, String, String, CmcOptionFlags) or AddRelatedColumn(String, String, String).
View | Always

On a cursor with the connections defined as 'direct columns', connected items are returned by Commence as comma-delimited strings without a text-qualifier, making it impossible to split them meaningfully.

See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.TextDelimiter Property

ExportSettingsTextDelimiter Property

Text-delimiter used in a Text export. Only applies to Text and Html exports. Default is tab character.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string TextDelimiter { get; set; }
Public Property TextDelimiter As String
    Get
    Set

Property Value

Type: String

Implements

IExportSettingsTextDelimiter
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.TextDelimiterConnections Property

ExportSettingsTextDelimiterConnections Property

Text-delimiter used for connected values. Only applies to Text and Html exports. Default is newline character (same as Commence uses).

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string TextDelimiterConnections { get; set; }
Public Property TextDelimiterConnections As String
    Get
    Set

Property Value

Type: String

Implements

IExportSettingsTextDelimiterConnections
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.TextQualifier Property

ExportSettingsTextQualifier Property

Text-qualifier. Only applies to Text and Html exports. Default is " (double-quote).

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string TextQualifier { get; set; }
Public Property TextQualifier As String
    Get
    Set

Property Value

Type: String

Implements

IExportSettingsTextQualifier
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.UseDDE Property

ExportSettingsUseDDE Property

Make Commence use DDE calls to retrieve data. WARNING: extremely slow!

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool UseDDE { get; set; }
Public Property UseDDE As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsUseDDE
Remarks
Should only be used as a last resort. Note that Fieldnames cannot contain a comma.

You would use this in case you run into trouble retrieving all items from a connection. This setting will request connected items one by one.

See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace
IExportSettingsPreserveAllConnections


ExportSettings.UseThids Property

ExportSettingsUseThids Property

Include additional column holding the item's THID and return THIDs instead of Name field values for connected items. (XML and Json). For text-based exports, connected items are not returned as thids. Default is false.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool UseThids { get; set; }
Public Property UseThids As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsUseThids
Remarks
Note that custom cursors must be created with the UseThids flag for this settings to take effect.
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.WriteSchema Property

ExportSettingsWriteSchema Property

Get serialized XML with a XmlSchema (XSD). Only applies to PreserveAllConnections in combination with Xml. Default is false.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool WriteSchema { get; set; }
Public Property WriteSchema As Boolean
    Get
    Set

Property Value

Type: Boolean

Implements

IExportSettingsWriteSchema
Remarks
Uses ADO.NET built-in serialization. Allows for importing into SQL Server as well as performing your own query logic on the result.
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings.XlUpdateOptions Property

ExportSettingsXlUpdateOptions Property

Update options when exporting to Microsoft Excel. See ExcelUpdateOptions.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public ExcelUpdateOptions XlUpdateOptions { get; set; }
Public Property XlUpdateOptions As ExcelUpdateOptions
    Get
    Set

Property Value

Type: ExcelUpdateOptions

Implements

IExportSettingsXlUpdateOptions
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


ExportSettings Methods

The ExportSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExportSettings Class
Vovin.CmcLibNet.Export Namespace


HeaderMode Enumeration

Enum specifying what headers (or nodenames) to use.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum HeaderMode
Public Enumeration HeaderMode
Members
Member name | Value | Description
Fieldname | 0 | (Default) Use fieldnames as headers.
Columnlabel | 1 | Use columnnames as headers. Only applies when exporting views. If columns have the same label, a sequence number is added. If no columlabel is defined, the underlying fieldname is used.
CustomLabel | 2 | Use custom headers. The number of supplied headers must be equal to the number of columns to export, regardless of whether SkipConnectedItems is set.
See Also

Reference

Vovin.CmcLibNet.Export Namespace


IExportCompleteArgs Interface

Interface for ExportCompleted, primarily for use with COM Interop.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IExportCompleteArgs
Public Interface IExportCompleteArgs

The IExportCompleteArgs type exposes the following members.

Properties
 | Name | Description
Public property | Rows | Rows processed.
Top
See Also

Reference

Vovin.CmcLibNet.Export Namespace


IExportCompleteArgs Properties

The IExportCompleteArgs type exposes the following members.

Properties
 | Name | Description
Public property | Rows | Rows processed.
Top
See Also

Reference

IExportCompleteArgs Interface
Vovin.CmcLibNet.Export Namespace


IExportCompleteArgs.Rows Property

IExportCompleteArgsRows Property

Rows processed.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int Rows { get; }
ReadOnly Property Rows As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IExportCompleteArgs Interface
Vovin.CmcLibNet.Export Namespace


IExportEngine Interface

interface for ExportEngine.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IExportEngine : IExportEngineEvents
Public Interface IExportEngine
    Inherits IExportEngineEvents

The IExportEngine type exposes the following members.

Properties
 | Name | Description
Public property | Settings | Controls the export settings.
Top
Methods
 | Name | Description
Public method | Close | Not needed, does nothing.
Public method | ExportCategory(String, String, IExportSettings) | Export a category.
Public method | ExportCategory(String, IEnumerableICursorFilter, String, IExportSettings) | Export a filtered category.
Public method | ExportView | Export a view.
Top
Events
 | Name | Description
Public event | ExportCompleted | ExportCompleted event. (Inherited from IExportEngineEvents.)
Public event | ExportProgressChanged | ExportProgressChanged event raised for every batch of rows read. (Inherited from IExportEngineEvents.)
Top
See Also

Reference

Vovin.CmcLibNet.Export Namespace


IExportEngine Properties

The IExportEngine type exposes the following members.

Properties
 | Name | Description
Public property | Settings | Controls the export settings.
Top
See Also

Reference

IExportEngine Interface
Vovin.CmcLibNet.Export Namespace


IExportEngine.Settings Property

IExportEngineSettings Property

Controls the export settings.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
IExportSettings Settings { get; }
ReadOnly Property Settings As IExportSettings
    Get

Property Value

Type: IExportSettings
See Also

Reference

IExportEngine Interface
Vovin.CmcLibNet.Export Namespace


IExportEngine Methods

The IExportEngine type exposes the following members.

Methods
 | Name | Description
Public method | Close | Not needed, does nothing.
Public method | ExportCategory(String, String, IExportSettings) | Export a category.
Public method | ExportCategory(String, IEnumerableICursorFilter, String, IExportSettings) | Export a filtered category.
Public method | ExportView | Export a view.
Top
See Also

Reference

IExportEngine Interface
Vovin.CmcLibNet.Export Namespace


IExportEngine.Close Method

IExportEngineClose Method

Not needed, does nothing.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close
Remarks
This method is only there to make the COM-creatable classes consistent.
See Also

Reference

IExportEngine Interface
Vovin.CmcLibNet.Export Namespace


IExportEngine.ExportCategory Method

IExportEngineExportCategory Method

Overload List
 | Name | Description
Public method | ExportCategory(String, String, IExportSettings) | Export a category.
Public method | ExportCategory(String, IEnumerableICursorFilter, String, IExportSettings) | Export a filtered category.
Top
See Also

Reference

IExportEngine Interface
Vovin.CmcLibNet.Export Namespace


IExportEngine.ExportCategory Method (String, String, IExportSettings)

IExportEngineExportCategory Method (String, String, IExportSettings)

Export a category.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void ExportCategory(
    string categoryName,
    string fileName,
    IExportSettings settings = null
)
Sub ExportCategory (
    categoryName As String,
    fileName As String,
    Optional settings As IExportSettings = Nothing
)

Parameters

categoryName
Type: SystemString
Commence category name.
fileName
Type: SystemString
Fully qualified filename.
settings (Optional)
Type: Vovin.CmcLibNet.ExportIExportSettings
IExportSettings
See Also

Reference

IExportEngine Interface
ExportCategory Overload
Vovin.CmcLibNet.Export Namespace


IExportEngine.ExportCategory Method (String, IEnumerable(ICursorFilter), String, IExportSettings)

IExportEngineExportCategory Method (String, IEnumerableICursorFilter, String, IExportSettings)

Export a filtered category.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void ExportCategory(
    string categoryName,
    IEnumerable<ICursorFilter> filters,
    string fileName,
    IExportSettings settings = null
)
Sub ExportCategory (
    categoryName As String,
    filters As IEnumerable(Of ICursorFilter),
    fileName As String,
    Optional settings As IExportSettings = Nothing
)

Parameters

categoryName
Type: SystemString
Commence category name.
filters
Type: System.Collections.GenericIEnumerable ICursorFilter
Filter(s) to apply to category
fileName
Type: SystemString
Fully qualified filename.
settings (Optional)
Type: Vovin.CmcLibNet.ExportIExportSettings
IExportSettings
See Also

Reference

IExportEngine Interface
ExportCategory Overload
Vovin.CmcLibNet.Export Namespace


IExportEngine.ExportView Method

IExportEngineExportView Method

Export a view.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void ExportView(
    string viewName,
    string fileName,
    IExportSettings settings = null
)
Sub ExportView (
    viewName As String,
    fileName As String,
    Optional settings As IExportSettings = Nothing
)

Parameters

viewName
Type: SystemString
Commence view name (case-sensitive). Pass an empty string to use the active view, if any. Note that not all view types can be exported.
fileName
Type: SystemString
Fully qualified filename.
settings (Optional)
Type: Vovin.CmcLibNet.ExportIExportSettings
IExportSettings
See Also

Reference

IExportEngine Interface
Vovin.CmcLibNet.Export Namespace


IExportEngine Events

The IExportEngine type exposes the following members.

Events
 | Name | Description
Public event | ExportCompleted | ExportCompleted event. (Inherited from IExportEngineEvents.)
Public event | ExportProgressChanged | ExportProgressChanged event raised for every batch of rows read. (Inherited from IExportEngineEvents.)
Top
See Also

Reference

IExportEngine Interface
Vovin.CmcLibNet.Export Namespace


IExportEngineCOMEvents Interface

Interface for COM clients to implement events raised by this asssembly.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IExportEngineCOMEvents
Public Interface IExportEngineCOMEvents

The IExportEngineCOMEvents type exposes the following members.

Methods
 | Name | Description
Public method | ExportCompleted | Export completed
Public method | ExportProgressChanged | Represents a batch of rows read from Commence.
Top
Remarks
When used in VBA (Microsoft Office macros) you have to be very specific as to how to implement the events:
VB
Copy
'Create a class module called 'Class1'
'Declare the assembly using the WithEvents keyword.
Private WithEvents cmclibnet as Vovin_CmcLibNet.ExportEngine
Sub DoExport ' have a method that performs export
    Set cmclibnet = New Vovin_CmcLibNet.ExportEngine
    'do something
    'cmclibnet.ExportView(..) ..
    'cmclibnet.ExportCategory(..) ..
    cmclibnet.Close
End Sub

'Subscribe to the event
'The sender argument has to be of type Variant, not Object.
'Also, do not leave ByVal out, and do not use ByRef.
Private Sub cmclibnet_ExportProgressChanged(ByVal sender As Variant, ByVal args As ExportProgressChangedArgs)
    Debug.Print args.CurrentRow
End Sub

In a regular module, you would use this as:

VB
Copy
Sub Test
    Dim x As New Class1
    Call x.DoExport
End Sub
See Also

Reference

Vovin.CmcLibNet.Export Namespace


IExportEngineCOMEvents Methods

The IExportEngineCOMEvents type exposes the following members.

Methods
 | Name | Description
Public method | ExportCompleted | Export completed
Public method | ExportProgressChanged | Represents a batch of rows read from Commence.
Top
See Also

Reference

IExportEngineCOMEvents Interface
Vovin.CmcLibNet.Export Namespace


IExportEngineCOMEvents.ExportCompleted Method

IExportEngineCOMEventsExportCompleted Method

Export completed

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void ExportCompleted(
    Object sender,
    ExportCompleteArgs e
)
Sub ExportCompleted (
    sender As Object,
    e As ExportCompleteArgs
)

Parameters

sender
Type: SystemObject
sender
e
Type: Vovin.CmcLibNet.ExportExportCompleteArgs
ExportCompleteArgs
See Also

Reference

IExportEngineCOMEvents Interface
Vovin.CmcLibNet.Export Namespace


IExportEngineCOMEvents.ExportProgressChanged Method

IExportEngineCOMEventsExportProgressChanged Method

Represents a batch of rows read from Commence.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void ExportProgressChanged(
    Object sender,
    ExportProgressChangedArgs e
)
Sub ExportProgressChanged (
    sender As Object,
    e As ExportProgressChangedArgs
)

Parameters

sender
Type: SystemObject
sender.
e
Type: Vovin.CmcLibNet.ExportExportProgressChangedArgs
ExportProgressChangedArgs.
See Also

Reference

IExportEngineCOMEvents Interface
Vovin.CmcLibNet.Export Namespace


IExportEngineEvents Interface

Interface for exposing events.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IExportEngineEvents
Public Interface IExportEngineEvents

The IExportEngineEvents type exposes the following members.

Events
 | Name | Description
Public event | ExportCompleted | ExportCompleted event.
Public event | ExportProgressChanged | ExportProgressChanged event raised for every batch of rows read.
Top
See Also

Reference

Vovin.CmcLibNet.Export Namespace


IExportEngineEvents Events

The IExportEngineEvents type exposes the following members.

Events
 | Name | Description
Public event | ExportCompleted | ExportCompleted event.
Public event | ExportProgressChanged | ExportProgressChanged event raised for every batch of rows read.
Top
See Also

Reference

IExportEngineEvents Interface
Vovin.CmcLibNet.Export Namespace


IExportEngineEvents.ExportCompleted Event

IExportEngineEventsExportCompleted Event

ExportCompleted event.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
event ExportCompletedHandler ExportCompleted
Event ExportCompleted As ExportCompletedHandler

Value

Type: Vovin.CmcLibNet.ExportExportCompletedHandler
See Also

Reference

IExportEngineEvents Interface
Vovin.CmcLibNet.Export Namespace


IExportEngineEvents.ExportProgressChanged Event

IExportEngineEventsExportProgressChanged Event

ExportProgressChanged event raised for every batch of rows read.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
event ExportProgressChangedHandler ExportProgressChanged
Event ExportProgressChanged As ExportProgressChangedHandler

Value

Type: Vovin.CmcLibNet.ExportExportProgressChangedHandler
See Also

Reference

IExportEngineEvents Interface
Vovin.CmcLibNet.Export Namespace


IExportProgressChangedArgs Interface

Interface for ExportProgressChanged, primarily for use with COM Interop.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IExportProgressChangedArgs
Public Interface IExportProgressChangedArgs

The IExportProgressChangedArgs type exposes the following members.

Properties
 | Name | Description
Public property | CurrentIteration | Current iteration
Public property | IterationCount | Total number of iterations.
Public property | RowsProcessed | Rows processed.
Public property | RowsTotal | Total number of rows to process.
Public property | RowValues | Rowdata in structured string representation.
Top
See Also

Reference

Vovin.CmcLibNet.Export Namespace


IExportProgressChangedArgs Properties

The IExportProgressChangedArgs type exposes the following members.

Properties
 | Name | Description
Public property | CurrentIteration | Current iteration
Public property | IterationCount | Total number of iterations.
Public property | RowsProcessed | Rows processed.
Public property | RowsTotal | Total number of rows to process.
Public property | RowValues | Rowdata in structured string representation.
Top
See Also

Reference

IExportProgressChangedArgs Interface
Vovin.CmcLibNet.Export Namespace


IExportProgressChangedArgs.CurrentIteration Property

IExportProgressChangedArgsCurrentIteration Property

Current iteration

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int CurrentIteration { get; }
ReadOnly Property CurrentIteration As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IExportProgressChangedArgs Interface
Vovin.CmcLibNet.Export Namespace


IExportProgressChangedArgs.IterationCount Property

IExportProgressChangedArgsIterationCount Property

Total number of iterations.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int IterationCount { get; }
ReadOnly Property IterationCount As Integer
    Get

Property Value

Type: Int32
Remarks
When PreserveAllConnections is set, there may be multiple iterations.
See Also

Reference

IExportProgressChangedArgs Interface
Vovin.CmcLibNet.Export Namespace


IExportProgressChangedArgs.RowsProcessed Property

IExportProgressChangedArgsRowsProcessed Property

Rows processed.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int RowsProcessed { get; }
ReadOnly Property RowsProcessed As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IExportProgressChangedArgs Interface
Vovin.CmcLibNet.Export Namespace


IExportProgressChangedArgs.RowsTotal Property

IExportProgressChangedArgsRowsTotal Property

Total number of rows to process.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int RowsTotal { get; }
ReadOnly Property RowsTotal As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IExportProgressChangedArgs Interface
Vovin.CmcLibNet.Export Namespace


IExportProgressChangedArgs.RowValues Property

IExportProgressChangedArgsRowValues Property

Rowdata in structured string representation.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string RowValues { get; }
ReadOnly Property RowValues As String
    Get

Property Value

Type: String
Remarks
Only contains data when ExportFormat is set to Event.
See Also

Reference

IExportProgressChangedArgs Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings Interface

Interface for ExportSettings.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IExportSettings
Public Interface IExportSettings

The IExportSettings type exposes the following members.

Properties
 | Name | Description
Public property | Canonical | Return data in a canonical format. Default is false.
Public property | CSSFile | External CSS file to be linked with an HTML export. Location is the output path. Only applies to HTML exports. Default is empty (no CSSFile).
Public property | CustomHeaders | Use custom columnheaders.
Public property | CustomRootNode | Custom root node for Xml, Json, Excel.
Public property | DeleteExcelFileBeforeExport | Obsolete. Delete and recreate Excel file when exporting. Only applies to Excel. Default is true.
Public property | ExportFormat | Data format the export engine should generate. Default is Xml.
Public property | HeaderMode | Headermode, i.e. what to use for columnames (Text, Html, Excel) or nodenames (Xml, Json). Default is Fieldname.
Public property | HeadersOnFirstRow | Use headers on the first row in table-like exports (like Text, Html, Excel). Default is true.
Public property | IncludeConnectionInfo | Include additional connection information. Only applies to Json. Default is true.
Public property | ISO8601Format | Make dates return in ISO8601 format.
Public property | MaxFieldSize | Maximum number of characters to retrieve from fields. This includes connected fields. The default is ~500.000, skabout five times the Commence default.
Public property | NestConnectedItems | Only applies to Json. Splits connection information into distinct elements/nodes.
Public property | NumRows | Specify the number of rows to export at a time. Default is 1024.
Public property | PreserveAllConnections | Include all connected items. Supported only for Xml, Json, Excel Overrides Canonical, ISO8601Format, SkipConnectedItems, SplitConnectedItems, ExcelUpdateOptions.
Public property | ReadCommenceDataAsync | Read Commence data in an asynchronous way. Async can be slightly faster, but it depends on a number of things, such as NumRows and MaxFieldSize. When you export to Excel or use PreserveAllConnections there is a performance gain. Default is true.
Public property | RemoveCurrencySymbol | Used in conjunction with Canonical, allows removal of the currency symbol that Commence will include when numeric fields were set to 'Display as currency' Default is false.
Public property | SkipConnectedItems | Ignore connected items.
Public property | SplitConnectedItems | Split connected values into separate nodes/elements. Only applies to Json and Xml. Default is true. If set to false, connected values are not split and you will get the data as Commence returns them.
Public property | TextDelimiter | Text-delimiter used in a Text export. Only applies to Text and Html exports. Default is tab character.
Public property | TextDelimiterConnections | Text-delimiter used for connected values. Only applies to Text and Html exports. Default is newline character (same as Commence uses).
Public property | TextQualifier | Text-qualifier. Only applies to Text and Html exports. Default is " (double-quote).
Public property | UseDDE | Make Commence use DDE calls to retrieve data. WARNING: extremely slow!
Public property | UseThids | Include additional column holding the item's THID and return THIDs instead of Name field values for connected items. (XML and Json). For text-based exports, connected items are not returned as thids. Default is false.
Public property | WriteSchema | Get serialized XML with a XmlSchema (XSD). Only applies to PreserveAllConnections in combination with Xml. Default is false.
Public property | XlUpdateOptions | Update options when exporting to Microsoft Excel. See ExcelUpdateOptions.
Top
Remarks
Some setttings will negate others or be ignored when not applicable or be manipulated internally. This is not always fully documented.

You should NOT create code that relies on the settings you provided. For example: if you set both MaxFieldSize and NumRows to a huge number, the assembly will balance them out so as to prevent out-of-memory exceptions.

See Also

Reference

Vovin.CmcLibNet.Export Namespace


IExportSettings Properties

The IExportSettings type exposes the following members.

Properties
 | Name | Description
Public property | Canonical | Return data in a canonical format. Default is false.
Public property | CSSFile | External CSS file to be linked with an HTML export. Location is the output path. Only applies to HTML exports. Default is empty (no CSSFile).
Public property | CustomHeaders | Use custom columnheaders.
Public property | CustomRootNode | Custom root node for Xml, Json, Excel.
Public property | DeleteExcelFileBeforeExport | Obsolete. Delete and recreate Excel file when exporting. Only applies to Excel. Default is true.
Public property | ExportFormat | Data format the export engine should generate. Default is Xml.
Public property | HeaderMode | Headermode, i.e. what to use for columnames (Text, Html, Excel) or nodenames (Xml, Json). Default is Fieldname.
Public property | HeadersOnFirstRow | Use headers on the first row in table-like exports (like Text, Html, Excel). Default is true.
Public property | IncludeConnectionInfo | Include additional connection information. Only applies to Json. Default is true.
Public property | ISO8601Format | Make dates return in ISO8601 format.
Public property | MaxFieldSize | Maximum number of characters to retrieve from fields. This includes connected fields. The default is ~500.000, skabout five times the Commence default.
Public property | NestConnectedItems | Only applies to Json. Splits connection information into distinct elements/nodes.
Public property | NumRows | Specify the number of rows to export at a time. Default is 1024.
Public property | PreserveAllConnections | Include all connected items. Supported only for Xml, Json, Excel Overrides Canonical, ISO8601Format, SkipConnectedItems, SplitConnectedItems, ExcelUpdateOptions.
Public property | ReadCommenceDataAsync | Read Commence data in an asynchronous way. Async can be slightly faster, but it depends on a number of things, such as NumRows and MaxFieldSize. When you export to Excel or use PreserveAllConnections there is a performance gain. Default is true.
Public property | RemoveCurrencySymbol | Used in conjunction with Canonical, allows removal of the currency symbol that Commence will include when numeric fields were set to 'Display as currency' Default is false.
Public property | SkipConnectedItems | Ignore connected items.
Public property | SplitConnectedItems | Split connected values into separate nodes/elements. Only applies to Json and Xml. Default is true. If set to false, connected values are not split and you will get the data as Commence returns them.
Public property | TextDelimiter | Text-delimiter used in a Text export. Only applies to Text and Html exports. Default is tab character.
Public property | TextDelimiterConnections | Text-delimiter used for connected values. Only applies to Text and Html exports. Default is newline character (same as Commence uses).
Public property | TextQualifier | Text-qualifier. Only applies to Text and Html exports. Default is " (double-quote).
Public property | UseDDE | Make Commence use DDE calls to retrieve data. WARNING: extremely slow!
Public property | UseThids | Include additional column holding the item's THID and return THIDs instead of Name field values for connected items. (XML and Json). For text-based exports, connected items are not returned as thids. Default is false.
Public property | WriteSchema | Get serialized XML with a XmlSchema (XSD). Only applies to PreserveAllConnections in combination with Xml. Default is false.
Public property | XlUpdateOptions | Update options when exporting to Microsoft Excel. See ExcelUpdateOptions.
Top
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.Canonical Property

IExportSettingsCanonical Property

Return data in a canonical format. Default is false.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool Canonical { get; set; }
Property Canonical As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Date | yyyymmdd
Time | hh:mm military time, 24 hour clock
Number | 123456.78 no separator, period for decimal delimiter. Note that when a field is defined as 'Show as currency' in the Commence UI, numerical values are prepended with a '$' sign.
Checkbox | TRUE or FALSE (English)
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.CSSFile Property

IExportSettingsCSSFile Property

External CSS file to be linked with an HTML export. Location is the output path. Only applies to HTML exports. Default is empty (no CSSFile).

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string CSSFile { get; set; }
Property CSSFile As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.CustomHeaders Property

IExportSettingsCustomHeaders Property

Use custom columnheaders.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
Object[] CustomHeaders { get; set; }
Property CustomHeaders As Object()
    Get
    Set

Property Value

Type: Object
Remarks
You cannot use custom headers in combination with NestConnectedItems.

You must supply custom headers for all columns in the cursor, even when you have set SkipConnectedItems to true.

Type is object[] for compatibility with COM.

See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.CustomRootNode Property

IExportSettingsCustomRootNode Property

Custom root node for Xml, Json, Excel.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string CustomRootNode { get; set; }
Property CustomRootNode As String
    Get
    Set

Property Value

Type: String
Remarks
For Text, Html and Event writers this property is ignored
Export format | Notes
Excel | Custom sheetname
Json | Custom top-level node name
Xml | Custom root element name

Defaults to the datasource name. For a view that is the viewname, for a category or custom cursor that is the category name.

See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.DeleteExcelFileBeforeExport Property

IExportSettingsDeleteExcelFileBeforeExport Property

Note: This API is now obsolete.

Delete and recreate Excel file when exporting. Only applies to Excel. Default is true.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
[ObsoleteAttribute]
bool DeleteExcelFileBeforeExport { get; set; }
<ObsoleteAttribute>
Property DeleteExcelFileBeforeExport As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.ExportFormat Property

IExportSettingsExportFormat Property

Data format the export engine should generate. Default is Xml.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ExportFormat ExportFormat { get; set; }
Property ExportFormat As ExportFormat
    Get
    Set

Property Value

Type: ExportFormat
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.HeaderMode Property

IExportSettingsHeaderMode Property

Headermode, i.e. what to use for columnames (Text, Html, Excel) or nodenames (Xml, Json). Default is Fieldname.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
HeaderMode HeaderMode { get; set; }
Property HeaderMode As HeaderMode
    Get
    Set

Property Value

Type: HeaderMode
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.HeadersOnFirstRow Property

IExportSettingsHeadersOnFirstRow Property

Use headers on the first row in table-like exports (like Text, Html, Excel). Default is true.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool HeadersOnFirstRow { get; set; }
Property HeadersOnFirstRow As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.IncludeConnectionInfo Property

IExportSettingsIncludeConnectionInfo Property

Include additional connection information. Only applies to Json. Default is true.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool IncludeConnectionInfo { get; set; }
Property IncludeConnectionInfo As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.ISO8601Format Property

IExportSettingsISO8601Format Property

Make dates return in ISO8601 format.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ISO8601Format { get; set; }
Property ISO8601Format As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Dates are returned as "yyyy-mm-dd", times are returned as "hh-mm-ss". Commence does not store seconds, so "ss" will always be "00".

Setting this option to true will return numeric values in Canonical format.

See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.MaxFieldSize Property

IExportSettingsMaxFieldSize Property

Maximum number of characters to retrieve from fields. This includes connected fields. The default is ~500.000, skabout five times the Commence default.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int MaxFieldSize { get; set; }
Property MaxFieldSize As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
Severely impacts memory usage. When set to >2^20, NumRows may be overridden to prevent your system from exploding.
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.NestConnectedItems Property

IExportSettingsNestConnectedItems Property

Only applies to Json. Splits connection information into distinct elements/nodes.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool NestConnectedItems { get; set; }
Property NestConnectedItems As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
This is not the same as SplitConnectedItems; that has to do with the data.
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.NumRows Property

IExportSettingsNumRows Property

Specify the number of rows to export at a time. Default is 1024.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int NumRows { get; set; }
Property NumRows As Integer
    Get
    Set

Property Value

Type: Int32
Remarks
This setting may be overridden internally for performance reasons.
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.PreserveAllConnections Property

IExportSettingsPreserveAllConnections Property

Include all connected items. Supported only for Xml, Json, Excel Overrides Canonical, ISO8601Format, SkipConnectedItems, SplitConnectedItems, ExcelUpdateOptions.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool PreserveAllConnections { get; set; }
Property PreserveAllConnections As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
The Commence API returns connected field values as a string, subject to MaxFieldSize . This means that if there are a large number of connected items, not all data may be retrieved. PreserveAllConnections will ensure all connected data are read. There is a performance penalty involved because it will perform multiple reads.

Alternatively, you can try adjust the MaxFieldSize parameter. Which setting is faster depends on the data. A high MaxFieldSize also significantly degrades Commence performance.

There is no golden rule to this, but for production environment exports you probably want to set this to true just to be safe.

See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.ReadCommenceDataAsync Property

IExportSettingsReadCommenceDataAsync Property

Read Commence data in an asynchronous way. Async can be slightly faster, but it depends on a number of things, such as NumRows and MaxFieldSize.

When you export to Excel or use PreserveAllConnections there is a performance gain.

Default is true.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool ReadCommenceDataAsync { get; set; }
Property ReadCommenceDataAsync As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
When true, errors are collected in a AggregateException. They are harder to debug. Set this to false if you want the immediate exception.
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.RemoveCurrencySymbol Property

IExportSettingsRemoveCurrencySymbol Property

Used in conjunction with Canonical, allows removal of the currency symbol that Commence will include when numeric fields were set to 'Display as currency' Default is false.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool RemoveCurrencySymbol { get; set; }
Property RemoveCurrencySymbol As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.SkipConnectedItems Property

IExportSettingsSkipConnectedItems Property

Ignore connected items.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SkipConnectedItems { get; set; }
Property SkipConnectedItems As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Note that connected data will still be read if defined, just ignored in the output.

Not all exports respect this setting.

For best performance create a custom cursor or view that does not include connected columns.

See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.SplitConnectedItems Property

IExportSettingsSplitConnectedItems Property

Split connected values into separate nodes/elements. Only applies to Json and Xml. Default is true. If set to false, connected values are not split and you will get the data as Commence returns them.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool SplitConnectedItems { get; set; }
Property SplitConnectedItems As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
This setting may be overridden internally if there is no meaningful way of splitting the items.
Category | If the connected field(s) were defined using SetRelatedColumn(Int32, String, String, String, CmcOptionFlags) or AddRelatedColumn(String, String, String).
View | Always

On a cursor with the connections defined as 'direct columns', connected items are returned by Commence as comma-delimited strings without a text-qualifier, making it impossible to split them meaningfully.

See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.TextDelimiter Property

IExportSettingsTextDelimiter Property

Text-delimiter used in a Text export. Only applies to Text and Html exports. Default is tab character.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string TextDelimiter { get; set; }
Property TextDelimiter As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.TextDelimiterConnections Property

IExportSettingsTextDelimiterConnections Property

Text-delimiter used for connected values. Only applies to Text and Html exports. Default is newline character (same as Commence uses).

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string TextDelimiterConnections { get; set; }
Property TextDelimiterConnections As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.TextQualifier Property

IExportSettingsTextQualifier Property

Text-qualifier. Only applies to Text and Html exports. Default is " (double-quote).

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string TextQualifier { get; set; }
Property TextQualifier As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.UseDDE Property

IExportSettingsUseDDE Property

Make Commence use DDE calls to retrieve data. WARNING: extremely slow!

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool UseDDE { get; set; }
Property UseDDE As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Should only be used as a last resort. Note that Fieldnames cannot contain a comma.

You would use this in case you run into trouble retrieving all items from a connection. This setting will request connected items one by one.

See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace
IExportSettingsPreserveAllConnections


IExportSettings.UseThids Property

IExportSettingsUseThids Property

Include additional column holding the item's THID and return THIDs instead of Name field values for connected items. (XML and Json). For text-based exports, connected items are not returned as thids. Default is false.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool UseThids { get; set; }
Property UseThids As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Note that custom cursors must be created with the UseThids flag for this settings to take effect.
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.WriteSchema Property

IExportSettingsWriteSchema Property

Get serialized XML with a XmlSchema (XSD). Only applies to PreserveAllConnections in combination with Xml. Default is false.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool WriteSchema { get; set; }
Property WriteSchema As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
Uses ADO.NET built-in serialization. Allows for importing into SQL Server as well as performing your own query logic on the result.
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


IExportSettings.XlUpdateOptions Property

IExportSettingsXlUpdateOptions Property

Update options when exporting to Microsoft Excel. See ExcelUpdateOptions.

Namespace: Vovin.CmcLibNet.Export
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
ExcelUpdateOptions XlUpdateOptions { get; set; }
Property XlUpdateOptions As ExcelUpdateOptions
    Get
    Set

Property Value

Type: ExcelUpdateOptions
See Also

Reference

IExportSettings Interface
Vovin.CmcLibNet.Export Namespace


Vovin.CmcLibNet.Services Namespace

Contains all services.
Classes
 | Class | Description
Public class | Services | Class that points to services
Interfaces
 | Interface | Description
Public interface | IServices | Interface for Services.
Enumerations
 | Enumeration | Description
Public enumeration | ClipActiveItem | Specifies how active item fields will be copied to clipboard.


ClipActiveItem Enumeration

Specifies how active item fields will be copied to clipboard.

Namespace: Vovin.CmcLibNet.Services
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public enum ClipActiveItem
Public Enumeration ClipActiveItem
Members
Member name | Value | Description
ValuesOnly | 0 | Just the values.
IncludeFieldName | 1 | Fieldnames and values.
IncludeColumnLabel | 2 | Columnames and values.
IncludeAll | 3 | Fieldnames, columnames and values.
See Also

Reference

Vovin.CmcLibNet.Services Namespace


IServices Interface

Interface for Services.

Namespace: Vovin.CmcLibNet.Services
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IServices
Public Interface IServices

The IServices type exposes the following members.

Methods
 | Name | Description
Public method | Close | Does not do anything, just in there for consistency.
Public method | CopyActiveItemToClipboard | Copies the values of the active item to clipboard. If no view is active, or the viewtype cannot be queried (like Document, Report Viewer), nothing happens.
Top
See Also

Reference

Vovin.CmcLibNet.Services Namespace


IServices Methods

The IServices type exposes the following members.

Methods
 | Name | Description
Public method | Close | Does not do anything, just in there for consistency.
Public method | CopyActiveItemToClipboard | Copies the values of the active item to clipboard. If no view is active, or the viewtype cannot be queried (like Document, Report Viewer), nothing happens.
Top
See Also

Reference

IServices Interface
Vovin.CmcLibNet.Services Namespace


IServices.Close Method

IServicesClose Method

Does not do anything, just in there for consistency.

Namespace: Vovin.CmcLibNet.Services
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
void Close()
Sub Close
See Also

Reference

IServices Interface
Vovin.CmcLibNet.Services Namespace


IServices.CopyActiveItemToClipboard Method

IServicesCopyActiveItemToClipboard Method

Copies the values of the active item to clipboard. If no view is active, or the viewtype cannot be queried (like Document, Report Viewer), nothing happens.

Namespace: Vovin.CmcLibNet.Services
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
bool CopyActiveItemToClipboard(
    ClipActiveItem flag = ClipActiveItem.ValuesOnly
)
Function CopyActiveItemToClipboard (
    Optional flag As ClipActiveItem = ClipActiveItem.ValuesOnly
) As Boolean

Parameters

flag (Optional)
Type: Vovin.CmcLibNet.ServicesClipActiveItem
Formatting options for columns.

Return Value

Type: Boolean
true if data was copied to clipboard.
See Also

Reference

IServices Interface
Vovin.CmcLibNet.Services Namespace


Services Class

Class that points to services
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.ServicesServices

Namespace: Vovin.CmcLibNet.Services
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class Services : IServices
Public Class Services
    Implements IServices

The Services type exposes the following members.

Constructors
 | Name | Description
Public method | Services | Initializes a new instance of the Services class
Top
Methods
 | Name | Description
Public method | Close | Does not do anything, just in there for consistency.
Public method | CopyActiveItemToClipboard | Copies the values of the active item to clipboard. If no view is active, or the viewtype cannot be queried (like Document, Report Viewer), nothing happens.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Services Namespace


Services Constructor

Initializes a new instance of the Services class

Namespace: Vovin.CmcLibNet.Services
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public Services()
Public Sub New
See Also

Reference

Services Class
Vovin.CmcLibNet.Services Namespace


Services Methods

The Services type exposes the following members.

Methods
 | Name | Description
Public method | Close | Does not do anything, just in there for consistency.
Public method | CopyActiveItemToClipboard | Copies the values of the active item to clipboard. If no view is active, or the viewtype cannot be queried (like Document, Report Viewer), nothing happens.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Services Class
Vovin.CmcLibNet.Services Namespace


Services.Close Method

ServicesClose Method

Does not do anything, just in there for consistency.

Namespace: Vovin.CmcLibNet.Services
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

IServicesClose
See Also

Reference

Services Class
Vovin.CmcLibNet.Services Namespace


Services.CopyActiveItemToClipboard Method

ServicesCopyActiveItemToClipboard Method

Copies the values of the active item to clipboard. If no view is active, or the viewtype cannot be queried (like Document, Report Viewer), nothing happens.

Namespace: Vovin.CmcLibNet.Services
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public bool CopyActiveItemToClipboard(
    ClipActiveItem flag = ClipActiveItem.ValuesOnly
)
Public Function CopyActiveItemToClipboard (
    Optional flag As ClipActiveItem = ClipActiveItem.ValuesOnly
) As Boolean

Parameters

flag (Optional)
Type: Vovin.CmcLibNet.ServicesClipActiveItem
Formatting options for columns.

Return Value

Type: Boolean
true if data was copied to clipboard.

Implements

IServicesCopyActiveItemToClipboard(ClipActiveItem)
See Also

Reference

Services Class
Vovin.CmcLibNet.Services Namespace


Vovin.CmcLibNet.Services.UI Namespace

Contains components with a user-interface
Classes
 | Class | Description
Public class | FilePicker | From VBScript, it is notoriously hard to get an OpenFileDialog. This class is intended primarily for use from Commence scripts. All it does is expose an OpenFileDialog
Interfaces
 | Interface | Description
Public interface | IFilePicker | Interface for FilePicker


FilePicker Class

From VBScript, it is notoriously hard to get an OpenFileDialog. This class is intended primarily for use from Commence scripts. All it does is expose an OpenFileDialog
Inheritance Hierarchy
SystemObject
Vovin.CmcLibNet.Services.UIFilePicker

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public class FilePicker : IFilePicker
Public Class FilePicker
    Implements IFilePicker

The FilePicker type exposes the following members.

Constructors
 | Name | Description
Public method | FilePicker | Initializes a new instance of the FilePicker class
Top
Properties
 | Name | Description
Public property | DefaultExt | Gets or sets the default file name extension.
Public property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box.
Public property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box. The default value is 1.
Public property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
Public property | Title | Gets or sets the file dialog box title.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowDialog | Returns an OpenFileDialog instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Vovin.CmcLibNet.Services.UI Namespace


FilePicker Constructor

Initializes a new instance of the FilePicker class

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public FilePicker()
Public Sub New
See Also

Reference

FilePicker Class
Vovin.CmcLibNet.Services.UI Namespace


FilePicker Properties

The FilePicker type exposes the following members.

Properties
 | Name | Description
Public property | DefaultExt | Gets or sets the default file name extension.
Public property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box.
Public property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box. The default value is 1.
Public property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
Public property | Title | Gets or sets the file dialog box title.
Top
See Also

Reference

FilePicker Class
Vovin.CmcLibNet.Services.UI Namespace


FilePicker.DefaultExt Property

FilePickerDefaultExt Property

Gets or sets the default file name extension.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string DefaultExt { get; set; }
Public Property DefaultExt As String
    Get
    Set

Property Value

Type: String

Implements

IFilePickerDefaultExt
See Also

Reference

FilePicker Class
Vovin.CmcLibNet.Services.UI Namespace


FilePicker.Filter Property

FilePickerFilter Property

Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Filter { get; set; }
Public Property Filter As String
    Get
    Set

Property Value

Type: String

Implements

IFilePickerFilter
See Also

Reference

FilePicker Class
Vovin.CmcLibNet.Services.UI Namespace


FilePicker.FilterIndex Property

FilePickerFilterIndex Property

Gets or sets the index of the filter currently selected in the file dialog box. The default value is 1.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public int FilterIndex { get; set; }
Public Property FilterIndex As Integer
    Get
    Set

Property Value

Type: Int32

Implements

IFilePickerFilterIndex
See Also

Reference

FilePicker Class
Vovin.CmcLibNet.Services.UI Namespace


FilePicker.InitialDirectory Property

FilePickerInitialDirectory Property

Gets or sets the initial directory displayed by the file dialog box.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string InitialDirectory { get; set; }
Public Property InitialDirectory As String
    Get
    Set

Property Value

Type: String

Implements

IFilePickerInitialDirectory
See Also

Reference

FilePicker Class
Vovin.CmcLibNet.Services.UI Namespace


FilePicker.Title Property

FilePickerTitle Property

Gets or sets the file dialog box title.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String

Implements

IFilePickerTitle
See Also

Reference

FilePicker Class
Vovin.CmcLibNet.Services.UI Namespace


FilePicker Methods

The FilePicker type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShowDialog | Returns an OpenFileDialog instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FilePicker Class
Vovin.CmcLibNet.Services.UI Namespace


FilePicker.ShowDialog Method

FilePickerShowDialog Method

Returns an OpenFileDialog instance.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public string ShowDialog()
Public Function ShowDialog As String

Return Value

Type: String
Return value from Dialog window.

Implements

IFilePickerShowDialog
See Also

Reference

FilePicker Class
Vovin.CmcLibNet.Services.UI Namespace


IFilePicker Interface

Interface for FilePicker

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
public interface IFilePicker
Public Interface IFilePicker

The IFilePicker type exposes the following members.

Properties
 | Name | Description
Public property | DefaultExt | Gets or sets the default file name extension.
Public property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box.
Public property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box. The default value is 1.
Public property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
Public property | Title | Gets or sets the file dialog box title.
Top
Methods
 | Name | Description
Public method | ShowDialog | Returns an OpenFileDialog instance.
Top
See Also

Reference

Vovin.CmcLibNet.Services.UI Namespace


IFilePicker Properties

The IFilePicker type exposes the following members.

Properties
 | Name | Description
Public property | DefaultExt | Gets or sets the default file name extension.
Public property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box.
Public property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box. The default value is 1.
Public property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
Public property | Title | Gets or sets the file dialog box title.
Top
See Also

Reference

IFilePicker Interface
Vovin.CmcLibNet.Services.UI Namespace


IFilePicker.DefaultExt Property

IFilePickerDefaultExt Property

Gets or sets the default file name extension.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string DefaultExt { get; set; }
Property DefaultExt As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IFilePicker Interface
Vovin.CmcLibNet.Services.UI Namespace


IFilePicker.Filter Property

IFilePickerFilter Property

Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Filter { get; set; }
Property Filter As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IFilePicker Interface
Vovin.CmcLibNet.Services.UI Namespace


IFilePicker.FilterIndex Property

IFilePickerFilterIndex Property

Gets or sets the index of the filter currently selected in the file dialog box. The default value is 1.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
int FilterIndex { get; set; }
Property FilterIndex As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IFilePicker Interface
Vovin.CmcLibNet.Services.UI Namespace


IFilePicker.InitialDirectory Property

IFilePickerInitialDirectory Property

Gets or sets the initial directory displayed by the file dialog box.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string InitialDirectory { get; set; }
Property InitialDirectory As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IFilePicker Interface
Vovin.CmcLibNet.Services.UI Namespace


IFilePicker.Title Property

IFilePickerTitle Property

Gets or sets the file dialog box title.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string Title { get; set; }
Property Title As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IFilePicker Interface
Vovin.CmcLibNet.Services.UI Namespace


IFilePicker Methods

The IFilePicker type exposes the following members.

Methods
 | Name | Description
Public method | ShowDialog | Returns an OpenFileDialog instance.
Top
See Also

Reference

IFilePicker Interface
Vovin.CmcLibNet.Services.UI Namespace


IFilePicker.ShowDialog Method

IFilePickerShowDialog Method

Returns an OpenFileDialog instance.

Namespace: Vovin.CmcLibNet.Services.UI
Assembly: Vovin.CmcLibNet (in Vovin.CmcLibNet.dll) Version: 1.0.7729.42686
Syntax
C#
VB
Copy
string ShowDialog()
Function ShowDialog As String

Return Value

Type: String
Return value from Dialog window.
See Also

Reference

IFilePicker Interface
Vovin.CmcLibNet.Services.UI Namespace